0.96 Error

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

0.96 Error

Vallejos, Andrew

SEVERE: Servlet.service() for servlet jsp threw exception

org.apache.jasper.JasperException: /begin.jsp(61,16) "${!isNewUser && !empty(WEB_PROPERTIES['begin.thirdBox.visitedTitle'])}" contains invalid expression(s): javax.el.ELException: Function ':empty' not found

 

I just updated the dev box to 0.96 and got the following error message (only on the home page).  I am guessing that I do not have a setting configured correctly and that the error checking doesn’t like that.

 

-Andrew

 

======================

Andrew Vallejos

Web Developer II

Biotechnology and Bioengineering Center

Medical College of Wisconsin

414-955-4104

[hidden email]


_______________________________________________
dev mailing list
[hidden email]
http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: 0.96 Error

Vallejos, Andrew

Still receiving the error.  Although the rest of the site works, the home page just appears blank underneath the menu.

 

-Andrew

 

From: Vallejos, Andrew
Sent: Tuesday, February 22, 2011 2:28 PM
To: [hidden email]
Subject: 0.96 Error

 

SEVERE: Servlet.service() for servlet jsp threw exception

org.apache.jasper.JasperException: /begin.jsp(61,16) "${!isNewUser && !empty(WEB_PROPERTIES['begin.thirdBox.visitedTitle'])}" contains invalid expression(s): javax.el.ELException: Function ':empty' not found

 

I just updated the dev box to 0.96 and got the following error message (only on the home page).  I am guessing that I do not have a setting configured correctly and that the error checking doesn’t like that.

 

-Andrew

 

======================

Andrew Vallejos

Web Developer II

Biotechnology and Bioengineering Center

Medical College of Wisconsin

414-955-4104

[hidden email]


_______________________________________________
dev mailing list
[hidden email]
http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: 0.96 Error

Richard Smith
Hi Andrew,
I see the bug as well on my local Tomcat.  Google tells me it's a bug/
incompatibility with Tomcat 6.0.18 and the JSTL JSP library.

The fix is to replace 'empty(' with 'empty (' in begin.jsp, 4 places in
total.  I just checked in a fix onto the 0.96 branch so if you update
you should see it working now.

Cheers,
Richard.


On 23/02/2011 15:37, Vallejos, Andrew wrote:

> Still receiving the error.  Although the rest of the site works, the
> home page just appears blank underneath the menu.
>
>
>
> -Andrew
>
>
>
> From: Vallejos, Andrew
> Sent: Tuesday, February 22, 2011 2:28 PM
> To: [hidden email]
> Subject: 0.96 Error
>
>
>
> SEVERE: Servlet.service() for servlet jsp threw exception
>
> org.apache.jasper.JasperException: /begin.jsp(61,16) "${!isNewUser&&
> !empty(WEB_PROPERTIES['begin.thirdBox.visitedTitle'])}" contains invalid
> expression(s): javax.el.ELException: Function ':empty' not found
>
>
>
> I just updated the dev box to 0.96 and got the following error message
> (only on the home page).  I am guessing that I do not have a setting
> configured correctly and that the error checking doesn't like that.
>
>
>
> -Andrew
>
>
>
> ======================
>
> Andrew Vallejos
>
> Web Developer II
>
> Biotechnology and Bioengineering Center
>
> Medical College of Wisconsin
>
> 414-955-4104
>
> [hidden email]
>
>
>
>
>
> _______________________________________________
> dev mailing list
> [hidden email]
> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev


_______________________________________________
dev mailing list
[hidden email]
http://mail.intermine.org/cgi-bin/mailman/listinfo/dev