404 in Chrome dev console on JBrowse requesting tracks.conf

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

404 in Chrome dev console on JBrowse requesting tracks.conf

Sam Hokin-3
Hiya, devs. I've just noticed a seemingly benign 404 in the Chrome dev console from the report page JBrowse (but not in the Firefox
dev console):

intermine.js:1 ƒ InterMine JavaScript Library loaded
report.do?id=4329650:5337 Using imtables: 2.0.0
report.do?id=4329650:5356 Webservice is at version 19
//peanutmine/service/jbrowse/config/130453/tracks.conf:1 GET
https://mines.legumeinfo.org//peanutmine/service/jbrowse/config/130453/tracks.conf 404 (Not Found)

Any suggestions? There seems to be no problem from this, but I thought I'd ask, since a 404 is a 404 and maybe there's some cool
track config option I'm missing.

FWIW, this is true on both the 12.1.1 stock JBrowse and the Araport JBrowse.
_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: 404 in Chrome dev console on JBrowse requesting tracks.conf

Justin Clark-Casey-2
Hi Sam.  As far as I remember, JBrowse makes a number of calls to
possible config locations where some won't exist.  I don't believe that
it's a problem or that there's any further configuration that can be
done at those locations.

I presume you have a JBrowse set up where the track data is
pre-generated and served directly, rather than fetching data directly
from the JBrowse InterMine web services?

On 2017-03-03 19:41, Sam Hokin wrote:

> Hiya, devs. I've just noticed a seemingly benign 404 in the Chrome dev
> console from the report page JBrowse (but not in the Firefox dev
> console):
>
> intermine.js:1 ƒ InterMine JavaScript Library loaded
> report.do?id=4329650:5337 Using imtables: 2.0.0
> report.do?id=4329650:5356 Webservice is at version 19
> //peanutmine/service/jbrowse/config/130453/tracks.conf:1 GET
> https://mines.legumeinfo.org//peanutmine/service/jbrowse/config/130453/tracks.conf
> 404 (Not Found)
>
> Any suggestions? There seems to be no problem from this, but I thought
> I'd ask, since a 404 is a 404 and maybe there's some cool track config
> option I'm missing.
>
> FWIW, this is true on both the 12.1.1 stock JBrowse and the Araport
> JBrowse.
> _______________________________________________
> dev mailing list
> [hidden email]
> https://lists.intermine.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: 404 in Chrome dev console on JBrowse requesting tracks.conf

Sam Hokin-3
No, it's an empty JBrowse strictly pulling data from the IM web services. I thought that was the brilliant idea behind the JBrowse
displayer. :) Not a huge issue, just wondered if there's a tweak I should do.

On 03/10/2017 02:21 AM, [hidden email] wrote:

> Hi Sam.  As far as I remember, JBrowse makes a number of calls to possible config locations where some won't exist.  I don't believe
> that it's a problem or that there's any further configuration that can be done at those locations.
>
> I presume you have a JBrowse set up where the track data is pre-generated and served directly, rather than fetching data directly
> from the JBrowse InterMine web services?
>
> On 2017-03-03 19:41, Sam Hokin wrote:
>> Hiya, devs. I've just noticed a seemingly benign 404 in the Chrome dev
>> console from the report page JBrowse (but not in the Firefox dev
>> console):
>>
>> intermine.js:1 ƒ InterMine JavaScript Library loaded
>> report.do?id=4329650:5337 Using imtables: 2.0.0
>> report.do?id=4329650:5356 Webservice is at version 19
>> //peanutmine/service/jbrowse/config/130453/tracks.conf:1 GET
>> https://mines.legumeinfo.org//peanutmine/service/jbrowse/config/130453/tracks.conf
>> 404 (Not Found)
>>
>> Any suggestions? There seems to be no problem from this, but I thought
>> I'd ask, since a 404 is a 404 and maybe there's some cool track config
>> option I'm missing.
>>
>> FWIW, this is true on both the 12.1.1 stock JBrowse and the Araport JBrowse.
>> _______________________________________________
>> dev mailing list
>> [hidden email]
>> https://lists.intermine.org/mailman/listinfo/dev
>
_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: 404 in Chrome dev console on JBrowse requesting tracks.conf

Gos Micklem-3
On Mar 10 2017, Sam Hokin wrote:
> No, it's an empty JBrowse strictly pulling data from the IM web
> services. I thought that was the brilliant idea behind the JBrowse
> displayer. :)

Would be interested to hear about performance e.g. at the hackathon.

Cheers,

Gos


> On 03/10/2017 02:21 AM, [hidden email] wrote:
> >Hi Sam.  As far as I remember, JBrowse makes a number of calls to possible config locations where some won't exist.  I don't believe
> >that it's a problem or that there's any further configuration that can be done at those locations.
> >
> >I presume you have a JBrowse set up where the track data is pre-generated and served directly, rather than fetching data directly
> >from the JBrowse InterMine web services?
> >
> >On 2017-03-03 19:41, Sam Hokin wrote:
> >>Hiya, devs. I've just noticed a seemingly benign 404 in the Chrome dev
> >>console from the report page JBrowse (but not in the Firefox dev
> >>console):
> >>
> >>intermine.js:1 ƒ InterMine JavaScript Library loaded
> >>report.do?id=4329650:5337 Using imtables: 2.0.0
> >>report.do?id=4329650:5356 Webservice is at version 19
> >>//peanutmine/service/jbrowse/config/130453/tracks.conf:1 GET
> >>https://mines.legumeinfo.org//peanutmine/service/jbrowse/config/130453/tracks.conf
> >>404 (Not Found)
> >>
> >>Any suggestions? There seems to be no problem from this, but I thought
> >>I'd ask, since a 404 is a 404 and maybe there's some cool track config
> >>option I'm missing.
> >>
> >>FWIW, this is true on both the 12.1.1 stock JBrowse and the Araport JBrowse.
> >>_______________________________________________
> >>dev mailing list
> >>[hidden email]
> >>https://lists.intermine.org/mailman/listinfo/dev
> >
> _______________________________________________
> dev mailing list
> [hidden email]
> https://lists.intermine.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: 404 in Chrome dev console on JBrowse requesting tracks.conf

Sam Hokin-3
The JBrowse is on the same server as the mines, so I'm not really pushing any network constraints. Just supplying data from the IM
web services rather than JBrowse files. Works fine.

On 03/10/2017 09:48 AM, Gos Micklem wrote:

> On Mar 10 2017, Sam Hokin wrote:
>> No, it's an empty JBrowse strictly pulling data from the IM web
>> services. I thought that was the brilliant idea behind the JBrowse
>> displayer. :)
>
> Would be interested to hear about performance e.g. at the hackathon.
>
> Cheers,
>
> Gos
>
>
>> On 03/10/2017 02:21 AM, [hidden email] wrote:
>>> Hi Sam.  As far as I remember, JBrowse makes a number of calls to possible config locations where some won't exist.  I don't believe
>>> that it's a problem or that there's any further configuration that can be done at those locations.
>>>
>>> I presume you have a JBrowse set up where the track data is pre-generated and served directly, rather than fetching data directly
>> >from the JBrowse InterMine web services?
>>>
>>> On 2017-03-03 19:41, Sam Hokin wrote:
>>>> Hiya, devs. I've just noticed a seemingly benign 404 in the Chrome dev
>>>> console from the report page JBrowse (but not in the Firefox dev
>>>> console):
>>>>
>>>> intermine.js:1 ƒ InterMine JavaScript Library loaded
>>>> report.do?id=4329650:5337 Using imtables: 2.0.0
>>>> report.do?id=4329650:5356 Webservice is at version 19
>>>> //peanutmine/service/jbrowse/config/130453/tracks.conf:1 GET
>>>> https://mines.legumeinfo.org//peanutmine/service/jbrowse/config/130453/tracks.conf
>>>> 404 (Not Found)
>>>>
>>>> Any suggestions? There seems to be no problem from this, but I thought
>>>> I'd ask, since a 404 is a 404 and maybe there's some cool track config
>>>> option I'm missing.
>>>>
>>>> FWIW, this is true on both the 12.1.1 stock JBrowse and the Araport JBrowse.
>>>> _______________________________________________
>>>> dev mailing list
>>>> [hidden email]
>>>> https://lists.intermine.org/mailman/listinfo/dev
>>>
>> _______________________________________________
>> dev mailing list
>> [hidden email]
>> https://lists.intermine.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: 404 in Chrome dev console on JBrowse requesting tracks.conf

Gos Micklem-3
On Mar 10 2017, Sam Hokin wrote:
> The JBrowse is on the same server as the mines, so I'm not really
> pushing any network constraints. Just supplying data from the IM web
> services rather than JBrowse files. Works fine.

Great, good to know!

> On 03/10/2017 09:48 AM, Gos Micklem wrote:
> >On Mar 10 2017, Sam Hokin wrote:
> >>No, it's an empty JBrowse strictly pulling data from the IM web
> >>services. I thought that was the brilliant idea behind the JBrowse
> >>displayer. :)
> >
> >Would be interested to hear about performance e.g. at the hackathon.
> >
> >Cheers,
> >
> >Gos
> >
> >
> >>On 03/10/2017 02:21 AM, [hidden email] wrote:
> >>>Hi Sam.  As far as I remember, JBrowse makes a number of calls to possible config locations where some won't exist.  I don't believe
> >>>that it's a problem or that there's any further configuration that can be done at those locations.
> >>>
> >>>I presume you have a JBrowse set up where the track data is pre-generated and served directly, rather than fetching data directly
> >>>from the JBrowse InterMine web services?
> >>>
> >>>On 2017-03-03 19:41, Sam Hokin wrote:
> >>>>Hiya, devs. I've just noticed a seemingly benign 404 in the Chrome dev
> >>>>console from the report page JBrowse (but not in the Firefox dev
> >>>>console):
> >>>>
> >>>>intermine.js:1 ƒ InterMine JavaScript Library loaded
> >>>>report.do?id=4329650:5337 Using imtables: 2.0.0
> >>>>report.do?id=4329650:5356 Webservice is at version 19
> >>>>//peanutmine/service/jbrowse/config/130453/tracks.conf:1 GET
> >>>>https://mines.legumeinfo.org//peanutmine/service/jbrowse/config/130453/tracks.conf
> >>>>404 (Not Found)
> >>>>
> >>>>Any suggestions? There seems to be no problem from this, but I thought
> >>>>I'd ask, since a 404 is a 404 and maybe there's some cool track config
> >>>>option I'm missing.
> >>>>
> >>>>FWIW, this is true on both the 12.1.1 stock JBrowse and the Araport JBrowse.
> >>>>_______________________________________________
> >>>>dev mailing list
> >>>>[hidden email]
> >>>>https://lists.intermine.org/mailman/listinfo/dev
> >>>
> >>_______________________________________________
> >>dev mailing list
> >>[hidden email]
> >>https://lists.intermine.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev