AWS launch error

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

AWS launch error

David Kovalic
Enis,

I am having issues launching previously existing clusters today, here is some more info:
  • I go to https://launch.usegalaxy.org/launch
  • I fill in the required AWS credentials
  • I click on "Choose a saved cluster"
  • the page goes into a loop trying to retrieve the 'Saved Cluster' information to populate  the drop down list
  • I can terminate this loop by clicking on the "x"
  • I can enter the cluster name manually
  • The cluster bucket entered does exist on my S3
  • After entering the cluster name manually I click "Create a cluster"
  • The next page is shown "Please wait, your scalable cluster is starting on the Amazon - Virginia cloud."
  • I see no instance stared on the AWS console
I have similar issues on the new page "https://beta.launch.usegalaxy.org/", on this page my previous clusters are not shown.

Nothing has changed on my end, to my knoledge… Any ideas? Need any more information from my end?

lmk and thanks,

David



David Kovalic Ph.D.   PresidentAnalome
phone: +314.496.8808



On Fri, Nov 3, 2017 11:00 AM, [hidden email] wrote:

Send galaxy-dev mailing list submissions to

[hidden email]


To subscribe or unsubscribe via the World Wide Web, visit

https://lists.galaxyproject.org/listinfo/galaxy-dev

or, via email, send a message with subject or body 'help' to

[hidden email]


You can reach the person managing the list at

[hidden email]


When replying, please edit your Subject line so it is more specific

than "Re: Contents of galaxy-dev digest..."

HEY! This is important! If you reply to a thread in a digest, please

1. Change the subject of your response from "Galaxy-dev Digest Vol ..." to the original subject for the thread.

2. Strip out everything else in the digest that is not part of the thread you are responding to.


Why?

1. This will keep the subject meaningful. People will have some idea from the subject line if they should read it or not.

2. Not doing this greatly increases the number of emails that match search queries, but that aren't actually informative.Today's Topics:


1. Re: AWS launch error (Enis Afgan)

2. Enable viewing of large HTML files (Peter Briggs)

3. Re: Enable viewing of large HTML files (Martin Čech)

_______________________________________________

galaxy-dev mailing list

[hidden email]

https://lists.galaxyproject.org/listinfo/galaxy-dev


To search Galaxy mailing lists use the unified search at:

http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/
Reply | Threaded
Open this post in threaded view
|

Re: AWS launch error

Enis Afgan
Hi David, 
Do you perhaps have credentials stored on the beta server? If not, and don't mind storing them, you can try that. I'm not having an issue at the moment but I know Nuwan has done some changes recently that I did not catch up with yet. CC'ing him in case he has additional input. 

On Tue, Nov 7, 2017 at 12:53 PM, David Kovalic <[hidden email]> wrote:
Enis,

I am having issues launching previously existing clusters today, here is some more info:
  • I go to https://launch.usegalaxy.org/launch
  • I fill in the required AWS credentials
  • I click on "Choose a saved cluster"
  • the page goes into a loop trying to retrieve the 'Saved Cluster' information to populate  the drop down list
  • I can terminate this loop by clicking on the "x"
  • I can enter the cluster name manually
  • The cluster bucket entered does exist on my S3
  • After entering the cluster name manually I click "Create a cluster"
  • The next page is shown "Please wait, your scalable cluster is starting on the Amazon - Virginia cloud."
  • I see no instance stared on the AWS console
I have similar issues on the new page "https://beta.launch.usegalaxy.org/", on this page my previous clusters are not shown.

Nothing has changed on my end, to my knoledge… Any ideas? Need any more information from my end?

lmk and thanks,

David



David Kovalic Ph.D.   PresidentAnalome
phone: +314.496.8808



On Fri, Nov 3, 2017 11:00 AM, [hidden email] wrote:

Send galaxy-dev mailing list submissions to

[hidden email]


To subscribe or unsubscribe via the World Wide Web, visit

https://lists.galaxyproject.org/listinfo/galaxy-dev

or, via email, send a message with subject or body 'help' to

[hidden email]


You can reach the person managing the list at

[hidden email]


When replying, please edit your Subject line so it is more specific

than "Re: Contents of galaxy-dev digest..."

HEY! This is important! If you reply to a thread in a digest, please

1. Change the subject of your response from "Galaxy-dev Digest Vol ..." to the original subject for the thread.

2. Strip out everything else in the digest that is not part of the thread you are responding to.


Why?

1. This will keep the subject meaningful. People will have some idea from the subject line if they should read it or not.

2. Not doing this greatly increases the number of emails that match search queries, but that aren't actually informative.Today's Topics:


1. Re: AWS launch error (Enis Afgan)

2. Enable viewing of large HTML files (Peter Briggs)

3. Re: Enable viewing of large HTML files (Martin Čech)

_______________________________________________

galaxy-dev mailing list

[hidden email]

https://lists.galaxyproject.org/listinfo/galaxy-dev


To search Galaxy mailing lists use the unified search at:

http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/
Reply | Threaded
Open this post in threaded view
|

Re: AWS launch error

David Kovalic

Enis,

Yes our credentials are in the beta system.

Lmk if you need me to do anything to help troubleshoot.

Right now we are recreating systems through aws. Are there docs for running cloudman from cli? This would get us going in the short term.

David


On Wed, Nov 8, 2017, 6:33 PM Enis Afgan <[hidden email]> wrote:
Hi David, 
Do you perhaps have credentials stored on the beta server? If not, and don't mind storing them, you can try that. I'm not having an issue at the moment but I know Nuwan has done some changes recently that I did not catch up with yet. CC'ing him in case he has additional input. 

On Tue, Nov 7, 2017 at 12:53 PM, David Kovalic <[hidden email]> wrote:
Enis,

I am having issues launching previously existing clusters today, here is some more info:
  • I go to https://launch.usegalaxy.org/launch
  • I fill in the required AWS credentials
  • I click on "Choose a saved cluster"
  • the page goes into a loop trying to retrieve the 'Saved Cluster' information to populate  the drop down list
  • I can terminate this loop by clicking on the "x"
  • I can enter the cluster name manually
  • The cluster bucket entered does exist on my S3
  • After entering the cluster name manually I click "Create a cluster"
  • The next page is shown "Please wait, your scalable cluster is starting on the Amazon - Virginia cloud."
  • I see no instance stared on the AWS console
I have similar issues on the new page "https://beta.launch.usegalaxy.org/", on this page my previous clusters are not shown.

Nothing has changed on my end, to my knoledge… Any ideas? Need any more information from my end?

lmk and thanks,

David



David Kovalic Ph.D.   PresidentAnalome
phone: +314.496.8808



On Fri, Nov 3, 2017 11:00 AM, [hidden email] wrote:

Send galaxy-dev mailing list submissions to

[hidden email]


To subscribe or unsubscribe via the World Wide Web, visit

https://lists.galaxyproject.org/listinfo/galaxy-dev

or, via email, send a message with subject or body 'help' to

[hidden email]


You can reach the person managing the list at

[hidden email]


When replying, please edit your Subject line so it is more specific

than "Re: Contents of galaxy-dev digest..."

HEY! This is important! If you reply to a thread in a digest, please

1. Change the subject of your response from "Galaxy-dev Digest Vol ..." to the original subject for the thread.

2. Strip out everything else in the digest that is not part of the thread you are responding to.


Why?

1. This will keep the subject meaningful. People will have some idea from the subject line if they should read it or not.

2. Not doing this greatly increases the number of emails that match search queries, but that aren't actually informative.Today's Topics:


1. Re: AWS launch error (Enis Afgan)

2. Enable viewing of large HTML files (Peter Briggs)

3. Re: Enable viewing of large HTML files (Martin Čech)

_______________________________________________

galaxy-dev mailing list

[hidden email]

https://lists.galaxyproject.org/listinfo/galaxy-dev


To search Galaxy mailing lists use the unified search at:

http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/


To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/
--


David Kovalic Ph.D.   President, Analome
phone: +314.496.8808

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/
Reply | Threaded
Open this post in threaded view
|

Re: AWS launch error

David Kovalic

Enis,

To clarify, our credentials are in the beta system which dosn't work.

To me it seems like an aws authentication issue.

David


On Wed, Nov 8, 2017, 7:22 PM David Kovalic <[hidden email]> wrote:

Enis,

Yes our credentials are in the beta system.

Lmk if you need me to do anything to help troubleshoot.

Right now we are recreating systems through aws. Are there docs for running cloudman from cli? This would get us going in the short term.

David


On Wed, Nov 8, 2017, 6:33 PM Enis Afgan <[hidden email]> wrote:
Hi David, 
Do you perhaps have credentials stored on the beta server? If not, and don't mind storing them, you can try that. I'm not having an issue at the moment but I know Nuwan has done some changes recently that I did not catch up with yet. CC'ing him in case he has additional input. 

On Tue, Nov 7, 2017 at 12:53 PM, David Kovalic <[hidden email]> wrote:
Enis,

I am having issues launching previously existing clusters today, here is some more info:
  • I go to https://launch.usegalaxy.org/launch
  • I fill in the required AWS credentials
  • I click on "Choose a saved cluster"
  • the page goes into a loop trying to retrieve the 'Saved Cluster' information to populate  the drop down list
  • I can terminate this loop by clicking on the "x"
  • I can enter the cluster name manually
  • The cluster bucket entered does exist on my S3
  • After entering the cluster name manually I click "Create a cluster"
  • The next page is shown "Please wait, your scalable cluster is starting on the Amazon - Virginia cloud."
  • I see no instance stared on the AWS console
I have similar issues on the new page "https://beta.launch.usegalaxy.org/", on this page my previous clusters are not shown.

Nothing has changed on my end, to my knoledge… Any ideas? Need any more information from my end?

lmk and thanks,

David



David Kovalic Ph.D.   PresidentAnalome
phone: +314.496.8808



On Fri, Nov 3, 2017 11:00 AM, [hidden email] wrote:

Send galaxy-dev mailing list submissions to

[hidden email]


To subscribe or unsubscribe via the World Wide Web, visit

https://lists.galaxyproject.org/listinfo/galaxy-dev

or, via email, send a message with subject or body 'help' to

[hidden email]


You can reach the person managing the list at

[hidden email]


When replying, please edit your Subject line so it is more specific

than "Re: Contents of galaxy-dev digest..."

HEY! This is important! If you reply to a thread in a digest, please

1. Change the subject of your response from "Galaxy-dev Digest Vol ..." to the original subject for the thread.

2. Strip out everything else in the digest that is not part of the thread you are responding to.


Why?

1. This will keep the subject meaningful. People will have some idea from the subject line if they should read it or not.

2. Not doing this greatly increases the number of emails that match search queries, but that aren't actually informative.Today's Topics:


1. Re: AWS launch error (Enis Afgan)

2. Enable viewing of large HTML files (Peter Briggs)

3. Re: Enable viewing of large HTML files (Martin Čech)

_______________________________________________

galaxy-dev mailing list

[hidden email]

https://lists.galaxyproject.org/listinfo/galaxy-dev


To search Galaxy mailing lists use the unified search at:

http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/


To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/
--


David Kovalic Ph.D.   President, Analome
phone: +314.496.8808
--


David Kovalic Ph.D.   President, Analome
phone: +314.496.8808

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/
Reply | Threaded
Open this post in threaded view
|

Re: AWS launch error

Nuwan Goonasekera-2
Hi David,

I'm not much of a user of this functionality but I suspect that it's failing in the old launcher because you can't enter the cluster name manually as I understand it. You have to wait for the list of clusters to be retrieved, and then make the appropriate selection from the dropdown, which can be quite time consuming if you have a large number of clusters. This is because the dropdown displays the cloudman cluster name, but uses the aws bucket name as the key.

In the new launcher, a similar limitation exists - but I also suspect there's a bug - we are keying on an incorrect value. I've created a new issue to track this: https://github.com/galaxyproject/cloudlaunch-ui/issues/21

cheers,
/Nuwan

On Thu, Nov 9, 2017 at 6:55 AM, David Kovalic <[hidden email]> wrote:

Enis,

To clarify, our credentials are in the beta system which dosn't work.

To me it seems like an aws authentication issue.

David


On Wed, Nov 8, 2017, 7:22 PM David Kovalic <[hidden email]> wrote:

Enis,

Yes our credentials are in the beta system.

Lmk if you need me to do anything to help troubleshoot.

Right now we are recreating systems through aws. Are there docs for running cloudman from cli? This would get us going in the short term.

David


On Wed, Nov 8, 2017, 6:33 PM Enis Afgan <[hidden email]> wrote:
Hi David, 
Do you perhaps have credentials stored on the beta server? If not, and don't mind storing them, you can try that. I'm not having an issue at the moment but I know Nuwan has done some changes recently that I did not catch up with yet. CC'ing him in case he has additional input. 

On Tue, Nov 7, 2017 at 12:53 PM, David Kovalic <[hidden email]> wrote:
Enis,

I am having issues launching previously existing clusters today, here is some more info:
  • I go to https://launch.usegalaxy.org/launch
  • I fill in the required AWS credentials
  • I click on "Choose a saved cluster"
  • the page goes into a loop trying to retrieve the 'Saved Cluster' information to populate  the drop down list
  • I can terminate this loop by clicking on the "x"
  • I can enter the cluster name manually
  • The cluster bucket entered does exist on my S3
  • After entering the cluster name manually I click "Create a cluster"
  • The next page is shown "Please wait, your scalable cluster is starting on the Amazon - Virginia cloud."
  • I see no instance stared on the AWS console
I have similar issues on the new page "https://beta.launch.usegalaxy.org/", on this page my previous clusters are not shown.

Nothing has changed on my end, to my knoledge… Any ideas? Need any more information from my end?

lmk and thanks,

David



David Kovalic Ph.D.   PresidentAnalome
phone: +314.496.8808



On Fri, Nov 3, 2017 11:00 AM, [hidden email] wrote:

Send galaxy-dev mailing list submissions to

[hidden email]


To subscribe or unsubscribe via the World Wide Web, visit

https://lists.galaxyproject.org/listinfo/galaxy-dev

or, via email, send a message with subject or body 'help' to

[hidden email]


You can reach the person managing the list at

[hidden email]


When replying, please edit your Subject line so it is more specific

than "Re: Contents of galaxy-dev digest..."

HEY! This is important! If you reply to a thread in a digest, please

1. Change the subject of your response from "Galaxy-dev Digest Vol ..." to the original subject for the thread.

2. Strip out everything else in the digest that is not part of the thread you are responding to.


Why?

1. This will keep the subject meaningful. People will have some idea from the subject line if they should read it or not.

2. Not doing this greatly increases the number of emails that match search queries, but that aren't actually informative.Today's Topics:


1. Re: AWS launch error (Enis Afgan)

2. Enable viewing of large HTML files (Peter Briggs)

3. Re: Enable viewing of large HTML files (Martin Čech)

_______________________________________________

galaxy-dev mailing list

[hidden email]

https://lists.galaxyproject.org/listinfo/galaxy-dev


To search Galaxy mailing lists use the unified search at:

http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/


To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/
--


David Kovalic Ph.D.   President, Analome
phone: +314.496.8808
--


David Kovalic Ph.D.   President, Analome
phone: +314.496.8808


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/