[BioMart Users] Problem with snp mart

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[BioMart Users] Problem with snp mart

Saskia Freytag
Hello,

I am new to biomaRt. My question might therefore have a really obvious
solution.

When I tried running the following command in R, R crashed each time.

library(biomaRt)
snp = useMart("snp", dataset="hsapiens_snp")
ensemblref<-getBM(attributes= c("refsnp_id","ensembl_gene_stable_id"),
filters=c("ensembl_gene"), values="ENSG00000067225", mart=snp)

What am I doing wrong?

Thank you so much in advance for your help,

Saskia Freytag
--

Saskia Freytag
Department of Genetic Epidemiology
Georg-August University Göttingen
Humboltallee 32
37073 Göttingen
Germany

Office Phone: +49 551 39 14234
_______________________________________________
Users mailing list
[hidden email]
https://lists.biomart.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: [BioMart Users] Problem with snp mart

Steffen Durinck-2
Hi Saskia,
I tried this query in R and it indeed seems not to return any result. Using the BioMart web interface at www.biomart.org, this query take a very long time to return a result and that might be why you have to wait a long time in R to get something back as well.  We have to ask the BioMart developers why this is using the following XML query.
<?xml version='1.0' encoding='UTF-8'?><!DOCTYPE Query><Query  virtualSchemaName = 'default' uniqueRows = '1' count = '0' datasetConfigVersion = '0.6' requestid= "biomaRt"> <Dataset name = 'hsapiens_snp'><Attribute name = 'refsnp_id'/><Attribute name = 'ensembl_gene_stable_id'/><Filter name = 'ensembl_gene' value = 'ENSG00000067225' /></Dataset></Query>
If you query the previous version of Ensembl (v61), the query returns a result very quickly, so that might be a solution for you until the problem with the current mart is resolved:
> snp=useMart( 'ENSEMBL_MART_SNP',dataset='hsapiens_snp',host="feb2011.archive.ensembl.org")
> ensemblref<-getBM(attributes= c("refsnp_id","ensembl_gene_stable_id"),
filters=c("ensembl_gene"), values="ENSG00000067225", mart=snp)
> head(ensemblref)
  refsnp_id ensembl_gene_stable_id
1   rs10514        ENSG00000067225
2  rs762804        ENSG00000067225
3  rs890312        ENSG00000067225
4  rs916133        ENSG00000067225
5 rs1037680        ENSG00000067225
6 rs1062430        ENSG00000067225


Cheers,
Steffen

Hello,

I am new to biomaRt. My question might therefore have a really obvious 
solution.

When I tried running the following command in R, R crashed each time.

library(biomaRt)
snp = useMart("snp", dataset="hsapiens_snp")
ensemblref<-getBM(attributes= c("refsnp_id","ensembl_gene_stable_id"),
filters=c("ensembl_gene"), values="ENSG00000067225", mart=snp)

What am I doing wrong?

Thank you so much in advance for your help,

Saskia Freytag
-- 

Saskia Freytag
Department of Genetic Epidemiology
Georg-August University Göttingen
Humboltallee 32
37073 Göttingen
Germany

Office Phone: +49 551 39 14234

_______________________________________________
Users mailing list
[hidden email]
https://lists.biomart.org/mailman/listinfo/users