[BioMart Users] Registry 0.7 to 0.8

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[BioMart Users] Registry 0.7 to 0.8

Uma Maheswari
Hi All,

I am trying to create a registery file (0.8) for Ensembl_genomes mart. I
am able to import the 0.7 register and save it using
release-0_8-candidate_6 martconfigurator.  I am able to see the two
(registry.xml and the .registry) new registry file. But I am not able to
open the saved file "0.8 registery file". I don't get  any error
message, I am not sure if I am missing something,

Basically I am trying to add a new core database to the existing mart
using release-0_8-candidate_6/martconfigurator, which will be the
easiest way do.

Thanks for the help
Uma
_______________________________________________
Users mailing list
[hidden email]
https://lists.biomart.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: [BioMart Users] Registry 0.7 to 0.8

Syed Haider
Hi Uma,

Have you tried adding your new core database independently ? what
happens when you add the source schema and then materialise it into a
mart. this needs to work independently, first and foremost. Let me know
how you get on with this.

Best,
Syed

On 04/10/2011 16:34, Uma Maheswari wrote:

> Hi All,
>
> I am trying to create a registery file (0.8) for Ensembl_genomes mart. I
> am able to import the 0.7 register and save it using
> release-0_8-candidate_6 martconfigurator.  I am able to see the two
> (registry.xml and the .registry) new registry file. But I am not able to
> open the saved file "0.8 registery file". I don't get  any error
> message, I am not sure if I am missing something,
>
> Basically I am trying to add a new core database to the existing mart
> using release-0_8-candidate_6/martconfigurator, which will be the
> easiest way do.
>
> Thanks for the help
> Uma
> _______________________________________________
> Users mailing list
> [hidden email]
> https://lists.biomart.org/mailman/listinfo/users
_______________________________________________
Users mailing list
[hidden email]
https://lists.biomart.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: [BioMart Users] Registry 0.7 to 0.8

Uma Maheswari
Hi Syed,

I tried adding just one core database and selected the main
tables(gene,transcript,translation) and when I try to materialise, I got
an error message "An error occurred while building mart (see logs for
more information)"  but the log files in /dist/logs/ are empty.  But in
this process we are not specify the biomart schema etc.  Should a add
access points before materializing? In 0.7 we used a xml file to give
all the specifications.

thanks for the help
Uma


On 05/10/11 13:59, Syed Haider wrote:

> Hi Uma,
>
> Have you tried adding your new core database independently ? what
> happens when you add the source schema and then materialise it into a
> mart. this needs to work independently, first and foremost. Let me
> know how you get on with this.
>
> Best,
> Syed
>
> On 04/10/2011 16:34, Uma Maheswari wrote:
>> Hi All,
>>
>> I am trying to create a registery file (0.8) for Ensembl_genomes mart. I
>> am able to import the 0.7 register and save it using
>> release-0_8-candidate_6 martconfigurator.  I am able to see the two
>> (registry.xml and the .registry) new registry file. But I am not able to
>> open the saved file "0.8 registery file". I don't get  any error
>> message, I am not sure if I am missing something,
>>
>> Basically I am trying to add a new core database to the existing mart
>> using release-0_8-candidate_6/martconfigurator, which will be the
>> easiest way do.
>>
>> Thanks for the help
>> Uma
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> https://lists.biomart.org/mailman/listinfo/users

_______________________________________________
Users mailing list
[hidden email]
https://lists.biomart.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: [BioMart Users] Registry 0.7 to 0.8

Syed Haider
Hi Uma,

few things you need to make sure if they are correct. try materialising
only gene dataset first ? Make sure both source schema and target mart
should be on same database server. Try generating only SQL first instead
of creating a mart directly, see if this works ?

Let me know how you get on with these options and which ones do work.

Best,
Syed



On 05/10/2011 14:23, Uma Maheswari wrote:

> Hi Syed,
>
> I tried adding just one core database and selected the main
> tables(gene,transcript,translation) and when I try to materialise, I got
> an error message "An error occurred while building mart (see logs for
> more information)"  but the log files in /dist/logs/ are empty.  But in
> this process we are not specify the biomart schema etc.  Should a add
> access points before materializing? In 0.7 we used a xml file to give
> all the specifications.
>
> thanks for the help
> Uma
>
>
> On 05/10/11 13:59, Syed Haider wrote:
>> Hi Uma,
>>
>> Have you tried adding your new core database independently ? what
>> happens when you add the source schema and then materialise it into a
>> mart. this needs to work independently, first and foremost. Let me
>> know how you get on with this.
>>
>> Best,
>> Syed
>>
>> On 04/10/2011 16:34, Uma Maheswari wrote:
>>> Hi All,
>>>
>>> I am trying to create a registery file (0.8) for Ensembl_genomes mart. I
>>> am able to import the 0.7 register and save it using
>>> release-0_8-candidate_6 martconfigurator.  I am able to see the two
>>> (registry.xml and the .registry) new registry file. But I am not able to
>>> open the saved file "0.8 registery file". I don't get  any error
>>> message, I am not sure if I am missing something,
>>>
>>> Basically I am trying to add a new core database to the existing mart
>>> using release-0_8-candidate_6/martconfigurator, which will be the
>>> easiest way do.
>>>
>>> Thanks for the help
>>> Uma
>>> _______________________________________________
>>> Users mailing list
>>> [hidden email]
>>> https://lists.biomart.org/mailman/listinfo/users
>
> _______________________________________________
> Users mailing list
> [hidden email]
> https://lists.biomart.org/mailman/listinfo/users
_______________________________________________
Users mailing list
[hidden email]
https://lists.biomart.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: [BioMart Users] Registry 0.7 to 0.8

Uma Maheswari
Hi Syed,

I am using the same database server for both source and target. I tried
materialising only the gene dataset first, if I send it to the mart
runner, I get the same error as before. but I am able to send the SQL to
a text file and manually import it to the database and I can see 7
tables getting created.

+---------------------------------------------+
| Tables_in_uma_mart_11                       |
+---------------------------------------------+
| gene                                        |
| gene__alt_allele                            |
| gene__gene_attrib                           |
| gene__operon_transcript_gene                |
| gene__splicing_event                        |
| gene__transcript                            |
| gene__unconventional_transcript_association |
+---------------------------------------------+

thanks
Uma


On 07/10/11 12:26, Syed Haider wrote:

> Hi Uma,
>
> few things you need to make sure if they are correct. try
> materialising only gene dataset first ? Make sure both source schema
> and target mart should be on same database server. Try generating only
> SQL first instead of creating a mart directly, see if this works ?
>
> Let me know how you get on with these options and which ones do work.
>
> Best,
> Syed
>
>
>
> On 05/10/2011 14:23, Uma Maheswari wrote:
>> Hi Syed,
>>
>> I tried adding just one core database and selected the main
>> tables(gene,transcript,translation) and when I try to materialise, I got
>> an error message "An error occurred while building mart (see logs for
>> more information)"  but the log files in /dist/logs/ are empty.  But in
>> this process we are not specify the biomart schema etc.  Should a add
>> access points before materializing? In 0.7 we used a xml file to give
>> all the specifications.
>>
>> thanks for the help
>> Uma
>>
>>
>> On 05/10/11 13:59, Syed Haider wrote:
>>> Hi Uma,
>>>
>>> Have you tried adding your new core database independently ? what
>>> happens when you add the source schema and then materialise it into a
>>> mart. this needs to work independently, first and foremost. Let me
>>> know how you get on with this.
>>>
>>> Best,
>>> Syed
>>>
>>> On 04/10/2011 16:34, Uma Maheswari wrote:
>>>> Hi All,
>>>>
>>>> I am trying to create a registery file (0.8) for Ensembl_genomes
>>>> mart. I
>>>> am able to import the 0.7 register and save it using
>>>> release-0_8-candidate_6 martconfigurator.  I am able to see the two
>>>> (registry.xml and the .registry) new registry file. But I am not
>>>> able to
>>>> open the saved file "0.8 registery file". I don't get  any error
>>>> message, I am not sure if I am missing something,
>>>>
>>>> Basically I am trying to add a new core database to the existing mart
>>>> using release-0_8-candidate_6/martconfigurator, which will be the
>>>> easiest way do.
>>>>
>>>> Thanks for the help
>>>> Uma
>>>> _______________________________________________
>>>> Users mailing list
>>>> [hidden email]
>>>> https://lists.biomart.org/mailman/listinfo/users
>>
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> https://lists.biomart.org/mailman/listinfo/users

_______________________________________________
Users mailing list
[hidden email]
https://lists.biomart.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: [BioMart Users] Registry 0.7 to 0.8

Syed Haider-2
Cool, that suggests to me that transformation algorithm as well as SQL
generation works just fine. Could you please go through the martrunner
section in the documentation and see if you have got everything setup
correctly e.g db connection parameters.



On 07/10/2011 13:50, Uma Maheswari wrote:

> Hi Syed,
>
> I am using the same database server for both source and target. I tried
> materialising only the gene dataset first, if I send it to the mart
> runner, I get the same error as before. but I am able to send the SQL to
> a text file and manually import it to the database and I can see 7
> tables getting created.
>
> +---------------------------------------------+
> | Tables_in_uma_mart_11                       |
> +---------------------------------------------+
> | gene                                        |
> | gene__alt_allele                            |
> | gene__gene_attrib                           |
> | gene__operon_transcript_gene                |
> | gene__splicing_event                        |
> | gene__transcript                            |
> | gene__unconventional_transcript_association |
> +---------------------------------------------+
>
> thanks
> Uma
>
>
> On 07/10/11 12:26, Syed Haider wrote:
>> Hi Uma,
>>
>> few things you need to make sure if they are correct. try
>> materialising only gene dataset first ? Make sure both source schema
>> and target mart should be on same database server. Try generating only
>> SQL first instead of creating a mart directly, see if this works ?
>>
>> Let me know how you get on with these options and which ones do work.
>>
>> Best,
>> Syed
>>
>>
>>
>> On 05/10/2011 14:23, Uma Maheswari wrote:
>>> Hi Syed,
>>>
>>> I tried adding just one core database and selected the main
>>> tables(gene,transcript,translation) and when I try to materialise, I got
>>> an error message "An error occurred while building mart (see logs for
>>> more information)"  but the log files in /dist/logs/ are empty.  But in
>>> this process we are not specify the biomart schema etc.  Should a add
>>> access points before materializing? In 0.7 we used a xml file to give
>>> all the specifications.
>>>
>>> thanks for the help
>>> Uma
>>>
>>>
>>> On 05/10/11 13:59, Syed Haider wrote:
>>>> Hi Uma,
>>>>
>>>> Have you tried adding your new core database independently ? what
>>>> happens when you add the source schema and then materialise it into a
>>>> mart. this needs to work independently, first and foremost. Let me
>>>> know how you get on with this.
>>>>
>>>> Best,
>>>> Syed
>>>>
>>>> On 04/10/2011 16:34, Uma Maheswari wrote:
>>>>> Hi All,
>>>>>
>>>>> I am trying to create a registery file (0.8) for Ensembl_genomes
>>>>> mart. I
>>>>> am able to import the 0.7 register and save it using
>>>>> release-0_8-candidate_6 martconfigurator.  I am able to see the two
>>>>> (registry.xml and the .registry) new registry file. But I am not
>>>>> able to
>>>>> open the saved file "0.8 registery file". I don't get  any error
>>>>> message, I am not sure if I am missing something,
>>>>>
>>>>> Basically I am trying to add a new core database to the existing mart
>>>>> using release-0_8-candidate_6/martconfigurator, which will be the
>>>>> easiest way do.
>>>>>
>>>>> Thanks for the help
>>>>> Uma
>>>>> _______________________________________________
>>>>> Users mailing list
>>>>> [hidden email]
>>>>> https://lists.biomart.org/mailman/listinfo/users
>>>
>>> _______________________________________________
>>> Users mailing list
>>> [hidden email]
>>> https://lists.biomart.org/mailman/listinfo/users
>
> _______________________________________________
> Users mailing list
> [hidden email]
> https://lists.biomart.org/mailman/listinfo/users
_______________________________________________
Users mailing list
[hidden email]
https://lists.biomart.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: [BioMart Users] Registry 0.7 to 0.8

Uma Maheswari
Hi Syed,

Sorry, I think the problem was with the port number, I restarted the
martrunner with a different port number and it works now, it also works
for genes,transcripts and translation together.  For adding a new core
to the existing mart database, I tried importing them from registry 0.7
to 0.8, but not able to load back the 0.8 saved registry and also what
will be the best way to add few new core to a existing mart (0.7) in 0.8?

thanks a lot for your help
Uma


On 07/10/11 13:59, Syed Haider wrote:

> Cool, that suggests to me that transformation algorithm as well as SQL
> generation works just fine. Could you please go through the martrunner
> section in the documentation and see if you have got everything setup
> correctly e.g db connection parameters.
>
>
>
> On 07/10/2011 13:50, Uma Maheswari wrote:
>> Hi Syed,
>>
>> I am using the same database server for both source and target. I tried
>> materialising only the gene dataset first, if I send it to the mart
>> runner, I get the same error as before. but I am able to send the SQL to
>> a text file and manually import it to the database and I can see 7
>> tables getting created.
>>
>> +---------------------------------------------+
>> | Tables_in_uma_mart_11                       |
>> +---------------------------------------------+
>> | gene                                        |
>> | gene__alt_allele                            |
>> | gene__gene_attrib                           |
>> | gene__operon_transcript_gene                |
>> | gene__splicing_event                        |
>> | gene__transcript                            |
>> | gene__unconventional_transcript_association |
>> +---------------------------------------------+
>>
>> thanks
>> Uma
>>
>>
>> On 07/10/11 12:26, Syed Haider wrote:
>>> Hi Uma,
>>>
>>> few things you need to make sure if they are correct. try
>>> materialising only gene dataset first ? Make sure both source schema
>>> and target mart should be on same database server. Try generating only
>>> SQL first instead of creating a mart directly, see if this works ?
>>>
>>> Let me know how you get on with these options and which ones do work.
>>>
>>> Best,
>>> Syed
>>>
>>>
>>>
>>> On 05/10/2011 14:23, Uma Maheswari wrote:
>>>> Hi Syed,
>>>>
>>>> I tried adding just one core database and selected the main
>>>> tables(gene,transcript,translation) and when I try to materialise,
>>>> I got
>>>> an error message "An error occurred while building mart (see logs for
>>>> more information)"  but the log files in /dist/logs/ are empty.  
>>>> But in
>>>> this process we are not specify the biomart schema etc.  Should a add
>>>> access points before materializing? In 0.7 we used a xml file to give
>>>> all the specifications.
>>>>
>>>> thanks for the help
>>>> Uma
>>>>
>>>>
>>>> On 05/10/11 13:59, Syed Haider wrote:
>>>>> Hi Uma,
>>>>>
>>>>> Have you tried adding your new core database independently ? what
>>>>> happens when you add the source schema and then materialise it into a
>>>>> mart. this needs to work independently, first and foremost. Let me
>>>>> know how you get on with this.
>>>>>
>>>>> Best,
>>>>> Syed
>>>>>
>>>>> On 04/10/2011 16:34, Uma Maheswari wrote:
>>>>>> Hi All,
>>>>>>
>>>>>> I am trying to create a registery file (0.8) for Ensembl_genomes
>>>>>> mart. I
>>>>>> am able to import the 0.7 register and save it using
>>>>>> release-0_8-candidate_6 martconfigurator.  I am able to see the two
>>>>>> (registry.xml and the .registry) new registry file. But I am not
>>>>>> able to
>>>>>> open the saved file "0.8 registery file". I don't get  any error
>>>>>> message, I am not sure if I am missing something,
>>>>>>
>>>>>> Basically I am trying to add a new core database to the existing
>>>>>> mart
>>>>>> using release-0_8-candidate_6/martconfigurator, which will be the
>>>>>> easiest way do.
>>>>>>
>>>>>> Thanks for the help
>>>>>> Uma
>>>>>> _______________________________________________
>>>>>> Users mailing list
>>>>>> [hidden email]
>>>>>> https://lists.biomart.org/mailman/listinfo/users
>>>>
>>>> _______________________________________________
>>>> Users mailing list
>>>> [hidden email]
>>>> https://lists.biomart.org/mailman/listinfo/users
>>
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> https://lists.biomart.org/mailman/listinfo/users

_______________________________________________
Users mailing list
[hidden email]
https://lists.biomart.org/mailman/listinfo/users