Biomart XML Registry Question

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Biomart XML Registry Question

vilente
Hi all,

I was wondering as I still haven't found a solid solution to this problem yet,
if I was able to download/query Biomart correctly with this Registry:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE MartRegistry>
<MartRegistry>

<MartURLLocation
                    name         = "ensembl"
                    displayName  = "ensembl"
                    host         = "www.biomart.org"
                    port         = "80"
                    visible      = "1"
                    default      = ""
                    includeDatasets = "btaurus_gene_ensembl"
                    martUser     = ""
/>

</MartRegistry>

What exactly do I need to change in my registry in order to download from the
SNP database?  I tried different name/displayName/includeDatasets (like
btaurus_snp) but to no avail, please help, thank you.

Dzu

Reply | Threaded
Open this post in threaded view
|

Re: Biomart XML Registry Question

Jonathan Guberman
Please replace the MartURLLocation section with the following:

<MartDBLocation 
databaseType="mysql" 
database="snp_mart_59" 
name="snp" 
displayName="ENSEMBL VARIATION 59 (SANGER UK)" 
port="5316" 
schema="snp_mart_59" 
user="anonymous" 
password="" 
visible="1" 
default="0"
martUser="" 
includeDatasets="" 
/>

Jonathan Guberman, PhD
Application Programmer

Ontario Institute for Cancer Research
MaRS Centre, South Tower
101 College Street, Suite 800
TorontoOntarioCanada M5G 0A3

Tel:         647-260-7818
Toll-free: 1-866-678-6427

On 2010-10-25, at 2:48 PM, <[hidden email]> <[hidden email]> wrote:

Hi all,

I was wondering as I still haven't found a solid solution to this problem yet,
if I was able to download/query Biomart correctly with this Registry:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE MartRegistry>
<MartRegistry>

<MartURLLocation
                   name         = "ensembl"
                   displayName  = "ensembl"
                   host         = "www.biomart.org"
                   port         = "80"
                   visible      = "1"
                   default      = ""
                   includeDatasets = "btaurus_gene_ensembl"
                   martUser     = ""
/>

</MartRegistry>

What exactly do I need to change in my registry in order to download from the
SNP database?  I tried different name/displayName/includeDatasets (like
btaurus_snp) but to no avail, please help, thank you.

Dzu


Reply | Threaded
Open this post in threaded view
|

Re: Biomart XML Registry Question

Syed Haider
just correcting the email client's mistake, please see below



On 25/10/2010 20:10, Jonathan Guberman wrote:

> Please replace the MartURLLocation section with the following:
>
> <MartDBLocation
> databaseType="mysql"
> host="martdb.ensembl.org<http://martdb.ensembl.org>"

^^^^^^
host="martdb.ensembl.org"

> database="snp_mart_59"
> name="snp"
> displayName="ENSEMBL VARIATION 59 (SANGER UK)"
> port="5316"
> schema="snp_mart_59"
> user="anonymous"
> password=""
> visible="1"
> default="0"
> martUser=""
> includeDatasets=""
> />
>

cheers
Syed

> Jonathan Guberman, PhD
> Application Programmer
>
> Ontario Institute for Cancer Research
> MaRS Centre, South Tower
> 101 College Street, Suite 800
> Toronto, Ontario, Canada M5G 0A3
>
> Tel:         647-260-7818
> Toll-free: 1-866-678-6427
> www.oicr.on.ca<http://www.oicr.on.ca>
>
> On 2010-10-25, at 2:48 PM,<[hidden email]<mailto:[hidden email]>>  <[hidden email]<mailto:[hidden email]>>  wrote:
>
> Hi all,
>
> I was wondering as I still haven't found a solid solution to this problem yet,
> if I was able to download/query Biomart correctly with this Registry:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <!DOCTYPE MartRegistry>
> <MartRegistry>
>
> <MartURLLocation
>                     name         = "ensembl"
>                     displayName  = "ensembl"
>                     host         = "www.biomart.org<http://www.biomart.org>"
>                     port         = "80"
>                     visible      = "1"
>                     default      = ""
>                     includeDatasets = "btaurus_gene_ensembl"
>                     martUser     = ""
> />
>
> </MartRegistry>
>
> What exactly do I need to change in my registry in order to download from the
> SNP database?  I tried different name/displayName/includeDatasets (like
> btaurus_snp) but to no avail, please help, thank you.
>
> Dzu
>
>
>
suo
Reply | Threaded
Open this post in threaded view
|

Martview starting problem

suo
In reply to this post by vilente
Hello all,

There is a problem with staring Martview (RHEL5 and MySQL5):
"Safari can’t open the page “http://192.168.*.*:9002/biomart/martview” because Safari can’t connect to the server “192.168.*.*”."

Port 9002 is opened in Iptable.

Change owner/group of /root/biomart-perl to apache/apache with 755

No errors recorded after this change.

But port 9002 is not active:
tcp        0      0 :::80                       :::*                        LISTEN      19456/httpd        
tcp        0      0 :::443                      :::*                        LISTEN      19456/httpd  

Thanks in advance!



     
Reply | Threaded
Open this post in threaded view
|

Re: Martview starting problem

Syed Haider
hi Suo,

have you seen the log files under biomart-perl/logs/ ?

what do they suggest ?

Best,
Syed

On 25/10/2010 22:35, suo wrote:

> Hello all,
>
> There is a problem with staring Martview (RHEL5 and MySQL5):
> "Safari can’t open the page “http://192.168.*.*:9002/biomart/martview” because Safari can’t connect to the server “192.168.*.*”."
>
> Port 9002 is opened in Iptable.
>
> Change owner/group of /root/biomart-perl to apache/apache with 755
>
> No errors recorded after this change.
>
> But port 9002 is not active:
> tcp        0      0 :::80                       :::*                        LISTEN      19456/httpd
> tcp        0      0 :::443                      :::*                        LISTEN      19456/httpd
>
> Thanks in advance!
>
>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Biomart XML Registry Question

vilente
In reply to this post by Syed Haider
Hi,

I replaced the file and now I get this little error when I run the example perl
script from Biomart:

....(linking) 100%
....(sorting) 100%
....(clustering) 1/1 - 0 remain
....(resolving) 100%
Dataset default.btaurus_snp not found in registry

Should the virtualSchemaName be different in the perl script (since it's set to
default right now)?  I'm sorry I'm still pretty new to all of this, thank you.

Dzu

Quoting Syed Haider <[hidden email]>:

> just correcting the email client's mistake, please see below
>
>
>
> On 25/10/2010 20:10, Jonathan Guberman wrote:
>
> > Please replace the MartURLLocation section with the following:
> >
> > <MartDBLocation
> > databaseType="mysql"
> > host="martdb.ensembl.org<http://martdb.ensembl.org>"
>
> ^^^^^^
> host="martdb.ensembl.org"
>
> > database="snp_mart_59"
> > name="snp"
> > displayName="ENSEMBL VARIATION 59 (SANGER UK)"
> > port="5316"
> > schema="snp_mart_59"
> > user="anonymous"
> > password=""
> > visible="1"
> > default="0"
> > martUser=""
> > includeDatasets=""
> > />
> >
>
> cheers
> Syed
>
> > Jonathan Guberman, PhD
> > Application Programmer
> >
> > Ontario Institute for Cancer Research
> > MaRS Centre, South Tower
> > 101 College Street, Suite 800
> > Toronto, Ontario, Canada M5G 0A3
> >
> > Tel:         647-260-7818
> > Toll-free: 1-866-678-6427
> > www.oicr.on.ca<http://www.oicr.on.ca>
> >
> > On 2010-10-25, at 2:48 PM,<[hidden email]<mailto:[hidden email]>>
> <[hidden email]<mailto:[hidden email]>>  wrote:
> >
> > Hi all,
> >
> > I was wondering as I still haven't found a solid solution to this problem
> yet,
> > if I was able to download/query Biomart correctly with this Registry:
> >
> > <?xml version="1.0" encoding="UTF-8"?>
> > <!DOCTYPE MartRegistry>
> > <MartRegistry>
> >
> > <MartURLLocation
> >                     name         = "ensembl"
> >                     displayName  = "ensembl"
> >                     host         =
> "www.biomart.org<http://www.biomart.org>"
> >                     port         = "80"
> >                     visible      = "1"
> >                     default      = ""
> >                     includeDatasets = "btaurus_gene_ensembl"
> >                     martUser     = ""
> > />
> >
> > </MartRegistry>
> >
> > What exactly do I need to change in my registry in order to download from
> the
> > SNP database?  I tried different name/displayName/includeDatasets (like
> > btaurus_snp) but to no avail, please help, thank you.
> >
> > Dzu
> >
> >
> >
>


Reply | Threaded
Open this post in threaded view
|

Re: Biomart XML Registry Question

Syed Haider
Please send me your perl script and registry file (off the list),

thanks
Syed

On 26/10/2010 17:45, [hidden email] wrote:

> Hi,
>
> I replaced the file and now I get this little error when I run the example perl
> script from Biomart:
>
> ....(linking) 100%
> ....(sorting) 100%
> ....(clustering) 1/1 - 0 remain
> ....(resolving) 100%
> Dataset default.btaurus_snp not found in registry
>
> Should the virtualSchemaName be different in the perl script (since it's set to
> default right now)?  I'm sorry I'm still pretty new to all of this, thank you.
>
> Dzu
>
> Quoting Syed Haider<[hidden email]>:
>
>> just correcting the email client's mistake, please see below
>>
>>
>>
>> On 25/10/2010 20:10, Jonathan Guberman wrote:
>>
>>> Please replace the MartURLLocation section with the following:
>>>
>>> <MartDBLocation
>>> databaseType="mysql"
>>> host="martdb.ensembl.org<http://martdb.ensembl.org>"
>>
>> ^^^^^^
>> host="martdb.ensembl.org"
>>
>>> database="snp_mart_59"
>>> name="snp"
>>> displayName="ENSEMBL VARIATION 59 (SANGER UK)"
>>> port="5316"
>>> schema="snp_mart_59"
>>> user="anonymous"
>>> password=""
>>> visible="1"
>>> default="0"
>>> martUser=""
>>> includeDatasets=""
>>> />
>>>
>>
>> cheers
>> Syed
>>
>>> Jonathan Guberman, PhD
>>> Application Programmer
>>>
>>> Ontario Institute for Cancer Research
>>> MaRS Centre, South Tower
>>> 101 College Street, Suite 800
>>> Toronto, Ontario, Canada M5G 0A3
>>>
>>> Tel:         647-260-7818
>>> Toll-free: 1-866-678-6427
>>> www.oicr.on.ca<http://www.oicr.on.ca>
>>>
>>> On 2010-10-25, at 2:48 PM,<[hidden email]<mailto:[hidden email]>>
>> <[hidden email]<mailto:[hidden email]>>   wrote:
>>>
>>> Hi all,
>>>
>>> I was wondering as I still haven't found a solid solution to this problem
>> yet,
>>> if I was able to download/query Biomart correctly with this Registry:
>>>
>>> <?xml version="1.0" encoding="UTF-8"?>
>>> <!DOCTYPE MartRegistry>
>>> <MartRegistry>
>>>
>>> <MartURLLocation
>>>                      name         = "ensembl"
>>>                      displayName  = "ensembl"
>>>                      host         =
>> "www.biomart.org<http://www.biomart.org>"
>>>                      port         = "80"
>>>                      visible      = "1"
>>>                      default      = ""
>>>                      includeDatasets = "btaurus_gene_ensembl"
>>>                      martUser     = ""
>>> />
>>>
>>> </MartRegistry>
>>>
>>> What exactly do I need to change in my registry in order to download from
>> the
>>> SNP database?  I tried different name/displayName/includeDatasets (like
>>> btaurus_snp) but to no avail, please help, thank you.
>>>
>>> Dzu
>>>
>>>
>>>
>>
>
>