Configuring MPI for the new MAKER version

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Configuring MPI for the new MAKER version

Gerrit
We would like to install the new MAKER 2.0.4-beta version on our cluster
and we would like to run it parallelized using MPI like we did before
with MAKER 2.0.3.

Unfortunately, we can`t find the /mpi folder in the maker directory
anymore so we can`t follow the instructions in the README!

Can you give us advice how to configure MPI in the new MAKER version?

Any help or advice is greatly appreciated!

Best wishes,
Gerrit


Gerrit Hartig - Diploma student
Center for Molecular Biodiversity
Zoological Research Museum Alexander Koenig
Adenauerallee 160-162
D-53113 Bonn
E-mail: [hidden email]

http://www.zfmk.de 



_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|

Re: Configuring MPI for the new MAKER version

Carson Hinton Holt
Re: [maker-devel] Configuring MPI for the new MAKER version I’m updating the documentation with the following:

1.  If you want to install the MPI version of MAKER, you need to have Perl
    compiled for threads.

  a. Install standard MAKER and verify that it runs.
  b. Install MPICH2 with the --enable-sharedlibs flag set to the
     appropriate value for your OS (See MPICH2 documentation)
  c. Use cd to change to the maker/src subdirectory in the MAKER
     installation folder.
  d. Run Build.PL by typing: perl Build.PL
  e. If MPICH2 is installed and configured correctly, it will be
     detected by MAKER and Build.PL will ask if you want to install
     MPI MAKER.  Select 'yes'.
  f. run ./Build install

Thanks,
Carson

On 11/9/10 7:00 AM, "Gerrit" <geha@...> wrote:

We would like to install the new MAKER 2.0.4-beta version on our cluster
and we would like to run it parallelized using MPI like we did before
with MAKER 2.0.3.

Unfortunately, we can`t find the /mpi folder in the maker directory
anymore so we can`t follow the instructions in the README!

Can you give us advice how to configure MPI in the new MAKER version?

Any help or advice is greatly appreciated!

Best wishes,
Gerrit


Gerrit Hartig - Diploma student
Center for Molecular Biodiversity
Zoological Research Museum Alexander Koenig
Adenauerallee 160-162
D-53113 Bonn
E-mail: geha@...

http://www.zfmk.de



_______________________________________________
maker-devel mailing list
maker-devel@...
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org


_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org