Corrupted annotation db files?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Corrupted annotation db files?

Chris Childers
Hi all,

We recently found a problem with one of our scaffolds in which the User-created annotation track has a red error box, that reads "TypeError:Cannot read property'className' of undefined".  There were annotations on this scaffold, and I was able to export the annotations as gff3, attached to this message.  The thing that surprised me most was that one of the annotations is missing the gene line, though the mRNA, exon and CDS lines are present.

Looking at the Annotations and history directory, it looks like these files have been touched today, though the issue started some time yesterday. 

Since this was found yesterday, another user reported this same behavior in a different Web Apollo instance. 

Has anyone else run into this issue? 

Best,
Chris


Annotations-Scaffold246 $ ll
total 1024

-rw-rw-r-- 1 tomcat tomcat 1043029 Jun 10 06:52 00000000.jdb
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.info.0
-rw-rw-r-- 1 tomcat tomcat       0 Jun 10 06:52 je.info.0.lck
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.lck



Annotations-Scaffold246_history $ ll
total 9792
-rw-rw-r-- 1 tomcat tomcat 9953314 Jun  9 12:10 00000000.jdb
-rw-rw-r-- 1 tomcat tomcat   61733 Jun 10 06:52 00000001.jdb
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.info.0
-rw-rw-r-- 1 tomcat tomcat       0 Jun 10 06:52 je.info.0.lck
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.lck


WA_error_in_user-created_annotations_track.tiff (480K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Corrupted annotation db files?

Chris Childers
As an addendum, here is the exported gff3 from the second case.  It also has an annotation that is missing a gene feature, but has mRNA, exon and CDS features.

Thanks,
Chris


On Tue, Jun 10, 2014 at 7:10 AM, Chris Childers <[hidden email]> wrote:
Hi all,

We recently found a problem with one of our scaffolds in which the User-created annotation track has a red error box, that reads "TypeError:Cannot read property'className' of undefined".  There were annotations on this scaffold, and I was able to export the annotations as gff3, attached to this message.  The thing that surprised me most was that one of the annotations is missing the gene line, though the mRNA, exon and CDS lines are present.

Looking at the Annotations and history directory, it looks like these files have been touched today, though the issue started some time yesterday. 

Since this was found yesterday, another user reported this same behavior in a different Web Apollo instance. 

Has anyone else run into this issue? 

Best,
Chris


Annotations-Scaffold246 $ ll
total 1024

-rw-rw-r-- 1 tomcat tomcat 1043029 Jun 10 06:52 00000000.jdb
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.info.0
-rw-rw-r-- 1 tomcat tomcat       0 Jun 10 06:52 je.info.0.lck
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.lck



Annotations-Scaffold246_history $ ll
total 9792
-rw-rw-r-- 1 tomcat tomcat 9953314 Jun  9 12:10 00000000.jdb
-rw-rw-r-- 1 tomcat tomcat   61733 Jun 10 06:52 00000001.jdb
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.info.0
-rw-rw-r-- 1 tomcat tomcat       0 Jun 10 06:52 je.info.0.lck
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.lck



annotations_scaffold2840.gff (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Corrupted annotation db files?

Colin
Hi Chris,
This problem appears to be similar to another recent problem. Can you look at the tips in this thread and see if they can help?

http://gmod.827538.n3.nabble.com/Single-Contig-Error-s-td4043053.html

-Colin


On Tue, Jun 10, 2014 at 6:55 AM, Chris Childers <[hidden email]> wrote:
As an addendum, here is the exported gff3 from the second case.  It also has an annotation that is missing a gene feature, but has mRNA, exon and CDS features.

Thanks,
Chris


On Tue, Jun 10, 2014 at 7:10 AM, Chris Childers <[hidden email]> wrote:
Hi all,

We recently found a problem with one of our scaffolds in which the User-created annotation track has a red error box, that reads "TypeError:Cannot read property'className' of undefined".  There were annotations on this scaffold, and I was able to export the annotations as gff3, attached to this message.  The thing that surprised me most was that one of the annotations is missing the gene line, though the mRNA, exon and CDS lines are present.

Looking at the Annotations and history directory, it looks like these files have been touched today, though the issue started some time yesterday. 

Since this was found yesterday, another user reported this same behavior in a different Web Apollo instance. 

Has anyone else run into this issue? 

Best,
Chris


Annotations-Scaffold246 $ ll
total 1024

-rw-rw-r-- 1 tomcat tomcat 1043029 Jun 10 06:52 00000000.jdb
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.info.0
-rw-rw-r-- 1 tomcat tomcat       0 Jun 10 06:52 je.info.0.lck
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.lck



Annotations-Scaffold246_history $ ll
total 9792
-rw-rw-r-- 1 tomcat tomcat 9953314 Jun  9 12:10 00000000.jdb
-rw-rw-r-- 1 tomcat tomcat   61733 Jun 10 06:52 00000001.jdb
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.info.0
-rw-rw-r-- 1 tomcat tomcat       0 Jun 10 06:52 je.info.0.lck
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.lck



Reply | Threaded
Open this post in threaded view
|

Re: Corrupted annotation db files?

Chris Childers
Hi Colin,

Thank you for the suggestion.  We have not updated our Web Apollo version mid annotation for any of the affected instances we've encountered so far.  I did follow the instructions and reinstall the Web Apollo plugin, clear my cache and reopen the page with the same results.

Have you found a preferred way to inspect the contents of the DB files?

Thanks,
Chris



On Tue, Jun 10, 2014 at 10:52 AM, Colin <[hidden email]> wrote:
Hi Chris,
This problem appears to be similar to another recent problem. Can you look at the tips in this thread and see if they can help?

http://gmod.827538.n3.nabble.com/Single-Contig-Error-s-td4043053.html

-Colin


On Tue, Jun 10, 2014 at 6:55 AM, Chris Childers <[hidden email]> wrote:
As an addendum, here is the exported gff3 from the second case.  It also has an annotation that is missing a gene feature, but has mRNA, exon and CDS features.

Thanks,
Chris


On Tue, Jun 10, 2014 at 7:10 AM, Chris Childers <[hidden email]> wrote:
Hi all,

We recently found a problem with one of our scaffolds in which the User-created annotation track has a red error box, that reads "TypeError:Cannot read property'className' of undefined".  There were annotations on this scaffold, and I was able to export the annotations as gff3, attached to this message.  The thing that surprised me most was that one of the annotations is missing the gene line, though the mRNA, exon and CDS lines are present.

Looking at the Annotations and history directory, it looks like these files have been touched today, though the issue started some time yesterday. 

Since this was found yesterday, another user reported this same behavior in a different Web Apollo instance. 

Has anyone else run into this issue? 

Best,
Chris


Annotations-Scaffold246 $ ll
total 1024

-rw-rw-r-- 1 tomcat tomcat 1043029 Jun 10 06:52 00000000.jdb
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.info.0
-rw-rw-r-- 1 tomcat tomcat       0 Jun 10 06:52 je.info.0.lck
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.lck



Annotations-Scaffold246_history $ ll
total 9792
-rw-rw-r-- 1 tomcat tomcat 9953314 Jun  9 12:10 00000000.jdb
-rw-rw-r-- 1 tomcat tomcat   61733 Jun 10 06:52 00000001.jdb
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.info.0
-rw-rw-r-- 1 tomcat tomcat       0 Jun 10 06:52 je.info.0.lck
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.lck




Reply | Threaded
Open this post in threaded view
|

Re: Corrupted annotation db files?

Colin
I am not sure how this happened, but you can use the tools to remove the orphan feature that you described ("remove_orphan_features.sh" )

Also, I personally think more "admin" type tools for the database would be great, but this is what we have for now!
Cheers,
-Colin



On Tue, Jun 10, 2014 at 10:17 AM, Chris Childers <[hidden email]> wrote:
Hi Colin,

Thank you for the suggestion.  We have not updated our Web Apollo version mid annotation for any of the affected instances we've encountered so far.  I did follow the instructions and reinstall the Web Apollo plugin, clear my cache and reopen the page with the same results.

Have you found a preferred way to inspect the contents of the DB files?

Thanks,
Chris



On Tue, Jun 10, 2014 at 10:52 AM, Colin <[hidden email]> wrote:
Hi Chris,
This problem appears to be similar to another recent problem. Can you look at the tips in this thread and see if they can help?

http://gmod.827538.n3.nabble.com/Single-Contig-Error-s-td4043053.html

-Colin


On Tue, Jun 10, 2014 at 6:55 AM, Chris Childers <[hidden email]> wrote:
As an addendum, here is the exported gff3 from the second case.  It also has an annotation that is missing a gene feature, but has mRNA, exon and CDS features.

Thanks,
Chris


On Tue, Jun 10, 2014 at 7:10 AM, Chris Childers <[hidden email]> wrote:
Hi all,

We recently found a problem with one of our scaffolds in which the User-created annotation track has a red error box, that reads "TypeError:Cannot read property'className' of undefined".  There were annotations on this scaffold, and I was able to export the annotations as gff3, attached to this message.  The thing that surprised me most was that one of the annotations is missing the gene line, though the mRNA, exon and CDS lines are present.

Looking at the Annotations and history directory, it looks like these files have been touched today, though the issue started some time yesterday. 

Since this was found yesterday, another user reported this same behavior in a different Web Apollo instance. 

Has anyone else run into this issue? 

Best,
Chris


Annotations-Scaffold246 $ ll
total 1024

-rw-rw-r-- 1 tomcat tomcat 1043029 Jun 10 06:52 00000000.jdb
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.info.0
-rw-rw-r-- 1 tomcat tomcat       0 Jun 10 06:52 je.info.0.lck
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.lck



Annotations-Scaffold246_history $ ll
total 9792
-rw-rw-r-- 1 tomcat tomcat 9953314 Jun  9 12:10 00000000.jdb
-rw-rw-r-- 1 tomcat tomcat   61733 Jun 10 06:52 00000001.jdb
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.info.0
-rw-rw-r-- 1 tomcat tomcat       0 Jun 10 06:52 je.info.0.lck
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.lck





Reply | Threaded
Open this post in threaded view
|

Re: Corrupted annotation db files?

Chris Childers
Hi Colin,

I agree, fixing issues as they come up is good, but understanding and resolving the cause would be much better.

Thanks again for all your suggestions,
Chris


On Tue, Jun 10, 2014 at 12:28 PM, Colin <[hidden email]> wrote:
I am not sure how this happened, but you can use the tools to remove the orphan feature that you described ("remove_orphan_features.sh" )

Also, I personally think more "admin" type tools for the database would be great, but this is what we have for now!
Cheers,
-Colin



On Tue, Jun 10, 2014 at 10:17 AM, Chris Childers <[hidden email]> wrote:
Hi Colin,

Thank you for the suggestion.  We have not updated our Web Apollo version mid annotation for any of the affected instances we've encountered so far.  I did follow the instructions and reinstall the Web Apollo plugin, clear my cache and reopen the page with the same results.

Have you found a preferred way to inspect the contents of the DB files?

Thanks,
Chris



On Tue, Jun 10, 2014 at 10:52 AM, Colin <[hidden email]> wrote:
Hi Chris,
This problem appears to be similar to another recent problem. Can you look at the tips in this thread and see if they can help?

http://gmod.827538.n3.nabble.com/Single-Contig-Error-s-td4043053.html

-Colin


On Tue, Jun 10, 2014 at 6:55 AM, Chris Childers <[hidden email]> wrote:
As an addendum, here is the exported gff3 from the second case.  It also has an annotation that is missing a gene feature, but has mRNA, exon and CDS features.

Thanks,
Chris


On Tue, Jun 10, 2014 at 7:10 AM, Chris Childers <[hidden email]> wrote:
Hi all,

We recently found a problem with one of our scaffolds in which the User-created annotation track has a red error box, that reads "TypeError:Cannot read property'className' of undefined".  There were annotations on this scaffold, and I was able to export the annotations as gff3, attached to this message.  The thing that surprised me most was that one of the annotations is missing the gene line, though the mRNA, exon and CDS lines are present.

Looking at the Annotations and history directory, it looks like these files have been touched today, though the issue started some time yesterday. 

Since this was found yesterday, another user reported this same behavior in a different Web Apollo instance. 

Has anyone else run into this issue? 

Best,
Chris


Annotations-Scaffold246 $ ll
total 1024

-rw-rw-r-- 1 tomcat tomcat 1043029 Jun 10 06:52 00000000.jdb
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.info.0
-rw-rw-r-- 1 tomcat tomcat       0 Jun 10 06:52 je.info.0.lck
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.lck



Annotations-Scaffold246_history $ ll
total 9792
-rw-rw-r-- 1 tomcat tomcat 9953314 Jun  9 12:10 00000000.jdb
-rw-rw-r-- 1 tomcat tomcat   61733 Jun 10 06:52 00000001.jdb
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.info.0
-rw-rw-r-- 1 tomcat tomcat       0 Jun 10 06:52 je.info.0.lck
-rw-rw-r-- 1 tomcat tomcat       0 Jun  9 09:13 je.lck