DBD::Pg::db pg_endcopy failed: ERROR: invalid input syntax for integer: ""

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

DBD::Pg::db pg_endcopy failed: ERROR: invalid input syntax for integer: ""

Seth_m55
Hello,

I ran into the following error message when I tried to use bulk_load_gff3.pl:

DBD::Pg::db pg_endcopy failed: ERROR:  invalid input syntax for integer: ""
CONTEXT:  COPY feature_relationship, line 1, column type_id: "" at /usr/local/share/perl/5.14.2/Bio/GMOD/DB/Adapter.pm line 3258, <$fh> line 193922.

------------- EXCEPTION: Bio::Root::Exception -------------
MSG: calling endcopy for feature_relationship failed:
TACK: Error::throw
STACK: Bio::Root::Root::throw /usr/share/perl5/Bio/Root/Root.pm:472
STACK: Bio::GMOD::DB::Adapter::copy_from_stdin /usr/local/share/perl/5.14.2/Bio/GMOD/DB/Adapter.pm:3258
STACK: Bio::GMOD::DB::Adapter::load_data /usr/local/share/perl/5.14.2/Bio/GMOD/DB/Adapter.pm:3180
STACK: /usr/local/bin/gmod_bulk_load_gff3.pl:1076
-----------------------------------------------------------

A quick google search showed a script to follow on the GMOD wiki page for Chado:
 UPDATE cvterm SET cv_id = (SELECT cv_id FROM cv WHERE name = 'relationship')
  WHERE name = 'part_of'
   AND cv_id IN (SELECT cv_id FROM cv WHERE name='gene_ontology');
This updated 0 lines for my DB though, next I found someone was having the same error and Mr. Caine gave the following advice:

"This can be caused by a few things, generally related to the Parent and Derives_from tags.

To track down the line that is causing the problem, you can try to do the load again, but this time add the "--save_files" argument to keep the loader from throwing a way the temp files it uses while it's parsing the GFF file.  Then you can look at the feature_relationship file, identify the feature_id of the offending feature (it should be in the second number in the line), and then go to one of the other temp files to help you sort out what the problematic GFF line is (for example, you could look in the featureprop temp file for the offending feature_id (again, the second number) to look for tags that would help you identify the lines, or featureloc to identify the coordinates).

You can also check the cvterm table for the derives_from and part_of terms and verify that they belong to the relationship ontology.  Some times loaders will "take" those terms and move them into other ontologies."

However the offending line in my feature_relationship temp file (line 193922) is a blank line after what I presume is null terminator line of "\."  I've used this GFF to populate a Chado DB previously, but due to massive hardware failures have to rebuild on a new machine.  I'm in the process of installing maker to see if the maker2chado script will solve it, but I would prefer to know what I missed on the rebuild.  Any suggestions?

- Seth Munholland
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: <a href="tel:%28519%29%20253-3000%20Ext%3A%204755" value="+15192533000" target="_blank">(519) 253-3000 Ext: 4755

------------------------------------------------------------------------------
See everything from the browser to the database with AppDynamics
Get end-to-end visibility with application monitoring from AppDynamics
Isolate bottlenecks and diagnose root cause in seconds.
Start your free trial of AppDynamics Pro today!
http://pubads.g.doubleclick.net/gampad/clk?id=48808831&iu=/4140/ostg.clktrk
_______________________________________________
Gmod-schema mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-schema