Dependencies issue with tool installation via ephemeris

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Dependencies issue with tool installation via ephemeris

RMSe17
Hello, I got a new Galaxy install using 17.01 latest.  I wanted to get
the same tools as are in Galaxy main.  I installed ephemeris with pip,
used get-tool-list to get a yml file with tools, and then shed-install
to my Galaxy server.  After a few hours, 452 tools got successfully
installed, 0 skipped and 0 errored.  However, when looking at Galaxy's
"manage installed tools", all of the tools that have dependencies are
in gray state - missing dependencies. (and error out if ran).  If I
select a tool, and go to "repository actions", "manage tool
dependencies", I see that dependencies are marked as never installed.
If I select dependencies and click install, they install - really fast
(too fast?), and then that tool works fine...   but I'm trying to
avoid manually telling each tool to install dependencies - there are a
lot of them :)

Any suggestions?
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/
Reply | Threaded
Open this post in threaded view
|

Re: Dependencies issue with tool installation via ephemeris

Björn Grüning-3
Hi,

please make sure you have set "install_resolver_dependencies: True"

https://github.com/bgruening/docker-galaxy-ngs-preprocessing/blob/master/ngs_preprocessing.yml#L41

This will install you all conda dependencies.
Btw. you can also use Galaxy 17.05. 17.09 will be released soon and also
can need some testing :)

Cheers,
Bjoern

On 06.09.2017 03:54, RMSe17 wrote:

> Hello, I got a new Galaxy install using 17.01 latest.  I wanted to get
> the same tools as are in Galaxy main.  I installed ephemeris with pip,
> used get-tool-list to get a yml file with tools, and then shed-install
> to my Galaxy server.  After a few hours, 452 tools got successfully
> installed, 0 skipped and 0 errored.  However, when looking at Galaxy's
> "manage installed tools", all of the tools that have dependencies are
> in gray state - missing dependencies. (and error out if ran).  If I
> select a tool, and go to "repository actions", "manage tool
> dependencies", I see that dependencies are marked as never installed.
> If I select dependencies and click install, they install - really fast
> (too fast?), and then that tool works fine...   but I'm trying to
> avoid manually telling each tool to install dependencies - there are a
> lot of them :)
>
> Any suggestions?
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/
Reply | Threaded
Open this post in threaded view
|

plane error for Rscript

Deepak Tanwar
Hello everyone,

I have a question about https://github.com/nturaga/bioc-galaxy-integration  I am trying to convert a RScript into a Galaxy tool.

planemo bioc_tool_init --rscript ./countsAroundTSS.R --input ENCFF027UTM.bam --input mm10 --input 500 --input 500 --input transcripts_mm10_UCSC.sqlite --output ENCFF027UTM.txt --test_case
Can only use the --test_case option if also specifying --example_command


planemo bioc_tool_init --rscript ./countsAroundTSS.R --example_command "Rscript countsAroundTSS.R--input ENCFF027UTM.bam --input mm10 --input 500 --input 500 --input transcripts_mm10_UCSC.sqlite --output ENCFF027UTM.txt”
Error: no such option: --example_command


I am able to build a tool is I just run planemo bioc_tool_init --rscript ./countsAroundTSS.R --input ENCFF027UTM.bam --input mm10 --input 500 --input 500 --input transcripts_mm10_UCSC.sqlite --output ENCFF027UTM.txt



https://github.com/galaxyproject/planemo/issues/718


Thank you,
Deepak


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/
Reply | Threaded
Open this post in threaded view
|

Re: Dependencies issue with tool installation via ephemeris

RMSe17
In reply to this post by Björn Grüning-3
Thanks for your help Bjorn, I was already setting
install_resolver_dependencies to True, but I looked at the example you
referenced, and saw couple other options that I didn't have set (I
didn't see them mentioned in the ephemeris documentation).

Once I set the following in the tools yml list, everything started
working correctly.
install_tool_dependencies: True
install_repositoty_dependencies: True

Interestingly according to the comments in the example, these should
be defaulting to true anyway, but I had to set them explicitly.

Thanks again for your help!
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/
Reply | Threaded
Open this post in threaded view
|

Re: Dependencies issue with tool installation via ephemeris

Björn Grüning-3
Hi,

On 13.09.2017 21:15, RMSe17 wrote:
> Thanks for your help Bjorn, I was already setting
> install_resolver_dependencies to True, but I looked at the example you
> referenced, and saw couple other options that I didn't have set (I
> didn't see them mentioned in the ephemeris documentation).
>
> Once I set the following in the tools yml list, everything started
> working correctly.
> install_tool_dependencies: True

This should not be needed, it will install old tool dependencies, which
are deprecated.

Which Galaxy version are you using, depending on this the defaults might
change.

Cheers,
Bjoern

> install_repositoty_dependencies: True
>
> Interestingly according to the comments in the example, these should
> be defaulting to true anyway, but I had to set them explicitly.
>
> Thanks again for your help!
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/
Reply | Threaded
Open this post in threaded view
|

Re: Dependencies issue with tool installation via ephemeris

RMSe17
Bjoern,

Looks like some tools install fine without the
"install_tool_dependencies: True" but others come up with dependencies
missing.  I wonder if some tools are older and are missing something
in conda?  That's just a guess on my part.

Using 17.01 latest, so yea defaults could be different.

Thanks!
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/
Reply | Threaded
Open this post in threaded view
|

Re: Dependencies issue with tool installation via ephemeris

Björn Grüning-3


On 14.09.2017 00:10, RMSe17 wrote:
> Bjoern,
>
> Looks like some tools install fine without the
> "install_tool_dependencies: True" but others come up with dependencies
> missing.  I wonder if some tools are older and are missing something
> in conda?  That's just a guess on my part.

This can very well be! Which tool is this?

Cheers,
Bjoern

> Using 17.01 latest, so yea defaults could be different.

17.05 is recent and 17.09 will be released soon!

Cheers,
Bjoern

> Thanks!
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/