Error with Sam tools in Galaxy 4

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Error with Sam tools in Galaxy 4

UMD Bioinformatics
Hello Devteam,

I’ve just updated my local instance to the latest version. With the migration of tools to the tool shed I used the migrate command to keep my tools as they were in the previous versions.

$ sh ./scripts/migrate_tools/0008_tools.sh install_dependencies

and I’ve updated the database to 117

$ sh manage_db.sh upgrade

However, when I’m using samtools I’m getting an error related to the data. I’m not sure what the issue is and I’ve check all the .loc and .sh files and everything is pointing to the proper locations. Any ideas what the issue might be?

An error occurred with this dataset:Could not determine Samtools version /bin/sh: line 1: 1616 Segmentation fault: 11 samtools 2>&1 Error extracting alignments from (/galaxy-dist/database/files/001/dataset_1585.dat),

Cheers
Ian


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Error with Sam tools in Galaxy 4

Dave Bouvier
Ian,

To assist tracking down this issue, could you provide the output of the
following commands?

uname -m
uname -s

    --Dave B.

On 12/20/2013 08:43 AM, UMD Bioinformatics wrote:

> Hello Devteam,
>
> I’ve just updated my local instance to the latest version. With the migration of tools to the tool shed I used the migrate command to keep my tools as they were in the previous versions.
>
> $ sh ./scripts/migrate_tools/0008_tools.sh install_dependencies
>
> and I’ve updated the database to 117
>
> $ sh manage_db.sh upgrade
>
> However, when I’m using samtools I’m getting an error related to the data. I’m not sure what the issue is and I’ve check all the .loc and .sh files and everything is pointing to the proper locations. Any ideas what the issue might be?
>
> An error occurred with this dataset:Could not determine Samtools version /bin/sh: line 1: 1616 Segmentation fault: 11 samtools 2>&1 Error extracting alignments from (/galaxy-dist/database/files/001/dataset_1585.dat),
>
> Cheers
> Ian
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>    http://lists.bx.psu.edu/
>
> To search Galaxy mailing lists use the unified search at:
>    http://galaxyproject.org/search/mailinglists/
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Error with Sam tools in Galaxy 4

UMD Bioinformatics
Dave,

Its an x86_64 Darwin

Ian

On Dec 20, 2013, at 8:55 AM, Dave Bouvier <[hidden email]> wrote:

> Ian,
>
> To assist tracking down this issue, could you provide the output of the following commands?
>
> uname -m
> uname -s
>
>   --Dave B.
>
> On 12/20/2013 08:43 AM, UMD Bioinformatics wrote:
>> Hello Devteam,
>>
>> I’ve just updated my local instance to the latest version. With the migration of tools to the tool shed I used the migrate command to keep my tools as they were in the previous versions.
>>
>> $ sh ./scripts/migrate_tools/0008_tools.sh install_dependencies
>>
>> and I’ve updated the database to 117
>>
>> $ sh manage_db.sh upgrade
>>
>> However, when I’m using samtools I’m getting an error related to the data. I’m not sure what the issue is and I’ve check all the .loc and .sh files and everything is pointing to the proper locations. Any ideas what the issue might be?
>>
>> An error occurred with this dataset:Could not determine Samtools version /bin/sh: line 1: 1616 Segmentation fault: 11 samtools 2>&1 Error extracting alignments from (/galaxy-dist/database/files/001/dataset_1585.dat),
>>
>> Cheers
>> Ian
>>
>>
>> ___________________________________________________________
>> Please keep all replies on the list by using "reply all"
>> in your mail client.  To manage your subscriptions to this
>> and other Galaxy lists, please use the interface at:
>>   http://lists.bx.psu.edu/
>>
>> To search Galaxy mailing lists use the unified search at:
>>   http://galaxyproject.org/search/mailinglists/
>>


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Error with Sam tools in Galaxy 4

UMD Bioinformatics
In reply to this post by Dave Bouvier
Dave,

I’ve just decide to uninstall all the samtools and reinstall them. Things are working for now. Not sure what went wrong with the migration but seems to be back up and running.

Cheers
Ian

On Dec 20, 2013, at 8:55 AM, Dave Bouvier <[hidden email]> wrote:

> Ian,
>
> To assist tracking down this issue, could you provide the output of the following commands?
>
> uname -m
> uname -s
>
>   --Dave B.
>
> On 12/20/2013 08:43 AM, UMD Bioinformatics wrote:
>> Hello Devteam,
>>
>> I’ve just updated my local instance to the latest version. With the migration of tools to the tool shed I used the migrate command to keep my tools as they were in the previous versions.
>>
>> $ sh ./scripts/migrate_tools/0008_tools.sh install_dependencies
>>
>> and I’ve updated the database to 117
>>
>> $ sh manage_db.sh upgrade
>>
>> However, when I’m using samtools I’m getting an error related to the data. I’m not sure what the issue is and I’ve check all the .loc and .sh files and everything is pointing to the proper locations. Any ideas what the issue might be?
>>
>> An error occurred with this dataset:Could not determine Samtools version /bin/sh: line 1: 1616 Segmentation fault: 11 samtools 2>&1 Error extracting alignments from (/galaxy-dist/database/files/001/dataset_1585.dat),
>>
>> Cheers
>> Ian
>>
>>
>> ___________________________________________________________
>> Please keep all replies on the list by using "reply all"
>> in your mail client.  To manage your subscriptions to this
>> and other Galaxy lists, please use the interface at:
>>   http://lists.bx.psu.edu/
>>
>> To search Galaxy mailing lists use the unified search at:
>>   http://galaxyproject.org/search/mailinglists/
>>


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/