Failed Jbrowse Install

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Failed Jbrowse Install

Shane McCoy
Hello! 
Using Apollo 2.0.4
Grails Version: 3.2.1
Groovy Version: 2.4.7
JVM Version: 1.8.0_91

I had a very similar problem previously (not installing Git before) and but now I do have git installed (used to grab apollo). 

Running ./apollo deploy

Cloning: https://github.com/gmod/jbrowse into jbrowse-download.
using bower to install: gmod/jbrowse#1.12.2-apollo
/usr/bin/env: ‘node’: No such file or directory
:installJBrowse FAILED
FAILURE: Build failed with an exception.
* Where:
Build file '/home/bjreadin/Apollo/build.gradle' line: 326
* What went wrong:
Execution failed for task ':installJBrowse'.
> Process 'command 'bower'' finished with non-zero exit value 127
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debu option to get more log output.
BUILD FAILED

Using ./install_jbrowse.sh 
Installing Perl prerequisites ... failed.  See setup.log (etc)
 
Setup.log
+ chmod +x web-app/jbrowse/bin/cpanm
chmod: cannot access 'web-app/jbrowse/bin/cpanm': No such file or directory
+ cd web-app/jbrowse
./install_jbrowse.sh: line 26: cd: web-app/jbrowse: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 27: bin/cpanm: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 28: bin/cpanm: No such file or directory
+ set -e
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 30: bin/cpanm: No such file or directory 

I do have cpanm installed - I used to install all the prereqs. I did use the --sudo at the end of each module install. could this be a permission issue?

Thanks,
Shane M. 





This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|

Re: Failed Jbrowse Install

Shane McCoy
On a side note - I did try to install JBrowse-1.21.1 on its own and it was successful. 

On Fri, Oct 21, 2016 at 2:55 PM, Shane McCoy <[hidden email]> wrote:
Hello! 
Using Apollo 2.0.4
Grails Version: 3.2.1
Groovy Version: 2.4.7
JVM Version: 1.8.0_91

I had a very similar problem previously (not installing Git before) and but now I do have git installed (used to grab apollo). 

Running ./apollo deploy

Cloning: https://github.com/gmod/jbrowse into jbrowse-download.
using bower to install: gmod/jbrowse#1.12.2-apollo
/usr/bin/env: ‘node’: No such file or directory
:installJBrowse FAILED
FAILURE: Build failed with an exception.
* Where:
Build file '/home/bjreadin/Apollo/build.gradle' line: 326
* What went wrong:
Execution failed for task ':installJBrowse'.
> Process 'command 'bower'' finished with non-zero exit value 127
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debu option to get more log output.
BUILD FAILED

Using ./install_jbrowse.sh 
Installing Perl prerequisites ... failed.  See setup.log (etc)
 
Setup.log
+ chmod +x web-app/jbrowse/bin/cpanm
chmod: cannot access 'web-app/jbrowse/bin/cpanm': No such file or directory
+ cd web-app/jbrowse
./install_jbrowse.sh: line 26: cd: web-app/jbrowse: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 27: bin/cpanm: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 28: bin/cpanm: No such file or directory
+ set -e
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 30: bin/cpanm: No such file or directory 

I do have cpanm installed - I used to install all the prereqs. I did use the --sudo at the end of each module install. could this be a permission issue?

Thanks,
Shane M. 






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|

Re: Failed Jbrowse Install

nathandunn

Shane.  There are a couple of problems that I can see, though I feel as though it should have given you better error feedback. 

1 - You need to install the most current and stable version of node / npm.   This is new in 2.0.4.  

2 - You should either install grails 2.5.5 and load it into your shell (using a tool like sdkman), or uninstall grails altogether and it will load the correct version automatically.  

3 - After 1 and 2 are installed, do an ./apollo clean-all and then ./apollo deploy again



Nathan Dunn, PhD
Berkeley Bioinformatics Open-source Projects (BBOP)
Genomics Division, Lawrence Berkeley National Laboratory
[hidden email]


On Oct 21, 2016, at 12:26 PM, Shane McCoy <[hidden email]> wrote:

On a side note - I did try to install JBrowse-1.21.1 on its own and it was successful. 

On Fri, Oct 21, 2016 at 2:55 PM, Shane McCoy <[hidden email]> wrote:
Hello! 
Using Apollo 2.0.4
Grails Version: 3.2.1
Groovy Version: 2.4.7
JVM Version: 1.8.0_91

I had a very similar problem previously (not installing Git before) and but now I do have git installed (used to grab apollo). 

Running ./apollo deploy

Cloning: https://github.com/gmod/jbrowse into jbrowse-download.
using bower to install: gmod/jbrowse#1.12.2-apollo
/usr/bin/env: ‘node’: No such file or directory
:installJBrowse FAILED
FAILURE: Build failed with an exception.
* Where:
Build file '/home/bjreadin/Apollo/build.gradle' line: 326
* What went wrong:
Execution failed for task ':installJBrowse'.
> Process 'command 'bower'' finished with non-zero exit value 127
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debu option to get more log output.
BUILD FAILED

Using ./install_jbrowse.sh 
Installing Perl prerequisites ... failed.  See setup.log (etc)
 
Setup.log
+ chmod +x web-app/jbrowse/bin/cpanm
chmod: cannot access 'web-app/jbrowse/bin/cpanm': No such file or directory
+ cd web-app/jbrowse
./install_jbrowse.sh: line 26: cd: web-app/jbrowse: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 27: bin/cpanm: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 28: bin/cpanm: No such file or directory
+ set -e
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 30: bin/cpanm: No such file or directory 

I do have cpanm installed - I used to install all the prereqs. I did use the --sudo at the end of each module install. could this be a permission issue?

Thanks,
Shane M. 









This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|

Re: Failed Jbrowse Install

Shane McCoy
Thanks Nathan!
Correcting both did the trick and I have a successful build and war file. 
Many thanks!
Shane M.

On Fri, Oct 21, 2016 at 3:57 PM, Nathan Dunn <[hidden email]> wrote:

Shane.  There are a couple of problems that I can see, though I feel as though it should have given you better error feedback. 

1 - You need to install the most current and stable version of node / npm.   This is new in 2.0.4.  

2 - You should either install grails 2.5.5 and load it into your shell (using a tool like sdkman), or uninstall grails altogether and it will load the correct version automatically.  

3 - After 1 and 2 are installed, do an ./apollo clean-all and then ./apollo deploy again



Nathan Dunn, PhD
Berkeley Bioinformatics Open-source Projects (BBOP)
Genomics Division, Lawrence Berkeley National Laboratory
[hidden email]


On Oct 21, 2016, at 12:26 PM, Shane McCoy <[hidden email]> wrote:

On a side note - I did try to install JBrowse-1.21.1 on its own and it was successful. 

On Fri, Oct 21, 2016 at 2:55 PM, Shane McCoy <[hidden email]> wrote:
Hello! 
Using Apollo 2.0.4
Grails Version: 3.2.1
Groovy Version: 2.4.7
JVM Version: 1.8.0_91

I had a very similar problem previously (not installing Git before) and but now I do have git installed (used to grab apollo). 

Running ./apollo deploy

Cloning: https://github.com/gmod/jbrowse into jbrowse-download.
using bower to install: gmod/jbrowse#1.12.2-apollo
/usr/bin/env: ‘node’: No such file or directory
:installJBrowse FAILED
FAILURE: Build failed with an exception.
* Where:
Build file '/home/bjreadin/Apollo/build.gradle' line: 326
* What went wrong:
Execution failed for task ':installJBrowse'.
> Process 'command 'bower'' finished with non-zero exit value 127
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debu option to get more log output.
BUILD FAILED

Using ./install_jbrowse.sh 
Installing Perl prerequisites ... failed.  See setup.log (etc)
 
Setup.log
+ chmod +x web-app/jbrowse/bin/cpanm
chmod: cannot access 'web-app/jbrowse/bin/cpanm': No such file or directory
+ cd web-app/jbrowse
./install_jbrowse.sh: line 26: cd: web-app/jbrowse: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 27: bin/cpanm: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 28: bin/cpanm: No such file or directory
+ set -e
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 30: bin/cpanm: No such file or directory 

I do have cpanm installed - I used to install all the prereqs. I did use the --sudo at the end of each module install. could this be a permission issue?

Thanks,
Shane M. 









This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.







This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|

Re: Failed Jbrowse Install

nathandunn

Excellent.  Glad it worked out. 

Nathan

On Oct 21, 2016, at 1:35 PM, Shane McCoy <[hidden email]> wrote:

Thanks Nathan!
Correcting both did the trick and I have a successful build and war file. 
Many thanks!
Shane M.

On Fri, Oct 21, 2016 at 3:57 PM, Nathan Dunn <[hidden email]> wrote:

Shane.  There are a couple of problems that I can see, though I feel as though it should have given you better error feedback. 

1 - You need to install the most current and stable version of node / npm.   This is new in 2.0.4.  

2 - You should either install grails 2.5.5 and load it into your shell (using a tool like sdkman), or uninstall grails altogether and it will load the correct version automatically.  

3 - After 1 and 2 are installed, do an ./apollo clean-all and then ./apollo deploy again



Nathan Dunn, PhD
Berkeley Bioinformatics Open-source Projects (BBOP)
Genomics Division, Lawrence Berkeley National Laboratory
[hidden email]


On Oct 21, 2016, at 12:26 PM, Shane McCoy <[hidden email]> wrote:

On a side note - I did try to install JBrowse-1.21.1 on its own and it was successful. 

On Fri, Oct 21, 2016 at 2:55 PM, Shane McCoy <[hidden email]> wrote:
Hello! 
Using Apollo 2.0.4
Grails Version: 3.2.1
Groovy Version: 2.4.7
JVM Version: 1.8.0_91

I had a very similar problem previously (not installing Git before) and but now I do have git installed (used to grab apollo). 

Running ./apollo deploy

Cloning: https://github.com/gmod/jbrowse into jbrowse-download.
using bower to install: gmod/jbrowse#1.12.2-apollo
/usr/bin/env: ‘node’: No such file or directory
:installJBrowse FAILED
FAILURE: Build failed with an exception.
* Where:
Build file '/home/bjreadin/Apollo/build.gradle' line: 326
* What went wrong:
Execution failed for task ':installJBrowse'.
> Process 'command 'bower'' finished with non-zero exit value 127
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debu option to get more log output.
BUILD FAILED

Using ./install_jbrowse.sh 
Installing Perl prerequisites ... failed.  See setup.log (etc)
 
Setup.log
+ chmod +x web-app/jbrowse/bin/cpanm
chmod: cannot access 'web-app/jbrowse/bin/cpanm': No such file or directory
+ cd web-app/jbrowse
./install_jbrowse.sh: line 26: cd: web-app/jbrowse: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 27: bin/cpanm: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 28: bin/cpanm: No such file or directory
+ set -e
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 30: bin/cpanm: No such file or directory 

I do have cpanm installed - I used to install all the prereqs. I did use the --sudo at the end of each module install. could this be a permission issue?

Thanks,
Shane M. 









This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.