Failed while polishing ESTs

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Failed while polishing ESTs

Seth_m55
After my clustering issue I figured I would go node by node and run MAKER locally on the test data set to be sure that it was working properly before trying it as a full MPI run.  After adjusting all my exes to point to the NFS versions I am consistently getting the same error on each node when it comes time to run exonerate:

polishig ESTs
running  est2genome search.
#--------- command -------------#
Widget::exonerate::est2genome:
/Data/Apps/exonerate/src/program/exonerate  -q /tmp/maker_q3n9fB/0/dpp-mRNA-5.for.26386-32056.0.fasta -t /tmp/maker_q3n9fB/0/contig-dpp-500-500.26386-32056.0.fasta -Q dna -T dna --model est2genome  --minintron 20 --maxintron 10000 --showcigar --percent 20 > /tmp/maker_q3n9fB/0/contig-dpp-500-500.26386-32056.dpp-mRNA-5.e.exonerate
#-------------------------------#
Messed up acceptor:TT in Widget::exonerate::est2genome::get_acceptor!
--> rank=NA, hostname=beanblade2
ERROR: Failed while polishig ESTs
ERROR: Chunk failed at level:2, tier_type:3
FAILED CONTIG:contig-dpp-500-500

ERROR: Chunk failed at level:4, tier_type:0
FAILED CONTIG:contig-dpp-500-500

The only results I find on google was an issue with an improper character in the est file, but a cat of the dpp_est.fasta shows nothing incorrect and since they all point to dpp-mRNA-5 I backed up the provided est and removed it.  The response was:

polishig ESTs
running  est2genome search.
#--------- command -------------#
Widget::exonerate::est2genome:
/Data/Apps/exonerate/src/program/exonerate  -q /tmp/maker_I7TZxt/0/dpp-mRNA-4.for.22889-32056.0.fasta -t /tmp/maker_I7TZxt/0/contig-dpp-500-500.22889-32056.0.fasta -Q dna -T dna --model est2genome  --minintron 20 --maxintron 10000 --showcigar --percent 20 > /tmp/maker_I7TZxt/0/contig-dpp-500-500.22889-32056.dpp-mRNA-4.e.exonerate
#-------------------------------#
Messed up acceptor:TT in Widget::exonerate::est2genome::get_acceptor!
--> rank=NA, hostname=beanblade4
ERROR: Failed while polishig ESTs
ERROR: Chunk failed at level:2, tier_type:3
FAILED CONTIG:contig-dpp-500-500

ERROR: Chunk failed at level:4, tier_type:0
FAILED CONTIG:contig-dpp-500-500

So the error seems to be pointing at something happening when wrapping up the ESTs.

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755

_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|

Re: Failed while polishing ESTs

Carson Holt-2
So you are running the test data job correct? So if you get any error with the test data job, something is wrong with your installation.

Make sure BioPerl is up to data (and the same everywhere). If using your own installation of Perl, make sure it had BerkleyDB support when you installed it (if you are using something like perlbrew , you may not have BerkleyDB support and this may affect BioPerl indexing). Also try reinstalling exonertate.

And make sure to delete any run directories before retrying.

—Carson


On Feb 22, 2017, at 11:03 AM, Seth Munholland <[hidden email]> wrote:

After my clustering issue I figured I would go node by node and run MAKER locally on the test data set to be sure that it was working properly before trying it as a full MPI run.  After adjusting all my exes to point to the NFS versions I am consistently getting the same error on each node when it comes time to run exonerate:

polishig ESTs
running  est2genome search.
#--------- command -------------#
Widget::exonerate::est2genome:
/Data/Apps/exonerate/src/program/exonerate  -q /tmp/maker_q3n9fB/0/dpp-mRNA-5.for.26386-32056.0.fasta -t /tmp/maker_q3n9fB/0/contig-dpp-500-500.26386-32056.0.fasta -Q dna -T dna --model est2genome  --minintron 20 --maxintron 10000 --showcigar --percent 20 > /tmp/maker_q3n9fB/0/contig-dpp-500-500.26386-32056.dpp-mRNA-5.e.exonerate
#-------------------------------#
Messed up acceptor:TT in Widget::exonerate::est2genome::get_acceptor!
--> rank=NA, hostname=beanblade2
ERROR: Failed while polishig ESTs
ERROR: Chunk failed at level:2, tier_type:3
FAILED CONTIG:contig-dpp-500-500

ERROR: Chunk failed at level:4, tier_type:0
FAILED CONTIG:contig-dpp-500-500

The only results I find on google was an issue with an improper character in the est file, but a cat of the dpp_est.fasta shows nothing incorrect and since they all point to dpp-mRNA-5 I backed up the provided est and removed it.  The response was:

polishig ESTs
running  est2genome search.
#--------- command -------------#
Widget::exonerate::est2genome:
/Data/Apps/exonerate/src/program/exonerate  -q /tmp/maker_I7TZxt/0/dpp-mRNA-4.for.22889-32056.0.fasta -t /tmp/maker_I7TZxt/0/contig-dpp-500-500.22889-32056.0.fasta -Q dna -T dna --model est2genome  --minintron 20 --maxintron 10000 --showcigar --percent 20 > /tmp/maker_I7TZxt/0/contig-dpp-500-500.22889-32056.dpp-mRNA-4.e.exonerate
#-------------------------------#
Messed up acceptor:TT in Widget::exonerate::est2genome::get_acceptor!
--> rank=NA, hostname=beanblade4
ERROR: Failed while polishig ESTs
ERROR: Chunk failed at level:2, tier_type:3
FAILED CONTIG:contig-dpp-500-500

ERROR: Chunk failed at level:4, tier_type:0
FAILED CONTIG:contig-dpp-500-500

So the error seems to be pointing at something happening when wrapping up the ESTs.

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755
_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org


_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|

Re: Failed while polishing ESTs

Seth_m55
It is the test data, the dpp set to be specific.

I already checked all the installs to be sure they configured and compile without error and are up to date.

I've been deleting between each run.

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755

On Wed, Feb 22, 2017 at 1:16 PM, Carson Holt <[hidden email]> wrote:
So you are running the test data job correct? So if you get any error with the test data job, something is wrong with your installation.

Make sure BioPerl is up to data (and the same everywhere). If using your own installation of Perl, make sure it had BerkleyDB support when you installed it (if you are using something like perlbrew , you may not have BerkleyDB support and this may affect BioPerl indexing). Also try reinstalling exonertate.

And make sure to delete any run directories before retrying.

—Carson


On Feb 22, 2017, at 11:03 AM, Seth Munholland <[hidden email]> wrote:

After my clustering issue I figured I would go node by node and run MAKER locally on the test data set to be sure that it was working properly before trying it as a full MPI run.  After adjusting all my exes to point to the NFS versions I am consistently getting the same error on each node when it comes time to run exonerate:

polishig ESTs
running  est2genome search.
#--------- command -------------#
Widget::exonerate::est2genome:
/Data/Apps/exonerate/src/program/exonerate  -q /tmp/maker_q3n9fB/0/dpp-mRNA-5.for.26386-32056.0.fasta -t /tmp/maker_q3n9fB/0/contig-dpp-500-500.26386-32056.0.fasta -Q dna -T dna --model est2genome  --minintron 20 --maxintron 10000 --showcigar --percent 20 > /tmp/maker_q3n9fB/0/contig-dpp-500-500.26386-32056.dpp-mRNA-5.e.exonerate
#-------------------------------#
Messed up acceptor:TT in Widget::exonerate::est2genome::get_acceptor!
--> rank=NA, hostname=beanblade2
ERROR: Failed while polishig ESTs
ERROR: Chunk failed at level:2, tier_type:3
FAILED CONTIG:contig-dpp-500-500

ERROR: Chunk failed at level:4, tier_type:0
FAILED CONTIG:contig-dpp-500-500

The only results I find on google was an issue with an improper character in the est file, but a cat of the dpp_est.fasta shows nothing incorrect and since they all point to dpp-mRNA-5 I backed up the provided est and removed it.  The response was:

polishig ESTs
running  est2genome search.
#--------- command -------------#
Widget::exonerate::est2genome:
/Data/Apps/exonerate/src/program/exonerate  -q /tmp/maker_I7TZxt/0/dpp-mRNA-4.for.22889-32056.0.fasta -t /tmp/maker_I7TZxt/0/contig-dpp-500-500.22889-32056.0.fasta -Q dna -T dna --model est2genome  --minintron 20 --maxintron 10000 --showcigar --percent 20 > /tmp/maker_I7TZxt/0/contig-dpp-500-500.22889-32056.dpp-mRNA-4.e.exonerate
#-------------------------------#
Messed up acceptor:TT in Widget::exonerate::est2genome::get_acceptor!
--> rank=NA, hostname=beanblade4
ERROR: Failed while polishig ESTs
ERROR: Chunk failed at level:2, tier_type:3
FAILED CONTIG:contig-dpp-500-500

ERROR: Chunk failed at level:4, tier_type:0
FAILED CONTIG:contig-dpp-500-500

So the error seems to be pointing at something happening when wrapping up the ESTs.

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755
_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org



_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|

Re: Failed while polishing ESTs

Seth_m55
On a whim I decided to switch to the hsap demo data and it completed without issue.  I went back to dpp and this time is completed.  I hadn't changed anything but the maker_opts.ctl lines that had "dpp" to "hsap" and then inverted the change. 

Mayhaps there was something not unloaded from memory in an earlier run?  It's that, ghosts, or rogue ions :/

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755

On Wed, Feb 22, 2017 at 1:57 PM, Seth Munholland <[hidden email]> wrote:
It is the test data, the dpp set to be specific.

I already checked all the installs to be sure they configured and compile without error and are up to date.

I've been deleting between each run.

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755

On Wed, Feb 22, 2017 at 1:16 PM, Carson Holt <[hidden email]> wrote:
So you are running the test data job correct? So if you get any error with the test data job, something is wrong with your installation.

Make sure BioPerl is up to data (and the same everywhere). If using your own installation of Perl, make sure it had BerkleyDB support when you installed it (if you are using something like perlbrew , you may not have BerkleyDB support and this may affect BioPerl indexing). Also try reinstalling exonertate.

And make sure to delete any run directories before retrying.

—Carson


On Feb 22, 2017, at 11:03 AM, Seth Munholland <[hidden email]> wrote:

After my clustering issue I figured I would go node by node and run MAKER locally on the test data set to be sure that it was working properly before trying it as a full MPI run.  After adjusting all my exes to point to the NFS versions I am consistently getting the same error on each node when it comes time to run exonerate:

polishig ESTs
running  est2genome search.
#--------- command -------------#
Widget::exonerate::est2genome:
/Data/Apps/exonerate/src/program/exonerate  -q /tmp/maker_q3n9fB/0/dpp-mRNA-5.for.26386-32056.0.fasta -t /tmp/maker_q3n9fB/0/contig-dpp-500-500.26386-32056.0.fasta -Q dna -T dna --model est2genome  --minintron 20 --maxintron 10000 --showcigar --percent 20 > /tmp/maker_q3n9fB/0/contig-dpp-500-500.26386-32056.dpp-mRNA-5.e.exonerate
#-------------------------------#
Messed up acceptor:TT in Widget::exonerate::est2genome::get_acceptor!
--> rank=NA, hostname=beanblade2
ERROR: Failed while polishig ESTs
ERROR: Chunk failed at level:2, tier_type:3
FAILED CONTIG:contig-dpp-500-500

ERROR: Chunk failed at level:4, tier_type:0
FAILED CONTIG:contig-dpp-500-500

The only results I find on google was an issue with an improper character in the est file, but a cat of the dpp_est.fasta shows nothing incorrect and since they all point to dpp-mRNA-5 I backed up the provided est and removed it.  The response was:

polishig ESTs
running  est2genome search.
#--------- command -------------#
Widget::exonerate::est2genome:
/Data/Apps/exonerate/src/program/exonerate  -q /tmp/maker_I7TZxt/0/dpp-mRNA-4.for.22889-32056.0.fasta -t /tmp/maker_I7TZxt/0/contig-dpp-500-500.22889-32056.0.fasta -Q dna -T dna --model est2genome  --minintron 20 --maxintron 10000 --showcigar --percent 20 > /tmp/maker_I7TZxt/0/contig-dpp-500-500.22889-32056.dpp-mRNA-4.e.exonerate
#-------------------------------#
Messed up acceptor:TT in Widget::exonerate::est2genome::get_acceptor!
--> rank=NA, hostname=beanblade4
ERROR: Failed while polishig ESTs
ERROR: Chunk failed at level:2, tier_type:3
FAILED CONTIG:contig-dpp-500-500

ERROR: Chunk failed at level:4, tier_type:0
FAILED CONTIG:contig-dpp-500-500

So the error seems to be pointing at something happening when wrapping up the ESTs.

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755
_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org




_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|

Re: Failed while polishing ESTs

Carson Holt-2
I still think you may have something wrong somewhere with some part of your installation (rogue libraries, compiler incompatibilities, etc.). Especially given your earlier issues with Perl libraries.

—Carson


On Feb 22, 2017, at 12:00 PM, Seth Munholland <[hidden email]> wrote:

On a whim I decided to switch to the hsap demo data and it completed without issue.  I went back to dpp and this time is completed.  I hadn't changed anything but the maker_opts.ctl lines that had "dpp" to "hsap" and then inverted the change. 

Mayhaps there was something not unloaded from memory in an earlier run?  It's that, ghosts, or rogue ions :/

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755

On Wed, Feb 22, 2017 at 1:57 PM, Seth Munholland <[hidden email]> wrote:
It is the test data, the dpp set to be specific.

I already checked all the installs to be sure they configured and compile without error and are up to date.

I've been deleting between each run.

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755

On Wed, Feb 22, 2017 at 1:16 PM, Carson Holt <[hidden email]> wrote:
So you are running the test data job correct? So if you get any error with the test data job, something is wrong with your installation.

Make sure BioPerl is up to data (and the same everywhere). If using your own installation of Perl, make sure it had BerkleyDB support when you installed it (if you are using something like perlbrew , you may not have BerkleyDB support and this may affect BioPerl indexing). Also try reinstalling exonertate.

And make sure to delete any run directories before retrying.

—Carson


On Feb 22, 2017, at 11:03 AM, Seth Munholland <[hidden email]> wrote:

After my clustering issue I figured I would go node by node and run MAKER locally on the test data set to be sure that it was working properly before trying it as a full MPI run.  After adjusting all my exes to point to the NFS versions I am consistently getting the same error on each node when it comes time to run exonerate:

polishig ESTs
running  est2genome search.
#--------- command -------------#
Widget::exonerate::est2genome:
/Data/Apps/exonerate/src/program/exonerate  -q /tmp/maker_q3n9fB/0/dpp-mRNA-5.for.26386-32056.0.fasta -t /tmp/maker_q3n9fB/0/contig-dpp-500-500.26386-32056.0.fasta -Q dna -T dna --model est2genome  --minintron 20 --maxintron 10000 --showcigar --percent 20 > /tmp/maker_q3n9fB/0/contig-dpp-500-500.26386-32056.dpp-mRNA-5.e.exonerate
#-------------------------------#
Messed up acceptor:TT in Widget::exonerate::est2genome::get_acceptor!
--> rank=NA, hostname=beanblade2
ERROR: Failed while polishig ESTs
ERROR: Chunk failed at level:2, tier_type:3
FAILED CONTIG:contig-dpp-500-500

ERROR: Chunk failed at level:4, tier_type:0
FAILED CONTIG:contig-dpp-500-500

The only results I find on google was an issue with an improper character in the est file, but a cat of the dpp_est.fasta shows nothing incorrect and since they all point to dpp-mRNA-5 I backed up the provided est and removed it.  The response was:

polishig ESTs
running  est2genome search.
#--------- command -------------#
Widget::exonerate::est2genome:
/Data/Apps/exonerate/src/program/exonerate  -q /tmp/maker_I7TZxt/0/dpp-mRNA-4.for.22889-32056.0.fasta -t /tmp/maker_I7TZxt/0/contig-dpp-500-500.22889-32056.0.fasta -Q dna -T dna --model est2genome  --minintron 20 --maxintron 10000 --showcigar --percent 20 > /tmp/maker_I7TZxt/0/contig-dpp-500-500.22889-32056.dpp-mRNA-4.e.exonerate
#-------------------------------#
Messed up acceptor:TT in Widget::exonerate::est2genome::get_acceptor!
--> rank=NA, hostname=beanblade4
ERROR: Failed while polishig ESTs
ERROR: Chunk failed at level:2, tier_type:3
FAILED CONTIG:contig-dpp-500-500

ERROR: Chunk failed at level:4, tier_type:0
FAILED CONTIG:contig-dpp-500-500

So the error seems to be pointing at something happening when wrapping up the ESTs.

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755
_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org





_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|

Re: Failed while polishing ESTs

Seth_m55
I'll wipe it clean and do a fresh install of everything to be 100% safe.

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755

On Wed, Feb 22, 2017 at 2:03 PM, Carson Holt <[hidden email]> wrote:
I still think you may have something wrong somewhere with some part of your installation (rogue libraries, compiler incompatibilities, etc.). Especially given your earlier issues with Perl libraries.

—Carson


On Feb 22, 2017, at 12:00 PM, Seth Munholland <[hidden email]> wrote:

On a whim I decided to switch to the hsap demo data and it completed without issue.  I went back to dpp and this time is completed.  I hadn't changed anything but the maker_opts.ctl lines that had "dpp" to "hsap" and then inverted the change. 

Mayhaps there was something not unloaded from memory in an earlier run?  It's that, ghosts, or rogue ions :/

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755

On Wed, Feb 22, 2017 at 1:57 PM, Seth Munholland <[hidden email]> wrote:
It is the test data, the dpp set to be specific.

I already checked all the installs to be sure they configured and compile without error and are up to date.

I've been deleting between each run.

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755

On Wed, Feb 22, 2017 at 1:16 PM, Carson Holt <[hidden email]> wrote:
So you are running the test data job correct? So if you get any error with the test data job, something is wrong with your installation.

Make sure BioPerl is up to data (and the same everywhere). If using your own installation of Perl, make sure it had BerkleyDB support when you installed it (if you are using something like perlbrew , you may not have BerkleyDB support and this may affect BioPerl indexing). Also try reinstalling exonertate.

And make sure to delete any run directories before retrying.

—Carson


On Feb 22, 2017, at 11:03 AM, Seth Munholland <[hidden email]> wrote:

After my clustering issue I figured I would go node by node and run MAKER locally on the test data set to be sure that it was working properly before trying it as a full MPI run.  After adjusting all my exes to point to the NFS versions I am consistently getting the same error on each node when it comes time to run exonerate:

polishig ESTs
running  est2genome search.
#--------- command -------------#
Widget::exonerate::est2genome:
/Data/Apps/exonerate/src/program/exonerate  -q /tmp/maker_q3n9fB/0/dpp-mRNA-5.for.26386-32056.0.fasta -t /tmp/maker_q3n9fB/0/contig-dpp-500-500.26386-32056.0.fasta -Q dna -T dna --model est2genome  --minintron 20 --maxintron 10000 --showcigar --percent 20 > /tmp/maker_q3n9fB/0/contig-dpp-500-500.26386-32056.dpp-mRNA-5.e.exonerate
#-------------------------------#
Messed up acceptor:TT in Widget::exonerate::est2genome::get_acceptor!
--> rank=NA, hostname=beanblade2
ERROR: Failed while polishig ESTs
ERROR: Chunk failed at level:2, tier_type:3
FAILED CONTIG:contig-dpp-500-500

ERROR: Chunk failed at level:4, tier_type:0
FAILED CONTIG:contig-dpp-500-500

The only results I find on google was an issue with an improper character in the est file, but a cat of the dpp_est.fasta shows nothing incorrect and since they all point to dpp-mRNA-5 I backed up the provided est and removed it.  The response was:

polishig ESTs
running  est2genome search.
#--------- command -------------#
Widget::exonerate::est2genome:
/Data/Apps/exonerate/src/program/exonerate  -q /tmp/maker_I7TZxt/0/dpp-mRNA-4.for.22889-32056.0.fasta -t /tmp/maker_I7TZxt/0/contig-dpp-500-500.22889-32056.0.fasta -Q dna -T dna --model est2genome  --minintron 20 --maxintron 10000 --showcigar --percent 20 > /tmp/maker_I7TZxt/0/contig-dpp-500-500.22889-32056.dpp-mRNA-4.e.exonerate
#-------------------------------#
Messed up acceptor:TT in Widget::exonerate::est2genome::get_acceptor!
--> rank=NA, hostname=beanblade4
ERROR: Failed while polishig ESTs
ERROR: Chunk failed at level:2, tier_type:3
FAILED CONTIG:contig-dpp-500-500

ERROR: Chunk failed at level:4, tier_type:0
FAILED CONTIG:contig-dpp-500-500

So the error seems to be pointing at something happening when wrapping up the ESTs.

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755
_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org






_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|

Re: Failed while polishing ESTs

Carson Holt-2
In the most extreme case, you may even need to go as far as setting up your own perl. If you do that, make sure to unset the PERL5LIB environmental variable, so other perl libraries don’t interfere.

—Carson



On Feb 22, 2017, at 12:26 PM, Seth Munholland <[hidden email]> wrote:

I'll wipe it clean and do a fresh install of everything to be 100% safe.

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755

On Wed, Feb 22, 2017 at 2:03 PM, Carson Holt <[hidden email]> wrote:
I still think you may have something wrong somewhere with some part of your installation (rogue libraries, compiler incompatibilities, etc.). Especially given your earlier issues with Perl libraries.

—Carson


On Feb 22, 2017, at 12:00 PM, Seth Munholland <[hidden email]> wrote:

On a whim I decided to switch to the hsap demo data and it completed without issue.  I went back to dpp and this time is completed.  I hadn't changed anything but the maker_opts.ctl lines that had "dpp" to "hsap" and then inverted the change. 

Mayhaps there was something not unloaded from memory in an earlier run?  It's that, ghosts, or rogue ions :/

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755

On Wed, Feb 22, 2017 at 1:57 PM, Seth Munholland <[hidden email]> wrote:
It is the test data, the dpp set to be specific.

I already checked all the installs to be sure they configured and compile without error and are up to date.

I've been deleting between each run.

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755

On Wed, Feb 22, 2017 at 1:16 PM, Carson Holt <[hidden email]> wrote:
So you are running the test data job correct? So if you get any error with the test data job, something is wrong with your installation.

Make sure BioPerl is up to data (and the same everywhere). If using your own installation of Perl, make sure it had BerkleyDB support when you installed it (if you are using something like perlbrew , you may not have BerkleyDB support and this may affect BioPerl indexing). Also try reinstalling exonertate.

And make sure to delete any run directories before retrying.

—Carson


On Feb 22, 2017, at 11:03 AM, Seth Munholland <[hidden email]> wrote:

After my clustering issue I figured I would go node by node and run MAKER locally on the test data set to be sure that it was working properly before trying it as a full MPI run.  After adjusting all my exes to point to the NFS versions I am consistently getting the same error on each node when it comes time to run exonerate:

polishig ESTs
running  est2genome search.
#--------- command -------------#
Widget::exonerate::est2genome:
/Data/Apps/exonerate/src/program/exonerate  -q /tmp/maker_q3n9fB/0/dpp-mRNA-5.for.26386-32056.0.fasta -t /tmp/maker_q3n9fB/0/contig-dpp-500-500.26386-32056.0.fasta -Q dna -T dna --model est2genome  --minintron 20 --maxintron 10000 --showcigar --percent 20 > /tmp/maker_q3n9fB/0/contig-dpp-500-500.26386-32056.dpp-mRNA-5.e.exonerate
#-------------------------------#
Messed up acceptor:TT in Widget::exonerate::est2genome::get_acceptor!
--> rank=NA, hostname=beanblade2
ERROR: Failed while polishig ESTs
ERROR: Chunk failed at level:2, tier_type:3
FAILED CONTIG:contig-dpp-500-500

ERROR: Chunk failed at level:4, tier_type:0
FAILED CONTIG:contig-dpp-500-500

The only results I find on google was an issue with an improper character in the est file, but a cat of the dpp_est.fasta shows nothing incorrect and since they all point to dpp-mRNA-5 I backed up the provided est and removed it.  The response was:

polishig ESTs
running  est2genome search.
#--------- command -------------#
Widget::exonerate::est2genome:
/Data/Apps/exonerate/src/program/exonerate  -q /tmp/maker_I7TZxt/0/dpp-mRNA-4.for.22889-32056.0.fasta -t /tmp/maker_I7TZxt/0/contig-dpp-500-500.22889-32056.0.fasta -Q dna -T dna --model est2genome  --minintron 20 --maxintron 10000 --showcigar --percent 20 > /tmp/maker_I7TZxt/0/contig-dpp-500-500.22889-32056.dpp-mRNA-4.e.exonerate
#-------------------------------#
Messed up acceptor:TT in Widget::exonerate::est2genome::get_acceptor!
--> rank=NA, hostname=beanblade4
ERROR: Failed while polishig ESTs
ERROR: Chunk failed at level:2, tier_type:3
FAILED CONTIG:contig-dpp-500-500

ERROR: Chunk failed at level:4, tier_type:0
FAILED CONTIG:contig-dpp-500-500

So the error seems to be pointing at something happening when wrapping up the ESTs.

Seth Munholland, B.Sc.
Department of Biological Sciences
Rm. 304 Biology Building
University of Windsor
401 Sunset Ave. N9B 3P4
T: (519) 253-3000 Ext: 4755
_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org







_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org