For help about masking repeats before annotation

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

For help about masking repeats before annotation

dcg@cau.edu.cn
Dear sir:
       Before the maker opeations, I do repeat masking first on my contigs. 
       However , when I followed " Repeat Library Construction-Advanced ",  no results generated after I running LTRharvest. So I couldn't do any further.
       
       When I attempted to followRepeat Library Construction-Basic " to run RepeatModeler, a note caused my attention even though RECON can return some results :
       NOTE: RepeatScout did not return any models.

       Is the situation above normal in masking progress? How can I deal with the problems to make a high-quality repeat library for my assemblied contigs?

       Hope to hear from you.
       Best wishes!

Chao Chao

2017.03.05

_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|

Re: For help about masking repeats before annotation

Michael Campbell
Hi Chao Chao,

I’ve not run into this before. Could you post the RepeatModeler command you used?

Thanks,
Mike
On Mar 5, 2017, at 6:26 AM, [hidden email] wrote:

Dear sir:
       Before the maker opeations, I do repeat masking first on my contigs. 
       However , when I followed " Repeat Library Construction-Advanced ",  no results generated after I running LTRharvest. So I couldn't do any further.
       
       When I attempted to followRepeat Library Construction-Basic " to run RepeatModeler, a note caused my attention even though RECON can return some results :
       NOTE: RepeatScout did not return any models.

       Is the situation above normal in masking progress? How can I deal with the problems to make a high-quality repeat library for my assemblied contigs?

       Hope to hear from you.
       Best wishes!

Chao Chao

2017.03.05
_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org


_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|

Re: For help about masking repeats before annotation

Michael Campbell
Hi Chao Chao,

I’m not sure how to trouble shoot this if there were no error messages. I’ve ccd a couple of people that have worked with this protocol much more than I have.

Ning and Kevin,
Do you have any tips for running these tools that may help Chao Chao?

Thanks,
Mike
On Mar 15, 2017, at 8:48 AM, [hidden email] wrote:

Thank for your reply!

To use LTRHarvest, my command is as below(the filename was set for my favor)
DIR1/gt suffixerator -db seqfile -indexname seqfileindex -tis -suf -lcp -des -ssp –dna
DIR1/gt ltrharvest -index seqfileindex -out seqfile.out99 -outinner seqfile.outinner99 -gff3 seqfile.gff99 -minlenltr 100 \
-maxlenltr 6000 -mindistltr 1500 -maxdistltr 25000 -mintsd 5 -maxtsd 5 -motif tgca -similar 99 -vic 10  > seqfile.result99
No error, but no results as well

Chao Chao

2017.03.15
 
Date: 2017-03-15 10:27
Subject: Re: [maker-devel] For help about masking repeats before annotation
Hi Chao Chao,

I’ve not run into this before. Could you post the RepeatModeler command you used?

Thanks,
Mike
On Mar 5, 2017, at 6:26 AM, [hidden email] wrote:

Dear sir:
       Before the maker opeations, I do repeat masking first on my contigs. 
       However , when I followed " Repeat Library Construction-Advanced ",  no results generated after I running LTRharvest. So I couldn't do any further.
       
       When I attempted to followRepeat Library Construction-Basic " to run RepeatModeler, a note caused my attention even though RECON can return some results :
       NOTE: RepeatScout did not return any models.

       Is the situation above normal in masking progress? How can I deal with the problems to make a high-quality repeat library for my assemblied contigs?

       Hope to hear from you.
       Best wishes!

Chao Chao

2017.03.05
_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org


_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|

Re: For help about masking repeats before annotation

jiangn

Hi Chao Chao,


I guess you have an extra "\" in your second command. We put that sign there to indicate the entire thing belong to one command (it is too long to put in one row). I suggest you remove the "\" and try again.


Good luck!


Ning Jiang


From: Michael Campbell <[hidden email]>
Sent: Wednesday, March 15, 2017 11:00:13 AM
To: [hidden email]
Cc: maker-devel; Jiang, Ning; Kevin Childs
Subject: Re: [maker-devel] For help about masking repeats before annotation
 
Hi Chao Chao,

I’m not sure how to trouble shoot this if there were no error messages. I’ve ccd a couple of people that have worked with this protocol much more than I have.

Ning and Kevin,
Do you have any tips for running these tools that may help Chao Chao?

Thanks,
Mike
On Mar 15, 2017, at 8:48 AM, [hidden email] wrote:

Thank for your reply!

To use LTRHarvest, my command is as below(the filename was set for my favor)
DIR1/gt suffixerator -db seqfile -indexname seqfileindex -tis -suf -lcp -des -ssp –dna
DIR1/gt ltrharvest -index seqfileindex -out seqfile.out99 -outinner seqfile.outinner99 -gff3 seqfile.gff99 -minlenltr 100 \
-maxlenltr 6000 -mindistltr 1500 -maxdistltr 25000 -mintsd 5 -maxtsd 5 -motif tgca -similar 99 -vic 10  > seqfile.result99
No error, but no results as well

Chao Chao

2017.03.15
 
Date: 2017-03-15 10:27
Subject: Re: [maker-devel] For help about masking repeats before annotation
Hi Chao Chao,

I’ve not run into this before. Could you post the RepeatModeler command you used?

Thanks,
Mike
On Mar 5, 2017, at 6:26 AM, [hidden email] wrote:

Dear sir:
       Before the maker opeations, I do repeat masking first on my contigs. 
       However , when I followed " Repeat Library Construction-Advanced ",  no results generated after I running LTRharvest. So I couldn't do any further.
       
       When I attempted to followRepeat Library Construction-Basic " to run RepeatModeler, a note caused my attention even though RECON can return some results :
       NOTE: RepeatScout did not return any models.

       Is the situation above normal in masking progress? How can I deal with the problems to make a high-quality repeat library for my assemblied contigs?

       Hope to hear from you.
       Best wishes!

Chao Chao

2017.03.05
_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org


_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org