[Gmod-tripal-devel] Drupal Tripal update and bytes patch

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Gmod-tripal-devel] Drupal Tripal update and bytes patch

Michael Dondrup-3
Hi,
we are finalizing our Drupal/Tripal update to D7. In the update documentation it is
stated that  drupal.pgsql-bytea.27 patch is required.

However checking the related issue in which the patch was posted, there have been several newer
patches:
https://www.drupal.org/node/1031122

In particular this notice catches my attention:
“Earlier in this issue a patch was committed that attempted to escape backslashes, but this was incorrect both due to different treatment of escaping on postgres (standard_conforming_strings can be configured differently and the default is different after 9.1. Also even with or without that setting, the backslash escaping didn't take into account PHP's own backslash escaping."

So I guess this refers to the bytea patch. Does Tripal still require patch 27, or have you tried the latest patch
https://www.drupal.org/files/issues/1031122-2.122.patch

Also, according to my understanding,  should it possibly be installed before the first db update of drupal core is run,
say as Step 10b?

Best
Michael

Michael Dondrup
Researcher
Sea Lice Research Centre
Department of Informatics
University of Bergen
Thormøhlensgate 55, N-5008 Bergen,
Norway


------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Gmod-tripal-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-tripal-devel

signature.asc (465 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Gmod-tripal-devel] [Gmod-tripal] Drupal Tripal update and bytes patch

Michael Dondrup-3
Hi again,

I have checked a bit more about  the proposed resolution, but the latest patch given for issue
> https://www.drupal.org/node/1031122
is not applicable to D7 but to D8. The bytea .27 patch however is not fixing the problem correctly according
to the issue summary. If effective, I suggest that such a patch has to be applied before running the core update anyway, not after.

Could you tell me where the bytea conversion is effectively used in Tripal, please?

Also, please let me know if anyone has a backport of the latest patch to D7 already.

Thank you very much
Michael


> On Feb 19, 2016, at 7:43 PM, Michael Dondrup <[hidden email]> wrote:
>
> Hi,
> we are finalizing our Drupal/Tripal update to D7. In the update documentation it is
> stated that  drupal.pgsql-bytea.27 patch is required.
>
> However checking the related issue in which the patch was posted, there have been several newer
> patches:
> https://www.drupal.org/node/1031122
>
> In particular this notice catches my attention:
> “Earlier in this issue a patch was committed that attempted to escape backslashes, but this was incorrect both due to different treatment of escaping on postgres (standard_conforming_strings can be configured differently and the default is different after 9.1. Also even with or without that setting, the backslash escaping didn't take into account PHP's own backslash escaping."
>
> So I guess this refers to the bytea patch. Does Tripal still require patch 27, or have you tried the latest patch
> https://www.drupal.org/files/issues/1031122-2.122.patch
>
> Also, according to my understanding,  should it possibly be installed before the first db update of drupal core is run,
> say as Step 10b?
>
> Best
> Michael
>
> Michael Dondrup
> Researcher
> Sea Lice Research Centre
> Department of Informatics
> University of Bergen
> Thormøhlensgate 55, N-5008 Bergen,
> Norway
>
> ------------------------------------------------------------------------------
> Site24x7 APM Insight: Get Deep Visibility into Application Performance
> APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
> Monitor end-to-end web transactions and take corrective actions now
> Troubleshoot faster and improve end-user experience. Signup Now!
> http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140_______________________________________________
> Gmod-tripal mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gmod-tripal

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Gmod-tripal-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-tripal-devel

signature.asc (465 bytes) Download Attachment