[Gmod-tripal-devel] Tribal taxonomy patch for update not recommended.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Gmod-tripal-devel] Tribal taxonomy patch for update not recommended.

Michael Dondrup-3
Hi,

again with some patch news. As of Drupal core 7.42 the Taxonomy patch listed under Step 10
of the update manual should no longer be applied. Please update the documentation.

Having the patch applied will result in the following error message during the update: (Tested with Postgres 8.4)

SQLSTATE[23502]: Not null violation: 7 ERROR:  null value in column  [error]
"n" violates not-null constraint
Performed update: taxonomy_update_7005

If the patch has already been applied it can be removed by simply applying it again and answering [y]
on the ‘assume -R’ question or simply
patch -R -p1 <  taxonomy_install.patch

In addition, to be able to run the updates again you have to run the following sql command on the drupal db:
drop table taxonomy_update_7005;


Best regards




Michael Dondrup
Researcher
Sea Lice Research Centre
Department of Informatics
University of Bergen
Thormøhlensgate 55, N-5008 Bergen,
Norway


------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Gmod-tripal-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-tripal-devel

signature.asc (465 bytes) Download Attachment