Installing galaxy with sge

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Installing galaxy with sge

Mariette
Hi everyone,
I installed galaxy on our system and it worked just fine until I tryed
to settled it
up to make it run on our cluster. So I edited the universe_wsgi.ini file
as following:

# Comma-separated list of job runners to start.  local is always
started.  If
# left commented, no jobs will be run on the cluster, even if a cluster
URL is
# explicitly defined in the [galaxy:tool_runners] section below.  The
runners
# currently available are 'pbs' and 'sge'.
start_job_runners = sge

# The URL for the default runner to use when a tool doesn't explicity
define a
# runner below.  For help on the cluster URL format, see the
ClusteringGalaxy
# Wiki.  Leave commented if not using a cluster job runner.
default_cluster_job_runner = sge://INRA_CLC/wflowq//-R y -l h_vmem=8G -l
mem=8G

I also did the egg thing like this :

SGE_ROOT=/SGE/n1ge62 python2.5 scripts/scramble.py DRMAA_python

This line looks like it worked out.

Then when starting the engine, I'm catching this error :

Traceback (most recent call last):
 File "/usr/local/bioinfo/src/galaxy_dist/lib/galaxy/web/buildapp.py",
line 61, in app_factory
   app = UniverseApplication( global_conf = global_conf, **kwargs )
 File "/usr/local/bioinfo/src/galaxy_dist/lib/galaxy/app.py", line 69,
in __init__
   self.job_manager = jobs.JobManager( self )
 File "/usr/local/bioinfo/src/galaxy_dist/lib/galaxy/jobs/__init__.py",
line 40, in __init__
   self.dispatcher = DefaultJobDispatcher( app )
 File "/usr/local/bioinfo/src/galaxy_dist/lib/galaxy/jobs/__init__.py",
line 777, in __init__
   self.job_runners[runner_name] = runners.sge.SGEJobRunner( app )
 File
"/usr/local/bioinfo/src/galaxy_dist/lib/galaxy/jobs/runners/sge.py",
line 83, in __init__
   self.ds.init( self.default_cell )
 File "build/bdist.linux-x86_64/egg/DRMAA.py", line 186, in init
   errParse(eno, estr)
 File "build/bdist.linux-x86_64/egg/DRMAA.py", line 167, in errParse
   else: raise _errindex[errno-_errMin](errstring)
InvalidArgumentError: The input value for an argument is invalid.
Exception DRMAA.NoActiveSessionError: NoActiveSessionError('',) in
<bound method Session.__del__ of <DRMAA.Session object at 0x104e2bd0>>
ignored

I'm guessing someting weird is happening with the DRMAA eggs, so I
edited the
/usr/local/bioinfo/src/galaxy_dist/lib/galaxy/jobs/runners/sge.py to
figure out if the module is
well loaded and sounds like it is ! So I'm kind of lost ... do you have
any idea on what is
going on ?

One other weird think is that I had to unset some tools from the
tool_conf.xml when starting
with the sge parameters, what hadn't to be done whitout sge, does it
sounds normal to you ?

thanks,
Jerome

_______________________________________________
galaxy-user mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-user