InterMine 4.0 installation failed at "./gradlew install" in "intermine/bio"

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

InterMine 4.0 installation failed at "./gradlew install" in "intermine/bio"

Pengcheng Yang
Hi InterMiners,

I am upgrading InterMine from 1.8.5 to 4.0.0. Following the instructions
(https://intermine.readthedocs.io/en/latest/system-requirements/software/git/),
I came across a error when run "./gradlew install" in "intermine/bio"
directory. The error information listed below. It seems that the link
"https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/bridges/bridges-core/1.1.0/bridges-core-1.1.0.pom"
gives 409 status. Could anyone help me on this problem?

BTW, how could the available JARs from the JCenter be used if no
customized changes are required?

Thank you and best,

Pengcheng


================= error message ============================

FAILURE: Build failed with an exception.

* What went wrong:
Could not resolve all files for configuration
':bio-webapp:compileClasspath'.
 > Could not resolve psidev.psi.mi.jami.bridges:bridges-core:1.1.0.
   Required by:
       project :bio-webapp
    > Could not resolve psidev.psi.mi.jami.bridges:bridges-core:1.1.0.
       > Could not get resource
'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/bridges/bridges-core/1.1.0/bridges-core-1.1.0.pom'.
          > Could not GET
'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/bridges/bridges-core/1.1.0/bridges-core-1.1.0.pom'.
Received status code 409 from server:
    > Could not resolve psidev.psi.mi.jami.bridges:bridges-core:1.1.0.
       > Could not get resource
'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/bridges/bridges-core/1.1.0/bridges-core-1.1.0.pom'.
          > Could not GET
'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/bridges/bridges-core/1.1.0/bridges-core-1.1.0.pom'.
             > sun.security.validator.ValidatorException: PKIX path
building failed:
sun.security.provider.certpath.SunCertPathBuilderException: unable to
find valid certification path to requested target
 > Could not resolve psidev.psi.mi.jami.bridges:jami-ols:1.1.0.
   Required by:
       project :bio-webapp
    > Could not resolve psidev.psi.mi.jami.bridges:jami-ols:1.1.0.
       > Could not get resource
'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/bridges/jami-ols/1.1.0/jami-ols-1.1.0.pom'.
          > Could not GET
'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/bridges/jami-ols/1.1.0/jami-ols-1.1.0.pom'.
Received status code 409 from server:
    > Could not resolve psidev.psi.mi.jami.bridges:jami-ols:1.1.0.
       > Could not get resource
'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/bridges/jami-ols/1.1.0/jami-ols-1.1.0.pom'.
          > Could not GET
'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/bridges/jami-ols/1.1.0/jami-ols-1.1.0.pom'.
             > sun.security.validator.ValidatorException: PKIX path
building failed:
sun.security.provider.certpath.SunCertPathBuilderException: unable to
find valid certification path to requested target
 > Could not resolve psidev.psi.mi.jami:jami-core:1.2.3.
   Required by:
       project :bio-webapp
    > Could not resolve psidev.psi.mi.jami:jami-core:1.2.3.
       > Could not get resource
'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/jami-core/1.2.3/jami-core-1.2.3.pom'.
          > Could not GET
'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/jami-core/1.2.3/jami-core-1.2.3.pom'.
Received status code 409 from server:
    > Could not resolve psidev.psi.mi.jami:jami-core:1.2.3.
       > Could not get resource
'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/jami-core/1.2.3/jami-core-1.2.3.pom'.
          > Could not GET
'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/jami-core/1.2.3/jami-core-1.2.3.pom'.
             > sun.security.validator.ValidatorException: PKIX path
building failed:
sun.security.provider.certpath.SunCertPathBuilderException: unable to
find valid certification path to requested target
 > Could not resolve psidev.psi.mi.jami:jami-interactionviewer-json:2.0.2.
   Required by:
       project :bio-webapp
    > Could not resolve
psidev.psi.mi.jami:jami-interactionviewer-json:2.0.2.
       > Could not get resource
'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/jami-interactionviewer-json/2.0.2/jami-interactionviewer-json-2.0.2.pom'.
          > Could not GET
'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/jami-interactionviewer-json/2.0.2/jami-interactionviewer-json-2.0.2.pom'.
Received status code 409 from server:
    > Could not resolve
psidev.psi.mi.jami:jami-interactionviewer-json:2.0.2.
       > Could not get resource
'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/jami-interactionviewer-json/2.0.2/jami-interactionviewer-json-2.0.2.pom'.
          > Could not GET
'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/jami-interactionviewer-json/2.0.2/jami-interactionviewer-json-2.0.2.pom'.
             > sun.security.validator.ValidatorException: PKIX path
building failed:
sun.security.provider.certpath.SunCertPathBuilderException: unable to
find valid certification path to requested target

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or
--debug option to get more log output.

* Get more help at https://help.gradle.org

BUILD FAILED in 30s
30 actionable tasks: 11 executed, 19 up-to-date

_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: InterMine 4.0 installation failed at "./gradlew install" in "intermine/bio"

Julie Sullivan-2
Hi Pengcheng!

We get that JAR from the EBI, and their Nexus seems to be down right
now. Let me investigate.

However, since your mine does not have custom InterMine code, you do not
need to install the InterMine JARs. Instead, deploy your webapp and
build your database as normal, in your $MINE directory.

Maven will download the needed JARs for you! No installation needed. :)

Cheers
Julie



On 20/05/2019 06:02, Pengcheng Yang wrote:

> Hi InterMiners,
>
> I am upgrading InterMine from 1.8.5 to 4.0.0. Following the instructions
> (https://intermine.readthedocs.io/en/latest/system-requirements/software/git/),
> I came across a error when run "./gradlew install" in "intermine/bio"
> directory. The error information listed below. It seems that the link
> "https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/bridges/bridges-core/1.1.0/bridges-core-1.1.0.pom"
> gives 409 status. Could anyone help me on this problem?
>
> BTW, how could the available JARs from the JCenter be used if no
> customized changes are required?
>
> Thank you and best,
>
> Pengcheng
>
>
> ================= error message ============================
>
> FAILURE: Build failed with an exception.
>
> * What went wrong:
> Could not resolve all files for configuration
> ':bio-webapp:compileClasspath'.
>  > Could not resolve psidev.psi.mi.jami.bridges:bridges-core:1.1.0.
>    Required by:
>        project :bio-webapp
>     > Could not resolve psidev.psi.mi.jami.bridges:bridges-core:1.1.0.
>        > Could not get resource
> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/bridges/bridges-core/1.1.0/bridges-core-1.1.0.pom'.
>
>           > Could not GET
> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/bridges/bridges-core/1.1.0/bridges-core-1.1.0.pom'.
> Received status code 409 from server:
>     > Could not resolve psidev.psi.mi.jami.bridges:bridges-core:1.1.0.
>        > Could not get resource
> 'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/bridges/bridges-core/1.1.0/bridges-core-1.1.0.pom'.
>
>           > Could not GET
> 'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/bridges/bridges-core/1.1.0/bridges-core-1.1.0.pom'.
>
>              > sun.security.validator.ValidatorException: PKIX path
> building failed:
> sun.security.provider.certpath.SunCertPathBuilderException: unable to
> find valid certification path to requested target
>  > Could not resolve psidev.psi.mi.jami.bridges:jami-ols:1.1.0.
>    Required by:
>        project :bio-webapp
>     > Could not resolve psidev.psi.mi.jami.bridges:jami-ols:1.1.0.
>        > Could not get resource
> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/bridges/jami-ols/1.1.0/jami-ols-1.1.0.pom'.
>
>           > Could not GET
> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/bridges/jami-ols/1.1.0/jami-ols-1.1.0.pom'.
> Received status code 409 from server:
>     > Could not resolve psidev.psi.mi.jami.bridges:jami-ols:1.1.0.
>        > Could not get resource
> 'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/bridges/jami-ols/1.1.0/jami-ols-1.1.0.pom'.
>
>           > Could not GET
> 'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/bridges/jami-ols/1.1.0/jami-ols-1.1.0.pom'.
>
>              > sun.security.validator.ValidatorException: PKIX path
> building failed:
> sun.security.provider.certpath.SunCertPathBuilderException: unable to
> find valid certification path to requested target
>  > Could not resolve psidev.psi.mi.jami:jami-core:1.2.3.
>    Required by:
>        project :bio-webapp
>     > Could not resolve psidev.psi.mi.jami:jami-core:1.2.3.
>        > Could not get resource
> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/jami-core/1.2.3/jami-core-1.2.3.pom'.
>
>           > Could not GET
> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/jami-core/1.2.3/jami-core-1.2.3.pom'.
> Received status code 409 from server:
>     > Could not resolve psidev.psi.mi.jami:jami-core:1.2.3.
>        > Could not get resource
> 'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/jami-core/1.2.3/jami-core-1.2.3.pom'.
>
>           > Could not GET
> 'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/jami-core/1.2.3/jami-core-1.2.3.pom'.
>
>              > sun.security.validator.ValidatorException: PKIX path
> building failed:
> sun.security.provider.certpath.SunCertPathBuilderException: unable to
> find valid certification path to requested target
>  > Could not resolve psidev.psi.mi.jami:jami-interactionviewer-json:2.0.2.
>    Required by:
>        project :bio-webapp
>     > Could not resolve
> psidev.psi.mi.jami:jami-interactionviewer-json:2.0.2.
>        > Could not get resource
> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/jami-interactionviewer-json/2.0.2/jami-interactionviewer-json-2.0.2.pom'.
>
>           > Could not GET
> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/jami-interactionviewer-json/2.0.2/jami-interactionviewer-json-2.0.2.pom'.
> Received status code 409 from server:
>     > Could not resolve
> psidev.psi.mi.jami:jami-interactionviewer-json:2.0.2.
>        > Could not get resource
> 'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/jami-interactionviewer-json/2.0.2/jami-interactionviewer-json-2.0.2.pom'.
>
>           > Could not GET
> 'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/jami-interactionviewer-json/2.0.2/jami-interactionviewer-json-2.0.2.pom'.
>
>              > sun.security.validator.ValidatorException: PKIX path
> building failed:
> sun.security.provider.certpath.SunCertPathBuilderException: unable to
> find valid certification path to requested target
>
> * Try:
> Run with --stacktrace option to get the stack trace. Run with --info or
> --debug option to get more log output.
>
> * Get more help at https://help.gradle.org
>
> BUILD FAILED in 30s
> 30 actionable tasks: 11 executed, 19 up-to-date
>
> _______________________________________________
> dev mailing list
> [hidden email]
> https://lists.intermine.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: InterMine 4.0 installation failed at "./gradlew install" in "intermine/bio"

Pengcheng Yang
Hi Julie,

Thank you for your provided help information.

I have tried to test the BioTest Mine with InterMine version 4.0.

best!

Pengcheng


On 2019-5-20 15:24, Julie Sullivan wrote:

> Hi Pengcheng!
>
> We get that JAR from the EBI, and their Nexus seems to be down right
> now. Let me investigate.
>
> However, since your mine does not have custom InterMine code, you do
> not need to install the InterMine JARs. Instead, deploy your webapp
> and build your database as normal, in your $MINE directory.
>
> Maven will download the needed JARs for you! No installation needed. :)
>
> Cheers
> Julie
>
>
>
> On 20/05/2019 06:02, Pengcheng Yang wrote:
>> Hi InterMiners,
>>
>> I am upgrading InterMine from 1.8.5 to 4.0.0. Following the
>> instructions
>> (https://intermine.readthedocs.io/en/latest/system-requirements/software/git/),
>> I came across a error when run "./gradlew install" in "intermine/bio"
>> directory. The error information listed below. It seems that the link
>> "https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/bridges/bridges-core/1.1.0/bridges-core-1.1.0.pom"
>> gives 409 status. Could anyone help me on this problem?
>>
>> BTW, how could the available JARs from the JCenter be used if no
>> customized changes are required?
>>
>> Thank you and best,
>>
>> Pengcheng
>>
>>
>> ================= error message ============================
>>
>> FAILURE: Build failed with an exception.
>>
>> * What went wrong:
>> Could not resolve all files for configuration
>> ':bio-webapp:compileClasspath'.
>>  > Could not resolve psidev.psi.mi.jami.bridges:bridges-core:1.1.0.
>>    Required by:
>>        project :bio-webapp
>>     > Could not resolve psidev.psi.mi.jami.bridges:bridges-core:1.1.0.
>>        > Could not get resource
>> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/bridges/bridges-core/1.1.0/bridges-core-1.1.0.pom'.
>>
>>           > Could not GET
>> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/bridges/bridges-core/1.1.0/bridges-core-1.1.0.pom'.
>> Received status code 409 from server:
>>     > Could not resolve psidev.psi.mi.jami.bridges:bridges-core:1.1.0.
>>        > Could not get resource
>> 'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/bridges/bridges-core/1.1.0/bridges-core-1.1.0.pom'.
>>
>>           > Could not GET
>> 'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/bridges/bridges-core/1.1.0/bridges-core-1.1.0.pom'.
>>
>>              > sun.security.validator.ValidatorException: PKIX path
>> building failed:
>> sun.security.provider.certpath.SunCertPathBuilderException: unable to
>> find valid certification path to requested target
>>  > Could not resolve psidev.psi.mi.jami.bridges:jami-ols:1.1.0.
>>    Required by:
>>        project :bio-webapp
>>     > Could not resolve psidev.psi.mi.jami.bridges:jami-ols:1.1.0.
>>        > Could not get resource
>> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/bridges/jami-ols/1.1.0/jami-ols-1.1.0.pom'.
>>
>>           > Could not GET
>> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/bridges/jami-ols/1.1.0/jami-ols-1.1.0.pom'.
>> Received status code 409 from server:
>>     > Could not resolve psidev.psi.mi.jami.bridges:jami-ols:1.1.0.
>>        > Could not get resource
>> 'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/bridges/jami-ols/1.1.0/jami-ols-1.1.0.pom'.
>>
>>           > Could not GET
>> 'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/bridges/jami-ols/1.1.0/jami-ols-1.1.0.pom'.
>>
>>              > sun.security.validator.ValidatorException: PKIX path
>> building failed:
>> sun.security.provider.certpath.SunCertPathBuilderException: unable to
>> find valid certification path to requested target
>>  > Could not resolve psidev.psi.mi.jami:jami-core:1.2.3.
>>    Required by:
>>        project :bio-webapp
>>     > Could not resolve psidev.psi.mi.jami:jami-core:1.2.3.
>>        > Could not get resource
>> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/jami-core/1.2.3/jami-core-1.2.3.pom'.
>>
>>           > Could not GET
>> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/jami-core/1.2.3/jami-core-1.2.3.pom'.
>> Received status code 409 from server:
>>     > Could not resolve psidev.psi.mi.jami:jami-core:1.2.3.
>>        > Could not get resource
>> 'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/jami-core/1.2.3/jami-core-1.2.3.pom'.
>>
>>           > Could not GET
>> 'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/jami-core/1.2.3/jami-core-1.2.3.pom'.
>>
>>              > sun.security.validator.ValidatorException: PKIX path
>> building failed:
>> sun.security.provider.certpath.SunCertPathBuilderException: unable to
>> find valid certification path to requested target
>>  > Could not resolve
>> psidev.psi.mi.jami:jami-interactionviewer-json:2.0.2.
>>    Required by:
>>        project :bio-webapp
>>     > Could not resolve
>> psidev.psi.mi.jami:jami-interactionviewer-json:2.0.2.
>>        > Could not get resource
>> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/jami-interactionviewer-json/2.0.2/jami-interactionviewer-json-2.0.2.pom'.
>>
>>           > Could not GET
>> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/psidev/psi/mi/jami/jami-interactionviewer-json/2.0.2/jami-interactionviewer-json-2.0.2.pom'.
>> Received status code 409 from server:
>>     > Could not resolve
>> psidev.psi.mi.jami:jami-interactionviewer-json:2.0.2.
>>        > Could not get resource
>> 'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/jami-interactionviewer-json/2.0.2/jami-interactionviewer-json-2.0.2.pom'.
>>
>>           > Could not GET
>> 'http://www.ebi.ac.uk/intact/maven/nexus/content/repositories/ebi-repo/psidev/psi/mi/jami/jami-interactionviewer-json/2.0.2/jami-interactionviewer-json-2.0.2.pom'.
>>
>>              > sun.security.validator.ValidatorException: PKIX path
>> building failed:
>> sun.security.provider.certpath.SunCertPathBuilderException: unable to
>> find valid certification path to requested target
>>
>> * Try:
>> Run with --stacktrace option to get the stack trace. Run with --info
>> or --debug option to get more log output.
>>
>> * Get more help at https://help.gradle.org
>>
>> BUILD FAILED in 30s
>> 30 actionable tasks: 11 executed, 19 up-to-date
>>
>> _______________________________________________
>> dev mailing list
>> [hidden email]
>> https://lists.intermine.org/mailman/listinfo/dev
>

_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev