Issue on building - 3.x and 4.x

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Issue on building - 3.x and 4.x

Paulo Nuin
Hi

I am experience a problem on building with 3.x and another with 4.x.

On 3.x, it’s not breaking but it might results in problems depending on sources:

createdb: database creation failed: ERROR:  source database "intermine_dev_3_273_1" is being accessed by other users
DETAIL:  There are 40 other sessions using the database.
Tue Nov  5 21:04:07 UTC 2019

Basically the database is new, processed with builddb and just run with a normal project_build command

./project_build -l -v localhost wormmine3_273

I put a dump=true parameter on the first step that populates the species table and the error above was just after the step. I noticed the same thing on our production build, that no dump step created any database, with similar errors as above.

BTW, I restarted Postgres prior to the builddb and actual build.

Is there any file, configuration missing?


Now, on 4.x I am getting an error on the builddb itself. After deleting .gradle and .m2, I did a install on the bio-sources and wormmine dirs and prceceeded to the builddb step. At this stage I got an error that some WomrMine specific pom files were not found with a 409 errors from the server. Mainly our womrbase-acedb, disease and anatomy ontology loaders that are specific from our Mine.

Received status code 409 from server
 https://oss.jfrog.org/artifactory/oss-snapshot-local/org/intermine/bio-source-wormbase-acedb/4.1.1.pom'.

Is there any extra step or change that needs to be done to have our specific loaders compiled to jar or pom?

Any help appreciated.

Thanks

Paulo


_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Issue on building - 3.x and 4.x

Daniela Butano-2

Hi Paulo,

On 05/11/2019 22:07, Paulo Nuin wrote:
Hi

I am experience a problem on building with 3.x and another with 4.x.

On 3.x, it’s not breaking but it might results in problems depending on sources:

createdb: database creation failed: ERROR:  source database "intermine_dev_3_273_1" is being accessed by other users
DETAIL:  There are 40 other sessions using the database.
Tue Nov  5 21:04:07 UTC 2019

Basically the database is new, processed with builddb and just run with a normal project_build command 

./project_build -l -v localhost wormmine3_273

I put a dump=true parameter on the first step that populates the species table and the error above was just after the step. I noticed the same thing on our production build, that no dump step created any database, with similar errors as above.

BTW, I restarted Postgres prior to the builddb and actual build.

Is there any file, configuration missing?
I think that the issue is due to tomcat still running. Please, stop tomcat and try again.


Now, on 4.x I am getting an error on the builddb itself. After deleting .gradle and .m2, I did a install on the bio-sources and wormmine dirs and prceceeded to the builddb step. At this stage I got an error that some WomrMine specific pom files were not found with a 409 errors from the server. Mainly our womrbase-acedb, disease and anatomy ontology loaders that are specific from our Mine. 

Received status code 409 from server
 https://oss.jfrog.org/artifactory/oss-snapshot-local/org/intermine/bio-source-wormbase-acedb/4.1.1.pom'. 

Is there any extra step or change that needs to be done to have our specific loaders compiled to jar or pom?

Any help appreciated.

You are using intermine 4.1.1 but you have probably installed a different version (older) for wormmine bio-sources. If it's that the case, you have to specify the bio-source version in the project.xml file.

Please, find here more details.

cheers,

Daniela


Thanks

Paulo


_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Issue on building - 3.x and 4.x

Paulo Nuin


On Nov 6, 2019, at 2:24 AM, Daniela Butano <[hidden email]> wrote:

Hi Paulo,

On 05/11/2019 22:07, Paulo Nuin wrote:
Hi

I am experience a problem on building with 3.x and another with 4.x.

On 3.x, it’s not breaking but it might results in problems depending on sources:

createdb: database creation failed: ERROR:  source database "intermine_dev_3_273_1" is being accessed by other users
DETAIL:  There are 40 other sessions using the database.
Tue Nov  5 21:04:07 UTC 2019

Basically the database is new, processed with builddb and just run with a normal project_build command 

./project_build -l -v localhost wormmine3_273

I put a dump=true parameter on the first step that populates the species table and the error above was just after the step. I noticed the same thing on our production build, that no dump step created any database, with similar errors as above.

BTW, I restarted Postgres prior to the builddb and actual build.

Is there any file, configuration missing?
I think that the issue is due to tomcat still running. Please, stop tomcat and try again.

Yes, it was this. Older versions didn’t have this issue, if Tomcat was connected to another DB, not the one being built.


Now, on 4.x I am getting an error on the builddb itself. After deleting .gradle and .m2, I did a install on the bio-sources and wormmine dirs and prceceeded to the builddb step. At this stage I got an error that some WomrMine specific pom files were not found with a 409 errors from the server. Mainly our womrbase-acedb, disease and anatomy ontology loaders that are specific from our Mine. 

Received status code 409 from server
 https://oss.jfrog.org/artifactory/oss-snapshot-local/org/intermine/bio-source-wormbase-acedb/4.1.1.pom'. 

Is there any extra step or change that needs to be done to have our specific loaders compiled to jar or pom?

Any help appreciated.

You are using intermine 4.1.1 but you have probably installed a different version (older) for wormmine bio-sources. If it's that the case, you have to specify the bio-source version in the project.xml file.

Please, find here more details.

I am building with 3.1.1 now, and I will test later with 4.1.1.

Thanks

Paulo



cheers,

Daniela

Thanks

Paulo


_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev


_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Issue on building - 3.x and 4.x

Paulo Nuin
In reply to this post by Daniela Butano-2
Hi Daniela

Tried everything in the document that you pointed out


  <source name="wb-acedb-species" type="wormbase-acedb" dump="false" version="4.1.1">
        <property name="src.data.dir" location="&datadir;/wormbase-acedb/species/XML" />
        <property name="mapping.file"
                        value="/home/nuin/properties/species_mapping.properties" />
        <property name="source.class" value="Organism"/>
        <property name="key.file"
                            value="../wormmine-bio-sources/wormbase-acedb/src/main/resources/wormbase-acedb_keys.properties" />
        <property name="rejects.file"
            value="&datadir;/wormbase-acedb/species/wormbase-acedb-species-rejects.xml"/>
        <property name="data.set" value="AceDB XML (Species)"/>
    </source>

         <source name="anatomy_ontology" type="anatomy_ontology" version="4.1.1">
            <property name="src.data.file" location="&datadir;/ontology/anatomy_ontology.obo"/>
        </source>

         <source name="disease_ontology" type="disease_ontology" version="4.1.1">
            <property name="src.data.file" location="&datadir;/ontology/disease_ontology.obo"/>
        </source>



And I still got the error on trying to install

Execution failed for task ':dbmodel:mergeModels'.
> Could not resolve all files for configuration ':dbmodel:mergeSource'.
   > Could not resolve org.intermine:bio-source-wormbase-acedb:4.1.1.
     Required by:
         project :dbmodel
      > Could not resolve org.intermine:bio-source-wormbase-acedb:4.1.1.
   > Could not resolve org.intermine:bio-source-anatomy_ontology:4.1.1.
     Required by:
         project :dbmodel
      > Could not resolve org.intermine:bio-source-anatomy_ontology:4.1.1.
   > Could not resolve org.intermine:bio-source-disease_ontology:4.1.1.
     Required by:
         project :dbmodel
      > Could not resolve org.intermine:bio-source-disease_ontology:4.1.1.


Any ideas?

Paulo



On Nov 6, 2019, at 2:24 AM, Daniela Butano <[hidden email]> wrote:

Now, on 4.x I am getting an error on the builddb itself. After deleting .gradle and .m2, I did a install on the bio-sources and wormmine dirs and prceceeded to the builddb step. At this stage I got an error that some WomrMine specific pom files were not found with a 409 errors from the server. Mainly our womrbase-acedb, disease and anatomy ontology loaders that are specific from our Mine. 

Received status code 409 from server
 https://oss.jfrog.org/artifactory/oss-snapshot-local/org/intermine/bio-source-wormbase-acedb/4.1.1.pom'. 

Is there any extra step or change that needs to be done to have our specific loaders compiled to jar or pom?

Any help appreciated.

You are using intermine 4.1.1 but you have probably installed a different version (older) for wormmine bio-sources. If it's that the case, you have to specify the bio-source version in the project.xml file.

Please, find here more details.

cheers,

Daniela

Thanks

Paulo


_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev


_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Issue on building - 3.x and 4.x

Paulo Nuin
Hi

All solved

Cheers
Paulo



On Nov 15, 2019, at 10:43 AM, Paulo Nuin <[hidden email]> wrote:

Hi Daniela

Tried everything in the document that you pointed out


  <source name="wb-acedb-species" type="wormbase-acedb" dump="false" version="4.1.1">
        <property name="src.data.dir" location="&datadir;/wormbase-acedb/species/XML" />
        <property name="mapping.file"
                        value="/home/nuin/properties/species_mapping.properties" />
        <property name="source.class" value="Organism"/>
        <property name="key.file"
                            value="../wormmine-bio-sources/wormbase-acedb/src/main/resources/wormbase-acedb_keys.properties" />
        <property name="rejects.file"
            value="&datadir;/wormbase-acedb/species/wormbase-acedb-species-rejects.xml"/>
        <property name="data.set" value="AceDB XML (Species)"/>
    </source>

         <source name="anatomy_ontology" type="anatomy_ontology" version="4.1.1">
            <property name="src.data.file" location="&datadir;/ontology/anatomy_ontology.obo"/>
        </source>

         <source name="disease_ontology" type="disease_ontology" version="4.1.1">
            <property name="src.data.file" location="&datadir;/ontology/disease_ontology.obo"/>
        </source>



And I still got the error on trying to install

Execution failed for task ':dbmodel:mergeModels'.
> Could not resolve all files for configuration ':dbmodel:mergeSource'.
   > Could not resolve org.intermine:bio-source-wormbase-acedb:4.1.1.
     Required by:
         project :dbmodel
      > Could not resolve org.intermine:bio-source-wormbase-acedb:4.1.1.
   > Could not resolve org.intermine:bio-source-anatomy_ontology:4.1.1.
     Required by:
         project :dbmodel
      > Could not resolve org.intermine:bio-source-anatomy_ontology:4.1.1.
   > Could not resolve org.intermine:bio-source-disease_ontology:4.1.1.
     Required by:
         project :dbmodel
      > Could not resolve org.intermine:bio-source-disease_ontology:4.1.1.


Any ideas?

Paulo



On Nov 6, 2019, at 2:24 AM, Daniela Butano <[hidden email]> wrote:
Now, on 4.x I am getting an error on the builddb itself. After deleting .gradle and .m2, I did a install on the bio-sources and wormmine dirs and prceceeded to the builddb step. At this stage I got an error that some WomrMine specific pom files were not found with a 409 errors from the server. Mainly our womrbase-acedb, disease and anatomy ontology loaders that are specific from our Mine. 

Received status code 409 from server
 https://oss.jfrog.org/artifactory/oss-snapshot-local/org/intermine/bio-source-wormbase-acedb/4.1.1.pom'. 

Is there any extra step or change that needs to be done to have our specific loaders compiled to jar or pom?

Any help appreciated.

You are using intermine 4.1.1 but you have probably installed a different version (older) for wormmine bio-sources. If it's that the case, you have to specify the bio-source version in the project.xml file.

Please, find here more details.

cheers,

Daniela

Thanks

Paulo


_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev



_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Issue on building - 3.x and 4.x

Daniela Butano-2
Great!
Sorry if we didn't reply.
Busy at the elixir biohackathon
cheers,
Daniela

> Hi
>
> All solved
>
> Cheers
> Paulo
>
>> On Nov 15, 2019, at 10:43 AM, Paulo Nuin <[hidden email]>
>> wrote:
>>
>> Hi Daniela
>>
>> Tried everything in the document that you pointed out
>>
>> <source name="wb-acedb-species" type="wormbase-acedb" dump="false"
>> version="4.1.1">
>> <property name="src.data.dir"
>> location="&datadir;/wormbase-acedb/species/XML" />
>> <property name="mapping.file"
>>
>> value="/home/nuin/properties/species_mapping.properties" />
>> <property name="source.class" value="Organism"/>
>> <property name="key.file"
>>
>>
> value="../wormmine-bio-sources/wormbase-acedb/src/main/resources/wormbase-acedb_keys.properties"
>> />
>> <property name="rejects.file"
>>
>>
> value="&datadir;/wormbase-acedb/species/wormbase-acedb-species-rejects.xml"/>
>> <property name="data.set" value="AceDB XML (Species)"/>
>> </source>
>>
>> <source name="anatomy_ontology" type="anatomy_ontology"
>> version="4.1.1">
>> <property name="src.data.file"
>> location="&datadir;/ontology/anatomy_ontology.obo"/>
>> </source>
>>
>> <source name="disease_ontology" type="disease_ontology"
>> version="4.1.1">
>> <property name="src.data.file"
>> location="&datadir;/ontology/disease_ontology.obo"/>
>> </source>
>>
>> And I still got the error on trying to install
>>
>> Execution failed for task ':dbmodel:mergeModels'.
>>> Could not resolve all files for configuration
>> ':dbmodel:mergeSource'.
>>> Could not resolve
>> org.intermine:bio-source-wormbase-acedb:4.1.1.
>> Required by:
>> project :dbmodel
>>> Could not resolve
>> org.intermine:bio-source-wormbase-acedb:4.1.1.
>>> Could not get resource
>>
> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/org/intermine/bio-source-wormbase-acedb/4.1.1/bio-source-wormbase-acedb-4.1.1.pom'.
>>> Could not GET
>>
> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/org/intermine/bio-source-wormbase-acedb/4.1.1/bio-source-wormbase-acedb-4.1.1.pom'.
>> Received status code 409 from server:
>>> Could not resolve
>> org.intermine:bio-source-anatomy_ontology:4.1.1.
>> Required by:
>> project :dbmodel
>>> Could not resolve
>> org.intermine:bio-source-anatomy_ontology:4.1.1.
>>> Could not get resource
>>
> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/org/intermine/bio-source-anatomy_ontology/4.1.1/bio-source-anatomy_ontology-4.1.1.pom'.
>>> Could not GET
>>
> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/org/intermine/bio-source-anatomy_ontology/4.1.1/bio-source-anatomy_ontology-4.1.1.pom'.
>> Received status code 409 from server:
>>> Could not resolve
>> org.intermine:bio-source-disease_ontology:4.1.1.
>> Required by:
>> project :dbmodel
>>> Could not resolve
>> org.intermine:bio-source-disease_ontology:4.1.1.
>>> Could not get resource
>>
> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/org/intermine/bio-source-disease_ontology/4.1.1/bio-source-disease_ontology-4.1.1.pom'.
>>> Could not GET
>>
> 'https://oss.jfrog.org/artifactory/oss-snapshot-local/org/intermine/bio-source-disease_ontology/4.1.1/bio-source-disease_ontology-4.1.1.pom'.
>> Received status code 409 from server:
>>
>> Any ideas?
>>
>> Paulo
>>
>> On Nov 6, 2019, at 2:24 AM, Daniela Butano <[hidden email]>
>> wrote:
>>
>> Now, on 4.x I am getting an error on the builddb itself. After
>> deleting .gradle and .m2, I did a install on the bio-sources and
>> wormmine dirs and prceceeded to the builddb step. At this stage I
>> got an error that some WomrMine specific pom files were not found
>> with a 409 errors from the server. Mainly our womrbase-acedb,
>> disease and anatomy ontology loaders that are specific from our
>> Mine.
>>
>> Received status code 409 from server
>>
> https://oss.jfrog.org/artifactory/oss-snapshot-local/org/intermine/bio-source-wormbase-acedb/4.1.1.pom'.
>>
>>
>> Is there any extra step or change that needs to be done to have our
>> specific loaders compiled to jar or pom?
>>
>> Any help appreciated.
>>
>> You are using intermine 4.1.1 but you have probably installed a
>> different version (older) for wormmine bio-sources. If it's that the
>> case, you have to specify the bio-source version in the project.xml
>> file.
>>
>> Please, find here [1] more details.
>>
>> cheers,
>>
>> Daniela
>>
>> Thanks
>>
>> Paulo
>>
>> _______________________________________________
>> dev mailing list
>> [hidden email]
>> https://lists.intermine.org/mailman/listinfo/dev
>>
>> _______________________________________________
>> dev mailing list
>> [hidden email]
>> https://lists.intermine.org/mailman/listinfo/dev
>
>
>
> Links:
> ------
> [1]
> https://intermine.readthedocs.io/en/2.1.1/database/data-sources/versions/#how-do-i-specify-which-version-to-use-in-my-build

_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev