Mpi_maker not working after upgrade to Ubuntu 11.04

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Mpi_maker not working after upgrade to Ubuntu 11.04

claudia

Hi.

  So it seems my MPI Maker is not working properly ( see errors below), and it seems to have coincided with upgrading from Ubuntu 10.10 to 11.04. I have tested the standard ( non-mpi)  maker and it works fine. Does anyone have any information about this, and if so, how to fix it? I have tried a Maker re-installation and that did not work as well, also I have followed the paths to all the perl libraries and nothing has changed, further, the upgrade did not update my perl version, it is still 5.10.


--FAILURE--
BEGIN failed--compilation aborted at /usr/local/genome/maker/maker-2.11-beta/bin/mpi_maker line 84.

--FAILURE--
Can't load '/usr/local/genome/maker/maker-2.11-beta/bin/../perl/lib/auto/Parallel/MPIcar/MPIcar.so' for module Parallel::MPIcar: libmpich.so.1.2: cannot open shared object file: No such file or directory at /usr/lib/perl/5.10/DynaLoader.pm line 192.
 at /usr/local/genome/maker/maker-2.11-beta/bin/mpi_maker line 84


Thank you,

Claudia


_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|

Re: Mpi_maker not working after upgrade to Ubuntu 11.04

Carson Holt-2
Upgrading can change dynamic libraries that both perl and maker's MPI module are linking against.  You will need to completely delete and then reinstall MAKER, but first delete and reinstall any old copies of MPICH2 on your system.

Thanks,
Carson

From: Dinatale C <[hidden email]>
Date: Thu, 15 Sep 2011 13:20:10 -0400
To: <[hidden email]>
Subject: [maker-devel] Mpi_maker not working after upgrade to Ubuntu 11.04

Hi.

  So it seems my MPI Maker is not working properly ( see errors below), and it seems to have coincided with upgrading from Ubuntu 10.10 to 11.04. I have tested the standard ( non-mpi)  maker and it works fine. Does anyone have any information about this, and if so, how to fix it? I have tried a Maker re-installation and that did not work as well, also I have followed the paths to all the perl libraries and nothing has changed, further, the upgrade did not update my perl version, it is still 5.10.


--FAILURE--
BEGIN failed--compilation aborted at /usr/local/genome/maker/maker-2.11-beta/bin/mpi_maker line 84.

--FAILURE--
Can't load '/usr/local/genome/maker/maker-2.11-beta/bin/../perl/lib/auto/Parallel/MPIcar/MPIcar.so' for module Parallel::MPIcar: libmpich.so.1.2: cannot open shared object file: No such file or directory at /usr/lib/perl/5.10/DynaLoader.pm line 192.
 at /usr/local/genome/maker/maker-2.11-beta/bin/mpi_maker line 84


Thank you,

Claudia

_______________________________________________ maker-devel mailing list [hidden email] http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org

_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|

Re: Mpi_maker not working after upgrade to Ubuntu 11.04

claudia
Hi Carson,

 When you say completely delete Maker, can a reinstall from src be just as efficient. Is there a command to completely uninstall Maker? I have reinstalled MPICH2 with mpd and it works fine, however, when reinstalling Maker after MPICH2 installation , I still get the same errors. I have also tried to install MPICH2 via Maker, and that did not solve the problem.  Not sure what is happening here.

Claudia



On 15/09/2011 1:22 PM, Carson Holt wrote:
Upgrading can change dynamic libraries that both perl and maker's MPI module are linking against.  You will need to completely delete and then reinstall MAKER, but first delete and reinstall any old copies of MPICH2 on your system.

Thanks,
Carson

From: Dinatale C <[hidden email]>
Date: Thu, 15 Sep 2011 13:20:10 -0400
To: <[hidden email]>
Subject: [maker-devel] Mpi_maker not working after upgrade to Ubuntu 11.04

Hi.

  So it seems my MPI Maker is not working properly ( see errors below), and it seems to have coincided with upgrading from Ubuntu 10.10 to 11.04. I have tested the standard ( non-mpi)  maker and it works fine. Does anyone have any information about this, and if so, how to fix it? I have tried a Maker re-installation and that did not work as well, also I have followed the paths to all the perl libraries and nothing has changed, further, the upgrade did not update my perl version, it is still 5.10.


--FAILURE--
BEGIN failed--compilation aborted at /usr/local/genome/maker/maker-2.11-beta/bin/mpi_maker line 84.

--FAILURE--
Can't load '/usr/local/genome/maker/maker-2.11-beta/bin/../perl/lib/auto/Parallel/MPIcar/MPIcar.so' for module Parallel::MPIcar: libmpich.so.1.2: cannot open shared object file: No such file or directory at /usr/lib/perl/5.10/DynaLoader.pm line 192.
 at /usr/local/genome/maker/maker-2.11-beta/bin/mpi_maker line 84


Thank you,

Claudia

_______________________________________________ maker-devel mailing list [hidden email] http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org


_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|

Re: Mpi_maker not working after upgrade to Ubuntu 11.04

Carson Holt-2
You can also just out the /maker/perl/ directory, and run "./Build realclean" before running "perl Buil.Pl" and "./Build install" again.

/maker/perl/ has all the compiled modules inside.  You basically just need to wipe out any old binaries (otherwise they won't necessarily be overwritten).

Thanks,
Carson

From: claudia <[hidden email]>
Date: Thu, 15 Sep 2011 15:40:17 -0400
To: Carson Holt <[hidden email]>, "[hidden email]" <[hidden email]>
Subject: Re: [maker-devel] Mpi_maker not working after upgrade to Ubuntu 11.04

Hi Carson,

 When you say completely delete Maker, can a reinstall from src be just as efficient. Is there a command to completely uninstall Maker? I have reinstalled MPICH2 with mpd and it works fine, however, when reinstalling Maker after MPICH2 installation , I still get the same errors. I have also tried to install MPICH2 via Maker, and that did not solve the problem.  Not sure what is happening here.

Claudia



On 15/09/2011 1:22 PM, Carson Holt wrote:
Upgrading can change dynamic libraries that both perl and maker's MPI module are linking against.  You will need to completely delete and then reinstall MAKER, but first delete and reinstall any old copies of MPICH2 on your system.

Thanks,
Carson

From: Dinatale C <[hidden email]>
Date: Thu, 15 Sep 2011 13:20:10 -0400
To: <[hidden email]>
Subject: [maker-devel] Mpi_maker not working after upgrade to Ubuntu 11.04

Hi.

  So it seems my MPI Maker is not working properly ( see errors below), and it seems to have coincided with upgrading from Ubuntu 10.10 to 11.04. I have tested the standard ( non-mpi)  maker and it works fine. Does anyone have any information about this, and if so, how to fix it? I have tried a Maker re-installation and that did not work as well, also I have followed the paths to all the perl libraries and nothing has changed, further, the upgrade did not update my perl version, it is still 5.10.


--FAILURE--
BEGIN failed--compilation aborted at /usr/local/genome/maker/maker-2.11-beta/bin/mpi_maker line 84.

--FAILURE--
Can't load '/usr/local/genome/maker/maker-2.11-beta/bin/../perl/lib/auto/Parallel/MPIcar/MPIcar.so' for module Parallel::MPIcar: libmpich.so.1.2: cannot open shared object file: No such file or directory at /usr/lib/perl/5.10/DynaLoader.pm line 192.
 at /usr/local/genome/maker/maker-2.11-beta/bin/mpi_maker line 84


Thank you,

Claudia

_______________________________________________ maker-devel mailing list [hidden email] http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org


_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org