New Dataset for GBrowse not working

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

New Dataset for GBrowse not working

Andy Pham
Hi,
I just finished loading loading a dataset into a postgres sql database using:
bp_seqfeature_load -c -d 'dbname=gb_maes_publicgenomev4_g_gff3;host=****' -a 'DBI::Pg' -u **** -p **** Maes.gff3

However, when I try to open the URL to see the gbrowse for this particular dataset, it redirects to another dataset. I've tried restarting the apache service and triple checking the names of both the database and the config files to see if they match up.

The GBrowse.config has this in it:

[maes_genomev4]
description  = M.esculenta (Cassava) Genome v4.1
path         = maes.conf

The maes.conf file is attached. Previous datasets have successfully loaded before but for some reason this dataset is giving us problems. I have also checked the sql database and there is data in that database, so the gff3 file loaded successfully. The permissions for the files have been checked as well. The server just doesn't seem to see the changes in the config files. 


------------------------------------------------------------------------------
One dashboard for servers and applications across Physical-Virtual-Cloud
Widest out-of-the-box monitoring support with 50+ applications
Performance metrics, stats and reports that give you Actionable Insights
Deep dive visibility with transaction tracing using APM Insight.
http://ad.doubleclick.net/ddm/clk/290420510;117567292;y
_______________________________________________
Gmod-gbrowse mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-gbrowse

maes.conf (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: New Dataset for GBrowse not working

Scott Cain
Hi Andy,

While I don't see anything obviously wrong with you configuration file, the redirecting to another data set is a symptom of there being something wrong with the config.  The redirecting is sort of like GBrowse saying, "I can't do that, maybe this will help" even though it never really does :-/

Is there anything in the apache error log that might give a hint at what the problem is?  If not, I'd suggest trimming things out that are unnecessary like include files and the tooltip section.  Also, make sure that the connection info for the database is correct and that the apache user can connect to the database.

Scott


On Thu, May 21, 2015 at 6:55 PM, Andy Pham <[hidden email]> wrote:
Hi,
I just finished loading loading a dataset into a postgres sql database using:
bp_seqfeature_load -c -d 'dbname=gb_maes_publicgenomev4_g_gff3;host=****' -a 'DBI::Pg' -u **** -p **** Maes.gff3

However, when I try to open the URL to see the gbrowse for this particular dataset, it redirects to another dataset. I've tried restarting the apache service and triple checking the names of both the database and the config files to see if they match up.

The GBrowse.config has this in it:

[maes_genomev4]
description  = M.esculenta (Cassava) Genome v4.1
path         = maes.conf

The maes.conf file is attached. Previous datasets have successfully loaded before but for some reason this dataset is giving us problems. I have also checked the sql database and there is data in that database, so the gff3 file loaded successfully. The permissions for the files have been checked as well. The server just doesn't seem to see the changes in the config files. 


------------------------------------------------------------------------------
One dashboard for servers and applications across Physical-Virtual-Cloud
Widest out-of-the-box monitoring support with 50+ applications
Performance metrics, stats and reports that give you Actionable Insights
Deep dive visibility with transaction tracing using APM Insight.
http://ad.doubleclick.net/ddm/clk/290420510;117567292;y
_______________________________________________
Gmod-gbrowse mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-gbrowse




--
------------------------------------------------------------------------
Scott Cain, Ph. D.                                   scott at scottcain dot net
GMOD Coordinator (http://gmod.org/)                     216-392-3087
Ontario Institute for Cancer Research

------------------------------------------------------------------------------
One dashboard for servers and applications across Physical-Virtual-Cloud
Widest out-of-the-box monitoring support with 50+ applications
Performance metrics, stats and reports that give you Actionable Insights
Deep dive visibility with transaction tracing using APM Insight.
http://ad.doubleclick.net/ddm/clk/290420510;117567292;y
_______________________________________________
Gmod-gbrowse mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-gbrowse
Reply | Threaded
Open this post in threaded view
|

Re: New Dataset for GBrowse not working

Andy Pham
Hi,
Thanks for the response! The apache error log shows no errors, just that it tries to connect to maes_genomev4, and the redirect to something it can find. No errors being recorded. The apache user and password are working correctly, and the connection info is correct as well. I did trim out the include files and tooltip section, but it's still redirecting as usual.
Thanks,
Andy

On Fri, May 22, 2015 at 7:05 AM, Scott Cain <[hidden email]> wrote:
Hi Andy,

While I don't see anything obviously wrong with you configuration file, the redirecting to another data set is a symptom of there being something wrong with the config.  The redirecting is sort of like GBrowse saying, "I can't do that, maybe this will help" even though it never really does :-/

Is there anything in the apache error log that might give a hint at what the problem is?  If not, I'd suggest trimming things out that are unnecessary like include files and the tooltip section.  Also, make sure that the connection info for the database is correct and that the apache user can connect to the database.

Scott


On Thu, May 21, 2015 at 6:55 PM, Andy Pham <[hidden email]> wrote:
Hi,
I just finished loading loading a dataset into a postgres sql database using:
bp_seqfeature_load -c -d 'dbname=gb_maes_publicgenomev4_g_gff3;host=****' -a 'DBI::Pg' -u **** -p **** Maes.gff3

However, when I try to open the URL to see the gbrowse for this particular dataset, it redirects to another dataset. I've tried restarting the apache service and triple checking the names of both the database and the config files to see if they match up.

The GBrowse.config has this in it:

[maes_genomev4]
description  = M.esculenta (Cassava) Genome v4.1
path         = maes.conf

The maes.conf file is attached. Previous datasets have successfully loaded before but for some reason this dataset is giving us problems. I have also checked the sql database and there is data in that database, so the gff3 file loaded successfully. The permissions for the files have been checked as well. The server just doesn't seem to see the changes in the config files. 


------------------------------------------------------------------------------
One dashboard for servers and applications across Physical-Virtual-Cloud
Widest out-of-the-box monitoring support with 50+ applications
Performance metrics, stats and reports that give you Actionable Insights
Deep dive visibility with transaction tracing using APM Insight.
http://ad.doubleclick.net/ddm/clk/290420510;117567292;y
_______________________________________________
Gmod-gbrowse mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-gbrowse




--
------------------------------------------------------------------------
Scott Cain, Ph. D.                                   scott at scottcain dot net
GMOD Coordinator (http://gmod.org/)                     <a href="tel:216-392-3087" value="+12163923087" target="_blank">216-392-3087
Ontario Institute for Cancer Research


------------------------------------------------------------------------------

_______________________________________________
Gmod-gbrowse mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-gbrowse