Postgresql 9.0.4

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Postgresql 9.0.4

Gail Binkley-2
Hi all,

We are getting a couple new servers for Intermine at Stanford and changing our system architecture at the same time.  Instead of a front-end machine for Tomcat and the web server, and a back-end machine for the database, we are going to put both the front- and back-ends on the same machine.  Multiple machines will be used to separate "production" and "development" environments.

When we set up our current production Yeastmine back-end machine, Postgresql 9.0 had just been released.  Now the stable release of Postgresql is up to 9.0.4.  I was wondering if anyone has installed Intermine on Postgresql 9.0.x yet.  I am thinking of upgrading our Postgresql version, unless anyone knows of a problem with the new version.  We are currently running Postgresql 8.4.

Thanks, 
Gail Binkley
Stanford University

_______________________________________________
dev mailing list
[hidden email]
http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Postgresql 9.0.4

Richard Smith
Hi Gail,
We still haven't tested Postgres 9 but I think it should be fine to use
it.  From looking through the release notes it looks like it could have
some performance improvements for us over 8.4 (faster EXPLAINs and some
query planner improvements).

The things that could go wrong are if the changes to EXPLAIN results
causes our parser to fail or if the patched JDBC driver we use no longer
works.  Both should give very obvious errors.

We'll put 9.0.4 on one of our build servers this week and run a test
build, I'll let you know how it goes.

Cheers,
Richard.




On 05/08/2011 20:55, Gail A. Binkley wrote:

>
> Hi all,
>
>
> We are getting a couple new servers for Intermine at Stanford and changing our system architecture at the same time. Instead of a front-end machine for Tomcat and the web server, and a back-end machine for the database, we are going to put both the front- and back-ends on the same machine. Multiple machines will be used to separate "production" and "development" environments.
>
>
> When we set up our current production Yeastmine back-end machine, Postgresql 9.0 had just been released. Now the stable release of Postgresql is up to 9.0.4. I was wondering if anyone has installed Intermine on Postgresql 9.0.x yet. I am thinking of upgrading our Postgresql version, unless anyone knows of a problem with the new version. We are currently running Postgresql 8.4.
>
>
> Thanks,
> Gail Binkley Stanford University
>
>
>
> _______________________________________________
> dev mailing list
> [hidden email]
> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev


_______________________________________________
dev mailing list
[hidden email]
http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Postgresql 9.0.4

Gail Binkley-2
Sounds good.  I'll let you know if we have any problems on our end.

- Gail


From: "Richard Smith" <[hidden email]>
To: "Gail A. Binkley" <[hidden email]>
Cc: [hidden email]
Sent: Monday, August 8, 2011 6:49:57 AM
Subject: Re: [InterMine Dev] Postgresql 9.0.4

Hi Gail,
We still haven't tested Postgres 9 but I think it should be fine to use
it.  From looking through the release notes it looks like it could have
some performance improvements for us over 8.4 (faster EXPLAINs and some
query planner improvements).

The things that could go wrong are if the changes to EXPLAIN results
causes our parser to fail or if the patched JDBC driver we use no longer
works.  Both should give very obvious errors.

We'll put 9.0.4 on one of our build servers this week and run a test
build, I'll let you know how it goes.

Cheers,
Richard.




On 05/08/2011 20:55, Gail A. Binkley wrote:

>
> Hi all,
>
>
> We are getting a couple new servers for Intermine at Stanford and changing our system architecture at the same time. Instead of a front-end machine for Tomcat and the web server, and a back-end machine for the database, we are going to put both the front- and back-ends on the same machine. Multiple machines will be used to separate "production" and "development" environments.
>
>
> When we set up our current production Yeastmine back-end machine, Postgresql 9.0 had just been released. Now the stable release of Postgresql is up to 9.0.4. I was wondering if anyone has installed Intermine on Postgresql 9.0.x yet. I am thinking of upgrading our Postgresql version, unless anyone knows of a problem with the new version. We are currently running Postgresql 8.4.
>
>
> Thanks,
> Gail Binkley Stanford University
>
>
>
> _______________________________________________
> dev mailing list
> [hidden email]
> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev



_______________________________________________
dev mailing list
[hidden email]
http://mail.intermine.org/cgi-bin/mailman/listinfo/dev