Problem compiling MAKER with Intel MPI

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem compiling MAKER with Intel MPI

Lior Glick
Hello,
I am trying to compile MAKER with Intel MPI.
We are using a cluster based on Intel x86_64 architecture and using lmod for environment variables.
All required dependencies have already been installed and the initial 'perl Build.PL' passes without issues (see attached).
When running './Build install' it always fails to find 'sys/types.h' and exits (see additional attachment).
The Build command probably searches for the '/usr/include/sys/types.h' file, but no matter which variable (INCLUDE, PERL5LIB etc...) I update with the required path (either '/usr/include' or '/usr/include/sys') - it keeps failing.
I would appreciate your input.
Thanks a lot!

_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org

Build.PL.out (2K) Download Attachment
Build_install.out (8K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Problem compiling MAKER with Intel MPI

Carson Holt-2
The problem is your perl perl installation. It’s broken. I’m guessing
it’s a version installed by conda?

The sys/types.h file is internal to perl itself (and will be bound to
the version of perl you are using - i.e. don’t use sys/types.h from a
different perl version). It’s used to map datatypes between perl and C.
If you search /powerapps/share/centos7/miniconda/ you may be able to
find it somewhere internally. You may be able to set it
with C_INCLUDE_PATH or CPLUS_INCLUDE_PATH once you find it . There may
be other environmental variables that must be set as well.

The line inside the C code perl is running internally is something like
“#include<sys/type.h>”, so make sure the path you give to 
C_INCLUDE_PATH
is the directory right before the /sys folder.

Alternatively you may need to do this outside of conda.

—Carson

On Oct 17, 2018, at 8:27 AM, Lior Glick <[hidden email]> wrote:

Hello,
I am trying to compile MAKER with Intel MPI.
We are using a cluster based on Intel x86_64 architecture and using lmod for environment variables.
All required dependencies have already been installed and the initial 'perl Build.PL' passes without issues (see attached).
When running './Build install' it always fails to find 'sys/types.h' and exits (see additional attachment).
The Build command probably searches for the '/usr/include/sys/types.h' file, but no matter which variable (INCLUDE, PERL5LIB etc...) I update with the required path (either '/usr/include' or '/usr/include/sys') - it keeps failing.
I would appreciate your input.
Thanks a lot!
<Build.PL.out><Build_install.out>_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org


_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org