Problem running apollo release

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem running apollo release

carlos vargas
Hello everyone,

I am having trouble running ./apollo release, the error is the following:


FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':release'.
> Warning: Could not find file /home/cvargas/Apollo/jbrowse-download/JBrowse-dev.zip to copy.

I have tried supplying externally the zip file but when running apollo release the file is unziped and it gives the error of not finding it. I have no trouble when running ./apollo deploy. Does anybody have an idea to solve this?

Thank you in advance!
Carlos




This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|

Re: Problem running apollo release

Colin
Hi Carlos

I would checkout the Apollo 2.0.2 release tag for your build and go from there. The master branch will probably give that error right now because it's targetting the latest jbrowse and needs some adjustments (https://github.com/GMOD/Apollo/issues/941 is tracking that issue)

It is possible that you will need to go into the jbrowse-download folder and also checkout the 1.11.6-release tag there as well for the time being.

Let me know if that helps!


-Colin

On Fri, Mar 25, 2016 at 4:56 AM, carlos vargas <[hidden email]> wrote:
Hello everyone,

I am having trouble running ./apollo release, the error is the following:


FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':release'.
> Warning: Could not find file /home/cvargas/Apollo/jbrowse-download/JBrowse-dev.zip to copy.

I have tried supplying externally the zip file but when running apollo release the file is unziped and it gives the error of not finding it. I have no trouble when running ./apollo deploy. Does anybody have an idea to solve this?

Thank you in advance!
Carlos




This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.







This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|

Re: Problem running apollo release

carlos vargas
Dear Colin,

Thank you very much for your prompt reply. I changed tag 2.0.2 for Apollo when downloading it and 1.11.6 for jbrowse in the apollo-config.groovy file but still it can't build the war file still giving the same error of not finding JBrowse-dev.zip. I also tried using git checkout tags/1.11.6-release in the jbrowse-download folder but it still gave the same error. In both cases deploy did work. Do you have other suggestions?

Best,
Carlos

On Fri, Mar 25, 2016 at 3:16 PM, Colin <[hidden email]> wrote:
Hi Carlos

I would checkout the Apollo 2.0.2 release tag for your build and go from there. The master branch will probably give that error right now because it's targetting the latest jbrowse and needs some adjustments (https://github.com/GMOD/Apollo/issues/941 is tracking that issue)

It is possible that you will need to go into the jbrowse-download folder and also checkout the 1.11.6-release tag there as well for the time being.

Let me know if that helps!


-Colin

On Fri, Mar 25, 2016 at 4:56 AM, carlos vargas <[hidden email]> wrote:
Hello everyone,

I am having trouble running ./apollo release, the error is the following:


FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':release'.
> Warning: Could not find file /home/cvargas/Apollo/jbrowse-download/JBrowse-dev.zip to copy.

I have tried supplying externally the zip file but when running apollo release the file is unziped and it gives the error of not finding it. I have no trouble when running ./apollo deploy. Does anybody have an idea to solve this?

Thank you in advance!
Carlos




This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.







This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.







This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|

Re: Problem running apollo release

nathandunn

Is the output the same? 

The only thing that I can think of would be to do:

./apollo clean-all
./apollo release 

but I don’t think it will do anything different. 

We are working on an update to this script if you can’t get this working.  

Hopefully, Colin may come up with something else, but in the interim, you can probably just use the deploy script.  


Nathan

On Mar 28, 2016, at 3:48 PM, carlos vargas <[hidden email]> wrote:

Dear Colin,

Thank you very much for your prompt reply. I changed tag 2.0.2 for Apollo when downloading it and 1.11.6 for jbrowse in the apollo-config.groovy file but still it can't build the war file still giving the same error of not finding JBrowse-dev.zip. I also tried using git checkout tags/1.11.6-release in the jbrowse-download folder but it still gave the same error. In both cases deploy did work. Do you have other suggestions?

Best,
Carlos

On Fri, Mar 25, 2016 at 3:16 PM, Colin <[hidden email]> wrote:
Hi Carlos

I would checkout the Apollo 2.0.2 release tag for your build and go from there. The master branch will probably give that error right now because it's targetting the latest jbrowse and needs some adjustments (https://github.com/GMOD/Apollo/issues/941 is tracking that issue)

It is possible that you will need to go into the jbrowse-download folder and also checkout the 1.11.6-release tag there as well for the time being.

Let me know if that helps!


-Colin

On Fri, Mar 25, 2016 at 4:56 AM, carlos vargas <[hidden email]> wrote:
Hello everyone,

I am having trouble running ./apollo release, the error is the following:


FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':release'.
> Warning: Could not find file /home/cvargas/Apollo/jbrowse-download/JBrowse-dev.zip to copy.

I have tried supplying externally the zip file but when running apollo release the file is unziped and it gives the error of not finding it. I have no trouble when running ./apollo deploy. Does anybody have an idea to solve this?

Thank you in advance!
Carlos




This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.







This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.