Problem with CPAN install

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problem with CPAN install

J.M.P. Alves
Hi,

I have installed GBrowse2 in a "clean" computer and it's working great.
I installed using CPAN.

When I installed in another computer (that has GBrowse 1.70 and all its
dependencies installed), I get errors in the test -- I tried force
installing, and it works, mostly. The problem is that some things don't
work, as expected due to the test failure. (what fails is the display of
multiple features in the "karyotype" like display, say like when one
searches for "hydrogenase", for example)

I did update all software listed in
http://gmod.org/wiki/GBrowse_2.0_Prerequisites to their latest versions,
but to no avail. I could not get what is wrong from the error messages,
which are quite uninformative (to me at least).

Here are the errors in CPAN, after building:

===============================================
   LDS/GBrowse-2.09.tar.gz
   ./Build -- OK
Running Build test
NOTE: Run ./Build reconfig to change existing configuration.
/etc/apache2/conf.d/gbrowse2.conf is already installed. Please run
./Build apache_conf to see this file's recommended contents.
t/01yeast.................ok

t/02.rearchitecture.......ok

t/03.render...............dubious

        Test returned status 0 (wstat 11, 0xb)
DIED. FAILED tests 116-138
        Failed 23/138 tests, 83.33% okay
t/04.remoteserver.........ok

t/05.deferredrendering....ok

t/06.featuresearch........ok

t/07.karyotype............dubious

        Test returned status 0 (wstat 11, 0xb)
DIED. FAILED tests 2-3
        Failed 2/3 tests, 33.33% okay
t/08.calign...............ok

Failed Test      Stat Wstat Total Fail  List of Failed
-------------------------------------------------------------------------------
t/03.render.t       0    11   138   46  116-138
t/07.karyotype.t    0    11     3    4  2-3
Failed 2/8 test scripts. 25/332 subtests failed.
Files=8, Tests=332, 31 wallclock secs (20.79 cusr +  2.98 csys = 23.77 CPU)
Failed 2/8 test programs. 25/332 subtests failed.
   LDS/GBrowse-2.09.tar.gz
   ./Build test -- NOT OK
//hint// to see the cpan-testers results for installing this module, try:
   reports LDS/GBrowse-2.09.tar.gz
===============================================

Is there a way to make this more informative, or some log file that
details what might be wrong?

I'm assuming it is OK to have both GBrowse 1.x and 2.x installed in the
same machine, since I did not see anything saying otherwise in the docs.

Thanks
J

--
-------------------------------
João Marcelo Pereira Alves (J)
Post-doctoral fellow
MCV / VCU - Richmond, VA
http://bioinfo.lpb.mic.vcu.edu
f. 1-804-828-3897


------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
Gmod-gbrowse mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-gbrowse