Re: Track Rendering Error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Track Rendering Error

Andrew Oberlin
Hello all again,

I was still wondering why I would get a track rendering error on this machine, but not another with almost the same install. I would like to mention that the last install of Chado was 1.1 I believe and this one is 1.2. However, we did the update script that was specified in the install for it and the only thing that pops up in the error log is that it is rendering the error track.

If there is any other information as to why this would happen, it would be greatly appreciated.

Here is the exact error message:

[1640] RUN(): POST: http://localhost/gb2/gbrowse/mycoplasma_agalactiae/ action=retrieve_multiple;track_ids=Genes;tk_Genes=54ad1b8336f0061918add849be948131 at /usr/local/lib/perl/5.12.4/Bio/Graphics/Browser2/Render.pm line 239.

[1640] session id = 9dad1033a6b18568fdc667a8ce2c75e2 at /usr/local/lib/perl/5.12.4/Bio/Graphics/Browser2/Render.pm line 243.

[1640] add_user_tracks() at /usr/local/lib/perl/5.12.4/Bio/Graphics/Browser2/Render.pm line 270.

[1640] testing for asynchronous event() at /usr/local/lib/perl/5.12.4/Bio/Graphics/Browser2/Render.pm line 273.

[1640] rendering error track:  feature query failed at /usr/local/lib/perl/5.12.4/Bio/Graphics/Browser2/Render.pm line 3646.

[1640] asynchronous exit at /usr/local/lib/perl/5.12.4/Bio/Graphics/Browser2/Render.pm line 275.

Thanks,

Andrew Oberlin

On Wed, Apr 25, 2012 at 10:16 AM, Raymond Wan <[hidden email]> wrote:

Hi Andrew,


On Tuesday, April 24, 2012 02:37 AM, Andrew Oberlin wrote:
> Track rendering error: feature query failed.
>
> I have turned the DEBUG option on to see what is happening
> on the server in the error.log file and it says that there
> was this error, which seems similar:
>
> rendering error track:  feature query failed at
> /usr/local/lib/perl/5.12.4/Bio/Graphics/Browser2/Render.pm
> line 3646.
>
> Why would a query fail if the database is already known to
> work with GBrowse?


I've been stuck on the same problem as you for a couple of weeks.  (Truthfully,
I've set it aside for the time being and hoping that something will dawn on me
at some point.)

I posted messages on April 11th and 16th.  But, perhaps we can share some
information to rule out the causes.  In my case, I am using:

1)  Ubuntu 12.04
2)  Latest GBrowse and Chado, both installed from source
3)  With renderfarm turned off, the system works
4)  The gbrowse_slave no longer starts during boot-up.  I *think* it use to, but
I can't remember.
5)  Manually starting gbrowse_slave doesn't seem to work.
6)  Nothing is being written to the /var/log/gbrowse/gbrowse_slave .

Fortunately for me, this is happening on a test server so I have the luxury of
time (well, a bit).  I am thinking of using the GBrowse package within Ubuntu
next.  That's version 2.42.

The only thing I am worried about is that /etc/gbrowse/GBrowse.conf had
variables instead of values for paths.  Something like ${PERSISTENT}, etc.  I
manually substituted them because the system didn't seem to be replacing them.
I'm wondering if you did that as well...

Ray



-------------------------------------------------
This e-mail is sent by CUHK WebMail http://webmail.cuhk.edu.hk




--
Andrew Oberlin
Miami University 2013
Computer Science & Mathematics
[hidden email]  (330) 998-1603


------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Gmod-schema mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-schema
Reply | Threaded
Open this post in threaded view
|

Re: [Gmod-gbrowse] Track Rendering Error

Scott Cain
Hi Andrew,

I have no idea.  Can you send me a dump from the offending database?

Scott

Sent from my iPad

On Apr 30, 2012, at 5:23 PM, Andrew Oberlin <[hidden email]> wrote:

Hello all again,

I was still wondering why I would get a track rendering error on this machine, but not another with almost the same install. I would like to mention that the last install of Chado was 1.1 I believe and this one is 1.2. However, we did the update script that was specified in the install for it and the only thing that pops up in the error log is that it is rendering the error track.

If there is any other information as to why this would happen, it would be greatly appreciated.

Here is the exact error message:

[1640] RUN(): POST: http://localhost/gb2/gbrowse/mycoplasma_agalactiae/ action=retrieve_multiple;track_ids=Genes;tk_Genes=54ad1b8336f0061918add849be948131 at /usr/local/lib/perl/5.12.4/Bio/Graphics/Browser2/Render.pm line 239.

[1640] session id = 9dad1033a6b18568fdc667a8ce2c75e2 at /usr/local/lib/perl/5.12.4/Bio/Graphics/Browser2/Render.pm line 243.

[1640] add_user_tracks() at /usr/local/lib/perl/5.12.4/Bio/Graphics/Browser2/Render.pm line 270.

[1640] testing for asynchronous event() at /usr/local/lib/perl/5.12.4/Bio/Graphics/Browser2/Render.pm line 273.

[1640] rendering error track:  feature query failed at /usr/local/lib/perl/5.12.4/Bio/Graphics/Browser2/Render.pm line 3646.

[1640] asynchronous exit at /usr/local/lib/perl/5.12.4/Bio/Graphics/Browser2/Render.pm line 275.

Thanks,

Andrew Oberlin

On Wed, Apr 25, 2012 at 10:16 AM, Raymond Wan <[hidden email]> wrote:

Hi Andrew,


On Tuesday, April 24, 2012 02:37 AM, Andrew Oberlin wrote:
> Track rendering error: feature query failed.
>
> I have turned the DEBUG option on to see what is happening
> on the server in the error.log file and it says that there
> was this error, which seems similar:
>
> rendering error track:  feature query failed at
> /usr/local/lib/perl/5.12.4/Bio/Graphics/Browser2/Render.pm
> line 3646.
>
> Why would a query fail if the database is already known to
> work with GBrowse?


I've been stuck on the same problem as you for a couple of weeks.  (Truthfully,
I've set it aside for the time being and hoping that something will dawn on me
at some point.)

I posted messages on April 11th and 16th.  But, perhaps we can share some
information to rule out the causes.  In my case, I am using:

1)  Ubuntu 12.04
2)  Latest GBrowse and Chado, both installed from source
3)  With renderfarm turned off, the system works
4)  The gbrowse_slave no longer starts during boot-up.  I *think* it use to, but
I can't remember.
5)  Manually starting gbrowse_slave doesn't seem to work.
6)  Nothing is being written to the /var/log/gbrowse/gbrowse_slave .

Fortunately for me, this is happening on a test server so I have the luxury of
time (well, a bit).  I am thinking of using the GBrowse package within Ubuntu
next.  That's version 2.42.

The only thing I am worried about is that /etc/gbrowse/GBrowse.conf had
variables instead of values for paths.  Something like ${PERSISTENT}, etc.  I
manually substituted them because the system didn't seem to be replacing them.
I'm wondering if you did that as well...

Ray



-------------------------------------------------
This e-mail is sent by CUHK WebMail http://webmail.cuhk.edu.hk




--
Andrew Oberlin
Miami University 2013
Computer Science & Mathematics
[hidden email]  (330) 998-1603

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Gmod-gbrowse mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-gbrowse

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Gmod-schema mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-schema