Re: [galaxy-dev] [Genome-mirror] Enabling bigWig for galaxy

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: [galaxy-dev] [Genome-mirror] Enabling bigWig for galaxy

Angie Hinrichs
Hi Davide,

It's difficult to tell what is going on because I can't access any of the URLs, and the error message is from a fairly low-level function with many callers (udcMustRead).  It is trying to read bytes from the local sparse file cache, and if it fails, you get that error message.  Most of its callers are in header-parsing functions.  But if you can read the bigWig file that you fetch with wget, then the header is not corrupted.  The first read that we attempt when opening a big* file is a 4-byte magic number, so it could be that our udc/net code is not able to get any bytes from your internal URL.  

If you can run hgTracks in gdb and send us a backtrace, that could help.  The process is something like this:

1. Cause the failure using an hgTracks GET url and copy the params that follow the ?.  E.g. if the failing URL is http://host..../hgTracks?hgsid=123&db=etc , copy "hgsid=123&db=etc".

2. cd /usr/local/apache/cgi-bin [or wherever hgTracks is installed]

3. export HGDB_CONF=hg.conf

4. gdb hgTracks
   break errAbort
   run 'hgsid=123&db=etc'
   where

If your hgTracks URL doesn't have any CGI params following a ?, let us know how you reach the failing page.  

Hope that helps,
Angie

----- "Davide Cittaro" <[hidden email]> wrote:

> From: "Davide Cittaro" <[hidden email]>
> To: [hidden email], [hidden email]
> Sent: Friday, May 28, 2010 2:43:39 AM GMT -08:00 US/Canada Pacific
> Subject: [Genome-mirror] Enabling bigWig for galaxy
>
> Dear all,
> I'm trying to enable bigwig support in Galaxy. Besides the sniff
> section which is probably not working, I'm trying to enable at least
> the visualization on a UCSC mirror. I see that galaxy link to display
> includes this hgt.customText
>
> http://host001.instruments.ifom-ieo-campus.it:8080/display_application/e00d4fc8bba8b6c5/ucsc_bigWig/campus/a3e0990f3de110b5/param/track
>
> which contains the track definition:
>
> track type=bigWig name="Pu1_100219.bw"
> bigDataUrl=http://host001.instruments.ifom-ieo-campus.it:8080/display_application/e00d4fc8bba8b6c5/ucsc_bigWig/campus/a3e0990f3de110b5/data/galaxy_e00d4fc8bba8b6c5.bw
> db=hg18
>
> Unfortunately the genome browser (a local mirror) says:
>
> Error udc couldn't read 4 bytes from
> http://host001.instruments.ifom-ieo-campus.it:8080/display_application/e00d4fc8bba8b6c5/ucsc_bigWig/campus/a3e0990f3de110b5/data/galaxy_e00d4fc8bba8b6c5.bw,
> did read 0
>
> I've tried to fetch the bigwig file in bigDataUrl link with wget and
> I'm able to reach it.
> Needless to say, the bigwig file is a proper one, I've tried to load
> it from another location and it can be displayed.
> At this point I don't know how to debug it...
> @UCSC people: when am I supposed to get that error? Which conditions
> raise it?
> @Galaxy people: since the link is valid, why I cannot present it to
> UCSC?
>
> Thanks
>
> d
>
>
> /*
> Davide Cittaro
>
> Cogentech - Consortium for Genomic Technologies
> via adamello, 16
> 20139 Milano
> Italy
>
> tel.: +39(02)574303007
> e-mail: [hidden email]
> */
>
>
>
> _______________________________________________
> Genome-mirror mailing list
> [hidden email]
> https://lists.soe.ucsc.edu/mailman/listinfo/genome-mirror
_______________________________________________
galaxy-dev mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-dev