Re: [mart-dev] biomart web interface errors

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: [mart-dev] biomart web interface errors

Syed Haider
Hi Daniel,

apologies for the late reply.

Could you please check if it works for you today ?

thanks
Syed

On 26/05/2010 13:27, Daniel Barrell wrote:

> Hi,
>
> I'm trying to use biomart to get protein coding sequences in fasta
> format with ensembl gene and peptide identifiers in the ID line for 8
> species. I was doing this via the API but consistently got http 500 and
> 502 errors yesterday. This morning I discovered how you could run a job
> in the background via the web site and get the compressed results
> emailed to you in a link. This worked a couple of times and now I am
> consistently getting the following error:
>
> ERROR: caught BioMart::Exception: non-BioMart die(): Can't locate object
> method "error" via package "Cannot fork: Cannot allocate memory
> " (perhaps you forgot to load "Cannot fork: Cannot allocate memory
> "?) at /ensemblweb/wwwmart/www_57/biomart-perl/lib/BioMart/Web.pm line 2516.
>
> If you repeatedly get directed to this error page, there may be a
> problem with your current session parameters. To clear your session and
> start with a clean slate, please click the *New* button below.
>
> Stacktrace:
> Exception::Class::Base::new
> /ensemblweb/wwwmart/www_57/biomart-perl/cgi-bin/martview:106
> ModPerl::ROOT::ModPerl::Registry::ensemblweb_wwwmart_www_57_biomart_2dperl_cgi_2dbin_martview::handler
> /localsw/ensembl_web/apache/lib/site_perl/5.8.8/x86_64-linux-thread-multi/ModPerl/RegistryCooker.pm:204
> (eval)
> /localsw/ensembl_web/apache/lib/site_perl/5.8.8/x86_64-linux-thread-multi/ModPerl/RegistryCooker.pm:204
> ModPerl::RegistryCooker::run
> /localsw/ensembl_web/apache/lib/site_perl/5.8.8/x86_64-linux-thread-multi/ModPerl/RegistryCooker.pm:170
> ModPerl::RegistryCooker::default_handler
> /localsw/ensembl_web/apache/lib/site_perl/5.8.8/x86_64-linux-thread-multi/ModPerl/Registry.pm:31
> ModPerl::Registry::handler -e:0
> (eval) -e:0
>
> Is this something that can be fixed your end or am I doing something wrong?
>
> Cheers
>
> Dan
>
> PS: here's the setup I was using @ ensembl.org/biomart
>
> Dataset
>
> Bos taurus genes (Btau_4.0)
> Bos taurus genes (Btau_4.0)
> Filters
>
> Gene type : protein_coding
> Attributes
>
> Ensembl Gene ID
> Ensembl Transcript ID
> [2 enabled]
> Ensembl Gene ID
> Ensembl Transcript ID
> [2 enabled][2 enabled]
> Ensembl Gene ID
> Ensembl Transcript ID
> [2 enabled][2 enabled]
> Ensembl Gene ID
> Ensembl Transcript ID
> Reference ID
> [3 enabled][3 enabled]
> Peptide
> Ensembl Gene ID
> [3 enabled]
> Ensembl Protein ID
> Dataset
>
> [None Selected]
>