Quantcast

RepeatMasker: NCBIBlastSearchEngine::search: Error

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RepeatMasker: NCBIBlastSearchEngine::search: Error

卢金原Jim
Hi, I'm a newbie of maker.
I met some errors in Repeatmasker step.

The error is here:

NCBIBlastSearchEngine::search: Error...compressed subject database (/home/softwares/RepeatMasker/Libraries/20170127/general/is.lib) does not exist!


I tried ncbi+blast 2.5.0 version and 2.6.0 version as the path to blast, both have the same error.

And when I use the command as "maker -R", which skips the repeatmasker step, the maker could work.

I checked the former similar errors reported by another user and he solved the problem by  updating the RepBase.

So,

  I deleted and re-installed the RepeatMasker, updated the RepBase,  also installed RMblast.

The error is the same.


I'm stuck in the problem now.

Would highly appreciate any help - thanks!


Jinyuan Lu
Shanghai Jiao Tong University
No. 800 Dong Chuan Road,Minhang District,  Shanghai, P.R. China

_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: RepeatMasker: NCBIBlastSearchEngine::search: Error

Ence,daniel
Hi, the error is regarding a specific file (is.lib) which isn’t being found. Can you verify that the file is there after you updated Repbase? Use the command:
“ls -l /home/softwares/RepeatMasker/Libraries/20170127/general/is.lib

Thanks,
Daniel Ence


On May 3, 2017, at 8:15 AM, 卢金原Jim <[hidden email]> wrote:

Hi, I'm a newbie of maker.
I met some errors in Repeatmasker step.

The error is here:
NCBIBlastSearchEngine::search: Error...compressed subject database (/home/softwares/RepeatMasker/Libraries/20170127/general/is.lib) does not exist!

I tried ncbi+blast 2.5.0 version and 2.6.0 version as the path to blast, both have the same error.
And when I use the command as "maker -R", which skips the repeatmasker step, the maker could work.
I checked the former similar errors reported by another user and he solved the problem by  updating the RepBase.
So,
  I deleted and re-installed the RepeatMasker, updated the RepBase,  also installed RMblast.
The error is the same.

I'm stuck in the problem now.
Would highly appreciate any help - thanks!

Jinyuan Lu
Shanghai Jiao Tong University
No. 800 Dong Chuan Road,Minhang District,  Shanghai, P.R. China
_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org


_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: RepeatMasker: NCBIBlastSearchEngine::search: Error

Carson Holt-2
In reply to this post by 卢金原Jim
RepBase and RepeatMasker have changed structure with the new 4.0.7 released two months ago. The new version and RepBase is only compatible with the new version of RepeatMasker. You have to update both (complete reinstall). Or you have to use the previous version of RepeatMasker with the previous version of RepBase.

—Carson



On May 3, 2017, at 6:15 AM, 卢金原Jim <[hidden email]> wrote:

Hi, I'm a newbie of maker.
I met some errors in Repeatmasker step.

The error is here:
NCBIBlastSearchEngine::search: Error...compressed subject database (/home/softwares/RepeatMasker/Libraries/20170127/general/is.lib) does not exist!

I tried ncbi+blast 2.5.0 version and 2.6.0 version as the path to blast, both have the same error.
And when I use the command as "maker -R", which skips the repeatmasker step, the maker could work.
I checked the former similar errors reported by another user and he solved the problem by  updating the RepBase.
So,
  I deleted and re-installed the RepeatMasker, updated the RepBase,  also installed RMblast.
The error is the same.

I'm stuck in the problem now.
Would highly appreciate any help - thanks!

Jinyuan Lu
Shanghai Jiao Tong University
No. 800 Dong Chuan Road,Minhang District,  Shanghai, P.R. China
_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org


_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: RepeatMasker: NCBIBlastSearchEngine::search: Error

Carson Holt-2
You may want to use the previous version of both as the new version may still have hidden bugs.

—Carson

On May 3, 2017, at 9:53 AM, Carson Holt <[hidden email]> wrote:

RepBase and RepeatMasker have changed structure with the new 4.0.7 released two months ago. The new version and RepBase is only compatible with the new version of RepeatMasker. You have to update both (complete reinstall). Or you have to use the previous version of RepeatMasker with the previous version of RepBase.

—Carson



On May 3, 2017, at 6:15 AM, 卢金原Jim <[hidden email]> wrote:

Hi, I'm a newbie of maker.
I met some errors in Repeatmasker step.

The error is here:
NCBIBlastSearchEngine::search: Error...compressed subject database (/home/softwares/RepeatMasker/Libraries/20170127/general/is.lib) does not exist!

I tried ncbi+blast 2.5.0 version and 2.6.0 version as the path to blast, both have the same error.
And when I use the command as "maker -R", which skips the repeatmasker step, the maker could work.
I checked the former similar errors reported by another user and he solved the problem by  updating the RepBase.
So,
  I deleted and re-installed the RepeatMasker, updated the RepBase,  also installed RMblast.
The error is the same.

I'm stuck in the problem now.
Would highly appreciate any help - thanks!

Jinyuan Lu
Shanghai Jiao Tong University
No. 800 Dong Chuan Road,Minhang District,  Shanghai, P.R. China
_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org



_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: RepeatMasker: NCBIBlastSearchEngine::search: Error

Carson Holt-2
You may have to contact RepBase via e-mail to find out how to get the libraries compatible with RepeatMasker 4.0.6 as it looks like they have removed the previous release from the website.

The last release for 4.0.6 was —> repeatmaskerlibraries-20160829.tar.gz

—Carson



On May 3, 2017, at 9:55 AM, Carson Holt <[hidden email]> wrote:

You may want to use the previous version of both as the new version may still have hidden bugs.

—Carson

On May 3, 2017, at 9:53 AM, Carson Holt <[hidden email]> wrote:

RepBase and RepeatMasker have changed structure with the new 4.0.7 released two months ago. The new version and RepBase is only compatible with the new version of RepeatMasker. You have to update both (complete reinstall). Or you have to use the previous version of RepeatMasker with the previous version of RepBase.

—Carson



On May 3, 2017, at 6:15 AM, 卢金原Jim <[hidden email]> wrote:

Hi, I'm a newbie of maker.
I met some errors in Repeatmasker step.

The error is here:
NCBIBlastSearchEngine::search: Error...compressed subject database (/home/softwares/RepeatMasker/Libraries/20170127/general/is.lib) does not exist!

I tried ncbi+blast 2.5.0 version and 2.6.0 version as the path to blast, both have the same error.
And when I use the command as "maker -R", which skips the repeatmasker step, the maker could work.
I checked the former similar errors reported by another user and he solved the problem by  updating the RepBase.
So,
  I deleted and re-installed the RepeatMasker, updated the RepBase,  also installed RMblast.
The error is the same.

I'm stuck in the problem now.
Would highly appreciate any help - thanks!

Jinyuan Lu
Shanghai Jiao Tong University
No. 800 Dong Chuan Road,Minhang District,  Shanghai, P.R. China
_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org




_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: RepeatMasker: NCBIBlastSearchEngine::search: Error

卢金原Jim
Thanks a lot!
Problem solved. 
I matched the RepeatMasker 4.0.7 with RepBase20170127 and it worked!

Thanks!
   ----Jinyuan Lu


At 2017-05-04 00:04:20, "Carson Holt" <[hidden email]> wrote:
You may have to contact RepBase via e-mail to find out how to get the libraries compatible with RepeatMasker 4.0.6 as it looks like they have removed the previous release from the website.

The last release for 4.0.6 was —> repeatmaskerlibraries-20160829.tar.gz

—Carson



On May 3, 2017, at 9:55 AM, Carson Holt <[hidden email]> wrote:

You may want to use the previous version of both as the new version may still have hidden bugs.

—Carson

On May 3, 2017, at 9:53 AM, Carson Holt <[hidden email]> wrote:

RepBase and RepeatMasker have changed structure with the new 4.0.7 released two months ago. The new version and RepBase is only compatible with the new version of RepeatMasker. You have to update both (complete reinstall). Or you have to use the previous version of RepeatMasker with the previous version of RepBase.

—Carson



On May 3, 2017, at 6:15 AM, 卢金原Jim <[hidden email]> wrote:

Hi, I'm a newbie of maker.
I met some errors in Repeatmasker step.

The error is here:
NCBIBlastSearchEngine::search: Error...compressed subject database (/home/softwares/RepeatMasker/Libraries/20170127/general/is.lib) does not exist!

I tried ncbi+blast 2.5.0 version and 2.6.0 version as the path to blast, both have the same error.
And when I use the command as "maker -R", which skips the repeatmasker step, the maker could work.
I checked the former similar errors reported by another user and he solved the problem by  updating the RepBase.
So,
  I deleted and re-installed the RepeatMasker, updated the RepBase,  also installed RMblast.
The error is the same.

I'm stuck in the problem now.
Would highly appreciate any help - thanks!

Jinyuan Lu
Shanghai Jiao Tong University
No. 800 Dong Chuan Road,Minhang District,  Shanghai, P.R. China
_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org




_______________________________________________
maker-devel mailing list
[hidden email]
http://box290.bluehost.com/mailman/listinfo/maker-devel_yandell-lab.org
Loading...