Run workflow permission denied

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Run workflow permission denied

gary_xie
Hi, there, 
We have a new installed Ergatis running from linux. I just created a one-step pipeline---formatdb. It has been always in incomplete,  and there is no output in my /usr/local/projects/gary/output_repository. Here are my logfile and stdout/stderr. We do have execution permission for RunWorkflow and ..ergatis/bin 
Maybe someone have some insight.
Thanks,
Gary


The Workflow is invoked. View Workflow Monitor to check the progress. 
log4j:WARN No appenders could be found for logger (org.tigr.antware.shared.util.AppConfig).
log4j:WARN Please initialize the log4j system properly.
Exception in thread "main" java.lang.NoClassDefFoundError: org.tigr.workflow.common.InterruptSignalHandler
   at org.tigr.workflow.common.WorkflowEngine.runWorkflow(WorkflowEngine.java:593)
   at org.tigr.workflow.common.WorkflowEngine.mainHelper(WorkflowEngine.java:2451)
   at org.tigr.workflow.common.WorkflowEngine.main(WorkflowEngine.java:2508)


     /usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml.log
INFO 17:17:03:026 [Thread: main] WorkflowEngine main:2497 Initialized logging system using config file '/opt/workflow/log4j.properties' watching 'true' frequency '60000'.
DEBUG 17:17:03:028 [Thread: main] WorkflowEngine main:2501  PROCESS ID IS 28.
INFO 17:17:03:028 [Thread: main] WorkflowEngine main:2505 MEMORY: Started with 9019392 total, 458752 free.
DEBUG 17:17:03:031 [Thread: main] WorkflowEngine mainHelper:2214 Parameters: {'-i', '/usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml', '-m', '1', '--pidfile', '.workflow.apache.18515', '--max-heap=1024m', }
DEBUG 17:17:03:031 [Thread: main] WorkflowEngine mainHelper:2220 Requested Marshalling interval : 1
INFO 17:17:03:031 [Thread: main] WorkflowEngine mainHelper:2293 Creating new WorkflowEngine...
DEBUG 17:17:03:041 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
INFO 17:17:03:042 [Thread: main] WorkflowChecker :90 Using file channel locking mechanism: false
DEBUG 17:17:03:042 [Thread: main] WorkflowEngine mainHelper:2306 Project Config file /opt/workflow/workflow.config
INFO 17:17:03:043 [Thread: main] WorkflowChecker lockFile:137 Attempting to lock file /usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml.lock for processID 28
DEBUG 17:17:03:043 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:043 [Thread: main] WorkflowChecker lockFile:212 Attempting to add shutdown hook to release lock on file /usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml.lock...
DEBUG 17:17:03:043 [Thread: main] WorkflowChecker lockFile:217 The file /usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml.lock should be unlocked on shutdown.
DEBUG 17:17:03:043 [Thread: main] WorkflowChecker lockFile:228 standInProcessID: File /usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml.lock LOCKED!!!!!!
INFO 17:17:03:044 [Thread: main] WorkflowChecker lockFile:240 Successfully obtained a file lock.
DEBUG 17:17:03:044 [Thread: main] WorkflowEngine mainHelper:2324 Checking to see this workflow is running. 
DEBUG 17:17:03:052 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:077 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:078 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:079 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:080 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:081 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:082 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:083 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:083 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:086 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:086 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:087 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:088 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:089 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:090 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:090 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:091 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:096 [Thread: main] WorkflowInstanceHelper unmarshal:161  Unmarshaling from /usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml using /opt/workflow/mapping/command_set_mapping.xml...
DEBUG 17:17:03:528 [Thread: main] CommandSet isRemote:1274 Command set type is : serial
DEBUG 17:17:03:529 [Thread: main] CommandSet isRemote:1282 Command set is remote: false
DEBUG 17:17:03:531 [Thread: main] CommandSet isRemote:1274 Command set type is : serial
DEBUG 17:17:03:532 [Thread: main] CommandSet isRemote:1282 Command set is remote: false
DEBUG 17:17:03:539 [Thread: main] CommandSet isRemote:1274 Command set type is : serial
DEBUG 17:17:03:540 [Thread: main] CommandSet isRemote:1282 Command set is remote: false
DEBUG 17:17:03:542 [Thread: main] WorkflowChecker checkWorkflow:319 Checking the status of command set: Name: start pipeline:  Type: serial  ID: 0
DEBUG 17:17:03:542 [Thread: main] WorkflowChecker checkWorkflow:335 Host not specified. Workflow was never launched before.
INFO 17:17:03:543 [Thread: main] WorkflowEngine mainHelper:2450 Running workflow...
INFO 17:17:03:543 [Thread: main] WorkflowEngine runWorkflow:580 Starting to run workflow specified in file '/usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml'.
/usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml.run.out
The Workflow is invoked. View Workflow Monitor to check the progress. 
log4j:WARN No appenders could be found for logger (org.tigr.antware.shared.util.AppConfig).
log4j:WARN Please initialize the log4j system properly.
Exception in thread "main" java.lang.NoClassDefFoundError: org.tigr.workflow.common.InterruptSignalHandler
   at org.tigr.workflow.common.WorkflowEngine.runWorkflow(WorkflowEngine.java:593)
   at org.tigr.workflow.common.WorkflowEngine.mainHelper(WorkflowEngine.java:2451)
   at org.tigr.workflow.common.WorkflowEngine.main(WorkflowEngine.java:2508)



------------------------------------------------------------------------------
vRanger cuts backup time in half-while increasing security.
With the market-leading solution for virtual backup and recovery,
you get blazing-fast, flexible, and affordable data protection.
Download your free trial now.
http://p.sf.net/sfu/quest-d2dcopy1
_______________________________________________
Ergatis-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ergatis-users
Reply | Threaded
Open this post in threaded view
|

Re: Run workflow permission denied

Joshua Orvis
Gary -

Could you create a tarball of that pipeline directory (it should be quite small) and attach that back to me?

tar -czf pipeline.tar.gz /usr/local/projects/gary/workflow/runtime/pipeline/11

Thanks -

Joshua



2011/5/27 Gary Xie <[hidden email]>
Hi, there, 
We have a new installed Ergatis running from linux. I just created a one-step pipeline---formatdb. It has been always in incomplete,  and there is no output in my /usr/local/projects/gary/output_repository. Here are my logfile and stdout/stderr. We do have execution permission for RunWorkflow and ..ergatis/bin 
Maybe someone have some insight.
Thanks,
Gary


The Workflow is invoked. View Workflow Monitor to check the progress. 
log4j:WARN No appenders could be found for logger (org.tigr.antware.shared.util.AppConfig).
log4j:WARN Please initialize the log4j system properly.
Exception in thread "main" java.lang.NoClassDefFoundError: org.tigr.workflow.common.InterruptSignalHandler
   at org.tigr.workflow.common.WorkflowEngine.runWorkflow(WorkflowEngine.java:593)
   at org.tigr.workflow.common.WorkflowEngine.mainHelper(WorkflowEngine.java:2451)
   at org.tigr.workflow.common.WorkflowEngine.main(WorkflowEngine.java:2508)


     /usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml.log
INFO 17:17:03:026 [Thread: main] WorkflowEngine main:2497 Initialized logging system using config file '/opt/workflow/log4j.properties' watching 'true' frequency '60000'.
DEBUG 17:17:03:028 [Thread: main] WorkflowEngine main:2501  PROCESS ID IS 28.
INFO 17:17:03:028 [Thread: main] WorkflowEngine main:2505 MEMORY: Started with 9019392 total, 458752 free.
DEBUG 17:17:03:031 [Thread: main] WorkflowEngine mainHelper:2214 Parameters: {'-i', '/usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml', '-m', '1', '--pidfile', '.workflow.apache.18515', '--max-heap=1024m', }
DEBUG 17:17:03:031 [Thread: main] WorkflowEngine mainHelper:2220 Requested Marshalling interval : 1
INFO 17:17:03:031 [Thread: main] WorkflowEngine mainHelper:2293 Creating new WorkflowEngine...
DEBUG 17:17:03:041 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
INFO 17:17:03:042 [Thread: main] WorkflowChecker :90 Using file channel locking mechanism: false
DEBUG 17:17:03:042 [Thread: main] WorkflowEngine mainHelper:2306 Project Config file /opt/workflow/workflow.config
INFO 17:17:03:043 [Thread: main] WorkflowChecker lockFile:137 Attempting to lock file /usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml.lock for processID 28
DEBUG 17:17:03:043 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:043 [Thread: main] WorkflowChecker lockFile:212 Attempting to add shutdown hook to release lock on file /usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml.lock...
DEBUG 17:17:03:043 [Thread: main] WorkflowChecker lockFile:217 The file /usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml.lock should be unlocked on shutdown.
DEBUG 17:17:03:043 [Thread: main] WorkflowChecker lockFile:228 standInProcessID: File /usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml.lock LOCKED!!!!!!
INFO 17:17:03:044 [Thread: main] WorkflowChecker lockFile:240 Successfully obtained a file lock.
DEBUG 17:17:03:044 [Thread: main] WorkflowEngine mainHelper:2324 Checking to see this workflow is running. 
DEBUG 17:17:03:052 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:077 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:078 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:079 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:080 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:081 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:082 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:083 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:083 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:086 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:086 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:087 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:088 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:089 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:090 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:090 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:091 [Thread: main] AppConfig getInstance:112 In getInstance: /opt/workflow/workflow.config
DEBUG 17:17:03:096 [Thread: main] WorkflowInstanceHelper unmarshal:161  Unmarshaling from /usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml using /opt/workflow/mapping/command_set_mapping.xml...
DEBUG 17:17:03:528 [Thread: main] CommandSet isRemote:1274 Command set type is : serial
DEBUG 17:17:03:529 [Thread: main] CommandSet isRemote:1282 Command set is remote: false
DEBUG 17:17:03:531 [Thread: main] CommandSet isRemote:1274 Command set type is : serial
DEBUG 17:17:03:532 [Thread: main] CommandSet isRemote:1282 Command set is remote: false
DEBUG 17:17:03:539 [Thread: main] CommandSet isRemote:1274 Command set type is : serial
DEBUG 17:17:03:540 [Thread: main] CommandSet isRemote:1282 Command set is remote: false
DEBUG 17:17:03:542 [Thread: main] WorkflowChecker checkWorkflow:319 Checking the status of command set: Name: start pipeline:  Type: serial  ID: 0
DEBUG 17:17:03:542 [Thread: main] WorkflowChecker checkWorkflow:335 Host not specified. Workflow was never launched before.
INFO 17:17:03:543 [Thread: main] WorkflowEngine mainHelper:2450 Running workflow...
INFO 17:17:03:543 [Thread: main] WorkflowEngine runWorkflow:580 Starting to run workflow specified in file '/usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml'.
/usr/local/projects/gary/workflow/runtime/pipeline/11/pipeline.xml.run.out
The Workflow is invoked. View Workflow Monitor to check the progress. 
log4j:WARN No appenders could be found for logger (org.tigr.antware.shared.util.AppConfig).
log4j:WARN Please initialize the log4j system properly.
Exception in thread "main" java.lang.NoClassDefFoundError: org.tigr.workflow.common.InterruptSignalHandler
   at org.tigr.workflow.common.WorkflowEngine.runWorkflow(WorkflowEngine.java:593)
   at org.tigr.workflow.common.WorkflowEngine.mainHelper(WorkflowEngine.java:2451)
   at org.tigr.workflow.common.WorkflowEngine.main(WorkflowEngine.java:2508)



------------------------------------------------------------------------------
vRanger cuts backup time in half-while increasing security.
With the market-leading solution for virtual backup and recovery,
you get blazing-fast, flexible, and affordable data protection.
Download your free trial now.
http://p.sf.net/sfu/quest-d2dcopy1
_______________________________________________
Ergatis-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ergatis-users



------------------------------------------------------------------------------
vRanger cuts backup time in half-while increasing security.
With the market-leading solution for virtual backup and recovery,
you get blazing-fast, flexible, and affordable data protection.
Download your free trial now.
http://p.sf.net/sfu/quest-d2dcopy1
_______________________________________________
Ergatis-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ergatis-users