Single Contig Error(s)

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Single Contig Error(s)

Kyle Tretina
Hello,

I noticed that during a recent download of the GFF3 file from our WebApollo instance that we were getting three kinds of unusual errors in the output that were not congruent with what I saw in the visual display for those gene models:

- isoforms that don't exist
- mRNAs with shared IDs
- orphan mRNA features (no gene parent)

I then realized that all of these errors were coming from a single contig. When I went to view some of these instances in WebApollo, I got the attached error (error1) and could not view the contig. Someone else trying to view the same contig from another location got error 2. These errors did not appear when viewing other contigs, which display just fine and don't have any of these errors. Any idea what the issue could be?

Thanks,
Kyle

Error1.png (99K) Download Attachment
Error2.png (50K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Single Contig Error(s)

Ed Lee
Hi Kyle,

Those errors might be due to an outdated plugin configuration.  Can you try running "add-webapollo-plugin.pl" on your JBrowse data directory and refreshing (making sure to clear your cache)?

I'm guessing that this data was generated from older versions of WebApollo that may have had some issues that caused these inconsistencies in the data.  Can you elaborate on these issues further (in particular #1)?  We have tools available to help remedy the offending annotations once they're identified.  You can run "remove_orphan_features.sh" to remove any orphan mRNAs and "remove_top_level_feature_by_id.sh" to remove any features that shouldn't be there (you'll need to find what the top level parent ID is to use the tool).

Cheers,
Ed


On Mon, Apr 28, 2014 at 6:36 AM, Kyle Tretina <[hidden email]> wrote:
Hello,

I noticed that during a recent download of the GFF3 file from our WebApollo instance that we were getting three kinds of unusual errors in the output that were not congruent with what I saw in the visual display for those gene models:

- isoforms that don't exist
- mRNAs with shared IDs
- orphan mRNA features (no gene parent)

I then realized that all of these errors were coming from a single contig. When I went to view some of these instances in WebApollo, I got the attached error (error1) and could not view the contig. Someone else trying to view the same contig from another location got error 2. These errors did not appear when viewing other contigs, which display just fine and don't have any of these errors. Any idea what the issue could be?

Thanks,
Kyle

Reply | Threaded
Open this post in threaded view
|

Re: Single Contig Error(s)

Kyle Tretina
Hi Ed,

We've run add-webapollo-plugin.pl as well as updated WebApollo to the latest release very recently (i.e. in the last couple weeks). It's also not very clear to me why only one contig would have this error and not others. Here is a little more details regarding the errors (below). Is there anything else that could be the reason for the TypeError and cfg file errors?

- isoforms that don't exist - mRNA isoforms that show up in the gff3 file but are not in the visual display
- mRNAs with shared IDs - mRNA features with the exact same ID, but different parent gene features
- orphan mRNA features - mRNA features with no parent gene features

Thank you for all of your help,
Kyle


On Tue, Apr 29, 2014 at 11:37 AM, Ed Lee <[hidden email]> wrote:
Hi Kyle,

Those errors might be due to an outdated plugin configuration.  Can you try running "add-webapollo-plugin.pl" on your JBrowse data directory and refreshing (making sure to clear your cache)?

I'm guessing that this data was generated from older versions of WebApollo that may have had some issues that caused these inconsistencies in the data.  Can you elaborate on these issues further (in particular #1)?  We have tools available to help remedy the offending annotations once they're identified.  You can run "remove_orphan_features.sh" to remove any orphan mRNAs and "remove_top_level_feature_by_id.sh" to remove any features that shouldn't be there (you'll need to find what the top level parent ID is to use the tool).

Cheers,
Ed


On Mon, Apr 28, 2014 at 6:36 AM, Kyle Tretina <[hidden email]> wrote:
Hello,

I noticed that during a recent download of the GFF3 file from our WebApollo instance that we were getting three kinds of unusual errors in the output that were not congruent with what I saw in the visual display for those gene models:

- isoforms that don't exist
- mRNAs with shared IDs
- orphan mRNA features (no gene parent)

I then realized that all of these errors were coming from a single contig. When I went to view some of these instances in WebApollo, I got the attached error (error1) and could not view the contig. Someone else trying to view the same contig from another location got error 2. These errors did not appear when viewing other contigs, which display just fine and don't have any of these errors. Any idea what the issue could be?

Thanks,
Kyle


Reply | Threaded
Open this post in threaded view
|

Re: Single Contig Error(s)

Ed Lee
Hi Kyle,

If you've run "add-webapollo-plugin.pl" from the latest release, then the configuration should be up to date.  It is a little weird that this only manifests itself in one contig.  Can you check the browser console and send me the stack trace for the error?  If you can grant me access to your instance, I might be able to dig deeper to find out what's causing this issue.

Cheers,
Ed


On Tue, Apr 29, 2014 at 10:55 AM, Kyle Tretina <[hidden email]> wrote:
Hi Ed,

We've run add-webapollo-plugin.pl as well as updated WebApollo to the latest release very recently (i.e. in the last couple weeks). It's also not very clear to me why only one contig would have this error and not others. Here is a little more details regarding the errors (below). Is there anything else that could be the reason for the TypeError and cfg file errors?

- isoforms that don't exist - mRNA isoforms that show up in the gff3 file but are not in the visual display
- mRNAs with shared IDs - mRNA features with the exact same ID, but different parent gene features
- orphan mRNA features - mRNA features with no parent gene features

Thank you for all of your help,
Kyle


On Tue, Apr 29, 2014 at 11:37 AM, Ed Lee <[hidden email]> wrote:
Hi Kyle,

Those errors might be due to an outdated plugin configuration.  Can you try running "add-webapollo-plugin.pl" on your JBrowse data directory and refreshing (making sure to clear your cache)?

I'm guessing that this data was generated from older versions of WebApollo that may have had some issues that caused these inconsistencies in the data.  Can you elaborate on these issues further (in particular #1)?  We have tools available to help remedy the offending annotations once they're identified.  You can run "remove_orphan_features.sh" to remove any orphan mRNAs and "remove_top_level_feature_by_id.sh" to remove any features that shouldn't be there (you'll need to find what the top level parent ID is to use the tool).

Cheers,
Ed


On Mon, Apr 28, 2014 at 6:36 AM, Kyle Tretina <[hidden email]> wrote:
Hello,

I noticed that during a recent download of the GFF3 file from our WebApollo instance that we were getting three kinds of unusual errors in the output that were not congruent with what I saw in the visual display for those gene models:

- isoforms that don't exist
- mRNAs with shared IDs
- orphan mRNA features (no gene parent)

I then realized that all of these errors were coming from a single contig. When I went to view some of these instances in WebApollo, I got the attached error (error1) and could not view the contig. Someone else trying to view the same contig from another location got error 2. These errors did not appear when viewing other contigs, which display just fine and don't have any of these errors. Any idea what the issue could be?

Thanks,
Kyle