Uninstall old tripal

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Uninstall old tripal

Hans Vasquez-Gross
Hi Stephen,

I am trying to install a very outdated version of tripal (from 2013).  However, I have upgraded my Drupal site from D6 to D7 between the first time I setup tripal and now.  

Since my website hasn't needed tripal for some time now, I decided to uninstall the modules.

However, when trying to do so, I get the following error.


Fatal error: Call to undefined function db_fetch_object() in /Library/WebServer/Documents/sites/all/modules/tripal/tripal_stock/tripal_stock.install on line 34

I read up on the function, which seems to be deprecated as of D7 and does not exist.

Do you have any suggestions on uninstall the modules?  Can I just remove all the tripal related directories from sites/all/modules?

tripal
tripal_blast_analysis
tripal_go_analysis
tripal_interpro_analysis
tripal_kegg_analysis
tripal_unigene_analysis


Cheers,
-Hans

------------------------------------------------------------------------------
Transform Data into Opportunity.
Accelerate data analysis in your applications with
Intel Data Analytics Acceleration Library.
Click to learn more.
http://pubads.g.doubleclick.net/gampad/clk?id=278785471&iu=/4140
_______________________________________________
Gmod-tripal mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-tripal
Reply | Threaded
Open this post in threaded view
|

Re: Uninstall old tripal

Stephen Ficklin-2
Hi Hans,

Are the Tripal modules upgraded to Drupal 7 or do you still have the old Drupal 6 Tripal modules? 

Stephen

On 3/29/2016 4:52 PM, Hans Vasquez-Gross wrote:
Hi Stephen,

I am trying to install a very outdated version of tripal (from 2013).  However, I have upgraded my Drupal site from D6 to D7 between the first time I setup tripal and now.  

Since my website hasn't needed tripal for some time now, I decided to uninstall the modules.

However, when trying to do so, I get the following error.


Fatal error: Call to undefined function db_fetch_object() in /Library/WebServer/Documents/sites/all/modules/tripal/tripal_stock/tripal_stock.install on line 34

I read up on the function, which seems to be deprecated as of D7 and does not exist.

Do you have any suggestions on uninstall the modules?  Can I just remove all the tripal related directories from sites/all/modules?

tripal
tripal_blast_analysis
tripal_go_analysis
tripal_interpro_analysis
tripal_kegg_analysis
tripal_unigene_analysis


Cheers,
-Hans


------------------------------------------------------------------------------
Transform Data into Opportunity.
Accelerate data analysis in your applications with
Intel Data Analytics Acceleration Library.
Click to learn more.
http://pubads.g.doubleclick.net/gampad/clk?id=278785471&iu=/4140


_______________________________________________
Gmod-tripal mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-tripal


------------------------------------------------------------------------------
Transform Data into Opportunity.
Accelerate data analysis in your applications with
Intel Data Analytics Acceleration Library.
Click to learn more.
http://pubads.g.doubleclick.net/gampad/clk?id=278785471&iu=/4140
_______________________________________________
Gmod-tripal mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-tripal
Reply | Threaded
Open this post in threaded view
|

Re: Uninstall old tripal

Hans Vasquez-Gross
Hi Stephen,

They are still the old D6 tripal modules.

Thanks,
-Hans

------------------------------------------------------------------------------
Transform Data into Opportunity.
Accelerate data analysis in your applications with
Intel Data Analytics Acceleration Library.
Click to learn more.
http://pubads.g.doubleclick.net/gampad/clk?id=278785471&iu=/4140
_______________________________________________
Gmod-tripal mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-tripal
Reply | Threaded
Open this post in threaded view
|

Re: Uninstall old tripal

Stephen Ficklin-2
Hi Hans,

Because you have D6 Tripal modules, Drupal would have automatically
disabled them when you upgraded.  It cannot use D6 modules. Therefore, I
don't think the error message you mentioned previously is coming from
the Tripal modules as they should be disabled. Although, I don't have a
Drupal instance in that state to test.

I believe you can safety remove those D6 Tripal modules by just moving
them out of the way.    Typically when you uninstall a Drupal module any
custom tables that that the module created will be removed. In this case
because you don't have a D7 compatible Tripal module you'll have some
Tripal "residue" around in your database. If you want to cleanly remove
these modules and if you can revert back to D6, you could remove the
Tripal modules first, then upgrade to D7.  Alternatively, you could go
through the process of upgrading Tripal for D7 and then uninstall it but
that's probably more effort than it's worth.    This problem is
unfortunately a Drupal upgrade issue.  I don't believe, Drupal will let
you remove the D6 modules without first upgrading them.

Also, we'd love to have feedback regarding your Tripal usage
experience.  Feel free to send along any thoughts you have either on the
list or privately which ever you prefer.

Best,
Stephen

On 3/29/2016 5:33 PM, Hans Vasquez-Gross wrote:
> Hi Stephen,
>
> They are still the old D6 tripal modules.
>
> Thanks,
> -Hans


------------------------------------------------------------------------------
Transform Data into Opportunity.
Accelerate data analysis in your applications with
Intel Data Analytics Acceleration Library.
Click to learn more.
http://pubads.g.doubleclick.net/gampad/clk?id=278785471&iu=/4140
_______________________________________________
Gmod-tripal mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-tripal