What's wrong with these queries?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

What's wrong with these queries?

Gabriel Berriz
Hi.  When I submit the following query to http://metazoa.ensembl.org/biomart/martservice:

<Query completionStamp="1" virtualSchemaName="default" uniqueRows="1" requestId="biomart-client">
  <Dataset interface="default" name="aaegypti_eg_gene">
    <Attribute name="ensembl_gene_id"/>
  </Dataset>
</Query>


I get the following error:

Query ERROR: caught BioMart::Exception::Usage: WITHIN Virtual Schema : default, Dataset aaegypti_eg_gene NOT FOUND


I get similar errors in response to the following queries:


<Query completionStamp="1" virtualSchemaName="default" uniqueRows="1" requestId="biomart-client">
  <Dataset interface="default" name="agambiae_eg_gene">
    <Attribute name="ensembl_gene_id"/>
  </Dataset>
</Query>



<Query completionStamp="1" virtualSchemaName="default" uniqueRows="1" requestId="biomart-client">
  <Dataset interface="default" name="athaliana_eg_gene">
    <Attribute name="ensembl_gene_id"/>
  </Dataset>
</Query>


In contrast, analogous queries to http://uswest.ensembl.org/biomart/martservice work fine; for example:

<Query completionStamp="1" virtualSchemaName="default" uniqueRows="1" requestId="biomart-client">
  <Dataset interface="default" name="btaurus_gene_ensembl">
    <Attribute name="affy_bovine"/>
  </Dataset>
</Query>



Can someone tell me what I'm doing wrong in the failing queries above?

TIA!

Gabriel Berriz



=============================================================
Gabriel F. Berriz, PhD
Senior Bioinformatics Developer
Roth Lab
Biological Chemistry and Molecular Pharmacology -- Harvard Medical School
250 Longwood Avenue
Seeley G. Mudd Building 322B
Boston, MA 02115-5701
Telephone: 617.432.3555
Fax: 617.432.3557





Reply | Threaded
Open this post in threaded view
|

Re: What's wrong with these queries?

Richard Holland
They've changed the virtualSchemaName as well as the dataset names - you should use 'metazoa_mart_4' instead. Check the XML button in their MartView to see an example and look closely at the opening Query tag.

cheers,
Richard

On 30 Aug 2010, at 21:05, Gabriel Berriz wrote:

> Hi.  When I submit the following query to http://metazoa.ensembl.org/biomart/martservice:
>
> <Query completionStamp="1" virtualSchemaName="default" uniqueRows="1" requestId="biomart-client">
>   <Dataset interface="default" name="aaegypti_eg_gene">
>     <Attribute name="ensembl_gene_id"/>
>   </Dataset>
> </Query>
>
>
> I get the following error:
>
> Query ERROR: caught BioMart::Exception::Usage: WITHIN Virtual Schema : default, Dataset aaegypti_eg_gene NOT FOUND
>
>
> I get similar errors in response to the following queries:
>
> (also to http://metazoa.ensembl.org/biomart/martservice)
>
> <Query completionStamp="1" virtualSchemaName="default" uniqueRows="1" requestId="biomart-client">
>   <Dataset interface="default" name="agambiae_eg_gene">
>     <Attribute name="ensembl_gene_id"/>
>   </Dataset>
> </Query>
>
>
> (to http://plants.ensembl.org/biomart/martservice)
>
> <Query completionStamp="1" virtualSchemaName="default" uniqueRows="1" requestId="biomart-client">
>   <Dataset interface="default" name="athaliana_eg_gene">
>     <Attribute name="ensembl_gene_id"/>
>   </Dataset>
> </Query>
>
>
> In contrast, analogous queries to http://uswest.ensembl.org/biomart/martservice work fine; for example:
>
> <Query completionStamp="1" virtualSchemaName="default" uniqueRows="1" requestId="biomart-client">
>   <Dataset interface="default" name="btaurus_gene_ensembl">
>     <Attribute name="affy_bovine"/>
>   </Dataset>
> </Query>
>
>
>
> Can someone tell me what I'm doing wrong in the failing queries above?
>
> TIA!
>
> Gabriel Berriz
>
>
>
> =============================================================
> Gabriel F. Berriz, PhD
> Senior Bioinformatics Developer
> Roth Lab
> Biological Chemistry and Molecular Pharmacology -- Harvard Medical School
> 250 Longwood Avenue
> Seeley G. Mudd Building 322B
> Boston, MA 02115-5701
> Telephone: 617.432.3555
> Fax: 617.432.3557
>
>
>
>
>

--
Richard Holland, BSc MBCS
Operations and Delivery Director, Eagle Genomics Ltd
T: +44 (0)1223 654481 ext 3 | E: [hidden email]
http://www.eaglegenomics.com/

Reply | Threaded
Open this post in threaded view
|

Re: What's wrong with these queries?

Syed Haider
Hi Gabriel,

the virtualSchemaName is "metazoa_mart_4".

you can programmatically find this information out by using the
following registry request:

http://metazoa.ensembl.org/biomart/martservice?type=registry

Best,
Syed


On 30/08/2010 21:36, Richard Holland wrote:

> They've changed the virtualSchemaName as well as the dataset names - you should use 'metazoa_mart_4' instead. Check the XML button in their MartView to see an example and look closely at the opening Query tag.
>
> cheers,
> Richard
>
> On 30 Aug 2010, at 21:05, Gabriel Berriz wrote:
>
>> Hi.  When I submit the following query to http://metazoa.ensembl.org/biomart/martservice:
>>
>> <Query completionStamp="1" virtualSchemaName="default" uniqueRows="1" requestId="biomart-client">
>>    <Dataset interface="default" name="aaegypti_eg_gene">
>>      <Attribute name="ensembl_gene_id"/>
>>    </Dataset>
>> </Query>
>>
>>
>> I get the following error:
>>
>> Query ERROR: caught BioMart::Exception::Usage: WITHIN Virtual Schema : default, Dataset aaegypti_eg_gene NOT FOUND
>>
>>
>> I get similar errors in response to the following queries:
>>
>> (also to http://metazoa.ensembl.org/biomart/martservice)
>>
>> <Query completionStamp="1" virtualSchemaName="default" uniqueRows="1" requestId="biomart-client">
>>    <Dataset interface="default" name="agambiae_eg_gene">
>>      <Attribute name="ensembl_gene_id"/>
>>    </Dataset>
>> </Query>
>>
>>
>> (to http://plants.ensembl.org/biomart/martservice)
>>
>> <Query completionStamp="1" virtualSchemaName="default" uniqueRows="1" requestId="biomart-client">
>>    <Dataset interface="default" name="athaliana_eg_gene">
>>      <Attribute name="ensembl_gene_id"/>
>>    </Dataset>
>> </Query>
>>
>>
>> In contrast, analogous queries to http://uswest.ensembl.org/biomart/martservice work fine; for example:
>>
>> <Query completionStamp="1" virtualSchemaName="default" uniqueRows="1" requestId="biomart-client">
>>    <Dataset interface="default" name="btaurus_gene_ensembl">
>>      <Attribute name="affy_bovine"/>
>>    </Dataset>
>> </Query>
>>
>>
>>
>> Can someone tell me what I'm doing wrong in the failing queries above?
>>
>> TIA!
>>
>> Gabriel Berriz
>>
>>
>>
>> =============================================================
>> Gabriel F. Berriz, PhD
>> Senior Bioinformatics Developer
>> Roth Lab
>> Biological Chemistry and Molecular Pharmacology -- Harvard Medical School
>> 250 Longwood Avenue
>> Seeley G. Mudd Building 322B
>> Boston, MA 02115-5701
>> Telephone: 617.432.3555
>> Fax: 617.432.3557
>>
>>
>>
>>
>>
>
> --
> Richard Holland, BSc MBCS
> Operations and Delivery Director, Eagle Genomics Ltd
> T: +44 (0)1223 654481 ext 3 | E: [hidden email]
> http://www.eaglegenomics.com/
>