[apollo] annotation editor / sequence appears as blank window

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[apollo] annotation editor / sequence appears as blank window

elizabeth henaff
Hello! 

Well, I have successfully managed to load all my computational results into Apollo (thanks Ed) and now I'd like to manually curate these... When I drag a result from the black section to the blue one it makes a new annotation, but when I right-click on this and select Sequence or Annotation Information Editor, a blank window pops up. 
I'm running version 1.11.12 on Ubuntu. 

Thanks for any help!

Cheers, 

Elizabeth

_______________________________________________
apollo mailing list
[hidden email]
http://mail.fruitfly.org/mailman/listinfo/apollo
Reply | Threaded
Open this post in threaded view
|

Re: [apollo] annotation editor / sequence appears as blank window

Ed Lee
Hi Elizabeth,

Are you just dragging the features from the results panel into the
annotation panel and then trying to launch the AIE?  Or are there
any steps in between?  Perhaps you can provide me with a sample
of your data and all the steps you're doing and I'll try to
replicate it and help out.

Cheers,
Ed

On Wed, 19 May 2010, elizabeth henaff wrote:

> Hello! 
> Well, I have successfully managed to load all my computational results into
> Apollo (thanks Ed) and now I'd like to manually curate these... When I drag
> a result from the black section to the blue one it makes a new annotation,
> but when I right-click on this and select Sequence or Annotation Information
> Editor, a blank window pops up. 
> I'm running version 1.11.12 on Ubuntu. 
>
> Thanks for any help!
>
> Cheers, 
>
> Elizabeth
>
>
_______________________________________________
apollo mailing list
[hidden email]
http://mail.fruitfly.org/mailman/listinfo/apollo
Reply | Threaded
Open this post in threaded view
|

Re: [apollo] annotation editor / sequence appears as blank window

Ed Lee
Hi Elizabeth,

I can't seem to replicate the issue you're having.  This is the steps
I've followed:

1) Loaded the Genbank file
2) Appended the GFF3 data (with "Embedded FASTA in GFF" checked, since
    the genomic sequence is already loaded
3) Dragged a transposon from the results track into the annotation
    track
4) The newly created feature showed both the sequence in "Sequence..."
    and the data in the "Annotation Info Editor..."

I've tried it in both Ubuntu and Mac OSX and they both seem to
behave correctly.

Genbank files always tend to be a cause of trouble, so if you're
successful in loading the GBK file and appending the GFF3 data,
I would sugest to then save it to GAME XML format, with both
"Save annotations" and "Save evidence (computational results)"
checked so that you retain all the data and work with a structured
format that Apollo will handle much better.

Cheers,
Ed

On Thu, 20 May 2010, elizabeth henaff wrote:

> Hi Ed, 
>   I've tried either dragging a result into the annotation panel, and also
> creating a new annotation, and for both whenever I launch the AIE or the
> sequence it pulls up a blank window. This is also the case for annotations
> that are part of the data that I load. 
>   I have a gff3 file of results, and a GenBank file of annotations. I've
> tried various combinations (like, loading the genebank then layering on the
> gff3, or saving the genbank as chado or game and layering that onto the
> gff3, or saving both the genbank and the gff3 together as chado or game, and
> loading them as one) thinking that it might be the data format, but to no
> avail. 
>
> To be able to layer on results when I load the genbank data I modified
> genbank.style and set ShowResults to "true". 
> I've attached the .style and .tiers files and data I'm using, thanks for any
> help!!
>
> cheers, 
>
> elizabeth
>
> On Wed, May 19, 2010 at 10:31 PM, Ed Lee <[hidden email]> wrote:
>       Hi Elizabeth,
>
>       Are you just dragging the features from the results panel into
>       the
>       annotation panel and then trying to launch the AIE?  Or are
>       there
>       any steps in between?  Perhaps you can provide me with a sample
>       of your data and all the steps you're doing and I'll try to
>       replicate it and help out.
>
>       Cheers,
>       Ed
>
>
> On Wed, 19 May 2010, elizabeth henaff wrote:
>
>       Hello! 
>       Well, I have successfully managed to load all my
>       computational results into
>       Apollo (thanks Ed) and now I'd like to manually curate
>       these... When I drag
>       a result from the black section to the blue one it makes a
>       new annotation,
>       but when I right-click on this and select Sequence or
>       Annotation Information
>       Editor, a blank window pops up. 
>       I'm running version 1.11.12 on Ubuntu. 
>
>       Thanks for any help!
>
>       Cheers, 
>
>       Elizabeth
>
>
>
>
_______________________________________________
apollo mailing list
[hidden email]
http://mail.fruitfly.org/mailman/listinfo/apollo
Reply | Threaded
Open this post in threaded view
|

Re: [apollo] annotation editor / sequence appears as blank window

elizabeth henaff
Hi Ed, 

   Thanks so much for taking the time to help me out! I performed the steps you listed, as there was a difference in what I had been doing in that previously I had been loading the sequence along with the gff3 file. Still had the same issue, so I decided to start from scratch and reinstall Apollo... and it works! maybe the issue was specific to the version I had, which was not the most current one.
So now I'm happily curating and annotating :)
  
Cheers, 

Elizabeth

On Tue, May 25, 2010 at 12:04 AM, Ed Lee <[hidden email]> wrote:
Hi Elizabeth,

I can't seem to replicate the issue you're having.  This is the steps
I've followed:

1) Loaded the Genbank file
2) Appended the GFF3 data (with "Embedded FASTA in GFF" checked, since
  the genomic sequence is already loaded
3) Dragged a transposon from the results track into the annotation
  track
4) The newly created feature showed both the sequence in "Sequence..."
  and the data in the "Annotation Info Editor..."

I've tried it in both Ubuntu and Mac OSX and they both seem to
behave correctly.

Genbank files always tend to be a cause of trouble, so if you're
successful in loading the GBK file and appending the GFF3 data,
I would sugest to then save it to GAME XML format, with both
"Save annotations" and "Save evidence (computational results)"
checked so that you retain all the data and work with a structured
format that Apollo will handle much better.

Cheers,
Ed


On Thu, 20 May 2010, elizabeth henaff wrote:

Hi Ed, 
  I've tried either dragging a result into the annotation panel, and also
creating a new annotation, and for both whenever I launch the AIE or the
sequence it pulls up a blank window. This is also the case for annotations
that are part of the data that I load. 
  I have a gff3 file of results, and a GenBank file of annotations. I've
tried various combinations (like, loading the genebank then layering on the
gff3, or saving the genbank as chado or game and layering that onto the
gff3, or saving both the genbank and the gff3 together as chado or game, and
loading them as one) thinking that it might be the data format, but to no
avail. 

To be able to layer on results when I load the genbank data I modified
genbank.style and set ShowResults to "true". 
I've attached the .style and .tiers files and data I'm using, thanks for any
help!!

cheers, 

elizabeth

On Wed, May 19, 2010 at 10:31 PM, Ed Lee <[hidden email]> wrote:
     Hi Elizabeth,

     Are you just dragging the features from the results panel into
     the
     annotation panel and then trying to launch the AIE?  Or are
     there
     any steps in between?  Perhaps you can provide me with a sample
     of your data and all the steps you're doing and I'll try to
     replicate it and help out.

     Cheers,
     Ed


On Wed, 19 May 2010, elizabeth henaff wrote:

     Hello! 
     Well, I have successfully managed to load all my
     computational results into
     Apollo (thanks Ed) and now I'd like to manually curate
     these... When I drag
     a result from the black section to the blue one it makes a
     new annotation,
     but when I right-click on this and select Sequence or
     Annotation Information
     Editor, a blank window pops up. 
     I'm running version 1.11.12 on Ubuntu. 

     Thanks for any help!

     Cheers, 

     Elizabeth





_______________________________________________
apollo mailing list
[hidden email]
http://mail.fruitfly.org/mailman/listinfo/apollo