[biomart-users] Having trouble connecting to biomart SQL server

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[biomart-users] Having trouble connecting to biomart SQL server

Karl Guo
Hello,

My script was running fine on 1-9-2018. However, today (1-10-2018) I started getting the error below which did not appear yesterday. Is this there a known issue connecting to biomart?

Query ERROR: caught BioMart::Exception::Database: Could not connect to mysql database snp_mart_91: DBI connect('database=snp_mart_91;host=hh-mysql-ens-grch37mart-web;port=4560','ensro',...) failed: Can't connect to MySQL server on 'hh-mysql-ens-grch37mart-web' (111) at /nfs/public/release/ensweb/latest/live/grch37-mart/www_91/biomart-perl/lib/BioMart/Configuration/DBLocation.pm line 98.
Execution halted

Also, when I try to run a simple call on my local, I receive this error:

> snp_mart <- useMart("ENSEMBL_MART_SNP", dataset="hsapiens_snp")
> snp_attributes = c("refsnp_id", "chr_name", "chrom_start", "chrom_end" ) 
> getBM(values="rs10208643", attributes = snp_attributes, filters = "snp_filter", mart = snp_mart) 
                                                                                                                                                  V1
1                                                                                                   <!DOCTYPE HTML PUBLIC -//IETF//DTD HTML 2.0//EN>
2                                                                                                                                       <html><head>
3                                                                                                                           <title>302 Found</title>
4                                                                                                                                      </head><body>
5                                                                                                                                     <h1>Found</h1>
6 <p>The document has moved <a href=//useast.ensembl.org/biomart/martservice?;redirectsrc=//www.ensembl.org%2Fbiomart%2Fmartservice%3F>here</a>.</p>
Error in getBM(values = "rs10208643", attributes = snp_attributes, filters = "snp_filter",  : 
  The query to the BioMart webservice returned an invalid result: the number of columns in the result table does not equal the number of attributes in the query. Please report this to the mailing list.


I am not sure if these two issues are related.

Many thanks,
-Karl

--
You received this message because you are subscribed to the Google Groups "biomart-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
Visit this group at https://groups.google.com/group/biomart-users.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

[biomart-users] Re: Having trouble connecting to biomart SQL server

Karl Guo
The issue seems to have been fixed.

Thanks!
-Karl

On Wednesday, January 10, 2018 at 9:10:45 PM UTC-5, Karl Guo wrote:
Hello,

My script was running fine on 1-9-2018. However, today (1-10-2018) I started getting the error below which did not appear yesterday. Is this there a known issue connecting to biomart?

Query ERROR: caught BioMart::Exception::Database: Could not connect to mysql database snp_mart_91: DBI connect('database=snp_mart_91;host=hh-mysql-ens-grch37mart-web;port=4560','ensro',...) failed: Can't connect to MySQL server on 'hh-mysql-ens-grch37mart-web' (111) at /nfs/public/release/ensweb/latest/live/grch37-mart/www_91/biomart-perl/lib/BioMart/Configuration/DBLocation.pm line 98.
Execution halted

Also, when I try to run a simple call on my local, I receive this error:

> snp_mart <- useMart("ENSEMBL_MART_SNP", dataset="hsapiens_snp")
> snp_attributes = c("refsnp_id", "chr_name", "chrom_start", "chrom_end" ) 
> getBM(values="rs10208643", attributes = snp_attributes, filters = "snp_filter", mart = snp_mart) 
                                                                                                                                                  V1
1                                                                                                   <!DOCTYPE HTML PUBLIC -//IETF//DTD HTML 2.0//EN>
2                                                                                                                                       <html><head>
3                                                                                                                           <title>302 Found</title>
4                                                                                                                                      </head><body>
5                                                                                                                                     <h1>Found</h1>
6 <p>The document has moved <a href=//<a href="http://useast.ensembl.org/biomart/martservice?;redirectsrc=//www.ensembl.org%2Fbiomart%2Fmartservice%3F" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fuseast.ensembl.org%2Fbiomart%2Fmartservice%3F%3Bredirectsrc%3D%2F%2Fwww.ensembl.org%252Fbiomart%252Fmartservice%253F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFzMZjdHfcYQgxkf38xuLAjOnp5g&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fuseast.ensembl.org%2Fbiomart%2Fmartservice%3F%3Bredirectsrc%3D%2F%2Fwww.ensembl.org%252Fbiomart%252Fmartservice%253F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGFzMZjdHfcYQgxkf38xuLAjOnp5g&#39;;return true;">useast.ensembl.org/biomart/martservice?;redirectsrc=//www.ensembl.org%2Fbiomart%2Fmartservice%3F>here</a>.</p>
Error in getBM(values = "rs10208643", attributes = snp_attributes, filters = "snp_filter",  : 
  The query to the BioMart webservice returned an invalid result: the number of columns in the result table does not equal the number of attributes in the query. Please report this to the mailing list.


I am not sure if these two issues are related.

Many thanks,
-Karl

--
You received this message because you are subscribed to the Google Groups "biomart-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
Visit this group at https://groups.google.com/group/biomart-users.
For more options, visit https://groups.google.com/d/optout.