[biomart-users] Re: Biomart unavailable

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[biomart-users] Re: Biomart unavailable

Arek Kasprzyk

Hope you don't mind that I am cc'ing this to our users mailing list to help others who might run into the same problem

a.

On 11 November 2015 at 00:26, Daniela Cassol <[hidden email]> wrote:
It works!
Thank you so much!!!!

Daniela

On Tue, Nov 10, 2015 at 3:47 PM Steffen Durinck <[hidden email]> wrote:
Problem is that their registry has as the host set to "localhost", which you can see here


And when you try to use a dataset, it will use that localhost as URL which does not exists outside of JGI.

Try the workaround below until they update their registry:

library(biomaRt)

mart = new("Mart", biomart ="phytozome_mart", vschema="zome_mart",host="http://phytozome.jgi.doe.gov/biomart/martservice")

mart = useDataset("phytozome",mart=mart)


Cheers,

Steffen




On Tue, Nov 10, 2015 at 9:19 AM, Daniela Cassol <[hidden email]> wrote:

Please, if you can help, I really need this!

Thank you so much!


On Tue, Nov 10, 2015, 10:18 AM Arek Kasprzyk <[hidden email]> wrote:
Hi Daniela,

the webservice on the phytozome site is definitely working. I can see it here:


Your error suggest that perhaps there maybe a problem with a version call? My knowledge ends there so perhaps we can ask the expert instead. Steffen, would you be able to diagnose this problem for Daniela?


a.





On 10 November 2015 at 12:02, Daniela Cassol <[hidden email]> wrote:
It is not possible.


> library(biomaRt)

> m <- useMart("phytozome_mart", dataset="phytozome", host="phytozome.jgi.doe.gov")

Request to BioMart web service failed. Verify if you are still connected to the internet.  Alternatively the BioMart web service is temporarily down.  Check http://www.biomart.org and verify if this website is available.
Error in if (BioMartVersion == "\n" | BioMartVersion == "") { : 
  argument is of length zero



On Tue, Nov 10, 2015 at 9:43 AM Arek Kasprzyk <[hidden email]> wrote:

Please try to change your host from 'www.biomart.org' to 'phytozome.jgi.doe.gov' and let me know if this works for you.

a.

On 10 November 2015 at 11:38, Daniela Cassol <[hidden email]> wrote:
Dear Arek, 
Thank you for the quick answer.  I appreciate that!
I used this code:
###############################################
library("biomaRt")
listMarts()
m <- useMart("phytozome_mart"); listDatasets(m)
m <- useMart("phytozome_mart", dataset="phytozome")
listAttributes(m)

how can I get it again?

Thank you so much, 

Best, 

Daniela

On Tue, Nov 10, 2015 at 7:17 AM Arek Kasprzyk <[hidden email]> wrote:
Hi Daniela,

the community portal may be offline for a little while. However, this should not impact your work if you switch to an alternative server. Are you experiencing problems with that? Is there anything i can help you with?

Arek




On 10 November 2015 at 00:11, Daniela Cassol <[hidden email]> wrote:
Please, how long will it be unvailable BiomaRt??

Thank you!

Best, Daniela Cassol





--
You received this message because you are subscribed to the Google Groups "biomart-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
Visit this group at http://groups.google.com/group/biomart-users.
For more options, visit https://groups.google.com/d/optout.