define collections in webconfig-model.xml?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

define collections in webconfig-model.xml?

Sierra Moxon
In the keyword search, I'd like Constructs to show up with a  
collection of their CDS's.
Is there a way to define this in the webconfig-model.xml?

 From the examples, I can't tell if showInInlineCollection does this  
or not; seems like it is used on fields that are single-value (like  
primaryIdentifier), but in all the examples it is set to =false?

Thanks,
Sierra

_______________________________________________
dev mailing list
[hidden email]
http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Losing Chromosomes

Vallejos, Andrew
Losing Chromosomes

As of the conference call I had RatMine working on 94.1, but I was not correctly loading the QTL position info.  I updated the script and rebuilt, but now the gene chromosomes are broken.  For example, one gene 'Snrpn' has chromosomeid=496000002, but there is no chromosome with that id.  I have all the chromosomes that I would expect in the table.  I have not seen any errors or warnings, other than the webapp crashing when it tries to display a gene report.

-Andrew


_______________________________________________
dev mailing list
[hidden email]
http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Losing Chromosomes

Julie Sullivan
Andrew,

Can you check your keys to make sure you have chromosome key in each source?

If a source loads a chromosome without using an chromosome key and a there
is already an chromosome in the database you will get two chromosomes.  If
a later source does use a key these two chromosomes will be merged - and
one of the existing ids will be assigned.

Anything pointing at the other chromosome object will now point at thin
air, this a problem with the merging system.  Null references will cause
all sorts of problems in the webapp.

The solution is not to load the chromosome object if it isn't needed and
always to use the key when it is being loaded.

Cheers,
Julie

> As of the conference call I had RatMine working on 94.1, but I was not
> correctly loading the QTL position info.  I updated the script and
> rebuilt, but now the gene chromosomes are broken.  For example, one gene
> 'Snrpn' has chromosomeid=496000002, but there is no chromosome with that
> id.  I have all the chromosomes that I would expect in the table.  I have
> not seen any errors or warnings, other than the webapp crashing when it
> tries to display a gene report.
>
> -Andrew
> _______________________________________________
> dev mailing list
> [hidden email]
> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
>



_______________________________________________
dev mailing list
[hidden email]
http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: define collections in webconfig-model.xml?

Richard Smith
In reply to this post by Sierra Moxon
You can only configure attributes and attributes of referenced objects
where there is one referenced object, not collections.

The display of collections would be difficult an unpredictable as we
don't know how many objects will appear in the collection.

Cheers,
Richard.



Sierra Moxon wrote:

> In the keyword search, I'd like Constructs to show up with a collection
> of their CDS's.
> Is there a way to define this in the webconfig-model.xml?
>
>  From the examples, I can't tell if showInInlineCollection does this or
> not; seems like it is used on fields that are single-value (like
> primaryIdentifier), but in all the examples it is set to =false?
>
> Thanks,
> Sierra
>
> _______________________________________________
> dev mailing list
> [hidden email]
> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
>


_______________________________________________
dev mailing list
[hidden email]
http://mail.intermine.org/cgi-bin/mailman/listinfo/dev