empty enrichment widgets box

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

empty enrichment widgets box

Pengcheng Yang

Hi miners,

I have implemented the enrichment widgets months ago. Until now, the enrichment widgets box could be displayed successfully some times on some browsers (Google Chrome and IE), but failed some times. Today, the display totally doesn't work [1]. I have also uploaded the source file onto the github for debugging [2] (https://github.com/pengchy/intermine/tree/master/locustmine). I have also searched the InterMine forum and found two related threads [3,4]. Accordingly, I found some warn information (in red) by pressing Ctrl+Shift+I (in Chrome) [1].

Could any one help me out?

Thank you and best,

Pengcheng

#References

[1] the empty enrichment widgets boxes.

The web page for this screenshot is: http://www.locustmine.org:8080/locustmine/bagDetails.do?scope=all&bagName=Gegg-VS-Segg-down

[2] https://github.com/pengchy/intermine/tree/master/locustmine

[3] http://gmod.827538.n3.nabble.com/Struggling-with-the-GO-term-enrichment-widget-td4043209.html

[4] http://gmod.827538.n3.nabble.com/Chromosome-Distribution-widget-displays-emptybox-td4031175.html







_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: empty enrichment widgets box

Yo Yehudi-2
Hey Pengcheng!

Are you still getting the error? It's working for me now, which suggests it's probably not a problem with your code (unless you've changed something since you sent the mail...) - likely either it was a temporary error or could be related to your location/network? 

If you're still getting it, could it be related to the fact that not all Google services are accessible in China? Many of the widgets are powered by Google Charts, and two of the error on the console screenshot you sent imply that some Google related resources were missing. Could you maybe screenshot the network tab as well? You can show more details about each load failure (assuming there are some) by clicking on it, similar to the screenshot I've attached. 

image.png

Yo



On Tue, 7 Aug 2018 at 03:02, Pengcheng Yang <[hidden email]> wrote:

Hi miners,

I have implemented the enrichment widgets months ago. Until now, the enrichment widgets box could be displayed successfully some times on some browsers (Google Chrome and IE), but failed some times. Today, the display totally doesn't work [1]. I have also uploaded the source file onto the github for debugging [2] (https://github.com/pengchy/intermine/tree/master/locustmine). I have also searched the InterMine forum and found two related threads [3,4]. Accordingly, I found some warn information (in red) by pressing Ctrl+Shift+I (in Chrome) [1].

Could any one help me out?

Thank you and best,

Pengcheng

#References

[1] the empty enrichment widgets boxes.

The web page for this screenshot is: http://www.locustmine.org:8080/locustmine/bagDetails.do?scope=all&bagName=Gegg-VS-Segg-down

[2] https://github.com/pengchy/intermine/tree/master/locustmine

[3] http://gmod.827538.n3.nabble.com/Struggling-with-the-GO-term-enrichment-widget-td4043209.html

[4] http://gmod.827538.n3.nabble.com/Chromosome-Distribution-widget-displays-emptybox-td4031175.html






_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev

jlfomkfheonbdjoa.png (139K) Download Attachment
jlfomkfheonbdjoa.png (139K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: empty enrichment widgets box

Pengcheng Yang

Hi Yo,

As you suggested, it is possible that the "not all Google services are accessible in China" produced this problem. Because the proxy used in the Google Chrome didn't always work, the widgets displayed now and then.

Now the page can be displayed normally on Chrome, Microsoft Edge, and Firefox, except IE.

Thank you,

Pengcheng




On 2018-8-7 17:04, Yo Yehudi wrote:
Hey Pengcheng!

Are you still getting the error? It's working for me now, which suggests it's probably not a problem with your code (unless you've changed something since you sent the mail...) - likely either it was a temporary error or could be related to your location/network? 

If you're still getting it, could it be related to the fact that not all Google services are accessible in China? Many of the widgets are powered by Google Charts, and two of the error on the console screenshot you sent imply that some Google related resources were missing. Could you maybe screenshot the network tab as well? You can show more details about each load failure (assuming there are some) by clicking on it, similar to the screenshot I've attached. 



Yo



On Tue, 7 Aug 2018 at 03:02, Pengcheng Yang <[hidden email]> wrote:

Hi miners,

I have implemented the enrichment widgets months ago. Until now, the enrichment widgets box could be displayed successfully some times on some browsers (Google Chrome and IE), but failed some times. Today, the display totally doesn't work [1]. I have also uploaded the source file onto the github for debugging [2] (https://github.com/pengchy/intermine/tree/master/locustmine). I have also searched the InterMine forum and found two related threads [3,4]. Accordingly, I found some warn information (in red) by pressing Ctrl+Shift+I (in Chrome) [1].

Could any one help me out?

Thank you and best,

Pengcheng

#References

[1] the empty enrichment widgets boxes.

The web page for this screenshot is: http://www.locustmine.org:8080/locustmine/bagDetails.do?scope=all&bagName=Gegg-VS-Segg-down

[2] https://github.com/pengchy/intermine/tree/master/locustmine

[3] http://gmod.827538.n3.nabble.com/Struggling-with-the-GO-term-enrichment-widget-td4043209.html

[4] http://gmod.827538.n3.nabble.com/Chromosome-Distribution-widget-displays-emptybox-td4031175.html






_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev


_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: empty enrichment widgets box

Pengcheng Yang

Hi all,

The empty-enrichment-widgets-box problem has the following update:

1. In my computer, the enrichment widgets worked quite well using Google Chrome, microsoft Edge and fireforx. However, this doesn't work on almost all other computers using all browsers.

2. After inspecting the webpage on Chrome [1], the error information said that 1) "Failed to load resource: ERR_CONNECTION_TIMED_OUT" and 2) "Uncaught ReferencedError: google is not defined" may be the cause of the problem.

3. After inspecting the webpage on Microsoft Edge browser, the similar error information also be displayed [2]

4. I have googled the "ERR_CONNECTION_TIMED_OUT" error, and found this webpage (https://whatsabyte.com/windows/err_connection_timed_out/) and followed the instructions, but the widgets box still be empty.

5. Some additional information on my test: 1) All the tested computer and mine are located within the same local area network. 2) all the visited websites are the same.

Thank you!

Pengcheng Yang

[1] error information from inspecting the enrichment webpage on Chrome.


[2]error information from inspecting the enrichment webpage on microsoft Edge.



On 2018-8-7 17:34, Pengcheng Yang wrote:

Hi Yo,

As you suggested, it is possible that the "not all Google services are accessible in China" produced this problem. Because the proxy used in the Google Chrome didn't always work, the widgets displayed now and then.

Now the page can be displayed normally on Chrome, Microsoft Edge, and Firefox, except IE.

Thank you,

Pengcheng




On 2018-8-7 17:04, Yo Yehudi wrote:
Hey Pengcheng!

Are you still getting the error? It's working for me now, which suggests it's probably not a problem with your code (unless you've changed something since you sent the mail...) - likely either it was a temporary error or could be related to your location/network? 

If you're still getting it, could it be related to the fact that not all Google services are accessible in China? Many of the widgets are powered by Google Charts, and two of the error on the console screenshot you sent imply that some Google related resources were missing. Could you maybe screenshot the network tab as well? You can show more details about each load failure (assuming there are some) by clicking on it, similar to the screenshot I've attached. 



Yo



On Tue, 7 Aug 2018 at 03:02, Pengcheng Yang <[hidden email]> wrote:

Hi miners,

I have implemented the enrichment widgets months ago. Until now, the enrichment widgets box could be displayed successfully some times on some browsers (Google Chrome and IE), but failed some times. Today, the display totally doesn't work [1]. I have also uploaded the source file onto the github for debugging [2] (https://github.com/pengchy/intermine/tree/master/locustmine). I have also searched the InterMine forum and found two related threads [3,4]. Accordingly, I found some warn information (in red) by pressing Ctrl+Shift+I (in Chrome) [1].

Could any one help me out?

Thank you and best,

Pengcheng

#References

[1] the empty enrichment widgets boxes.

The web page for this screenshot is: http://www.locustmine.org:8080/locustmine/bagDetails.do?scope=all&bagName=Gegg-VS-Segg-down

[2] https://github.com/pengchy/intermine/tree/master/locustmine

[3] http://gmod.827538.n3.nabble.com/Struggling-with-the-GO-term-enrichment-widget-td4043209.html

[4] http://gmod.827538.n3.nabble.com/Chromosome-Distribution-widget-displays-emptybox-td4031175.html






_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev



_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev


_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: empty enrichment widgets box

Julie Sullivan-2
Hi Pengcheng!

How did you get around the Google issue that Yo mentioned? These widgets
show up for me correctly:

http://www.locustmine.org:8080/locustmine/bagDetails.do?scope=all&bagName=Gegg-VS-Segg-down

Is that the right site?

Looking at the screenshots, it does say that google is not defined --
further evidence that this is the issue. Do you agree?

Julie

On 13/11/2018 08:55, Pengcheng Yang wrote:

> Hi all,
>
> The empty-enrichment-widgets-box problem has the following update:
>
> 1. In my computer, the enrichment widgets worked quite well using Google
> Chrome, microsoft Edge and fireforx. However, this doesn't work on
> almost all other computers using all browsers.
>
> 2. After inspecting the webpage on Chrome [1], the error information
> said that 1) "Failed to load resource: ERR_CONNECTION_TIMED_OUT" and 2)
> "Uncaught ReferencedError: google is not defined" may be the cause of
> the problem.
>
> 3. After inspecting the webpage on Microsoft Edge browser, the similar
> error information also be displayed [2]
>
> 4. I have googled the "ERR_CONNECTION_TIMED_OUT" error, and found this
> webpage (https://whatsabyte.com/windows/err_connection_timed_out/) and
> followed the instructions, but the widgets box still be empty.
>
> 5. Some additional information on my test: 1) All the tested computer
> and mine are located within the same local area network. 2) all the
> visited websites are the same.
>
> Thank you!
>
> Pengcheng Yang
>
> [1] error information from inspecting the enrichment webpage on Chrome.
>
>
> [2]error information from inspecting the enrichment webpage on microsoft
> Edge.
>
>
>
> On 2018-8-7 17:34, Pengcheng Yang wrote:
>>
>> Hi Yo,
>>
>> As you suggested, it is possible that the "not all Google services are
>> accessible in China" produced this problem. Because the proxy used in
>> the Google Chrome didn't always work, the widgets displayed now and then.
>>
>> Now the page can be displayed normally on Chrome, Microsoft Edge, and
>> Firefox, except IE.
>>
>> Thank you,
>>
>> Pengcheng
>>
>>
>>
>>
>> On 2018-8-7 17:04, Yo Yehudi wrote:
>>> Hey Pengcheng!
>>>
>>> Are you still getting the error? It's working for me now, which
>>> suggests it's probably not a problem with your code (unless you've
>>> changed something since you sent the mail...) - likely either it was
>>> a temporary error or could be related to your location/network?
>>>
>>> If you're still getting it, could it be related to the fact that not
>>> all Google services are accessible in China? Many of the widgets are
>>> powered by Google Charts, and two of the error on the console
>>> screenshot you sent imply that some Google related resources were
>>> missing. Could you maybe screenshot the network tab as well? You can
>>> show more details about each load failure (assuming there are some)
>>> by clicking on it, similar to the screenshot I've attached.
>>>
>>>
>>>
>>> Yo
>>>
>>>
>>>
>>> On Tue, 7 Aug 2018 at 03:02, Pengcheng Yang <[hidden email]
>>> <mailto:[hidden email]>> wrote:
>>>
>>>     Hi miners,
>>>
>>>     I have implemented the enrichment widgets months ago. Until now,
>>>     the enrichment widgets box could be displayed successfully some
>>>     times on some browsers (Google Chrome and IE), but failed some
>>>     times. Today, the display totally doesn't work [1]. I have also
>>>     uploaded the source file onto the github for debugging [2]
>>>     (https://github.com/pengchy/intermine/tree/master/locustmine). I
>>>     have also searched the InterMine forum and found two related
>>>     threads [3,4]. Accordingly, I found some warn information (in
>>>     red) by pressing Ctrl+Shift+I (in Chrome) [1].
>>>
>>>     Could any one help me out?
>>>
>>>     Thank you and best,
>>>
>>>     Pengcheng
>>>
>>>     *#References*
>>>
>>>     [1] the empty enrichment widgets boxes.
>>>
>>>     The web page for this screenshot is:
>>>     http://www.locustmine.org:8080/locustmine/bagDetails.do?scope=all&bagName=Gegg-VS-Segg-down
>>>
>>>     [2] https://github.com/pengchy/intermine/tree/master/locustmine
>>>
>>>     [3]
>>>     http://gmod.827538.n3.nabble.com/Struggling-with-the-GO-term-enrichment-widget-td4043209.html
>>>
>>>     [4]
>>>     http://gmod.827538.n3.nabble.com/Chromosome-Distribution-widget-displays-emptybox-td4031175.html
>>>
>>>
>>>
>>>
>>>
>>>
>>>     _______________________________________________
>>>     dev mailing list
>>>     [hidden email] <mailto:[hidden email]>
>>>     https://lists.intermine.org/mailman/listinfo/dev
>>>
>>
>>
>>
>> _______________________________________________
>> dev mailing list
>> [hidden email]
>> https://lists.intermine.org/mailman/listinfo/dev
>
>
> _______________________________________________
> dev mailing list
> [hidden email]
> https://lists.intermine.org/mailman/listinfo/dev
>
_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: empty enrichment widgets box

Pengcheng Yang
Hi Julie,

It turned out that this is caused by the blocking of Google service here
in China. One solution is to install the extension "assistant for Google
service" (http://www.ggfwzs.com/) on Chrome and some other browsers
developed in China. The tutorial on how to use the "谷歌访问助手" is
detailed on the webpage (http://www.ggfwzs.com/).

Thank you Julie.

Best,

Pengcheng


On 2018-11-13 17:17, Julie Sullivan wrote:

> Hi Pengcheng!
>
> How did you get around the Google issue that Yo mentioned? These
> widgets show up for me correctly:
>
> http://www.locustmine.org:8080/locustmine/bagDetails.do?scope=all&bagName=Gegg-VS-Segg-down 
>
>
> Is that the right site?
>
> Looking at the screenshots, it does say that google is not defined --
> further evidence that this is the issue. Do you agree?
>
> Julie
>
> On 13/11/2018 08:55, Pengcheng Yang wrote:
>> Hi all,
>>
>> The empty-enrichment-widgets-box problem has the following update:
>>
>> 1. In my computer, the enrichment widgets worked quite well using
>> Google Chrome, microsoft Edge and fireforx. However, this doesn't
>> work on almost all other computers using all browsers.
>>
>> 2. After inspecting the webpage on Chrome [1], the error information
>> said that 1) "Failed to load resource: ERR_CONNECTION_TIMED_OUT" and
>> 2) "Uncaught ReferencedError: google is not defined" may be the cause
>> of the problem.
>>
>> 3. After inspecting the webpage on Microsoft Edge browser, the
>> similar error information also be displayed [2]
>>
>> 4. I have googled the "ERR_CONNECTION_TIMED_OUT" error, and found
>> this webpage
>> (https://whatsabyte.com/windows/err_connection_timed_out/) and
>> followed the instructions, but the widgets box still be empty.
>>
>> 5. Some additional information on my test: 1) All the tested computer
>> and mine are located within the same local area network. 2) all the
>> visited websites are the same.
>>
>> Thank you!
>>
>> Pengcheng Yang
>>
>> [1] error information from inspecting the enrichment webpage on Chrome.
>>
>>
>> [2]error information from inspecting the enrichment webpage on
>> microsoft Edge.
>>
>>
>>
>> On 2018-8-7 17:34, Pengcheng Yang wrote:
>>>
>>> Hi Yo,
>>>
>>> As you suggested, it is possible that the "not all Google services
>>> are accessible in China" produced this problem. Because the proxy
>>> used in the Google Chrome didn't always work, the widgets displayed
>>> now and then.
>>>
>>> Now the page can be displayed normally on Chrome, Microsoft Edge,
>>> and Firefox, except IE.
>>>
>>> Thank you,
>>>
>>> Pengcheng
>>>
>>>
>>>
>>>
>>> On 2018-8-7 17:04, Yo Yehudi wrote:
>>>> Hey Pengcheng!
>>>>
>>>> Are you still getting the error? It's working for me now, which
>>>> suggests it's probably not a problem with your code (unless you've
>>>> changed something since you sent the mail...) - likely either it
>>>> was a temporary error or could be related to your location/network?
>>>>
>>>> If you're still getting it, could it be related to the fact that
>>>> not all Google services are accessible in China? Many of the
>>>> widgets are powered by Google Charts, and two of the error on the
>>>> console screenshot you sent imply that some Google related
>>>> resources were missing. Could you maybe screenshot the network tab
>>>> as well? You can show more details about each load failure
>>>> (assuming there are some) by clicking on it, similar to the
>>>> screenshot I've attached.
>>>>
>>>>
>>>>
>>>> Yo
>>>>
>>>>
>>>>
>>>> On Tue, 7 Aug 2018 at 03:02, Pengcheng Yang <[hidden email]
>>>> <mailto:[hidden email]>> wrote:
>>>>
>>>>     Hi miners,
>>>>
>>>>     I have implemented the enrichment widgets months ago. Until now,
>>>>     the enrichment widgets box could be displayed successfully some
>>>>     times on some browsers (Google Chrome and IE), but failed some
>>>>     times. Today, the display totally doesn't work [1]. I have also
>>>>     uploaded the source file onto the github for debugging [2]
>>>> (https://github.com/pengchy/intermine/tree/master/locustmine). I
>>>>     have also searched the InterMine forum and found two related
>>>>     threads [3,4]. Accordingly, I found some warn information (in
>>>>     red) by pressing Ctrl+Shift+I (in Chrome) [1].
>>>>
>>>>     Could any one help me out?
>>>>
>>>>     Thank you and best,
>>>>
>>>>     Pengcheng
>>>>
>>>>     *#References*
>>>>
>>>>     [1] the empty enrichment widgets boxes.
>>>>
>>>>     The web page for this screenshot is:
>>>> http://www.locustmine.org:8080/locustmine/bagDetails.do?scope=all&bagName=Gegg-VS-Segg-down
>>>>
>>>>     [2] https://github.com/pengchy/intermine/tree/master/locustmine
>>>>
>>>>     [3]
>>>> http://gmod.827538.n3.nabble.com/Struggling-with-the-GO-term-enrichment-widget-td4043209.html
>>>>
>>>>     [4]
>>>> http://gmod.827538.n3.nabble.com/Chromosome-Distribution-widget-displays-emptybox-td4031175.html
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>     _______________________________________________
>>>>     dev mailing list
>>>>     [hidden email] <mailto:[hidden email]>
>>>>     https://lists.intermine.org/mailman/listinfo/dev
>>>>
>>>
>>>
>>>
>>> _______________________________________________
>>> dev mailing list
>>> [hidden email]
>>> https://lists.intermine.org/mailman/listinfo/dev
>>
>>
>> _______________________________________________
>> dev mailing list
>> [hidden email]
>> https://lists.intermine.org/mailman/listinfo/dev
>>
>

_______________________________________________
dev mailing list
[hidden email]
https://lists.intermine.org/mailman/listinfo/dev