error while loading taxonomy

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

error while loading taxonomy

longbow leo
Hi all,

I followed this wiki page, http://gmod.org/wiki/Load_ncbi_taxonomy, to load NCBI taxonomy into Chado database.

According to the documentation of load_ncbi_taxonomy.pl, I run "load_taxonomy_cvterms.pl" first:

load_taxonomy_cvterms.pl -H localhost -D chado -t

After inputed the database name and password, I encountered this error message:

CXGN::Configuration: None of the requested configuration files were found.
Can't call method "get_conf" on an undefined value at /usr/local/share/perl/5.10.1/CXGN/VHost.pm line 405, <STDIN> line 2.

I have read the CXGN::Configuration manpage (http://csurs7.csr.uky.edu/cgi-bin/man/man2html?CXGN::Configuration+3#lbAB), but what configuration I have to give here? Or how to run load_ncbi_taxonomy.pl correctly?

Thanks!


Sincerely,


Haizhou Liu



------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
Gmod-schema mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-schema
Reply | Threaded
Open this post in threaded view
|

Re: error while loading taxonomy

Naama Menda
hi Haizhou Liu,

please try to update your svn repository and run the script again.
The CXGN dependency should not be there.
I just committed a fix.

Let me know if it works for you now.

Thanks,
-Naama


Naama Menda
Boyce Thompson Institute for Plant Research
Tower Rd
Ithaca NY 14853
USA

(607) 254 3569
Sol Genomics Network
http://solgenomics.net/
[hidden email]


On Tue, Jun 29, 2010 at 9:07 AM, longbow leo <[hidden email]> wrote:
Hi all,

I followed this wiki page, http://gmod.org/wiki/Load_ncbi_taxonomy, to load NCBI taxonomy into Chado database.

According to the documentation of load_ncbi_taxonomy.pl, I run "load_taxonomy_cvterms.pl" first:

load_taxonomy_cvterms.pl -H localhost -D chado -t

After inputed the database name and password, I encountered this error message:

CXGN::Configuration: None of the requested configuration files were found.
Can't call method "get_conf" on an undefined value at /usr/local/share/perl/5.10.1/CXGN/VHost.pm line 405, <STDIN> line 2.

I have read the CXGN::Configuration manpage (http://csurs7.csr.uky.edu/cgi-bin/man/man2html?CXGN::Configuration+3#lbAB), but what configuration I have to give here? Or how to run load_ncbi_taxonomy.pl correctly?

Thanks!


Sincerely,


Haizhou Liu



------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
Gmod-schema mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-schema



------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
Gmod-schema mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-schema