error with protein blast

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

error with protein blast

Sofia Robb
I have a weird problem. when I run blastp the db is reported correctly when printed below "Calling" and the "Executing blastp" but the db used in the command (Executing the following BLAST command) is incorrect. pep is missing from the run command.

Calling: run_BLAST_tripal_job(blastp, /tmp/2016Nov28_135901_query.fasta, /var/other_data/organisms/zebrafish/Drer/transcriptomes/Danio_rerio.GRCz10.86/Danio_rerio.GRCz10.pep.all.fa, sites/default/files/tripal/tripal_blast/2016Nov28_135901.blast, Array, 353)

Executing blastp

Query: /tmp/2016Nov28_135901_query.fasta
Database: /var/other_data/organisms/zebrafish/Drer/transcriptomes/Danio_rerio.GRCz10.86/Danio_rerio.GRCz10.pep.all.fa
Results File: sites/default/files/tripal/tripal_blast/2016Nov28_135901.blast.asn
Options:
evalue: 0.001
word_size: 3
gapopen: 7
gapextend: 2
matrix: PAM30

Executing the following BLAST command:
'/usr/bin/blastp' -query '/tmp/2016Nov28_135901_query.fasta' -db '/var/other_data/organisms/zebrafish/Drer/transcriptomes/Danio_rerio.GRCz10.86/Danio_rerio.GRCz10.all.fa' -out 'sites/default/files/tripal/tripal_blast/2016Nov28_135901.blast.asn' -outfmt=11 -'evalue' '0.001' -'word_size' '3' -'gapopen' '7' -'gapextend' '2' -'matrix' 'PAM30' -num_threads '1'
BLAST Database error: No alias or index file found for protein database [/var/other_data/organisms/zebrafish/Drer/transcriptomes/Danio_rerio.GRCz10.86/Danio_rerio.GRCz10.all.fa] in search path [/var/www/html::]

------------------------------------------------------------------------------

_______________________________________________
Gmod-tripal mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-tripal
Reply | Threaded
Open this post in threaded view
|

Re: error with protein blast

Kucheran, Lacey Sanderson
Hi Sofia,

Could you try changing the regex on that line to "/(.*)\.[pn]\w\w/$” and tell me if it fixes it?

~Lacey

------------------------------------------------------
Lacey-Anne Sanderson
Bioinformaticist
Pulse Crop Breeding and Genetics
Phone: (306) <a href="tel://966-3208">966-3208
Room 2C33 Agriculture
Department of Plant Sciences
University of Saskatchewan

On November 28, 2016 at 2:05:26 PM, Sofia Robb ([hidden email] ) wrote:

I have a weird problem. when I run blastp the db is reported correctly when printed below "Calling" and the "Executing blastp" but the db used in the command (Executing the following BLAST command) is incorrect. pep is missing from the run command.

Calling : run_BLAST_tripal_job(blastp, /tmp/2016Nov28_135901_query.fasta, /var/other_data/organisms/zebrafish/Drer/transcriptomes/Danio_rerio.GRCz10.86/Danio_rerio.GRCz10.pep.all.fa , sites/default/files/tripal/tripal_blast/2016Nov28_135901.blast, Array, 353)

Executing blastp

Query: /tmp/2016Nov28_135901_query.fasta
Database: /var/other_data/organisms/zebrafish/Drer/transcriptomes/Danio_rerio.GRCz10.86/Danio_rerio.GRCz10.pep .all.fa
Results File: sites/default/files/tripal/tripal_blast/2016Nov28_135901.blast.asn
Options:
evalue: 0.001
word_size: 3
gapopen: 7
gapextend: 2
matrix: PAM30

Executing the following BLAST command:
'/usr/bin/blastp' -query '/tmp/2016Nov28_135901_query.fasta' -db '/var/other_data/organisms/zebrafish/Drer/transcriptomes/Danio_rerio.GRCz10.86/Danio_rerio.GRCz10.all.fa ' -out 'sites/default/files/tripal/tripal_blast/2016Nov28_135901.blast.asn' -outfmt=11 -'evalue' '0.001' -'word_size' '3' -'gapopen' '7' -'gapextend' '2' -'matrix' 'PAM30' -num_threads '1'
BLAST Database error: No alias or index file found for protein database [/var/other_data/organisms/zebrafish/Drer/transcriptomes/Danio_rerio.GRCz10.86/Danio_rerio.GRCz10.all.fa ] in search path [/var/www/html::]
------------------------------------------------------------------------------
_______________________________________________
Gmod-tripal mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-tripal

------------------------------------------------------------------------------

_______________________________________________
Gmod-tripal mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-tripal
Reply | Threaded
Open this post in threaded view
|

Re: error with protein blast

Sofia Robb
Thanks!! Yes, that worked! You have a typo in your fix 

"/(.*)\.[pn]\w\w/$”

should have the / after the $

"/(.*)\.[pn]\w\w$/”

On Mon, Nov 28, 2016 at 1:31 PM, Kucheran, Lacey Sanderson <[hidden email]> wrote:
Hi Sofia,

Could you try changing the regex on that line to "/(.*)\.[pn]\w\w/$” and tell me if it fixes it?

~Lacey

------------------------------------------------------
Lacey-Anne Sanderson
Bioinformaticist
Pulse Crop Breeding and Genetics
Phone: (306) <a href="tel://966-3208" target="_blank">966-3208
Room 2C33 Agriculture
Department of Plant Sciences
University of Saskatchewan

On November 28, 2016 at 2:05:26 PM, Sofia Robb ([hidden email] ) wrote:

I have a weird problem. when I run blastp the db is reported correctly when printed below "Calling" and the "Executing blastp" but the db used in the command (Executing the following BLAST command) is incorrect. pep is missing from the run command.

Calling : run_BLAST_tripal_job(blastp, /tmp/2016Nov28_135901_query.fasta, /var/other_data/organisms/zebrafish/Drer/transcriptomes/Danio_rerio.GRCz10.86/Danio_rerio.GRCz10.pep.all.fa , sites/default/files/tripal/tripal_blast/2016Nov28_135901.blast, Array, 353)

Executing blastp

Query: /tmp/2016Nov28_135901_query.fasta
Database: /var/other_data/organisms/zebrafish/Drer/transcriptomes/Danio_rerio.GRCz10.86/Danio_rerio.GRCz10.pep .all.fa
Results File: sites/default/files/tripal/tripal_blast/2016Nov28_135901.blast.asn
Options:
evalue: 0.001
word_size: 3
gapopen: 7
gapextend: 2
matrix: PAM30

Executing the following BLAST command:
'/usr/bin/blastp' -query '/tmp/2016Nov28_135901_query.fasta' -db '/var/other_data/organisms/zebrafish/Drer/transcriptomes/Danio_rerio.GRCz10.86/Danio_rerio.GRCz10.all.fa ' -out 'sites/default/files/tripal/tripal_blast/2016Nov28_135901.blast.asn' -outfmt=11 -'evalue' '0.001' -'word_size' '3' -'gapopen' '7' -'gapextend' '2' -'matrix' 'PAM30' -num_threads '1'
BLAST Database error: No alias or index file found for protein database [/var/other_data/organisms/zebrafish/Drer/transcriptomes/Danio_rerio.GRCz10.86/Danio_rerio.GRCz10.all.fa ] in search path [/var/www/html::]
------------------------------------------------------------------------------
_______________________________________________
Gmod-tripal mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-tripal


------------------------------------------------------------------------------

_______________________________________________
Gmod-tripal mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-tripal
Reply | Threaded
Open this post in threaded view
|

Re: error with protein blast

Kucheran, Lacey Sanderson
Awesome :-) I’ve made the fix on github so this issue doesn’t pop-up again :-)

Good catch!
~Lacey

------------------------------------------------------
Lacey-Anne Sanderson
Bioinformaticist
Pulse Crop Breeding and Genetics
Phone: (306) <a href="tel://966-3208">966-3208
Room 2C33 Agriculture
Department of Plant Sciences
University of Saskatchewan

On November 28, 2016 at 2:49:59 PM, Sofia Robb ([hidden email]) wrote:

Thanks!! Yes, that worked! You have a typo in your fix 

"/(.*)\.[pn]\w\w/$”

should have the / after the $

"/(.*)\.[pn]\w\w$/”

On Mon, Nov 28, 2016 at 1:31 PM, Kucheran, Lacey Sanderson <[hidden email]> wrote:
Hi Sofia,

Could you try changing the regex on that line to "/(.*)\.[pn]\w\w/$” and tell me if it fixes it?

~Lacey

------------------------------------------------------
Lacey-Anne Sanderson
Bioinformaticist
Pulse Crop Breeding and Genetics
Phone: (306) <a href="tel://966-3208" target="_blank">966-3208
Room 2C33 Agriculture
Department of Plant Sciences
University of Saskatchewan

On November 28, 2016 at 2:05:26 PM, Sofia Robb ([hidden email] ) wrote:

I have a weird problem. when I run blastp the db is reported correctly when printed below "Calling" and the "Executing blastp" but the db used in the command (Executing the following BLAST command) is incorrect. pep is missing from the run command.

Calling : run_BLAST_tripal_job(blastp, /tmp/2016Nov28_135901_query.fasta, /var/other_data/organisms/zebrafish/Drer/transcriptomes/Danio_rerio.GRCz10.86/Danio_rerio.GRCz10.pep.all.fa , sites/default/files/tripal/tripal_blast/2016Nov28_135901.blast, Array, 353)

Executing blastp

Query: /tmp/2016Nov28_135901_query.fasta
Database: /var/other_data/organisms/zebrafish/Drer/transcriptomes/Danio_rerio.GRCz10.86/Danio_rerio.GRCz10.pep .all.fa
Results File: sites/default/files/tripal/tripal_blast/2016Nov28_135901.blast.asn
Options:
evalue: 0.001
word_size: 3
gapopen: 7
gapextend: 2
matrix: PAM30

Executing the following BLAST command:
'/usr/bin/blastp' -query '/tmp/2016Nov28_135901_query.fasta' -db '/var/other_data/organisms/zebrafish/Drer/transcriptomes/Danio_rerio.GRCz10.86/Danio_rerio.GRCz10.all.fa ' -out 'sites/default/files/tripal/tripal_blast/2016Nov28_135901.blast.asn' -outfmt=11 -'evalue' '0.001' -'word_size' '3' -'gapopen' '7' -'gapextend' '2' -'matrix' 'PAM30' -num_threads '1'
BLAST Database error: No alias or index file found for protein database [/var/other_data/organisms/zebrafish/Drer/transcriptomes/Danio_rerio.GRCz10.86/Danio_rerio.GRCz10.all.fa ] in search path [/var/www/html::]
------------------------------------------------------------------------------
_______________________________________________
Gmod-tripal mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-tripal


------------------------------------------------------------------------------

_______________________________________________
Gmod-tripal mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-tripal