[galaxy-dev] Enabling bigWig for galaxy

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[galaxy-dev] Enabling bigWig for galaxy

Davide Cittaro
Dear all, 
I'm trying to enable bigwig support in Galaxy. Besides the sniff section which is probably not working, I'm trying to enable at least the visualization on a UCSC mirror. I see that galaxy link to display includes this hgt.customText


which contains the track definition:

track type=bigWig name="Pu1_100219.bw" bigDataUrl=http://host001.instruments.ifom-ieo-campus.it:8080/display_application/e00d4fc8bba8b6c5/ucsc_bigWig/campus/a3e0990f3de110b5/data/galaxy_e00d4fc8bba8b6c5.bw db=hg18

Unfortunately the genome browser (a local mirror) says:


I've tried to fetch the bigwig file in bigDataUrl link with wget and I'm able to reach it.
Needless to say, the bigwig file is a proper one, I've tried to load it from another location and it can be displayed.
At this point I don't know how to debug it... 
@UCSC people: when am I supposed to get that error? Which conditions raise it?
@Galaxy people: since the link is valid, why I cannot present it to UCSC?

Thanks



/*
Davide Cittaro

Cogentech - Consortium for Genomic Technologies
via adamello, 16
20139 Milano
Italy

tel.: +39(02)574303007
*/




_______________________________________________
galaxy-dev mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-dev