gbrowse2 global instillation problem with inkscape

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

gbrowse2 global instillation problem with inkscape

Nikhat Zafar

Hi ,

We are trying to install gbrowse2 globalyy on our network, but are
running into issues which are stated below. The messages are given to me
by our IT people. Does anybody else ran into the same problem or does
anybody knows solution to this. Basically problem we are having is with
inkscape instillation. Any suggestion would be greatly appreciated.




The problem as things stand now...

inkscape build requires gtkmm
gtkmm build requires gtk+
gtk+ build requires pango/pangocairo.h -- which cannot be found

Question:  How to build/obtain pangocairo.h???


================================================================================

Packages installed in /usr/local/packages on speedy (64-bit rhel 5)
================================================================================


gc-7.0
gc -> gc-7.0

lcms -> lcms-1.19
lcms-1.19

poppler -> poppler-0.13.3
poppler-0.13.3

----------------------------------------

libsigc++-2.2.6
libsigc++ -> libsigc++-2.2.6

glibmm -> glibmm-2.24.1
glibmm-2.24.1

gsl -> gsl-1.14
gsl-1.14

glib -> glib-2.24.0
glib-2.24.0

----------------------------------------

atk -> atk-1.30.0
atk-1.30.0

pango -> pango-1.28.0
pango-1.28.0

cairomm -> cairomm-1.8.4
cairomm-1.8.4

cairo -> cairo-1.8.10
cairo-1.8.10

pixman -> pixman-1.18.0
pixman-1.18.0

================================================================================

Inkscape configure/build/installation steps
================================================================================


[root@speedy inkscape-0.47]# ./configure
--prefix=/usr/local/packages/inkscape-0.47
...
checking gc.h usability... no
checking gc.h presence... no
checking for gc.h... no
checking gc/gc.h usability... no
checking gc/gc.h presence... no
checking for gc/gc.h... no
configure: error: libgc (the Boehm Conservative Collector) 6.4+, is
needed to compile inkscape -- http://www.hpl.hp.com/personal/Hans_Boehm/gc

export PKG_CONFIG_PATH=/usr/local/packages/gc/lib/pkgconfig
# appears that pkgconfig not honored for gc
(/usr/local/packages/gc/lib/pkgconfig).  So...
unset PKG_CONFIG_PATH

export LDFLAGS=-L/usr/local/packages/gc/lib
export CPPFLAGS=-I/usr/local/packages/gc/include

works!

--------------------------------------------------------------------------------

LCMS:

checking for LCMS... no
configure: error: --enable-lcms was specified, but appropriate LittleCms
development packages could not be found

export PKG_CONFIG_PATH=/usr/local/packages/lcms/lib/pkgconfig

works!

export CPPFLAGS=-I/usr/local/packages/lcms/include
export LDFLAGS=-L/usr/local/packages/lcms/lib

works!

/configure --prefix=/usr/local/packages/inkscape-0.47

checking for LCMS... yes
checking for POPPLER... no
checking for POPPLERNEW... no
checking for LIBWPG... no
checking for IMAGEMAGICK... no
checking for CAIRO_USER_FONTS... no
checking for INKSCAPE... configure: error: Package requirements
(gdkmm-2.4  glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0  gtk+-2.0  
libxml-2.0 >= 2.6.11  libxslt >= 1.0.15  cairo  sigc++-2.0 >= 2.0.12    
gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:

No package 'gdkmm-2.4' found
No package 'glibmm-2.4' found
No package 'giomm-2.4' found
No package 'gtkmm-2.4' found
No package 'sigc++-2.0' found
No package 'gsl' found

--------------------------------------------------------------------------------

POPPLER:

checking for POPPLER... no

export PKG_CONFIG_PATH=/usr/local/packages/lcms/lib/pkgconfig:
                       /usr/local/packages/poppler/lib/pkgconfig

works!

export POPPLER_CFLAGS=-I/usr/local/packages/poppler/include/poppler
export POPPLER_LIBS=-L/usr/local/packages/poppler/lib

doesn't work :(

./configure --prefix=/usr/local/packages/inkscape-0.47

checking for LCMS... yes
checking for POPPLER... yes
checking for POPPLER_GLIB... no
checking for POPPLER_CAIRO... no
checking for POPPLERNEW... yes
checking for LIBWPG... no
checking for IMAGEMAGICK... no
checking for CAIRO_USER_FONTS... no
checking for INKSCAPE... configure: error: Package requirements
(gdkmm-2.4  glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0  gtk+-2.0  
libxml-2.0 >= 2.6.11  libxslt >= 1.0.15  cairo  sigc++-2.0 >= 2.0.12    
gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:

No package 'gdkmm-2.4' found
No package 'glibmm-2.4' found
No package 'giomm-2.4' found
No package 'gtkmm-2.4' found
No package 'sigc++-2.0' found
No package 'gsl' found

--------------------------------------------------------------------------------

IMAGEMAGICK:

checking for IMAGEMAGICK... no

export PKG_CONFIG_PATH=/usr/local/packages/lcms/lib/pkgconfig:
                       /usr/local/packages/poppler/lib/pkgconfig:
                       /usr/local/packages/ImageMagick/lib/pkgconfig

works!

./configure --prefix=/usr/local/packages/inkscape-0.47

checking for LCMS... yes
checking for POPPLER... yes
checking for POPPLER_GLIB... no
checking for POPPLER_CAIRO... no
checking for POPPLERNEW... yes
checking for LIBWPG... no
checking for IMAGEMAGICK... yes
checking for CAIRO_USER_FONTS... no
checking for INKSCAPE... configure: error: Package requirements
(gdkmm-2.4  glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0  gtk+-2.0  
libxml-2.0 >= 2.6.11  libxslt >= 1.0.15  cairo  sigc++-2.0 >= 2.0.12    
gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:

No package 'gdkmm-2.4' found
No package 'glibmm-2.4' found
No package 'giomm-2.4' found
No package 'gtkmm-2.4' found
No package 'sigc++-2.0' found
No package 'gsl' found

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------

LIBSIGC++:

export PKG_CONFIG_PATH=/usr/local/packages/lcms/lib/pkgconfig:
                       /usr/local/packages/poppler/lib/pkgconfig:
                       /usr/local/packages/ImageMagick/lib/pkgconfig
                       /usr/local/packages/libsigc++/lib/pkgconfig

./configure --prefix=/usr/local/packages/inkscape-0.47

works!

checking for INKSCAPE... configure: error: Package requirements
(gdkmm-2.4  glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0  gtk+-2.0  
libxml-2.0 >= 2.6.11  libxslt >= 1.0.15  cairo  sigc++-2.0 >= 2.0.12    
gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:

No package 'gdkmm-2.4' found
No package 'glibmm-2.4' found
No package 'giomm-2.4' found
No package 'gtkmm-2.4' found
No package 'gsl' found

--------------------------------------------------------------------------------

GLIBMM:

export PKG_CONFIG_PATH=/usr/local/packages/lcms/lib/pkgconfig:
                       /usr/local/packages/poppler/lib/pkgconfig:
                       /usr/local/packages/ImageMagick/lib/pkgconfig:
                       /usr/local/packages/libsigc++/lib/pkgconfig:
                       /usr/local/packages/glibmm/lib/pkgconfig

works!

./configure --prefix=/usr/local/packages/inkscape-0.47

checking for INKSCAPE... configure: error: Package requirements
(gdkmm-2.4  glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0  gtk+-2.0  
libxml-2.0 >= 2.6.11  libxslt >= 1.0.15  cairo  sigc++-2.0 >= 2.0.12    
gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:

No package 'gdkmm-2.4' found
Package gio-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gio-2.0.pc'
to the PKG_CONFIG_PATH environment variable
Package 'gio-2.0', required by 'giomm', not found

--------------------------------------------------------------------------------

GIO:

export PKG_CONFIG_PATH=/usr/local/packages/lcms/lib/pkgconfig:
                       /usr/local/packages/poppler/lib/pkgconfig:
                       /usr/local/packages/ImageMagick/lib/pkgconfig:
                       /usr/local/packages/libsigc++/lib/pkgconfig:
                       /usr/local/packages/glibmm/lib/pkgconfig:
                       /usr/local/packages/glib/lib/pkgconfig

works!

./configure --prefix=/usr/local/packages/inkscape-0.47

checking for INKSCAPE... configure: error: Package requirements
(gdkmm-2.4  glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0  gtk+-2.0  
libxml-2.0 >= 2.6.11  libxslt >= 1.0.15  cairo  sigc++-2.0 >= 2.0.12    
gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:

No package 'gdkmm-2.4' found
No package 'gtkmm-2.4' found
No package 'gsl' found

--------------------------------------------------------------------------------

GSL

export PKG_CONFIG_PATH=/usr/local/packages/lcms/lib/pkgconfig:
                       /usr/local/packages/poppler/lib/pkgconfig:
                       /usr/local/packages/ImageMagick/lib/pkgconfig:
                       /usr/local/packages/libsigc++/lib/pkgconfig:
                       /usr/local/packages/glibmm/lib/pkgconfig:
                       /usr/local/packages/glib/lib/pkgconfig
                       /usr/local/packages/gsl/lib/pkgconfig
works!

./configure --prefix=/usr/local/packages/inkscape-0.47

checking for INKSCAPE... configure: error: Package requirements
(gdkmm-2.4  glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0  gtk+-2.0  
libxml-2.0 >= 2.6.11  libxslt >= 1.0.15  cairo  sigc++-2.0 >= 2.0.12    
gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:

No package 'gdkmm-2.4' found
No package 'gtkmm-2.4' found

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------

GTKMM:

./configure --prefix=/usr/local/packages/gtkmm-2.20.2

checking for ATKMM... yes
checking for GDKMM... configure: error: Package requirements (giomm-2.4
 >= 2.24 pangomm-1.4 >= 2.26 gtk+-2.0 >= 2.20.0) were not met:

No package 'pangomm-1.4' found
Requested 'gtk+-2.0 >= 2.20.0' but version of GTK+ is 2.10.4



--------------------------------------------------------------------------------

GTK+

./configure --prefix=/usr/local/packages/gtk+-2.18.9

checking for BASE_DEPENDENCIES... configure: error: Package requirements
(glib-2.0 >= 2.21.3    atk >= 1.13.0    pango >= 1.20    cairo >= 1.6)
were not met:

Requested 'glib-2.0 >= 2.21.3' but version of GLib is 2.12.3
Requested 'atk >= 1.13.0' but version of Atk is 1.12.2
Requested 'pango >= 1.20' but version of Pango is 1.14.9
Requested 'cairo >= 1.6' but version of cairo is 1.2.4

2)

export
PKG_CONFIG_PATH=/usr/local/packages/glib/lib/pkgconfig:/usr/local/packages/atk/lib/pkgconfig:/usr/local/packages/pango/lib/pkgconfig:/usr/local/packages/cairo/lib/pkgconfig


./configure --prefix=/usr/local/packages/gtk+-2.18.9

checking for BASE_DEPENDENCIES... configure: error: Package requirements
(glib-2.0 >= 2.21.3    atk >= 1.13.0    pango >= 1.20    cairo >= 1.6)
were not met:

Package pixman-1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `pixman-1.pc'
to the PKG_CONFIG_PATH environment variable
Package 'pixman-1', required by 'cairo', not found

3)

export
PKG_CONFIG_PATH=/usr/local/packages/glib/lib/pkgconfig:/usr/local/packages/atk/lib/pkgconfig:/usr/local/packages/pango/lib/pkgconfig:/usr/local/packages/cairo/lib/pkgconfig:/usr/local/packages/pixman/lib/pkgconfig


./configure --prefix=/usr/local/packages/gtk+-2.18.9

4)

CPPFLAGS=-I/usr/local/packages/glib/include
LDFLAGS=-L/usr/local/packages/glib/lib

./configure --prefix=/usr/local/packages/gtk+-2.18.9

5)

LD_LIBRARY_PATH=/usr/local/packages/glib/lib

./configure --prefix=/usr/local/packages/gtk+-2.18.9

works!

make

make[4]: Entering directory
`/local/src/gtk+/gtk+-2.18.9/rhel5x86_64/gtk+-2.18.9/gdk/x11'
/bin/sh ../../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.
-I../.. -DG_LOG_DOMAIN=\"Gdk\" -DGDK_COMPILATION -I../.. -I../../gdk
-I../../gdk -DG_DISABLE_CAST_CHECKS -pthread
-I/usr/local/packages/glib-2.24.0/include/glib-2.0
-I/usr/local/packages/glib-2.24.0/lib/glib-2.0/include
-I/usr/local/packages/pango-1.28.0/include/pango-1.0
-I/usr/local/packages/cairo-1.8.10/include/cairo
-I/usr/local/packages/pixman-1.18.0/include/pixman-1
-I/usr/include/freetype2 -I/usr/include/libpng12      
-I/usr/local/packages/glib/include -DG_DISABLE_SINGLE_INCLUDES
-DATK_DISABLE_SINGLE_INCLUDES -DGDK_PIXBUF_DISABLE_SINGLE_INCLUDES
-DGTK_DISABLE_SINGLE_INCLUDES    -DGDK_PIXBUF_DISABLE_DEPRECATED -g -O2
-Wall -MT gdkapplaunchcontext-x11.lo -MD -MP -MF
.deps/gdkapplaunchcontext-x11.Tpo -c -o gdkapplaunchcontext-x11.lo
gdkapplaunchcontext-x11.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I../..
-DG_LOG_DOMAIN=\"Gdk\" -DGDK_COMPILATION -I../.. -I../../gdk -I../../gdk
-DG_DISABLE_CAST_CHECKS -pthread
-I/usr/local/packages/glib-2.24.0/include/glib-2.0
-I/usr/local/packages/glib-2.24.0/lib/glib-2.0/include
-I/usr/local/packages/pango-1.28.0/include/pango-1.0
-I/usr/local/packages/cairo-1.8.10/include/cairo
-I/usr/local/packages/pixman-1.18.0/include/pixman-1
-I/usr/include/freetype2 -I/usr/include/libpng12
-I/usr/local/packages/glib/include -DG_DISABLE_SINGLE_INCLUDES
-DATK_DISABLE_SINGLE_INCLUDES -DGDK_PIXBUF_DISABLE_SINGLE_INCLUDES
-DGTK_DISABLE_SINGLE_INCLUDES -DGDK_PIXBUF_DISABLE_DEPRECATED -g -O2
-Wall -MT gdkapplaunchcontext-x11.lo -MD -MP -MF
.deps/gdkapplaunchcontext-x11.Tpo -c gdkapplaunchcontext-x11.c  -fPIC
-DPIC -o .libs/gdkapplaunchcontext-x11.o
In file included from ../../gdk/gdk.h:33,
                from ../../gdk/gdkprivate.h:30,
                from gdkx.h:30,
                from gdkapplaunchcontext-x11.c:30:
../../gdk/gdkcairo.h:29:30: error: pango/pangocairo.h: No such file or
directory
make[4]: *** [gdkapplaunchcontext-x11.lo] Error 1
make[4]: Leaving directory
`/local/src/gtk+/gtk+-2.18.9/rhel5x86_64/gtk+-2.18.9/gdk/x11'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory
`/local/src/gtk+/gtk+-2.18.9/rhel5x86_64/gtk+-2.18.9/gdk'
make[2]: *** [all] Error 2
make[2]: Leaving directory
`/local/src/gtk+/gtk+-2.18.9/rhel5x86_64/gtk+-2.18.9/gdk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
`/local/src/gtk+/gtk+-2.18.9/rhel5x86_64/gtk+-2.18.9'

------------------------------------------------------------------------------

_______________________________________________
Gmod-gbrowse mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-gbrowse
Reply | Threaded
Open this post in threaded view
|

Re: gbrowse2 global instillation problem with inkscape

Scott Cain
Hi Nikhat,

I don't know anything about building inkscape from source (let alone a
prerequisite); whenever I've installed it, I just used a package
manger like apt or yum.  I do want to point out though that inkscape
is not required; you only need it if you want to produce pdf images.
Without it, you can still produce SVG images from GD::SVG.

Scott


On Tue, May 25, 2010 at 12:33 PM, Nikhat Zafar <[hidden email]> wrote:

>
> Hi ,
>
> We are trying to install gbrowse2 globalyy on our network, but are
> running into issues which are stated below. The messages are given to me
> by our IT people. Does anybody else ran into the same problem or does
> anybody knows solution to this. Basically problem we are having is with
> inkscape instillation. Any suggestion would be greatly appreciated.
>
>
>
>
> The problem as things stand now...
>
> inkscape build requires gtkmm
> gtkmm build requires gtk+
> gtk+ build requires pango/pangocairo.h -- which cannot be found
>
> Question:  How to build/obtain pangocairo.h???
>
>
> ================================================================================
>
> Packages installed in /usr/local/packages on speedy (64-bit rhel 5)
> ================================================================================
>
>
> gc-7.0
> gc -> gc-7.0
>
> lcms -> lcms-1.19
> lcms-1.19
>
> poppler -> poppler-0.13.3
> poppler-0.13.3
>
> ----------------------------------------
>
> libsigc++-2.2.6
> libsigc++ -> libsigc++-2.2.6
>
> glibmm -> glibmm-2.24.1
> glibmm-2.24.1
>
> gsl -> gsl-1.14
> gsl-1.14
>
> glib -> glib-2.24.0
> glib-2.24.0
>
> ----------------------------------------
>
> atk -> atk-1.30.0
> atk-1.30.0
>
> pango -> pango-1.28.0
> pango-1.28.0
>
> cairomm -> cairomm-1.8.4
> cairomm-1.8.4
>
> cairo -> cairo-1.8.10
> cairo-1.8.10
>
> pixman -> pixman-1.18.0
> pixman-1.18.0
>
> ================================================================================
>
> Inkscape configure/build/installation steps
> ================================================================================
>
>
> [root@speedy inkscape-0.47]# ./configure
> --prefix=/usr/local/packages/inkscape-0.47
> ...
> checking gc.h usability... no
> checking gc.h presence... no
> checking for gc.h... no
> checking gc/gc.h usability... no
> checking gc/gc.h presence... no
> checking for gc/gc.h... no
> configure: error: libgc (the Boehm Conservative Collector) 6.4+, is
> needed to compile inkscape -- http://www.hpl.hp.com/personal/Hans_Boehm/gc
>
> export PKG_CONFIG_PATH=/usr/local/packages/gc/lib/pkgconfig
> # appears that pkgconfig not honored for gc
> (/usr/local/packages/gc/lib/pkgconfig).  So...
> unset PKG_CONFIG_PATH
>
> export LDFLAGS=-L/usr/local/packages/gc/lib
> export CPPFLAGS=-I/usr/local/packages/gc/include
>
> works!
>
> --------------------------------------------------------------------------------
>
> LCMS:
>
> checking for LCMS... no
> configure: error: --enable-lcms was specified, but appropriate LittleCms
> development packages could not be found
>
> export PKG_CONFIG_PATH=/usr/local/packages/lcms/lib/pkgconfig
>
> works!
>
> export CPPFLAGS=-I/usr/local/packages/lcms/include
> export LDFLAGS=-L/usr/local/packages/lcms/lib
>
> works!
>
> /configure --prefix=/usr/local/packages/inkscape-0.47
>
> checking for LCMS... yes
> checking for POPPLER... no
> checking for POPPLERNEW... no
> checking for LIBWPG... no
> checking for IMAGEMAGICK... no
> checking for CAIRO_USER_FONTS... no
> checking for INKSCAPE... configure: error: Package requirements
> (gdkmm-2.4  glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0  gtk+-2.0
> libxml-2.0 >= 2.6.11  libxslt >= 1.0.15  cairo  sigc++-2.0 >= 2.0.12
> gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:
>
> No package 'gdkmm-2.4' found
> No package 'glibmm-2.4' found
> No package 'giomm-2.4' found
> No package 'gtkmm-2.4' found
> No package 'sigc++-2.0' found
> No package 'gsl' found
>
> --------------------------------------------------------------------------------
>
> POPPLER:
>
> checking for POPPLER... no
>
> export PKG_CONFIG_PATH=/usr/local/packages/lcms/lib/pkgconfig:
>                       /usr/local/packages/poppler/lib/pkgconfig
>
> works!
>
> export POPPLER_CFLAGS=-I/usr/local/packages/poppler/include/poppler
> export POPPLER_LIBS=-L/usr/local/packages/poppler/lib
>
> doesn't work :(
>
> ./configure --prefix=/usr/local/packages/inkscape-0.47
>
> checking for LCMS... yes
> checking for POPPLER... yes
> checking for POPPLER_GLIB... no
> checking for POPPLER_CAIRO... no
> checking for POPPLERNEW... yes
> checking for LIBWPG... no
> checking for IMAGEMAGICK... no
> checking for CAIRO_USER_FONTS... no
> checking for INKSCAPE... configure: error: Package requirements
> (gdkmm-2.4  glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0  gtk+-2.0
> libxml-2.0 >= 2.6.11  libxslt >= 1.0.15  cairo  sigc++-2.0 >= 2.0.12
> gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:
>
> No package 'gdkmm-2.4' found
> No package 'glibmm-2.4' found
> No package 'giomm-2.4' found
> No package 'gtkmm-2.4' found
> No package 'sigc++-2.0' found
> No package 'gsl' found
>
> --------------------------------------------------------------------------------
>
> IMAGEMAGICK:
>
> checking for IMAGEMAGICK... no
>
> export PKG_CONFIG_PATH=/usr/local/packages/lcms/lib/pkgconfig:
>                       /usr/local/packages/poppler/lib/pkgconfig:
>                       /usr/local/packages/ImageMagick/lib/pkgconfig
>
> works!
>
> ./configure --prefix=/usr/local/packages/inkscape-0.47
>
> checking for LCMS... yes
> checking for POPPLER... yes
> checking for POPPLER_GLIB... no
> checking for POPPLER_CAIRO... no
> checking for POPPLERNEW... yes
> checking for LIBWPG... no
> checking for IMAGEMAGICK... yes
> checking for CAIRO_USER_FONTS... no
> checking for INKSCAPE... configure: error: Package requirements
> (gdkmm-2.4  glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0  gtk+-2.0
> libxml-2.0 >= 2.6.11  libxslt >= 1.0.15  cairo  sigc++-2.0 >= 2.0.12
> gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:
>
> No package 'gdkmm-2.4' found
> No package 'glibmm-2.4' found
> No package 'giomm-2.4' found
> No package 'gtkmm-2.4' found
> No package 'sigc++-2.0' found
> No package 'gsl' found
>
> --------------------------------------------------------------------------------
>
> --------------------------------------------------------------------------------
>
> LIBSIGC++:
>
> export PKG_CONFIG_PATH=/usr/local/packages/lcms/lib/pkgconfig:
>                       /usr/local/packages/poppler/lib/pkgconfig:
>                       /usr/local/packages/ImageMagick/lib/pkgconfig
>                       /usr/local/packages/libsigc++/lib/pkgconfig
>
> ./configure --prefix=/usr/local/packages/inkscape-0.47
>
> works!
>
> checking for INKSCAPE... configure: error: Package requirements
> (gdkmm-2.4  glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0  gtk+-2.0
> libxml-2.0 >= 2.6.11  libxslt >= 1.0.15  cairo  sigc++-2.0 >= 2.0.12
> gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:
>
> No package 'gdkmm-2.4' found
> No package 'glibmm-2.4' found
> No package 'giomm-2.4' found
> No package 'gtkmm-2.4' found
> No package 'gsl' found
>
> --------------------------------------------------------------------------------
>
> GLIBMM:
>
> export PKG_CONFIG_PATH=/usr/local/packages/lcms/lib/pkgconfig:
>                       /usr/local/packages/poppler/lib/pkgconfig:
>                       /usr/local/packages/ImageMagick/lib/pkgconfig:
>                       /usr/local/packages/libsigc++/lib/pkgconfig:
>                       /usr/local/packages/glibmm/lib/pkgconfig
>
> works!
>
> ./configure --prefix=/usr/local/packages/inkscape-0.47
>
> checking for INKSCAPE... configure: error: Package requirements
> (gdkmm-2.4  glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0  gtk+-2.0
> libxml-2.0 >= 2.6.11  libxslt >= 1.0.15  cairo  sigc++-2.0 >= 2.0.12
> gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:
>
> No package 'gdkmm-2.4' found
> Package gio-2.0 was not found in the pkg-config search path.
> Perhaps you should add the directory containing `gio-2.0.pc'
> to the PKG_CONFIG_PATH environment variable
> Package 'gio-2.0', required by 'giomm', not found
>
> --------------------------------------------------------------------------------
>
> GIO:
>
> export PKG_CONFIG_PATH=/usr/local/packages/lcms/lib/pkgconfig:
>                       /usr/local/packages/poppler/lib/pkgconfig:
>                       /usr/local/packages/ImageMagick/lib/pkgconfig:
>                       /usr/local/packages/libsigc++/lib/pkgconfig:
>                       /usr/local/packages/glibmm/lib/pkgconfig:
>                       /usr/local/packages/glib/lib/pkgconfig
>
> works!
>
> ./configure --prefix=/usr/local/packages/inkscape-0.47
>
> checking for INKSCAPE... configure: error: Package requirements
> (gdkmm-2.4  glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0  gtk+-2.0
> libxml-2.0 >= 2.6.11  libxslt >= 1.0.15  cairo  sigc++-2.0 >= 2.0.12
> gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:
>
> No package 'gdkmm-2.4' found
> No package 'gtkmm-2.4' found
> No package 'gsl' found
>
> --------------------------------------------------------------------------------
>
> GSL
>
> export PKG_CONFIG_PATH=/usr/local/packages/lcms/lib/pkgconfig:
>                       /usr/local/packages/poppler/lib/pkgconfig:
>                       /usr/local/packages/ImageMagick/lib/pkgconfig:
>                       /usr/local/packages/libsigc++/lib/pkgconfig:
>                       /usr/local/packages/glibmm/lib/pkgconfig:
>                       /usr/local/packages/glib/lib/pkgconfig
>                       /usr/local/packages/gsl/lib/pkgconfig
> works!
>
> ./configure --prefix=/usr/local/packages/inkscape-0.47
>
> checking for INKSCAPE... configure: error: Package requirements
> (gdkmm-2.4  glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0  gtk+-2.0
> libxml-2.0 >= 2.6.11  libxslt >= 1.0.15  cairo  sigc++-2.0 >= 2.0.12
> gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:
>
> No package 'gdkmm-2.4' found
> No package 'gtkmm-2.4' found
>
> --------------------------------------------------------------------------------
>
> --------------------------------------------------------------------------------
>
> --------------------------------------------------------------------------------
>
> GTKMM:
>
> ./configure --prefix=/usr/local/packages/gtkmm-2.20.2
>
> checking for ATKMM... yes
> checking for GDKMM... configure: error: Package requirements (giomm-2.4
>  >= 2.24 pangomm-1.4 >= 2.26 gtk+-2.0 >= 2.20.0) were not met:
>
> No package 'pangomm-1.4' found
> Requested 'gtk+-2.0 >= 2.20.0' but version of GTK+ is 2.10.4
>
>
>
> --------------------------------------------------------------------------------
>
> GTK+
>
> ./configure --prefix=/usr/local/packages/gtk+-2.18.9
>
> checking for BASE_DEPENDENCIES... configure: error: Package requirements
> (glib-2.0 >= 2.21.3    atk >= 1.13.0    pango >= 1.20    cairo >= 1.6)
> were not met:
>
> Requested 'glib-2.0 >= 2.21.3' but version of GLib is 2.12.3
> Requested 'atk >= 1.13.0' but version of Atk is 1.12.2
> Requested 'pango >= 1.20' but version of Pango is 1.14.9
> Requested 'cairo >= 1.6' but version of cairo is 1.2.4
>
> 2)
>
> export
> PKG_CONFIG_PATH=/usr/local/packages/glib/lib/pkgconfig:/usr/local/packages/atk/lib/pkgconfig:/usr/local/packages/pango/lib/pkgconfig:/usr/local/packages/cairo/lib/pkgconfig
>
>
> ./configure --prefix=/usr/local/packages/gtk+-2.18.9
>
> checking for BASE_DEPENDENCIES... configure: error: Package requirements
> (glib-2.0 >= 2.21.3    atk >= 1.13.0    pango >= 1.20    cairo >= 1.6)
> were not met:
>
> Package pixman-1 was not found in the pkg-config search path.
> Perhaps you should add the directory containing `pixman-1.pc'
> to the PKG_CONFIG_PATH environment variable
> Package 'pixman-1', required by 'cairo', not found
>
> 3)
>
> export
> PKG_CONFIG_PATH=/usr/local/packages/glib/lib/pkgconfig:/usr/local/packages/atk/lib/pkgconfig:/usr/local/packages/pango/lib/pkgconfig:/usr/local/packages/cairo/lib/pkgconfig:/usr/local/packages/pixman/lib/pkgconfig
>
>
> ./configure --prefix=/usr/local/packages/gtk+-2.18.9
>
> 4)
>
> CPPFLAGS=-I/usr/local/packages/glib/include
> LDFLAGS=-L/usr/local/packages/glib/lib
>
> ./configure --prefix=/usr/local/packages/gtk+-2.18.9
>
> 5)
>
> LD_LIBRARY_PATH=/usr/local/packages/glib/lib
>
> ./configure --prefix=/usr/local/packages/gtk+-2.18.9
>
> works!
>
> make
>
> make[4]: Entering directory
> `/local/src/gtk+/gtk+-2.18.9/rhel5x86_64/gtk+-2.18.9/gdk/x11'
> /bin/sh ../../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.
> -I../.. -DG_LOG_DOMAIN=\"Gdk\" -DGDK_COMPILATION -I../.. -I../../gdk
> -I../../gdk -DG_DISABLE_CAST_CHECKS -pthread
> -I/usr/local/packages/glib-2.24.0/include/glib-2.0
> -I/usr/local/packages/glib-2.24.0/lib/glib-2.0/include
> -I/usr/local/packages/pango-1.28.0/include/pango-1.0
> -I/usr/local/packages/cairo-1.8.10/include/cairo
> -I/usr/local/packages/pixman-1.18.0/include/pixman-1
> -I/usr/include/freetype2 -I/usr/include/libpng12
> -I/usr/local/packages/glib/include -DG_DISABLE_SINGLE_INCLUDES
> -DATK_DISABLE_SINGLE_INCLUDES -DGDK_PIXBUF_DISABLE_SINGLE_INCLUDES
> -DGTK_DISABLE_SINGLE_INCLUDES    -DGDK_PIXBUF_DISABLE_DEPRECATED -g -O2
> -Wall -MT gdkapplaunchcontext-x11.lo -MD -MP -MF
> .deps/gdkapplaunchcontext-x11.Tpo -c -o gdkapplaunchcontext-x11.lo
> gdkapplaunchcontext-x11.c
> libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I../..
> -DG_LOG_DOMAIN=\"Gdk\" -DGDK_COMPILATION -I../.. -I../../gdk -I../../gdk
> -DG_DISABLE_CAST_CHECKS -pthread
> -I/usr/local/packages/glib-2.24.0/include/glib-2.0
> -I/usr/local/packages/glib-2.24.0/lib/glib-2.0/include
> -I/usr/local/packages/pango-1.28.0/include/pango-1.0
> -I/usr/local/packages/cairo-1.8.10/include/cairo
> -I/usr/local/packages/pixman-1.18.0/include/pixman-1
> -I/usr/include/freetype2 -I/usr/include/libpng12
> -I/usr/local/packages/glib/include -DG_DISABLE_SINGLE_INCLUDES
> -DATK_DISABLE_SINGLE_INCLUDES -DGDK_PIXBUF_DISABLE_SINGLE_INCLUDES
> -DGTK_DISABLE_SINGLE_INCLUDES -DGDK_PIXBUF_DISABLE_DEPRECATED -g -O2
> -Wall -MT gdkapplaunchcontext-x11.lo -MD -MP -MF
> .deps/gdkapplaunchcontext-x11.Tpo -c gdkapplaunchcontext-x11.c  -fPIC
> -DPIC -o .libs/gdkapplaunchcontext-x11.o
> In file included from ../../gdk/gdk.h:33,
>                from ../../gdk/gdkprivate.h:30,
>                from gdkx.h:30,
>                from gdkapplaunchcontext-x11.c:30:
> ../../gdk/gdkcairo.h:29:30: error: pango/pangocairo.h: No such file or
> directory
> make[4]: *** [gdkapplaunchcontext-x11.lo] Error 1
> make[4]: Leaving directory
> `/local/src/gtk+/gtk+-2.18.9/rhel5x86_64/gtk+-2.18.9/gdk/x11'
> make[3]: *** [all-recursive] Error 1
> make[3]: Leaving directory
> `/local/src/gtk+/gtk+-2.18.9/rhel5x86_64/gtk+-2.18.9/gdk'
> make[2]: *** [all] Error 2
> make[2]: Leaving directory
> `/local/src/gtk+/gtk+-2.18.9/rhel5x86_64/gtk+-2.18.9/gdk'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory
> `/local/src/gtk+/gtk+-2.18.9/rhel5x86_64/gtk+-2.18.9'
>
> ------------------------------------------------------------------------------
>
> _______________________________________________
> Gmod-gbrowse mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gmod-gbrowse
>



--
------------------------------------------------------------------------
Scott Cain, Ph. D.                                   scott at scottcain dot net
GMOD Coordinator (http://gmod.org/)                     216-392-3087
Ontario Institute for Cancer Research

------------------------------------------------------------------------------

_______________________________________________
Gmod-gbrowse mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-gbrowse