Quantcast

installation problems

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

installation problems

Heleen
Hi,

I am new to Apollo and also very rusty with UNIX. I am trying to install Apollo but I get an error after the build:

BUILD SUCCESSFUL

Total time: 3.592 secs
| Error Error initializing classpath: No builders are available to build a model of type 'org.grails.gradle.plugin.model.GrailsClasspath'. (Use --stacktrace to see the full trace)

I've installed grails with sdkman. So far it seems I can only run ./apollo devmode. The apollo run-local 8080 will start to make a build and fail in the end. The apollo deploy does the same and I cannot find a .war file.

The webserver is running.

Many thanks in advance for your help.

Regards,
Heleen.




This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: installation problems

nathandunn

Heleen,

A few questions:

1 - Are you running “./apollo deploy”?   What is the full output when you see this? 

2 - Did you install Grails 2.5.5: (you can type “grails version”).  If not use can add it by running: 

sdk install grails 2.5.5

It will ask you if you want to run the default.


4 - What do you see when you do run “./apollo run-local”? 

Other thoughts:

 - Also, if you want to skip all of this and have access to amazon’s web services, you can install search for “Apollo” in most regions and you should see an “Apollo 2.0.6 Template” which you can run (I would recommend m3.large).   


Nathan Dunn, PhD
Berkeley Bioinformatics Open-source Projects (BBOP)
Environmental Genomics and Systems Biology, Lawrence Berkeley National Laboratory
[hidden email]


On Feb 7, 2017, at 8:10 AM, Heleen Pruyn <[hidden email]> wrote:

Hi,

I am new to Apollo and also very rusty with UNIX. I am trying to install Apollo but I get an error after the build:

BUILD SUCCESSFUL

Total time: 3.592 secs
| Error Error initializing classpath: No builders are available to build a model of type 'org.grails.gradle.plugin.model.GrailsClasspath'. (Use --stacktrace to see the full trace)

I've installed grails with sdkman. So far it seems I can only run ./apollo devmode. The apollo run-local 8080 will start to make a build and fail in the end. The apollo deploy does the same and I cannot find a .war file.

The webserver is running.

Many thanks in advance for your help.

Regards,
Heleen.



This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: installation problems

Heleen
Hi Nathan,

Thanks for your very prompt reply. Doing 2. installing Grails 2.5.5 solved the problem and it is running local now. Will test deploy later on.

Thanks again,
Heleen.

2017-02-07 17:44 GMT+01:00 Nathan Dunn <[hidden email]>:

Heleen,

A few questions:

1 - Are you running “./apollo deploy”?   What is the full output when you see this? 

2 - Did you install Grails 2.5.5: (you can type “grails version”).  If not use can add it by running: 

sdk install grails 2.5.5

It will ask you if you want to run the default.


4 - What do you see when you do run “./apollo run-local”? 

Other thoughts:

 - Also, if you want to skip all of this and have access to amazon’s web services, you can install search for “Apollo” in most regions and you should see an “Apollo 2.0.6 Template” which you can run (I would recommend m3.large).   


Nathan Dunn, PhD
Berkeley Bioinformatics Open-source Projects (BBOP)
Environmental Genomics and Systems Biology, Lawrence Berkeley National Laboratory
[hidden email]


On Feb 7, 2017, at 8:10 AM, Heleen Pruyn <[hidden email]> wrote:

Hi,

I am new to Apollo and also very rusty with UNIX. I am trying to install Apollo but I get an error after the build:

BUILD SUCCESSFUL

Total time: 3.592 secs
| Error Error initializing classpath: No builders are available to build a model of type 'org.grails.gradle.plugin.model.GrailsClasspath'. (Use --stacktrace to see the full trace)

I've installed grails with sdkman. So far it seems I can only run ./apollo devmode. The apollo run-local 8080 will start to make a build and fail in the end. The apollo deploy does the same and I cannot find a .war file.

The webserver is running.

Many thanks in advance for your help.

Regards,
Heleen.



This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.







This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Loading...