intermine.log files missing

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

intermine.log files missing

kkarra@stanford.edu
Hi,

Again, on our new linux build machines, when I run build-db or any other ant task in any one of the 4 directories, I don't see _intermine.log_ file being generated. No error either.

-Kalpana


_______________________________________________
dev mailing list
[hidden email]
http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: intermine.log files missing

Richard Smith
Hi Kalpana,
This may be that there is log4j.properties found on the classpath before
the InterMine log4j.properties files.  Can you check what your classpath
is on the new machines and see if it points to other directories?  This
should be $CLASSPATH.

The asm cglib error may be caused by the same thing.  Sierra had a
similar problem running on a machine with Hibernate and Spring installed
but I can't find what the eventual fix was.  Looking for any other
asm.jar files or cglib jars would be a start.

You could also run ant clean-all in the intermine directories before
running a normal command to see if that helps.

Cheers,
Richard.




On 04/01/2011 20:50, Kalpana Karra wrote:

> Hi,
>
> Again, on our new linux build machines, when I run build-db or any other ant task in any one of the 4 directories, I don't see _intermine.log_ file being generated. No error either.
>
> -Kalpana
>
>
> _______________________________________________
> dev mailing list
> [hidden email]
> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
>


_______________________________________________
dev mailing list
[hidden email]
http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: intermine.log files missing

kkarra@stanford.edu
In reply to this post by kkarra@stanford.edu
Moving the log4j related jars out of /usr/local/ant/lib solved the problem (there seem to be quite a few extra JARS included in the ant installed from a package or that came default).
The log files are being written in the current directory!

On Jan 4, 2011, at 12:50 PM, Kalpana Karra wrote:

> Hi,
>
> Again, on our new linux build machines, when I run build-db or any other ant task in any one of the 4 directories, I don't see _intermine.log_ file being generated. No error either.
>
> -Kalpana
>


_______________________________________________
dev mailing list
[hidden email]
http://mail.intermine.org/cgi-bin/mailman/listinfo/dev