links missing on history items sometimes

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

links missing on history items sometimes

Michael Pheasant
Hi

History items in the green boxes on the RHS of the galaxy screen
usually have hyperlinks on the names. Cliking on the link expands or
un-expands the text in the green box.

Sometimes the links disappear on my instance, see the attached image
(if its not stripped off by the mailing list).

I havent been able to figure out why this happens or how to fix it.

Is it controlled by an .ini file setting? Or something else? The session?

Cheers
Mike.


--
Michael Pheasant
Software Engineer
Queensland Facility for Advanced Bioinformatics
Level 6, QBP
University of Queensland, QLD 4072
T: +61 (0)7 3346 2070
F: +61 (0)7 3346 2101
www.qfab.org

_______________________________________________
galaxy-dev mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-dev

links.png (16K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: links missing on history items sometimes

Jeremy Goecks
Hi Mike,

We've heard about this problem but haven't been able to replicate it and hence haven't been able to fix it.

The problem is not the result of a bad .ini setting; it's a Javascript error. When you see the links disappear, can you please open your Javascript console and, if there are any errors present, send them to us.

Thanks,
J.



On Jun 1, 2010, at 10:55 PM, Michael Pheasant wrote:

> Hi
>
> History items in the green boxes on the RHS of the galaxy screen
> usually have hyperlinks on the names. Cliking on the link expands or
> un-expands the text in the green box.
>
> Sometimes the links disappear on my instance, see the attached image
> (if its not stripped off by the mailing list).
>
> I havent been able to figure out why this happens or how to fix it.
>
> Is it controlled by an .ini file setting? Or something else? The session?
>
> Cheers
> Mike.
>
>
> --
> Michael Pheasant
> Software Engineer
> Queensland Facility for Advanced Bioinformatics
> Level 6, QBP
> University of Queensland, QLD 4072
> T: +61 (0)7 3346 2070
> F: +61 (0)7 3346 2101
> www.qfab.org
> <links.png>_______________________________________________
> galaxy-dev mailing list
> [hidden email]
> http://lists.bx.psu.edu/listinfo/galaxy-dev


_______________________________________________
galaxy-dev mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-dev
Reply | Threaded
Open this post in threaded view
|

Re: links missing on history items sometimes

Michael Pheasant
Thanks for the tip, I assumed it was a server side problem, didnt
think to try another browser.
Sure enough in Chrome its OK, Firefox fail.

Firefox "Firebug" console gives 2 js errors on that page:


1) Security error" code: "1000
return window.localStorage !== u... || window.globalStorage !== undefined;\n

The info says its in line 1460 of: /static/scripts/jquery.jstore.js?v=2
Which is:

    function ()
    {
/*line 1460:*/         return window.localStorage !== undefined ||
window.globalStorage !== undefined;
    });


2) the 2nd error is:

uncaught exception: JSTORE_ENGINE_UNAVAILABLE


*) I'm using firefox 3.5.9 on linux.

--
Michael Pheasant
Software Engineer
Queensland Facility for Advanced Bioinformatics
Level 6, QBP
University of Queensland, QLD 4072
T: +61 (0)7 3346 2070
F: +61 (0)7 3346 2101
www.qfab.org



On Wed, Jun 2, 2010 at 1:06 PM, Jeremy Goecks <[hidden email]> wrote:

> Hi Mike,
>
> We've heard about this problem but haven't been able to replicate it and hence haven't been able to fix it.
>
> The problem is not the result of a bad .ini setting; it's a Javascript error. When you see the links disappear, can you please open your Javascript console and, if there are any errors present, send them to us.
>
> Thanks,
> J.
>
>
>
> On Jun 1, 2010, at 10:55 PM, Michael Pheasant wrote:
>
>> Hi
>>
>> History items in the green boxes on the RHS of the galaxy screen
>> usually have hyperlinks on the names. Cliking on the link expands or
>> un-expands the text in the green box.
>>
>> Sometimes the links disappear on my instance, see the attached image
>> (if its not stripped off by the mailing list).
>>
>> I havent been able to figure out why this happens or how to fix it.
>>
>> Is it controlled by an .ini file setting? Or something else? The session?
>>
>> Cheers
>> Mike.
>>
>>
>> --
>> Michael Pheasant
>> Software Engineer
>> Queensland Facility for Advanced Bioinformatics
>> Level 6, QBP
>> University of Queensland, QLD 4072
>> T: +61 (0)7 3346 2070
>> F: +61 (0)7 3346 2101
>> www.qfab.org
>> <links.png>_______________________________________________
>> galaxy-dev mailing list
>> [hidden email]
>> http://lists.bx.psu.edu/listinfo/galaxy-dev
>
>
_______________________________________________
galaxy-dev mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-dev
Reply | Threaded
Open this post in threaded view
|

Re: links missing on history items sometimes

Kanwei Li
Hi Michael,

Thanks for the report.. do please let us know if you can reproduce it
consistently.

Kanwei

On Wed, Jun 2, 2010 at 12:36 AM, Michael Pheasant <[hidden email]> wrote:

> Thanks for the tip, I assumed it was a server side problem, didnt
> think to try another browser.
> Sure enough in Chrome its OK, Firefox fail.
>
> Firefox "Firebug" console gives 2 js errors on that page:
>
>
> 1) Security error" code: "1000
> return window.localStorage !== u... || window.globalStorage !== undefined;\n
>
> The info says its in line 1460 of: /static/scripts/jquery.jstore.js?v=2
> Which is:
>
>    function ()
>    {
> /*line 1460:*/         return window.localStorage !== undefined ||
> window.globalStorage !== undefined;
>    });
>
>
> 2) the 2nd error is:
>
> uncaught exception: JSTORE_ENGINE_UNAVAILABLE
>
>
> *) I'm using firefox 3.5.9 on linux.
>
> --
> Michael Pheasant
> Software Engineer
> Queensland Facility for Advanced Bioinformatics
> Level 6, QBP
> University of Queensland, QLD 4072
> T: +61 (0)7 3346 2070
> F: +61 (0)7 3346 2101
> www.qfab.org
>
>
>
> On Wed, Jun 2, 2010 at 1:06 PM, Jeremy Goecks <[hidden email]> wrote:
>> Hi Mike,
>>
>> We've heard about this problem but haven't been able to replicate it and hence haven't been able to fix it.
>>
>> The problem is not the result of a bad .ini setting; it's a Javascript error. When you see the links disappear, can you please open your Javascript console and, if there are any errors present, send them to us.
>>
>> Thanks,
>> J.
>>
>>
>>
>> On Jun 1, 2010, at 10:55 PM, Michael Pheasant wrote:
>>
>>> Hi
>>>
>>> History items in the green boxes on the RHS of the galaxy screen
>>> usually have hyperlinks on the names. Cliking on the link expands or
>>> un-expands the text in the green box.
>>>
>>> Sometimes the links disappear on my instance, see the attached image
>>> (if its not stripped off by the mailing list).
>>>
>>> I havent been able to figure out why this happens or how to fix it.
>>>
>>> Is it controlled by an .ini file setting? Or something else? The session?
>>>
>>> Cheers
>>> Mike.
>>>
>>>
>>> --
>>> Michael Pheasant
>>> Software Engineer
>>> Queensland Facility for Advanced Bioinformatics
>>> Level 6, QBP
>>> University of Queensland, QLD 4072
>>> T: +61 (0)7 3346 2070
>>> F: +61 (0)7 3346 2101
>>> www.qfab.org
>>> <links.png>_______________________________________________
>>> galaxy-dev mailing list
>>> [hidden email]
>>> http://lists.bx.psu.edu/listinfo/galaxy-dev
>>
>>
>

_______________________________________________
galaxy-dev mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-dev