Quantcast

prepare-refseqs.pl - can't locate

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

prepare-refseqs.pl - can't locate

Shane McCoy
Hello!
I've run into an issue - would love some help on this one. 
After running ./apollo deploy I can't get my head around why the bin/prepare-refseqs.pl script is not running

$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
Can't locate local/lib.pm in @INC (you may need to install the local::lib module) (@INC contains: /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1 /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5 /home/bjreadin/Apollo/bin/../src/perl5 /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.1 /usr/local/share/perl/5.22.1 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /home/bjreadin/Apollo/bin/../src/perl5/JBlibs.pm line 25.
Compilation failed in require at bin/prepare-refseqs.pl line 5.
BEGIN failed--compilation aborted at bin/prepare-refseqs.pl line 5. 

Perl Version 5.22.1 - modules installed at:
/home/bjreadin/perl5/lib/perl5

 I have local::lib installed and my paths seem correct. 
$ perl -V
  %ENV:
    PERL5LIB="/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib/perl5:/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib"
    PERL_LOCAL_LIB_ROOT="/home/bjreadin/perl5:"
    PERL_MB_OPT="--install_base "/home/bjreadin/perl5""
    PERL_MM_OPT="INSTALL_BASE=/home/bjreadin/perl5"
  @INC:
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5/5.22.1
    /home/bjreadin/perl5/lib/perl5/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib
    /etc/perl
    /usr/local/lib/x86_64-linux-gnu/perl/5.22.1
    /usr/local/share/perl/5.22.1
    /usr/lib/x86_64-linux-gnu/perl5/5.22
    /usr/share/perl5
    /usr/lib/x86_64-linux-gnu/perl/5.22
    /usr/share/perl/5.22
    /usr/local/lib/site_perl
    /usr/lib/x86_64-linux-gnu/perl-base

The last perl version I used was 5.18.2 on a previous install and I had no issues. Could this be due to 5.22.x? Thanks for any insight! 
Shane M.
 




This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: prepare-refseqs.pl - can't locate

nathandunn

Shane,

What happens if you run ./install_jbrowse.sh ? 

Nathan

On Oct 24, 2016, at 5:43 PM, Shane McCoy <[hidden email]> wrote:

Hello!
I've run into an issue - would love some help on this one. 
After running ./apollo deploy I can't get my head around why the bin/prepare-refseqs.pl script is not running

$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
Can't locate local/lib.pm in @INC (you may need to install the local::lib module) (@INC contains: /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1 /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5 /home/bjreadin/Apollo/bin/../src/perl5 /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.1 /usr/local/share/perl/5.22.1 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /home/bjreadin/Apollo/bin/../src/perl5/JBlibs.pm line 25.
Compilation failed in require at bin/prepare-refseqs.pl line 5.
BEGIN failed--compilation aborted at bin/prepare-refseqs.pl line 5. 

Perl Version 5.22.1 - modules installed at:
/home/bjreadin/perl5/lib/perl5

 I have local::lib installed and my paths seem correct. 
$ perl -V
  %ENV:
    PERL5LIB="/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib/perl5:/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib"
    PERL_LOCAL_LIB_ROOT="/home/bjreadin/perl5:"
    PERL_MB_OPT="--install_base "/home/bjreadin/perl5""
    PERL_MM_OPT="INSTALL_BASE=/home/bjreadin/perl5"
  @INC:
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5/5.22.1
    /home/bjreadin/perl5/lib/perl5/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib
    /etc/perl
    /usr/local/lib/x86_64-linux-gnu/perl/5.22.1
    /usr/local/share/perl/5.22.1
    /usr/lib/x86_64-linux-gnu/perl5/5.22
    /usr/share/perl5
    /usr/lib/x86_64-linux-gnu/perl/5.22
    /usr/share/perl/5.22
    /usr/local/lib/site_perl
    /usr/lib/x86_64-linux-gnu/perl-base

The last perl version I used was 5.18.2 on a previous install and I had no issues. Could this be due to 5.22.x? Thanks for any insight! 
Shane M.
 



This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: prepare-refseqs.pl - can't locate

Shane McCoy
Hi Nathan,
after ./apollo deploy it installs fine:
$ ./install_jbrowse.sh 
Installing Perl prerequisites ...Prerequisites installed, finished.

 I had tried after ./apollo clean-all and it would not install. Not sure if that matters? 
Installing Perl prerequisites ... failed.  See setup.log file for error messages.
 
Apollo/setup.log
+ chmod +x web-app/jbrowse/bin/cpanm
chmod: cannot access 'web-app/jbrowse/bin/cpanm': No such file or directory
+ cd web-app/jbrowse
./install_jbrowse.sh: line 26: cd: web-app/jbrowse: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 27: bin/cpanm: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 28: bin/cpanm: No such file or directory
+ set -e
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 30: bin/cpanm: No such file or directory
 Thanks!
Shane

On Mon, Oct 24, 2016 at 7:27 PM, Nathan Dunn <[hidden email]> wrote:

Shane,

What happens if you run ./install_jbrowse.sh ? 

Nathan

On Oct 24, 2016, at 5:43 PM, Shane McCoy <[hidden email]> wrote:

Hello!
I've run into an issue - would love some help on this one. 
After running ./apollo deploy I can't get my head around why the bin/prepare-refseqs.pl script is not running

$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
Can't locate local/lib.pm in @INC (you may need to install the local::lib module) (@INC contains: /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1 /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5 /home/bjreadin/Apollo/bin/../src/perl5 /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.1 /usr/local/share/perl/5.22.1 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /home/bjreadin/Apollo/bin/../src/perl5/JBlibs.pm line 25.
Compilation failed in require at bin/prepare-refseqs.pl line 5.
BEGIN failed--compilation aborted at bin/prepare-refseqs.pl line 5. 

Perl Version 5.22.1 - modules installed at:
/home/bjreadin/perl5/lib/perl5

 I have local::lib installed and my paths seem correct. 
$ perl -V
  %ENV:
    PERL5LIB="/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib/perl5:/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib"
    PERL_LOCAL_LIB_ROOT="/home/bjreadin/perl5:"
    PERL_MB_OPT="--install_base "/home/bjreadin/perl5""
    PERL_MM_OPT="INSTALL_BASE=/home/bjreadin/perl5"
  @INC:
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5/5.22.1
    /home/bjreadin/perl5/lib/perl5/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib
    /etc/perl
    /usr/local/lib/x86_64-linux-gnu/perl/5.22.1
    /usr/local/share/perl/5.22.1
    /usr/lib/x86_64-linux-gnu/perl5/5.22
    /usr/share/perl5
    /usr/lib/x86_64-linux-gnu/perl/5.22
    /usr/share/perl/5.22
    /usr/local/lib/site_perl
    /usr/lib/x86_64-linux-gnu/perl-base

The last perl version I used was 5.18.2 on a previous install and I had no issues. Could this be due to 5.22.x? Thanks for any insight! 
Shane M.
 



This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.







This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: prepare-refseqs.pl - can't locate

Shane McCoy
I am getting permission denied now
$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
mkdir /opt/apollo: Permission denied at /home/bjreadin/Apollo/bin/../src/perl5/JsonFileStorage.pm line 64.

I did use --sudo on cpanm installs but I have done that prior without this issue.  

On Mon, Oct 24, 2016 at 8:03 PM, Shane McCoy <[hidden email]> wrote:
Hi Nathan,
after ./apollo deploy it installs fine:
$ ./install_jbrowse.sh 
Installing Perl prerequisites ...Prerequisites installed, finished.

 I had tried after ./apollo clean-all and it would not install. Not sure if that matters? 
Installing Perl prerequisites ... failed.  See setup.log file for error messages.
 
Apollo/setup.log
+ chmod +x web-app/jbrowse/bin/cpanm
chmod: cannot access 'web-app/jbrowse/bin/cpanm': No such file or directory
+ cd web-app/jbrowse
./install_jbrowse.sh: line 26: cd: web-app/jbrowse: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 27: bin/cpanm: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 28: bin/cpanm: No such file or directory
+ set -e
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 30: bin/cpanm: No such file or directory
 Thanks!
Shane

On Mon, Oct 24, 2016 at 7:27 PM, Nathan Dunn <[hidden email]> wrote:

Shane,

What happens if you run ./install_jbrowse.sh ? 

Nathan

On Oct 24, 2016, at 5:43 PM, Shane McCoy <[hidden email]> wrote:

Hello!
I've run into an issue - would love some help on this one. 
After running ./apollo deploy I can't get my head around why the bin/prepare-refseqs.pl script is not running

$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
Can't locate local/lib.pm in @INC (you may need to install the local::lib module) (@INC contains: /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1 /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5 /home/bjreadin/Apollo/bin/../src/perl5 /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.1 /usr/local/share/perl/5.22.1 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /home/bjreadin/Apollo/bin/../src/perl5/JBlibs.pm line 25.
Compilation failed in require at bin/prepare-refseqs.pl line 5.
BEGIN failed--compilation aborted at bin/prepare-refseqs.pl line 5. 

Perl Version 5.22.1 - modules installed at:
/home/bjreadin/perl5/lib/perl5

 I have local::lib installed and my paths seem correct. 
$ perl -V
  %ENV:
    PERL5LIB="/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib/perl5:/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib"
    PERL_LOCAL_LIB_ROOT="/home/bjreadin/perl5:"
    PERL_MB_OPT="--install_base "/home/bjreadin/perl5""
    PERL_MM_OPT="INSTALL_BASE=/home/bjreadin/perl5"
  @INC:
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5/5.22.1
    /home/bjreadin/perl5/lib/perl5/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib
    /etc/perl
    /usr/local/lib/x86_64-linux-gnu/perl/5.22.1
    /usr/local/share/perl/5.22.1
    /usr/lib/x86_64-linux-gnu/perl5/5.22
    /usr/share/perl5
    /usr/lib/x86_64-linux-gnu/perl/5.22
    /usr/share/perl/5.22
    /usr/local/lib/site_perl
    /usr/lib/x86_64-linux-gnu/perl-base

The last perl version I used was 5.18.2 on a previous install and I had no issues. Could this be due to 5.22.x? Thanks for any insight! 
Shane M.
 



This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.








This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: prepare-refseqs.pl - can't locate

Deepak Unni
Hi Shane,

I am stepping in for Nathan as he is busy on a conference this week.

Looking at your recent error with prepare-refseqs.pl script, it looks like you don't have permission to write to /opt folder.
Since /opt is a system-wide directory, you will have to first create /opt/apollo as the root user, and then change ownership of /opt/apollo folder to your username.

Ex:
sudo mkdir /opt/apollo
sudo chown <username>:<group> /opt/apollo

Once you have this done, you can run the prepare-refseqs.pl script again and it should process your datasets and place them properly in /opt/apollo/data.

Let me know if this works or if you encounter any other issues.

Cheers,

Deepak


On Tue, Oct 25, 2016 at 9:04 AM, Shane McCoy <[hidden email]> wrote:
I am getting permission denied now
$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
mkdir /opt/apollo: Permission denied at /home/bjreadin/Apollo/bin/../src/perl5/JsonFileStorage.pm line 64.

I did use --sudo on cpanm installs but I have done that prior without this issue.  

On Mon, Oct 24, 2016 at 8:03 PM, Shane McCoy <[hidden email]> wrote:
Hi Nathan,
after ./apollo deploy it installs fine:
$ ./install_jbrowse.sh 
Installing Perl prerequisites ...Prerequisites installed, finished.

 I had tried after ./apollo clean-all and it would not install. Not sure if that matters? 
Installing Perl prerequisites ... failed.  See setup.log file for error messages.
 
Apollo/setup.log
+ chmod +x web-app/jbrowse/bin/cpanm
chmod: cannot access 'web-app/jbrowse/bin/cpanm': No such file or directory
+ cd web-app/jbrowse
./install_jbrowse.sh: line 26: cd: web-app/jbrowse: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 27: bin/cpanm: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 28: bin/cpanm: No such file or directory
+ set -e
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 30: bin/cpanm: No such file or directory
 Thanks!
Shane

On Mon, Oct 24, 2016 at 7:27 PM, Nathan Dunn <[hidden email]> wrote:

Shane,

What happens if you run ./install_jbrowse.sh ? 

Nathan

On Oct 24, 2016, at 5:43 PM, Shane McCoy <[hidden email]> wrote:

Hello!
I've run into an issue - would love some help on this one. 
After running ./apollo deploy I can't get my head around why the bin/prepare-refseqs.pl script is not running

$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
Can't locate local/lib.pm in @INC (you may need to install the local::lib module) (@INC contains: /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1 /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5 /home/bjreadin/Apollo/bin/../src/perl5 /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.1 /usr/local/share/perl/5.22.1 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /home/bjreadin/Apollo/bin/../src/perl5/JBlibs.pm line 25.
Compilation failed in require at bin/prepare-refseqs.pl line 5.
BEGIN failed--compilation aborted at bin/prepare-refseqs.pl line 5. 

Perl Version 5.22.1 - modules installed at:
/home/bjreadin/perl5/lib/perl5

 I have local::lib installed and my paths seem correct. 
$ perl -V
  %ENV:
    PERL5LIB="/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib/perl5:/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib"
    PERL_LOCAL_LIB_ROOT="/home/bjreadin/perl5:"
    PERL_MB_OPT="--install_base "/home/bjreadin/perl5""
    PERL_MM_OPT="INSTALL_BASE=/home/bjreadin/perl5"
  @INC:
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5/5.22.1
    /home/bjreadin/perl5/lib/perl5/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib
    /etc/perl
    /usr/local/lib/x86_64-linux-gnu/perl/5.22.1
    /usr/local/share/perl/5.22.1
    /usr/lib/x86_64-linux-gnu/perl5/5.22
    /usr/share/perl5
    /usr/lib/x86_64-linux-gnu/perl/5.22
    /usr/share/perl/5.22
    /usr/local/lib/site_perl
    /usr/lib/x86_64-linux-gnu/perl-base

The last perl version I used was 5.18.2 on a previous install and I had no issues. Could this be due to 5.22.x? Thanks for any insight! 
Shane M.
 



This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.








This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.





--
Research Analyst
S104A Animal Science Research Center,
University of Missouri, Columbia




This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: prepare-refseqs.pl - can't locate

Shane McCoy
Hi Deepak! thanks for replying. I was just about to send this email when I saw yours. Here is the updated info:

I have switched to the system perl and added all the proper modules. I redid my postgresql setup and used the guidelines from the Readdocs
sudo su postgres -c "createuser -RDIElPS $PGUSER"
sudo su postgres -c "createdb -E UTF-8 -O $PGUSER apollo-production"
I updated apollo-config.groovy, plus commented out the password (didn't do before, missed it!)
ran clean-all and redeployed. Now getting:
$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
Permission denied writing Msax_1-0.txt at /home/bjreadin/Apollo/bin/../src/perl5/Bio/JBrowse/Cmd/FormatSequences.pm line 455, <$fasta_fh> line 2.
I can run as sudo now, but I assume that is not the best idea.
Shane

On Tue, Oct 25, 2016 at 1:10 PM, Deepak Unni <[hidden email]> wrote:
Hi Shane,

I am stepping in for Nathan as he is busy on a conference this week.

Looking at your recent error with prepare-refseqs.pl script, it looks like you don't have permission to write to /opt folder.
Since /opt is a system-wide directory, you will have to first create /opt/apollo as the root user, and then change ownership of /opt/apollo folder to your username.

Ex:
sudo mkdir /opt/apollo
sudo chown <username>:<group> /opt/apollo

Once you have this done, you can run the prepare-refseqs.pl script again and it should process your datasets and place them properly in /opt/apollo/data.

Let me know if this works or if you encounter any other issues.

Cheers,

Deepak


On Tue, Oct 25, 2016 at 9:04 AM, Shane McCoy <[hidden email]> wrote:
I am getting permission denied now
$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
mkdir /opt/apollo: Permission denied at /home/bjreadin/Apollo/bin/../src/perl5/JsonFileStorage.pm line 64.

I did use --sudo on cpanm installs but I have done that prior without this issue.  

On Mon, Oct 24, 2016 at 8:03 PM, Shane McCoy <[hidden email]> wrote:
Hi Nathan,
after ./apollo deploy it installs fine:
$ ./install_jbrowse.sh 
Installing Perl prerequisites ...Prerequisites installed, finished.

 I had tried after ./apollo clean-all and it would not install. Not sure if that matters? 
Installing Perl prerequisites ... failed.  See setup.log file for error messages.
 
Apollo/setup.log
+ chmod +x web-app/jbrowse/bin/cpanm
chmod: cannot access 'web-app/jbrowse/bin/cpanm': No such file or directory
+ cd web-app/jbrowse
./install_jbrowse.sh: line 26: cd: web-app/jbrowse: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 27: bin/cpanm: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 28: bin/cpanm: No such file or directory
+ set -e
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 30: bin/cpanm: No such file or directory
 Thanks!
Shane

On Mon, Oct 24, 2016 at 7:27 PM, Nathan Dunn <[hidden email]> wrote:

Shane,

What happens if you run ./install_jbrowse.sh ? 

Nathan

On Oct 24, 2016, at 5:43 PM, Shane McCoy <[hidden email]> wrote:

Hello!
I've run into an issue - would love some help on this one. 
After running ./apollo deploy I can't get my head around why the bin/prepare-refseqs.pl script is not running

$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
Can't locate local/lib.pm in @INC (you may need to install the local::lib module) (@INC contains: /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1 /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5 /home/bjreadin/Apollo/bin/../src/perl5 /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.1 /usr/local/share/perl/5.22.1 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /home/bjreadin/Apollo/bin/../src/perl5/JBlibs.pm line 25.
Compilation failed in require at bin/prepare-refseqs.pl line 5.
BEGIN failed--compilation aborted at bin/prepare-refseqs.pl line 5. 

Perl Version 5.22.1 - modules installed at:
/home/bjreadin/perl5/lib/perl5

 I have local::lib installed and my paths seem correct. 
$ perl -V
  %ENV:
    PERL5LIB="/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib/perl5:/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib"
    PERL_LOCAL_LIB_ROOT="/home/bjreadin/perl5:"
    PERL_MB_OPT="--install_base "/home/bjreadin/perl5""
    PERL_MM_OPT="INSTALL_BASE=/home/bjreadin/perl5"
  @INC:
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5/5.22.1
    /home/bjreadin/perl5/lib/perl5/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib
    /etc/perl
    /usr/local/lib/x86_64-linux-gnu/perl/5.22.1
    /usr/local/share/perl/5.22.1
    /usr/lib/x86_64-linux-gnu/perl5/5.22
    /usr/share/perl5
    /usr/lib/x86_64-linux-gnu/perl/5.22
    /usr/share/perl/5.22
    /usr/local/lib/site_perl
    /usr/lib/x86_64-linux-gnu/perl-base

The last perl version I used was 5.18.2 on a previous install and I had no issues. Could this be due to 5.22.x? Thanks for any insight! 
Shane M.
 



This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.








This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.





--
Research Analyst
S104A Animal Science Research Center,
University of Missouri, Columbia




This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.







This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: prepare-refseqs.pl - can't locate

Deepak Unni
Hi Shane,

Based on the Permission denied error, it still looks like the script is having trouble writing to /opt/apollo/data directory.

Running as sudo is not recommended and you might come across additional errors.

Could you go to /opt/apollo/data folder and try creating a file in that directory. Chances are you might have Permission Denied. 
Let me know if this is the case.

On Tue, Oct 25, 2016 at 12:12 PM, Shane McCoy <[hidden email]> wrote:
Hi Deepak! thanks for replying. I was just about to send this email when I saw yours. Here is the updated info:

I have switched to the system perl and added all the proper modules. I redid my postgresql setup and used the guidelines from the Readdocs
sudo su postgres -c "createuser -RDIElPS $PGUSER"
sudo su postgres -c "createdb -E UTF-8 -O $PGUSER apollo-production"
I updated apollo-config.groovy, plus commented out the password (didn't do before, missed it!)
ran clean-all and redeployed. Now getting:
$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
Permission denied writing Msax_1-0.txt at /home/bjreadin/Apollo/bin/../src/perl5/Bio/JBrowse/Cmd/FormatSequences.pm line 455, <$fasta_fh> line 2.
I can run as sudo now, but I assume that is not the best idea.
Shane

On Tue, Oct 25, 2016 at 1:10 PM, Deepak Unni <[hidden email]> wrote:
Hi Shane,

I am stepping in for Nathan as he is busy on a conference this week.

Looking at your recent error with prepare-refseqs.pl script, it looks like you don't have permission to write to /opt folder.
Since /opt is a system-wide directory, you will have to first create /opt/apollo as the root user, and then change ownership of /opt/apollo folder to your username.

Ex:
sudo mkdir /opt/apollo
sudo chown <username>:<group> /opt/apollo

Once you have this done, you can run the prepare-refseqs.pl script again and it should process your datasets and place them properly in /opt/apollo/data.

Let me know if this works or if you encounter any other issues.

Cheers,

Deepak


On Tue, Oct 25, 2016 at 9:04 AM, Shane McCoy <[hidden email]> wrote:
I am getting permission denied now
$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
mkdir /opt/apollo: Permission denied at /home/bjreadin/Apollo/bin/../src/perl5/JsonFileStorage.pm line 64.

I did use --sudo on cpanm installs but I have done that prior without this issue.  

On Mon, Oct 24, 2016 at 8:03 PM, Shane McCoy <[hidden email]> wrote:
Hi Nathan,
after ./apollo deploy it installs fine:
$ ./install_jbrowse.sh 
Installing Perl prerequisites ...Prerequisites installed, finished.

 I had tried after ./apollo clean-all and it would not install. Not sure if that matters? 
Installing Perl prerequisites ... failed.  See setup.log file for error messages.
 
Apollo/setup.log
+ chmod +x web-app/jbrowse/bin/cpanm
chmod: cannot access 'web-app/jbrowse/bin/cpanm': No such file or directory
+ cd web-app/jbrowse
./install_jbrowse.sh: line 26: cd: web-app/jbrowse: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 27: bin/cpanm: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 28: bin/cpanm: No such file or directory
+ set -e
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 30: bin/cpanm: No such file or directory
 Thanks!
Shane

On Mon, Oct 24, 2016 at 7:27 PM, Nathan Dunn <[hidden email]> wrote:

Shane,

What happens if you run ./install_jbrowse.sh ? 

Nathan

On Oct 24, 2016, at 5:43 PM, Shane McCoy <[hidden email]> wrote:

Hello!
I've run into an issue - would love some help on this one. 
After running ./apollo deploy I can't get my head around why the bin/prepare-refseqs.pl script is not running

$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
Can't locate local/lib.pm in @INC (you may need to install the local::lib module) (@INC contains: /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1 /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5 /home/bjreadin/Apollo/bin/../src/perl5 /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.1 /usr/local/share/perl/5.22.1 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /home/bjreadin/Apollo/bin/../src/perl5/JBlibs.pm line 25.
Compilation failed in require at bin/prepare-refseqs.pl line 5.
BEGIN failed--compilation aborted at bin/prepare-refseqs.pl line 5. 

Perl Version 5.22.1 - modules installed at:
/home/bjreadin/perl5/lib/perl5

 I have local::lib installed and my paths seem correct. 
$ perl -V
  %ENV:
    PERL5LIB="/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib/perl5:/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib"
    PERL_LOCAL_LIB_ROOT="/home/bjreadin/perl5:"
    PERL_MB_OPT="--install_base "/home/bjreadin/perl5""
    PERL_MM_OPT="INSTALL_BASE=/home/bjreadin/perl5"
  @INC:
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5/5.22.1
    /home/bjreadin/perl5/lib/perl5/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib
    /etc/perl
    /usr/local/lib/x86_64-linux-gnu/perl/5.22.1
    /usr/local/share/perl/5.22.1
    /usr/lib/x86_64-linux-gnu/perl5/5.22
    /usr/share/perl5
    /usr/lib/x86_64-linux-gnu/perl/5.22
    /usr/share/perl/5.22
    /usr/local/lib/site_perl
    /usr/lib/x86_64-linux-gnu/perl-base

The last perl version I used was 5.18.2 on a previous install and I had no issues. Could this be due to 5.22.x? Thanks for any insight! 
Shane M.
 



This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.








This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.





--
Research Analyst
S104A Animal Science Research Center,
University of Missouri, Columbia




This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.







This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.





--
Research Analyst
S104A Animal Science Research Center,
University of Missouri, Columbia




This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: prepare-refseqs.pl - can't locate

Shane McCoy
Hi Deepak,
I just got through another redeploy and it is working now. I did chown ... /opt/apollo/data
thank you for your help!
Shane M.

On Tue, Oct 25, 2016 at 1:19 PM, Deepak Unni <[hidden email]> wrote:
Hi Shane,

Based on the Permission denied error, it still looks like the script is having trouble writing to /opt/apollo/data directory.

Running as sudo is not recommended and you might come across additional errors.

Could you go to /opt/apollo/data folder and try creating a file in that directory. Chances are you might have Permission Denied. 
Let me know if this is the case.

On Tue, Oct 25, 2016 at 12:12 PM, Shane McCoy <[hidden email]> wrote:
Hi Deepak! thanks for replying. I was just about to send this email when I saw yours. Here is the updated info:

I have switched to the system perl and added all the proper modules. I redid my postgresql setup and used the guidelines from the Readdocs
sudo su postgres -c "createuser -RDIElPS $PGUSER"
sudo su postgres -c "createdb -E UTF-8 -O $PGUSER apollo-production"
I updated apollo-config.groovy, plus commented out the password (didn't do before, missed it!)
ran clean-all and redeployed. Now getting:
$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
Permission denied writing Msax_1-0.txt at /home/bjreadin/Apollo/bin/../src/perl5/Bio/JBrowse/Cmd/FormatSequences.pm line 455, <$fasta_fh> line 2.
I can run as sudo now, but I assume that is not the best idea.
Shane

On Tue, Oct 25, 2016 at 1:10 PM, Deepak Unni <[hidden email]> wrote:
Hi Shane,

I am stepping in for Nathan as he is busy on a conference this week.

Looking at your recent error with prepare-refseqs.pl script, it looks like you don't have permission to write to /opt folder.
Since /opt is a system-wide directory, you will have to first create /opt/apollo as the root user, and then change ownership of /opt/apollo folder to your username.

Ex:
sudo mkdir /opt/apollo
sudo chown <username>:<group> /opt/apollo

Once you have this done, you can run the prepare-refseqs.pl script again and it should process your datasets and place them properly in /opt/apollo/data.

Let me know if this works or if you encounter any other issues.

Cheers,

Deepak


On Tue, Oct 25, 2016 at 9:04 AM, Shane McCoy <[hidden email]> wrote:
I am getting permission denied now
$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
mkdir /opt/apollo: Permission denied at /home/bjreadin/Apollo/bin/../src/perl5/JsonFileStorage.pm line 64.

I did use --sudo on cpanm installs but I have done that prior without this issue.  

On Mon, Oct 24, 2016 at 8:03 PM, Shane McCoy <[hidden email]> wrote:
Hi Nathan,
after ./apollo deploy it installs fine:
$ ./install_jbrowse.sh 
Installing Perl prerequisites ...Prerequisites installed, finished.

 I had tried after ./apollo clean-all and it would not install. Not sure if that matters? 
Installing Perl prerequisites ... failed.  See setup.log file for error messages.
 
Apollo/setup.log
+ chmod +x web-app/jbrowse/bin/cpanm
chmod: cannot access 'web-app/jbrowse/bin/cpanm': No such file or directory
+ cd web-app/jbrowse
./install_jbrowse.sh: line 26: cd: web-app/jbrowse: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 27: bin/cpanm: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 28: bin/cpanm: No such file or directory
+ set -e
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 30: bin/cpanm: No such file or directory
 Thanks!
Shane

On Mon, Oct 24, 2016 at 7:27 PM, Nathan Dunn <[hidden email]> wrote:

Shane,

What happens if you run ./install_jbrowse.sh ? 

Nathan

On Oct 24, 2016, at 5:43 PM, Shane McCoy <[hidden email]> wrote:

Hello!
I've run into an issue - would love some help on this one. 
After running ./apollo deploy I can't get my head around why the bin/prepare-refseqs.pl script is not running

$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
Can't locate local/lib.pm in @INC (you may need to install the local::lib module) (@INC contains: /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1 /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5 /home/bjreadin/Apollo/bin/../src/perl5 /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.1 /usr/local/share/perl/5.22.1 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /home/bjreadin/Apollo/bin/../src/perl5/JBlibs.pm line 25.
Compilation failed in require at bin/prepare-refseqs.pl line 5.
BEGIN failed--compilation aborted at bin/prepare-refseqs.pl line 5. 

Perl Version 5.22.1 - modules installed at:
/home/bjreadin/perl5/lib/perl5

 I have local::lib installed and my paths seem correct. 
$ perl -V
  %ENV:
    PERL5LIB="/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib/perl5:/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib"
    PERL_LOCAL_LIB_ROOT="/home/bjreadin/perl5:"
    PERL_MB_OPT="--install_base "/home/bjreadin/perl5""
    PERL_MM_OPT="INSTALL_BASE=/home/bjreadin/perl5"
  @INC:
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5/5.22.1
    /home/bjreadin/perl5/lib/perl5/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib
    /etc/perl
    /usr/local/lib/x86_64-linux-gnu/perl/5.22.1
    /usr/local/share/perl/5.22.1
    /usr/lib/x86_64-linux-gnu/perl5/5.22
    /usr/share/perl5
    /usr/lib/x86_64-linux-gnu/perl/5.22
    /usr/share/perl/5.22
    /usr/local/lib/site_perl
    /usr/lib/x86_64-linux-gnu/perl-base

The last perl version I used was 5.18.2 on a previous install and I had no issues. Could this be due to 5.22.x? Thanks for any insight! 
Shane M.
 



This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.








This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.





--
Research Analyst
S104A Animal Science Research Center,
University of Missouri, Columbia




This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.







This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.





--
Research Analyst
S104A Animal Science Research Center,
University of Missouri, Columbia




This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.







This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: prepare-refseqs.pl - can't locate

Deepak Unni
Awesome! Glad to hear it worked out.

Cheers,

Deepak

On Tue, Oct 25, 2016 at 12:24 PM, Shane McCoy <[hidden email]> wrote:
Hi Deepak,
I just got through another redeploy and it is working now. I did chown ... /opt/apollo/data
thank you for your help!
Shane M.

On Tue, Oct 25, 2016 at 1:19 PM, Deepak Unni <[hidden email]> wrote:
Hi Shane,

Based on the Permission denied error, it still looks like the script is having trouble writing to /opt/apollo/data directory.

Running as sudo is not recommended and you might come across additional errors.

Could you go to /opt/apollo/data folder and try creating a file in that directory. Chances are you might have Permission Denied. 
Let me know if this is the case.

On Tue, Oct 25, 2016 at 12:12 PM, Shane McCoy <[hidden email]> wrote:
Hi Deepak! thanks for replying. I was just about to send this email when I saw yours. Here is the updated info:

I have switched to the system perl and added all the proper modules. I redid my postgresql setup and used the guidelines from the Readdocs
sudo su postgres -c "createuser -RDIElPS $PGUSER"
sudo su postgres -c "createdb -E UTF-8 -O $PGUSER apollo-production"
I updated apollo-config.groovy, plus commented out the password (didn't do before, missed it!)
ran clean-all and redeployed. Now getting:
$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
Permission denied writing Msax_1-0.txt at /home/bjreadin/Apollo/bin/../src/perl5/Bio/JBrowse/Cmd/FormatSequences.pm line 455, <$fasta_fh> line 2.
I can run as sudo now, but I assume that is not the best idea.
Shane

On Tue, Oct 25, 2016 at 1:10 PM, Deepak Unni <[hidden email]> wrote:
Hi Shane,

I am stepping in for Nathan as he is busy on a conference this week.

Looking at your recent error with prepare-refseqs.pl script, it looks like you don't have permission to write to /opt folder.
Since /opt is a system-wide directory, you will have to first create /opt/apollo as the root user, and then change ownership of /opt/apollo folder to your username.

Ex:
sudo mkdir /opt/apollo
sudo chown <username>:<group> /opt/apollo

Once you have this done, you can run the prepare-refseqs.pl script again and it should process your datasets and place them properly in /opt/apollo/data.

Let me know if this works or if you encounter any other issues.

Cheers,

Deepak


On Tue, Oct 25, 2016 at 9:04 AM, Shane McCoy <[hidden email]> wrote:
I am getting permission denied now
$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
mkdir /opt/apollo: Permission denied at /home/bjreadin/Apollo/bin/../src/perl5/JsonFileStorage.pm line 64.

I did use --sudo on cpanm installs but I have done that prior without this issue.  

On Mon, Oct 24, 2016 at 8:03 PM, Shane McCoy <[hidden email]> wrote:
Hi Nathan,
after ./apollo deploy it installs fine:
$ ./install_jbrowse.sh 
Installing Perl prerequisites ...Prerequisites installed, finished.

 I had tried after ./apollo clean-all and it would not install. Not sure if that matters? 
Installing Perl prerequisites ... failed.  See setup.log file for error messages.
 
Apollo/setup.log
+ chmod +x web-app/jbrowse/bin/cpanm
chmod: cannot access 'web-app/jbrowse/bin/cpanm': No such file or directory
+ cd web-app/jbrowse
./install_jbrowse.sh: line 26: cd: web-app/jbrowse: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 27: bin/cpanm: No such file or directory
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 28: bin/cpanm: No such file or directory
+ set -e
+ bin/cpanm -v --notest -l ../../extlib/ --installdeps .
./install_jbrowse.sh: line 30: bin/cpanm: No such file or directory
 Thanks!
Shane

On Mon, Oct 24, 2016 at 7:27 PM, Nathan Dunn <[hidden email]> wrote:

Shane,

What happens if you run ./install_jbrowse.sh ? 

Nathan

On Oct 24, 2016, at 5:43 PM, Shane McCoy <[hidden email]> wrote:

Hello!
I've run into an issue - would love some help on this one. 
After running ./apollo deploy I can't get my head around why the bin/prepare-refseqs.pl script is not running

$ bin/prepare-refseqs.pl --fasta genome.fa --out /opt/apollo/data
Can't locate local/lib.pm in @INC (you may need to install the local::lib module) (@INC contains: /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/5.22.1 /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5/x86_64-linux-gnu-thread-multi /home/bjreadin/Apollo/bin/../src/perl5/../../extlib/lib/perl5 /home/bjreadin/Apollo/bin/../src/perl5 /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.1 /usr/local/share/perl/5.22.1 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /home/bjreadin/Apollo/bin/../src/perl5/JBlibs.pm line 25.
Compilation failed in require at bin/prepare-refseqs.pl line 5.
BEGIN failed--compilation aborted at bin/prepare-refseqs.pl line 5. 

Perl Version 5.22.1 - modules installed at:
/home/bjreadin/perl5/lib/perl5

 I have local::lib installed and my paths seem correct. 
$ perl -V
  %ENV:
    PERL5LIB="/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib/perl5:/home/bjreadin/src/bioperl-live:/home/bjreadin/perl5/lib"
    PERL_LOCAL_LIB_ROOT="/home/bjreadin/perl5:"
    PERL_MB_OPT="--install_base "/home/bjreadin/perl5""
    PERL_MM_OPT="INSTALL_BASE=/home/bjreadin/perl5"
  @INC:
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib/perl5/5.22.1/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5/5.22.1
    /home/bjreadin/perl5/lib/perl5/x86_64-linux-gnu-thread-multi
    /home/bjreadin/perl5/lib/perl5
    /home/bjreadin/src/bioperl-live
    /home/bjreadin/perl5/lib
    /etc/perl
    /usr/local/lib/x86_64-linux-gnu/perl/5.22.1
    /usr/local/share/perl/5.22.1
    /usr/lib/x86_64-linux-gnu/perl5/5.22
    /usr/share/perl5
    /usr/lib/x86_64-linux-gnu/perl/5.22
    /usr/share/perl/5.22
    /usr/local/lib/site_perl
    /usr/lib/x86_64-linux-gnu/perl-base

The last perl version I used was 5.18.2 on a previous install and I had no issues. Could this be due to 5.22.x? Thanks for any insight! 
Shane M.
 



This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.






This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.








This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.





--
Research Analyst
S104A Animal Science Research Center,
University of Missouri, Columbia




This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.







This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.





--
Research Analyst
S104A Animal Science Research Center,
University of Missouri, Columbia




This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.







This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.





--
Research Analyst
S104A Animal Science Research Center,
University of Missouri, Columbia




This list is for the Apollo Annotation Editing Tool. Info at http://genomearchitect.org/
If you wish to unsubscribe from the Apollo List: 1. From the address with which you subscribed to the list, send a message to [hidden email] | 2. In the subject line of your email type: unsubscribe apollo | 3. Leave the message body blank.

Loading...