problems with install on OSX 10.5, Python 2.5.1

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

problems with install on OSX 10.5, Python 2.5.1

Arlin Stoltzfus
Hello.  I'm a Python newbie having problems trying to install galaxy  
on a Mac (PPC) running OSX 10.5.8 and Python 2.5.1.

Do I need to upgrade my Python or OSX version?

If not, below are the gory details for anyone who wants to help.

Arlin
----------------------------- gory details (narrative description  
followed by transcript) ---------------------

I've been through this several times and loaded various packages  
manually, and it all seems to come down to numpy 1.3.0 and bx-python  
0.5.0.  I installed more recent versions of these myself (numpy 1.4.1  
and bx-python 0.6.0), and verified that they were installed correctly,  
but Galaxy seems to want specific versions that are not the current  
versions.  I found a binary of numpy 1.3.0 but the installer would not  
let me install it on the grounds that it requires "System Python 2.5",  
which is confusing because thats what I thought I had. I haven't found  
bx-python 0.5.0 anywhere though I suppose I could just build an old  
release from the source repository.

camel12:dev arlin$ uname -a
Darwin camel12.umbi.umd.edu 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul  
15 16:57:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_PPC Power Macintosh

camel12:dev arlin$ python --version
Python 2.5.1

camel12:dev arlin$ hg clone http://bitbucket.org/galaxy/galaxy-dist
(works fine)

camel12:dev arlin$ cd galaxy-dist/

camel12:galaxy-dist arlin$ sudo sh setup.sh
. . . (lots of messages)
Fetched http://eggs.g2.bx.psu.edu/new/pexpect/pexpect-2.4-py2.5.egg
Traceback (most recent call last):
   File "./scripts/fetch_eggs.py", line 31, in <module>
     c.resolve() # Only fetch eggs required by the config
   File "/Users/arlin/dev/galaxy-dist/lib/galaxy/eggs/__init__.py",  
line 284, in resolve
     egg.resolve()
   File "/Users/arlin/dev/galaxy-dist/lib/galaxy/eggs/__init__.py",  
line 172, in resolve
     r =  
pkg_resources
.working_set.resolve( ( self.distribution.as_requirement(), ), env,  
self.fetch )
   File "/Library/Python/2.5/site-packages/distribute-0.6.10-py2.5.egg/
pkg_resources.py", line 565, in resolve
     )
pkg_resources.DistributionNotFound: bx-python==0.5.0-dev-f74aec067563

----------------------- end of gory details  
--------------------------------------

-------
Arlin Stoltzfus ([hidden email])
Fellow, IBBR; Adj. Assoc. Prof., UMCP; Research Biologist, NIST
IBBR, 9600 Gudelsky Drive, Rockville, MD
tel: 240 314 6208; web: www.molevol.org

_______________________________________________
galaxy-dev mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-dev
Reply | Threaded
Open this post in threaded view
|

Re: problems with install on OSX 10.5, Python 2.5.1

Nate Coraor (nate@bx.psu.edu)
Arlin Stoltzfus wrote:
> Hello.  I'm a Python newbie having problems trying to install galaxy on
> a Mac (PPC) running OSX 10.5.8 and Python 2.5.1.
>
> Do I need to upgrade my Python or OSX version?
>
> If not, below are the gory details for anyone who wants to help.

Hi Arlin,

Sorry for the late reply.  It looks like your Python is not the system
version (as evidenced by the path '/Library' as opposed to
'/System/Library'), although it may be the python.org version, which is
also supported.

>
> Arlin
> ----------------------------- gory details (narrative description
> followed by transcript) ---------------------
>
> I've been through this several times and loaded various packages
> manually, and it all seems to come down to numpy 1.3.0 and bx-python
> 0.5.0.  I installed more recent versions of these myself (numpy 1.4.1
> and bx-python 0.6.0), and verified that they were installed correctly,
> but Galaxy seems to want specific versions that are not the current
> versions.  I found a binary of numpy 1.3.0 but the installer would not
> let me install it on the grounds that it requires "System Python 2.5",
> which is confusing because thats what I thought I had. I haven't found
> bx-python 0.5.0 anywhere though I suppose I could just build an old
> release from the source repository.
>
> camel12:dev arlin$ uname -a
> Darwin camel12.umbi.umd.edu 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul
> 15 16:57:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_PPC Power Macintosh
>
> camel12:dev arlin$ python --version
> Python 2.5.1
>
> camel12:dev arlin$ hg clone http://bitbucket.org/galaxy/galaxy-dist
> (works fine)
>
> camel12:dev arlin$ cd galaxy-dist/
>
> camel12:galaxy-dist arlin$ sudo sh setup.sh

!!

Galaxy should not be run as root, nor should the setup.

> . . . (lots of messages)
> Fetched http://eggs.g2.bx.psu.edu/new/pexpect/pexpect-2.4-py2.5.egg
> Traceback (most recent call last):
>   File "./scripts/fetch_eggs.py", line 31, in <module>
>     c.resolve() # Only fetch eggs required by the config
>   File "/Users/arlin/dev/galaxy-dist/lib/galaxy/eggs/__init__.py", line
> 284, in resolve
>     egg.resolve()
>   File "/Users/arlin/dev/galaxy-dist/lib/galaxy/eggs/__init__.py", line
> 172, in resolve
>     r = pkg_resources.working_set.resolve( (
> self.distribution.as_requirement(), ), env, self.fetch )
>   File
> "/Library/Python/2.5/site-packages/distribute-0.6.10-py2.5.egg/pkg_resources.py",
> line 565, in resolve
>     )
> pkg_resources.DistributionNotFound: bx-python==0.5.0-dev-f74aec067563

It looks like there may be conflicts with existing things in
/Library/Python/2.5/site-packages, if there's a lot in there.

The safest thing to do here is to set up a virtualenv:

% wget http://bitbucket.org/ianb/virtualenv/raw/tip/virtualenv.py
% python virtualenv.py galaxy_env --no-site-packages
% ./galaxy_env/bin/activate
% cd galaxy_dist
% sh run.sh

And see if that solves it.  If not, please let us know.

--nate

>
> ----------------------- end of gory details
> --------------------------------------
>
> -------
> Arlin Stoltzfus ([hidden email])
> Fellow, IBBR; Adj. Assoc. Prof., UMCP; Research Biologist, NIST
> IBBR, 9600 Gudelsky Drive, Rockville, MD
> tel: 240 314 6208; web: www.molevol.org
>
> _______________________________________________
> galaxy-dev mailing list
> [hidden email]
> http://lists.bx.psu.edu/listinfo/galaxy-dev

_______________________________________________
galaxy-dev mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-dev