search in libraries

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

search in libraries

Davide Cittaro
Hi all, 
how does the library search tool work? I'm trying on the public galaxy but I can't get any result...

d
/*
Davide Cittaro

Cogentech - Consortium for Genomic Technologies
via adamello, 16
20139 Milano
Italy

tel.: +39(02)574303007
*/




_______________________________________________
galaxy-user mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-user
Reply | Threaded
Open this post in threaded view
|

Re: search in libraries

Davide Cittaro

On Jun 29, 2010, at 2:29 PM, Davide Cittaro wrote:

Hi all, 
how does the library search tool work? I'm trying on the public galaxy but I can't get any result...


I mean, does it only work at "first level"?

d
/*
Davide Cittaro

Cogentech - Consortium for Genomic Technologies
via adamello, 16
20139 Milano
Italy

tel.: +39(02)574303007
*/




_______________________________________________
galaxy-user mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-user
Reply | Threaded
Open this post in threaded view
|

Re: search in libraries

Greg Von Kuster
Hi Davide,

When browsing all libraries, you can currently search on the name or description of the library itself, but searching does not currently work for library contents ( folders and datasets ).  It is on our development plans to enable searching on contents.

On Jun 29, 2010, at 8:37 AM, Davide Cittaro wrote:


On Jun 29, 2010, at 2:29 PM, Davide Cittaro wrote:

Hi all, 
how does the library search tool work? I'm trying on the public galaxy but I can't get any result...


I mean, does it only work at "first level"?

d
/*
Davide Cittaro

Cogentech - Consortium for Genomic Technologies
via adamello, 16
20139 Milano
Italy

tel.: +39(02)574303007
*/



_______________________________________________
galaxy-user mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-user

Greg Von Kuster
Galaxy Development Team




_______________________________________________
galaxy-user mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-user
Reply | Threaded
Open this post in threaded view
|

Tool search missing

Pieter Neerincx-3
Hi,

When I click the Options button in the tool pane on the left there's no option to search for tools. I can only show or hide recently used tools. Is there something I need to configure/enable to make this work? I browsed the Wiki, but could not find relevant documentation...

Cheers,

Pi
_______________________________________________
galaxy-user mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-user
Reply | Threaded
Open this post in threaded view
|

Re: Tool search missing

Jeremy Goecks
> When I click the Options button in the tool pane on the left there's no option to search for tools. I can only show or hide recently used tools. Is there something I need to configure/enable to make this work? I browsed the Wiki, but could not find relevant documentation...

Pieter,

Configuration is not necessary for tool search; it should always be available from the Options menu. Answering a couple questions should help us debug the issue:

*Are you using the public/main Galaxy instance or an instance of your own?
*What web browser are you using?
*Are there any Javascript errors that your web browser is reporting?

Thanks,
J.
_______________________________________________
galaxy-user mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-user
Reply | Threaded
Open this post in threaded view
|

Re: Tool search missing

Pieter Neerincx-3
Dear Jeremy,

On Aug 17, 2010, at 2:31 PM, Jeremy Goecks wrote:

>> When I click the Options button in the tool pane on the left there's no option to search for tools. I can only show or hide recently used tools. Is there something I need to configure/enable to make this work? I browsed the Wiki, but could not find relevant documentation...
>
> Pieter,
>
> Configuration is not necessary for tool search; it should always be available from the Options menu.

Thanks, good to know. Then I can stop searching for the magic setting on the config files :)

> Answering a couple questions should help us debug the issue:
>
> *Are you using the public/main Galaxy instance or an instance of your own?

Our own instance. I just tried the public/main Galaxy instance and tool search works just fine for me over there, so I doubt it's my web browser.

> *What web browser are you using?

I tried Camino, FireFox and Safari all on OS X. All with the same result.

> *Are there any Javascript errors that your web browser is reporting?

No, the only errors I can see are a missing favicon.ico and a missing </div> tag in tool_menu just before the closing </body> </html> tags...
Our Galaxy is not 100% up to date, but fairly recent: it's from 03-aug-2010. Were there any recent fixes for the tool search or should our instance be recent enough?

Cheers,

Pi


> Thanks,
> J.

------------------------------------------------------------------
Biomolecular Mass Spectrometry & Proteomics group
Utrecht University

phone: +31 6 143 66 783
email: [hidden email]
skype: pieter.online

visiting address:
H.R. Kruyt building // room O607
Padualaan 8 // 3584 CH Utrecht // The Netherlands

mail address:
P.O. box 80.082 // 3508 TB Utrecht // The Netherlands
------------------------------------------------------------------


_______________________________________________
galaxy-user mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-user
Reply | Threaded
Open this post in threaded view
|

Sniffers not working

Pieter Neerincx-3
In reply to this post by Jeremy Goecks
Hi all,

I used to have working sniffers for custom data formats, but the documentation on the wiki is no longer enough to make it work :(...

When I start our Galaxy I do see log messages like this:

        galaxy.datatypes.registry INFO 2010-08-17 18:20:28,666 Loaded sniffer for datatype: galaxy.datatypes.nbic:RAW

which suggests that the sniffers should be enabled, but unfortunately they don't work. If I add the sniffers to the default list in galaxy/lib/galaxy/datatypes/registry.py like this:

        ....
        # Default values - the order in which we attempt to determine data types is critical
        # because some formats are much more flexibly defined than others.
        if len(self.sniff_order) < 1:
            self.sniff_order = [
                nbic.RAW(),
                nbic.OtherCustomFormat(),
                binary.Bam(),
                binary.Sff(),
                xml.BlastXml(),
                sequence.Maf(),
                sequence.Lav(),
                sequence.csFasta(),
                etc.....

my sniffers do work, so I'm pretty sure it's not the sniff-logic. Does anyone have an idea how I can make my sniffers work again by simply adding them to datatypes_conf.xml and importing them in registry.py, but without hacking the code in registry.py that builds the list of sniffers?

Cheers,

Pi


------------------------------------------------------------------
Biomolecular Mass Spectrometry & Proteomics group
Utrecht University

phone: +31 6 143 66 783
email: [hidden email]
skype: pieter.online

visiting address:
H.R. Kruyt building // room O607
Padualaan 8 // 3584 CH Utrecht // The Netherlands

mail address:
P.O. box 80.082 // 3508 TB Utrecht // The Netherlands
------------------------------------------------------------------


_______________________________________________
galaxy-user mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-user
Reply | Threaded
Open this post in threaded view
|

Re: Tool search missing

Jeremy Goecks
In reply to this post by Pieter Neerincx-3
Our Galaxy is not 100% up to date, but fairly recent: it's from 03-aug-2010. Were there any recent fixes for the tool search or should our instance be recent enough?


Hmm. This should be recent enough to include the tool search and any bug fixes after we rolled it out. However, it would be nice if you could update your Galaxy instance and try again. If it still breaks, at least we're working from the current and same codebase. 

Is it possible for you to update your Galaxy instance and try again?

Thanks,
J. 

_______________________________________________
galaxy-user mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-user
Reply | Threaded
Open this post in threaded view
|

Re: Sniffers not working

Nate Coraor (nate@bx.psu.edu)
In reply to this post by Pieter Neerincx-3
Hi Pieter,

Thanks for reporting this.  It should be fixed in changeset
4158:03be4a0828ce.

Thanks,
--nate

Pieter Neerincx wrote:

> Hi all,
>
> I used to have working sniffers for custom data formats, but the documentation on the wiki is no longer enough to make it work :(...
>
> When I start our Galaxy I do see log messages like this:
>
> galaxy.datatypes.registry INFO 2010-08-17 18:20:28,666 Loaded sniffer for datatype: galaxy.datatypes.nbic:RAW
>
> which suggests that the sniffers should be enabled, but unfortunately they don't work. If I add the sniffers to the default list in galaxy/lib/galaxy/datatypes/registry.py like this:
>
> ....
> # Default values - the order in which we attempt to determine data types is critical
>         # because some formats are much more flexibly defined than others.
>         if len(self.sniff_order) < 1:
>             self.sniff_order = [
>                 nbic.RAW(),
>                 nbic.OtherCustomFormat(),
>                 binary.Bam(),
>                 binary.Sff(),
>                 xml.BlastXml(),
>                 sequence.Maf(),
>                 sequence.Lav(),
>                 sequence.csFasta(),
>                 etc.....
>
> my sniffers do work, so I'm pretty sure it's not the sniff-logic. Does anyone have an idea how I can make my sniffers work again by simply adding them to datatypes_conf.xml and importing them in registry.py, but without hacking the code in registry.py that builds the list of sniffers?
>
> Cheers,
>
> Pi
>
>
> ------------------------------------------------------------------
> Biomolecular Mass Spectrometry & Proteomics group
> Utrecht University
>
> phone: +31 6 143 66 783
> email: [hidden email]
> skype: pieter.online
>
> visiting address:
> H.R. Kruyt building // room O607
> Padualaan 8 // 3584 CH Utrecht // The Netherlands
>
> mail address:
> P.O. box 80.082 // 3508 TB Utrecht // The Netherlands
> ------------------------------------------------------------------
>
>
> _______________________________________________
> galaxy-user mailing list
> [hidden email]
> http://lists.bx.psu.edu/listinfo/galaxy-user

_______________________________________________
galaxy-user mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-user
Reply | Threaded
Open this post in threaded view
|

Re: Tool search missing

Pieter Neerincx-3
In reply to this post by Jeremy Goecks
Hi Jeremy,

On Aug 17, 2010, at 10:08 PM, Jeremy Goecks wrote:

> Our Galaxy is not 100% up to date, but fairly recent: it's from 03-aug-2010. Were there any recent fixes for the tool search or should our instance be recent enough?
>
>
> Hmm. This should be recent enough to include the tool search and any bug fixes after we rolled it out. However, it would be nice if you could update your Galaxy instance and try again. If it still breaks, at least we're working from the current and same codebase.
>
> Is it possible for you to update your Galaxy instance and try again?

Yes, but probably not until next week. I'll get back to you when I've tried it on the latest version...

Cheers,

Pi

> Thanks,
> J.

-------------------------------------------------------------
mobile: +31 6 143 66 783
e-mail: [hidden email]
skype:  pieter.online
-------------------------------------------------------------


_______________________________________________
galaxy-user mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-user
Reply | Threaded
Open this post in threaded view
|

Re: Sniffers not working

Pieter Neerincx-3
In reply to this post by Nate Coraor (nate@bx.psu.edu)
Hi Nate,

Thanks for the fast reply and fix! I'll give the update a try...

Cheers,

Pi

On Aug 18, 2010, at 9:16 PM, Nate Coraor wrote:

> Hi Pieter,
>
> Thanks for reporting this.  It should be fixed in changeset 4158:03be4a0828ce.
>
> Thanks,
> --nate
>
> Pieter Neerincx wrote:
>> Hi all,
>> I used to have working sniffers for custom data formats, but the documentation on the wiki is no longer enough to make it work :(...
>> When I start our Galaxy I do see log messages like this:
>> galaxy.datatypes.registry INFO 2010-08-17 18:20:28,666 Loaded sniffer for datatype: galaxy.datatypes.nbic:RAW
>> which suggests that the sniffers should be enabled, but unfortunately they don't work. If I add the sniffers to the default list in galaxy/lib/galaxy/datatypes/registry.py like this:
>> ....
>> # Default values - the order in which we attempt to determine data types is critical
>>        # because some formats are much more flexibly defined than others.
>>        if len(self.sniff_order) < 1:
>>            self.sniff_order = [
>>                nbic.RAW(),
>>                nbic.OtherCustomFormat(),
>>                binary.Bam(),
>>                binary.Sff(),
>>                xml.BlastXml(),
>>                sequence.Maf(),
>>                sequence.Lav(),
>>                sequence.csFasta(),
>>                etc.....
>> my sniffers do work, so I'm pretty sure it's not the sniff-logic. Does anyone have an idea how I can make my sniffers work again by simply adding them to datatypes_conf.xml and importing them in registry.py, but without hacking the code in registry.py that builds the list of sniffers?
>> Cheers,
>> Pi
>> ------------------------------------------------------------------
>> Biomolecular Mass Spectrometry & Proteomics group
>> Utrecht University
>> phone: +31 6 143 66 783
>> email: [hidden email]
>> skype: pieter.online
>> visiting address:
>> H.R. Kruyt building // room O607
>> Padualaan 8 // 3584 CH Utrecht // The Netherlands
>> mail address:
>> P.O. box 80.082 // 3508 TB Utrecht // The Netherlands
>> ------------------------------------------------------------------
>> _______________________________________________
>> galaxy-user mailing list
>> [hidden email]
>> http://lists.bx.psu.edu/listinfo/galaxy-user
>

-------------------------------------------------------------
mobile: +31 6 143 66 783
e-mail: [hidden email]
skype:  pieter.online
-------------------------------------------------------------


_______________________________________________
galaxy-user mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-user