searching a second DB

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

searching a second DB

Sofia Robb
Hi Everyone,

I have a gbrowse 2 set up that uses two databases. The first database is in the [General] section and the 2nd is in a separate [database] stanza. I have "search options = default +autocomplete" in my 2nd Database stanza and the autocomplete is working but if I search for one of the names that pops up in the autocomplete I get 
The search timed out; try a more specific search 

Is there something else I need to add to my 2nd db stanza so that the search function works?

Thanks,
Sofia


------------------------------------------------------------------------------
Don't Limit Your Business. Reach for the Cloud.
GigeNET's Cloud Solutions provide you with the tools and support that
you need to offload your IT needs and focus on growing your business.
Configured For All Businesses. Start Your Cloud Today.
https://www.gigenetcloud.com/
_______________________________________________
Gmod-gbrowse mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-gbrowse
Reply | Threaded
Open this post in threaded view
|

Re: searching a second DB

Sofia Robb
Hello All,

I have also tried this with no success. 
[General]
database = db1

[db1:database]
db_adaptor    = Bio::DB::SeqFeature::Store
db_args       = -dsn    dbi:mysql:database=ABC;host=XYZ
                -adaptor    DBI::mysql
                -user   XYZ
                -pass  123
search options = default +autocomplete

[db2:database]
db_adaptor    = Bio::DB::SeqFeature::Store
db_args       = -dsn    dbi:mysql:database=DEF;host=XYZ
                -adaptor    DBI::mysql
                -user   XYZ
                -pass  123
search options = default +autocomplete


Names in my second db are not search even though the autocomplete for the second db is working just fine. I will search for one of the autocompleted names and i get the search timed out; try a more specific search error. Any suggestions?



Thanks,
Sofia

On Tue, Jul 14, 2015 at 10:11 AM, Sofia Robb <[hidden email]> wrote:
Hi Everyone,

I have a gbrowse 2 set up that uses two databases. The first database is in the [General] section and the 2nd is in a separate [database] stanza. I have "search options = default +autocomplete" in my 2nd Database stanza and the autocomplete is working but if I search for one of the names that pops up in the autocomplete I get 
The search timed out; try a more specific search 

Is there something else I need to add to my 2nd db stanza so that the search function works?

Thanks,
Sofia



------------------------------------------------------------------------------

_______________________________________________
Gmod-gbrowse mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-gbrowse
Reply | Threaded
Open this post in threaded view
|

Re: searching a second DB

Timothy Parnell
Hi Sofia,
My gbrowse instance also does not appear to search a second SeqFeature::Store database from the search window. I wonder if the search window is restricted to only the default database defined in the [General] section.

I think the search is handled in Bio::Graphics::Browser2::RegionSearch. This module has a DEBUG constant parameter close to the top of the file. Flip this value from 0 to 1 (restart if necessary), and you should get lots of debug statements in the apache log, which will tell you if that second database is even being queried or not. Maybe this might be useful info; I don’t know.

As to getting it to work properly, I’m not sure how to fix that.

Tim

On Jul 22, 2015, at 11:12 AM, Sofia Robb <[hidden email]<mailto:[hidden email]>> wrote:

Hello All,

I have also tried this with no success.
[General]
database = db1

[db1:database]
db_adaptor    = Bio::DB::SeqFeature::Store
db_args       = -dsn    dbi:mysql:database=ABC;host=XYZ
                -adaptor    DBI::mysql
                -user   XYZ
                -pass  123
search options = default +autocomplete

[db2:database]
db_adaptor    = Bio::DB::SeqFeature::Store
db_args       = -dsn    dbi:mysql:database=DEF;host=XYZ
                -adaptor    DBI::mysql
                -user   XYZ
                -pass  123
search options = default +autocomplete


Names in my second db are not search even though the autocomplete for the second db is working just fine. I will search for one of the autocompleted names and i get the search timed out; try a more specific search error. Any suggestions?



Thanks,
Sofia

On Tue, Jul 14, 2015 at 10:11 AM, Sofia Robb <[hidden email]<mailto:[hidden email]>> wrote:
Hi Everyone,

I have a gbrowse 2 set up that uses two databases. The first database is in the [General] section and the 2nd is in a separate [database] stanza. I have "search options = default +autocomplete" in my 2nd Database stanza and the autocomplete is working but if I search for one of the names that pops up in the autocomplete I get
The search timed out; try a more specific search

Is there something else I need to add to my 2nd db stanza so that the search function works?

Thanks,
Sofia


------------------------------------------------------------------------------
_______________________________________________
Gmod-gbrowse mailing list
[hidden email]<mailto:[hidden email]>
https://lists.sourceforge.net/lists/listinfo/gmod-gbrowse

------------------------------------------------------------------------------
_______________________________________________
Gmod-gbrowse mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-gbrowse
Reply | Threaded
Open this post in threaded view
|

Re: searching a second DB

Sofia Robb
Got IT!! From the debug statements I saw it was trying to search all the databases including all the BAM databases and hit a time out.  I set all the BAM dbs to "search options = none" for now and my 2 seqfeature store dbs were search and i found what I was looking for. 

Thanks Tim!!

Sofia

On Wed, Jul 22, 2015 at 12:18 PM, Timothy Parnell <[hidden email]> wrote:
Hi Sofia,
My gbrowse instance also does not appear to search a second SeqFeature::Store database from the search window. I wonder if the search window is restricted to only the default database defined in the [General] section.

I think the search is handled in Bio::Graphics::Browser2::RegionSearch. This module has a DEBUG constant parameter close to the top of the file. Flip this value from 0 to 1 (restart if necessary), and you should get lots of debug statements in the apache log, which will tell you if that second database is even being queried or not. Maybe this might be useful info; I don’t know.

As to getting it to work properly, I’m not sure how to fix that.

Tim

On Jul 22, 2015, at 11:12 AM, Sofia Robb <[hidden email]<mailto:[hidden email]>> wrote:

Hello All,

I have also tried this with no success.
[General]
database = db1

[db1:database]
db_adaptor    = Bio::DB::SeqFeature::Store
db_args       = -dsn    dbi:mysql:database=ABC;host=XYZ
                -adaptor    DBI::mysql
                -user   XYZ
                -pass  123
search options = default +autocomplete

[db2:database]
db_adaptor    = Bio::DB::SeqFeature::Store
db_args       = -dsn    dbi:mysql:database=DEF;host=XYZ
                -adaptor    DBI::mysql
                -user   XYZ
                -pass  123
search options = default +autocomplete


Names in my second db are not search even though the autocomplete for the second db is working just fine. I will search for one of the autocompleted names and i get the search timed out; try a more specific search error. Any suggestions?



Thanks,
Sofia

On Tue, Jul 14, 2015 at 10:11 AM, Sofia Robb <[hidden email]<mailto:[hidden email]>> wrote:
Hi Everyone,

I have a gbrowse 2 set up that uses two databases. The first database is in the [General] section and the 2nd is in a separate [database] stanza. I have "search options = default +autocomplete" in my 2nd Database stanza and the autocomplete is working but if I search for one of the names that pops up in the autocomplete I get
The search timed out; try a more specific search

Is there something else I need to add to my 2nd db stanza so that the search function works?

Thanks,
Sofia


------------------------------------------------------------------------------
_______________________________________________
Gmod-gbrowse mailing list
[hidden email]<mailto:[hidden email]>
https://lists.sourceforge.net/lists/listinfo/gmod-gbrowse



------------------------------------------------------------------------------

_______________________________________________
Gmod-gbrowse mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gmod-gbrowse