shed_tool_conf.xml

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

shed_tool_conf.xml

Rathert, Philipp, Dr.
shed_tool_conf.xml

Dear all,


I think I made a really stupid mistake. I edited the shed_tool_con.xml file to change the order and section of tools.


Doing this I might have introduced an error I cannot locate. However (now comes the stupidity), I didn't save the old version of the shed_tool_conf.xml file...


Is there a way to fix this or do I have to reinstall all tools again?


Thank you for your help.


cheers,


Philipp 


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: shed_tool_conf.xml

Peter Cock
I would try validating the broken XML file (e.g. using an online tool,
or an XML aware editor). That might be enough to find the error and
fix it by hand.

I don't know if there is a clever way to regenerate the file instead...

Peter


On Tue, Mar 22, 2016 at 11:49 AM, Rathert, Philipp, Dr.
<[hidden email]> wrote:

> Dear all,
>
>
> I think I made a really stupid mistake. I edited the shed_tool_con.xml file
> to change the order and section of tools.
>
>
> Doing this I might have introduced an error I cannot locate. However (now
> comes the stupidity), I didn't save the old version of the
> shed_tool_conf.xml file...
>
>
> Is there a way to fix this or do I have to reinstall all tools again?
>
>
> Thank you for your help.
>
>
> cheers,
>
>
> Philipp
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: shed_tool_conf.xml

Gildas Le Corguillé
A stupid way to do that is to remove the half bottom of your xml and open it using Firefox for example.
If OK
Add the half top of the half bottom -> firefox
If OK
If KO
Remove the half bottom of the remain -> firefox
..

It’s stupid but it’s often work :)


Gildas

-----------------------------------------------------------------
Gildas Le Corguillé - Bioinformatician/Bioanalyste

Plateform ABiMS (Analyses and Bioinformatics for Marine Science)
http://abims.sb-roscoff.fr

Member of the Workflow4Metabolomics project
http://workflow4metabolomics.org

Station Biologique de Roscoff - UPMC/CNRS - FR2424
Place Georges Teissier 29680 Roscoff FRANCE
tel: +33 2 98 29 23 81
------------------------------------------------------------------



Le 22 mars 2016 à 12:56, Peter Cock <[hidden email]> a écrit :

I would try validating the broken XML file (e.g. using an online tool,
or an XML aware editor). That might be enough to find the error and
fix it by hand.

I don't know if there is a clever way to regenerate the file instead...

Peter


On Tue, Mar 22, 2016 at 11:49 AM, Rathert, Philipp, Dr.
<[hidden email]> wrote:
Dear all,


I think I made a really stupid mistake. I edited the shed_tool_con.xml file
to change the order and section of tools.


Doing this I might have introduced an error I cannot locate. However (now
comes the stupidity), I didn't save the old version of the
shed_tool_conf.xml file...


Is there a way to fix this or do I have to reinstall all tools again?


Thank you for your help.


cheers,


Philipp


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: shed_tool_conf.xml

Björn Grüning-3
As Peter already mentioned a XML validator is a nice tool for this purpose.

For example this one:
http://www.xmlvalidation.com


A stupid way to do that is to remove the half bottom of your xml and open it using Firefox for example.
If OK
Add the half top of the half bottom -> firefox
If OK
If KO
Remove the half bottom of the remain -> firefox
..

It’s stupid but it’s often work :)


Gildas

-----------------------------------------------------------------
Gildas Le Corguillé - Bioinformatician/Bioanalyste

Plateform ABiMS (Analyses and Bioinformatics for Marine Science)
http://abims.sb-roscoff.fr

Member of the Workflow4Metabolomics project
http://workflow4metabolomics.org

Station Biologique de Roscoff - UPMC/CNRS - FR2424
Place Georges Teissier 29680 Roscoff FRANCE
tel: +33 2 98 29 23 81
------------------------------------------------------------------



Le 22 mars 2016 à 12:56, Peter Cock <[hidden email]> a écrit :

I would try validating the broken XML file (e.g. using an online tool,
or an XML aware editor). That might be enough to find the error and
fix it by hand.

I don't know if there is a clever way to regenerate the file instead...

Peter


On Tue, Mar 22, 2016 at 11:49 AM, Rathert, Philipp, Dr.
<[hidden email]> wrote:
Dear all,


I think I made a really stupid mistake. I edited the shed_tool_con.xml file
to change the order and section of tools.


Doing this I might have introduced an error I cannot locate. However (now
comes the stupidity), I didn't save the old version of the
shed_tool_conf.xml file...


Is there a way to fix this or do I have to reinstall all tools again?


Thank you for your help.


cheers,


Philipp


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: shed_tool_conf.xml

Rathert, Philipp, Dr.
In reply to this post by Rathert, Philipp, Dr.
RE: [galaxy-dev] shed_tool_conf.xml

Hi Peter,


thx for the hint. Xcode was very helpful and I could localize the error.


However, this couldn't tell me why my label ids didn't work.

how do I implement those. Does this need a delimiter at the end like the sections?


<label id="basic_tools" text="Basic Tools" version="" />



Cheers,


Philipp

-----Original message-----
From: Peter Cock <[hidden email]>
Sent: Tuesday 22nd March 2016 12:56
To: Rathert, Philipp, Dr. <[hidden email]>
Cc: [hidden email]
Subject: Re: [galaxy-dev] shed_tool_conf.xml

I would try validating the broken XML file (e.g. using an online tool,
or an XML aware editor). That might be enough to find the error and
fix it by hand.

I don't know if there is a clever way to regenerate the file instead...

Peter


On Tue, Mar 22, 2016 at 11:49 AM, Rathert, Philipp, Dr.
<[hidden email]> wrote:

> Dear all,
>
>
> I think I made a really stupid mistake. I edited the shed_tool_con.xml file
> to change the order and section of tools.
>
>
> Doing this I might have introduced an error I cannot locate. However (now
> comes the stupidity), I didn't save the old version of the
> shed_tool_conf.xml file...
>
>
> Is there a way to fix this or do I have to reinstall all tools again?
>
>
> Thank you for your help.
>
>
> cheers,
>
>
> Philipp
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client. To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
> https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
> http://galaxyproject.org/search/mailinglists/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: shed_tool_conf.xml

Hans-Rudolf Hotz
In reply to this post by Peter Cock


On 03/22/2016 12:56 PM, Peter Cock wrote:
> I would try validating the broken XML file (e.g. using an online tool,
> or an XML aware editor). That might be enough to find the error and
> fix it by hand.
>
> I don't know if there is a clever way to regenerate the file instead...
>

probably a lot of 'manual' work including comparing with the admin page
'Installed tool shed repositories'.

Also, look at the file "integrated_tool_panel.xml". all tools listed
there which are not listed in "tool_conf.xml" need an entry in
shed_tool_conf.xml....as far as I know.


Hans-Rudolf




> Peter
>
>
> On Tue, Mar 22, 2016 at 11:49 AM, Rathert, Philipp, Dr.
> <[hidden email]> wrote:
>> Dear all,
>>
>>
>> I think I made a really stupid mistake. I edited the shed_tool_con.xml file
>> to change the order and section of tools.
>>
>>
>> Doing this I might have introduced an error I cannot locate. However (now
>> comes the stupidity), I didn't save the old version of the
>> shed_tool_conf.xml file...
>>
>>
>> Is there a way to fix this or do I have to reinstall all tools again?
>>
>>
>> Thank you for your help.
>>
>>
>> cheers,
>>
>>
>> Philipp
>>
>>
>> ___________________________________________________________
>> Please keep all replies on the list by using "reply all"
>> in your mail client.  To manage your subscriptions to this
>> and other Galaxy lists, please use the interface at:
>>    https://lists.galaxyproject.org/
>>
>> To search Galaxy mailing lists use the unified search at:
>>    http://galaxyproject.org/search/mailinglists/
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>    https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>    http://galaxyproject.org/search/mailinglists/
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/